Jump to content
wmchris

[GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation

1,753 posts in this topic

Recommended Posts

Hello wmchris, kudos for a great job you made for a whole community. I'm also probably will go with XPS 9550 instead of new MBPr 2016.

One question regarding to displays - did you, or any of you guys tried connecting to external 4K display by HDMI or USB-C -> Displayport adapter, and got working 4K 60Hz? Actually only this stops me from purchase. 

 

Anyway, I'm software developer and my setup will be like this: 3x 1920x1200 external displays connected in the office, and single 4K Dell P2415Q at home. Maybe some of you has similar configuration and will be able to share thoughts about setup, flow etc.

 

If available, I will also glad to donate via PPal or something. XPS is a new Macbook Pro ;)

 

Best, Kris

Share this post


Link to post
Share on other sites
Advertisement

Hello wmchris, kudos for a great job you made for a whole community. I'm also probably will go with XPS 9550 instead of new MBPr 2016.

One question regarding to displays - did you, or any of you guys tried connecting to external 4K display by HDMI or USB-C -> Displayport adapter, and got working 4K 60Hz? Actually only this stops me from purchase. 

 

Anyway, I'm software developer and my setup will be like this: 3x 1920x1200 external displays connected in the office, and single 4K Dell P2415Q at home. Maybe someof you has similar configuration and will be able to share thoughts about setup, flow etc.

 

If available, I will also glad to donate via PPal or something. XPS is a new Macbook Pro ;)

 

Best, Kris

4k @ 60Hz worked by HDMI on my Philips TV, but you only have two monitor sockets (HDMI and DP). You can daisy chain the DP, but this will reduce the maximum resolution on each monitor plugged in.

hey wmchris

 

thank you so much for the guide. so far almost everything went really smooth without hassle.

 

the only "issue" right now is the missing wifi, because i have no internet connection at all right now. as i understood the killer wifi will not work. so my options are: getting the dell adapter, replacing the wifi card or using an external usb wifi stick? right?

 

is anybody aware of an external usb wifi solution?

which wifi card for replacement is suggested? (offtopic: does anybody know if this will kill the warranty?)

 

thanks again, i am really happy right know with my hackbook! 

which card you should use depends on your setup at home (router etc.) just take a look at compatibility charts around the web. Warranty depends on your location. In europe you're safe, in the US your warranty will be probably voided. Dont forget to check if you have a 2x2 or a 3x3 card setup.

 

If you plug another dell card in it (https://wikidevi.com/wiki/Dell_Wireless_1830_(DW1830)), a 3x3 card, dell will not notice that you swapped something.

Share this post


Link to post
Share on other sites

You will probably lose your warranty. If you don't care you can get dw1830.

 

Wysłane z mojego Pixel przy użyciu Tapatalka

Share this post


Link to post
Share on other sites

Apple has only a driver for their own NVMe devices. PikerAlpha hacked it and added the posibility to use this driver on non apple OEM SSDs. But this hack doesnt work with hynix devices.

 

Because i never had one i cant tell you why. It's possible that it can be easily fixed, but this requires at least some amount of time and skill.

 

The good thing is: you can easily swap the M.2 SSD for something compatible.

 

So is there any restriction on M.2 SSD Harddrive. I found Samsung 850 EVO series SSD 500GB M.2 at a local vendor, just to double check: this SSD would work?

 

Edit: Also, do I need to replace the WiFi as well? 

Share this post


Link to post
Share on other sites

So is there any restriction on M.2 SSD Harddrive. I found Samsung 850 EVO series SSD 500GB M.2 at a local vendor, just to double check: this SSD would work?

 

Edit: Also, do I need to replace the WiFi as well? 

regarding the M2 SSD: you have to research this by yourself, i never swapped my SSD, so i cant tell you which replacement is good and i dont want to give false informations.

 

wifi: maybe, maybe not. depens on if you have the Dell Wireles 1820 or 1830. 1820 needs replacement, 1830 not. 1820 is used in the low end XPS 15 devices. 1820 = Atheros, 1830 = Broadcom.

Share this post


Link to post
Share on other sites

Hey wmchris,

 

I was sad to see your great tutorial disappear from the other website and I'm glad I was able to find it over here. I've successfully installed Sierra on my i5 9550 and only have a few kinks to work out. My USB ports won't recognize anything and my volume keys stopped working after I enabled HD530 fully. I'm sure these are relatively easy problems to fix and I'm just overlooking something. Thanks for your work!

 

Edit:

USB functionality is working and now my only problem is that the function 1-3 keys do not work to change volume. Does anyone have any idea on how to resolve this?

Share this post


Link to post
Share on other sites

Hello wmchris, I would like to thank you a lot for a perfect guide to have a new OSX on my Dell XPS 9550. Now I have a couple of questions for you I would like to be answered:

 

1. There's "no hardware" message in Thunderbolt category even though I have USB-C switched on in BIOS.

2. Playing 4K mp4 videos are very slow (I have SSD drive). I have had El Capitan OS installed previously and have not had any issues.

3. When bluetooth is switched on together with wi-fi connection, my Magic Trackpad 2 lags a lot. There was no lag during El Capitan using.

 

Despite all these issues, the whole OSX runs like a charm :)

Share this post


Link to post
Share on other sites

Hello wmchris, I would like to thank you a lot for a perfect guide to have a new OSX on my Dell XPS 9550. Now I have a couple of questions for you I would like to be answered:

 

1. There's "no hardware" message in Thunderbolt category even though I have USB-C switched on in BIOS.

2. Playing 4K mp4 videos are very slow (I have SSD drive). I have had El Capitan OS installed previously and have not had any issues.

3. When bluetooth is switched on together with wi-fi connection, my Magic Trackpad 2 lags a lot. There was no lag during El Capitan using.

 

Despite all these issues, the whole OSX runs like a charm :)

to 1st: looks like you dont have anything plugged in the thunderbolt port. If you plug something in, then hardware can be found ;-)

to 2nd: sounds like QE/QI is not enabled.

to 3rd: the DW 1830 is known for wifi + bt speed drops, but if it worked before, i've no idea. I cant confirm this on my setup, so there is more debugging needed. But maybe it also has something to do with 2nd.

Share this post


Link to post
Share on other sites

i recently bought the 4k 6700hq verion and been reading this and wathcing videos to get the hackintosh working for me 

it took me almost 6 hours to get to the clover boot options and now I see Sierra, as a bootable option, after selecting sierra 

i get this 

 

osxaptiofixdrv starting overrides for \.iabootfiles\boot.efi using reloc blovck: yes hibernate : no

 

and then it gets stuck there. 

 

I have ditto'ed your clover folder into my efi partition.  is this a currupt os problem? 

 

Any help is appreciated. 

 

thank you

Share this post


Link to post
Share on other sites

i recently bought the 4k 6700hq verion and been reading this and wathcing videos to get the hackintosh working for me 

it took me almost 6 hours to get to the clover boot options and now I see Sierra, as a bootable option, after selecting sierra 

i get this 

 

osxaptiofixdrv starting overrides for \.iabootfiles\boot.efi using reloc blovck: yes hibernate : no

 

and then it gets stuck there. 

 

I have ditto'ed your clover folder into my efi partition.  is this a currupt os problem? 

 

Any help is appreciated. 

 

thank you

 

Welcome!

 

In your EFI/CLOVER/driver64 do you see osxaptiofixdrv or osxaptifix2drv, or both?

For your configuration we need ONLY the osxaptiofixdrv.

I have the exact same challenge.

 

I've managed through ApplePS2SmartTouchPad.kext 4.7 b5 get everything working except for the forward/backward in Safari. It does however work in Finder (with 3 finger swipe motion instead of 2).

 

I have attached my Info.plist in case someone else might be interested in my configuration.

 

EDIT: Added attachment as .zip file

 

 

Has anyone made any progress on this yet? I'm at a stale mate, just can't get it too work.

I have a feeling that Apple are not using cmd+left arrow/ cmd+right arrow for back/forth where the screen "slides in and out", but rather another command.

Share this post


Link to post
Share on other sites

I'm still getting the truncation error, despite following the steps of the guide as accurately as possible. Here is a screen dump of the system information page. Can anyone please help me out? I've also attached my fakeSMBIOS.kext and config.plist file for reference.

Thanks in advance!

 

EDIT: The machine displays itself as iMac 5K Retina, which was my previous SMBIOS. 

 

EDIT #2: So it seems that Clover Configurator received an update with SMBIOS options for the MacBookPro13,2 and MacBookPro13,3. The only method to boot for me was by removing the SSDT.aml file in the ACPI/Patched folder. 

FAKESMBIOS + CONFIG PLIST.zip

post-1338533-0-62282400-1484259124_thumb.png

Share this post


Link to post
Share on other sites

Is it though? The XPS 15 9560's only substantial upgrade is the upgrade to Kaby Lake, right? 

- Kaby lake

- nVidia 1050 4gb

- Bigger battery!!

- Don't know if anything more

Share this post


Link to post
Share on other sites

- Kaby lake

- nVidia 1050 4gb

- Bigger battery!!

- Don't know if anything more

  • Newer CPU: check (but not very good for hackintosh)
  • NVIDIA 1050: check (not usable in hackintosh)
  • Bigger battery: check (+13Ah, 97Ah instead of 84Ah)

But it also has worse wifi and less antennas and an unknown SSD (dunno if this is compatible with the NVMe driver)

 

so if you plan to buy a hackintosh notebook right now i would suggest buying the 9550 instead. It's cheaper and more compatible.

Share this post


Link to post
Share on other sites

i recently bought the 4k 6700hq verion and been reading this and wathcing videos to get the hackintosh working for me 

it took me almost 6 hours to get to the clover boot options and now I see Sierra, as a bootable option, after selecting sierra 

i get this 

 

osxaptiofixdrv starting overrides for \.iabootfiles\boot.efi using reloc blovck: yes hibernate : no

 

and then it gets stuck there. 

 

I have ditto'ed your clover folder into my efi partition.  is this a currupt os problem? 

 

Any help is appreciated. 

 

thank you

Try clearing NVRAM and restarting. I've seen that work for other people having the same problem.

Share this post


Link to post
Share on other sites

thanks wmchris, JLee7695 and Lockzi 

my main issue was that I never started with a clean drive, I partitioned the drive and left the origianl windows first. which was a mistake.

 

WOW 

I am definitely a newbie but after spending two days I got most of this computer to work. 

 

the only major issue I have at the moment is that thunderbolt 3 does not work. I do have startech adapter (tb2 to tb3) and apple adapter. (tb2 to tb3) and have drives that are thunderbolt and also an audio interface that is thunderbolt. With all these hardware I do not get any tb hardware to show up, I plugged them before turning it on, i plugged them after boot. no luck. 

 

any idea what i should do?

 

i dont understand dsdt editing although I did get the original .aml files and turned them into .dsl files but when i open it in the MaciASL, im just lost. also I dont know which one to open if i need to do any change.  :(

Share this post


Link to post
Share on other sites

thanks wmchris, JLee7695 and Lockzi 

my main issue was that I never started with a clean drive, I partitioned the drive and left the origianl windows first. which was a mistake.

 

WOW 

I am definitely a newbie but after spending two days I got most of this computer to work. 

 

the only major issue I have at the moment is that thunderbolt 3 does not work. I do have startech adapter (tb2 to tb3) and apple adapter. (tb2 to tb3) and have drives that are thunderbolt and also an audio interface that is thunderbolt. With all these hardware I do not get any tb hardware to show up, I plugged them before turning it on, i plugged them after boot. no luck. 

 

any idea what i should do?

 

i dont understand dsdt editing although I did get the original .aml files and turned them into .dsl files but when i open it in the MaciASL, im just lost. also I dont know which one to open if i need to do any change.   :(

can you suggest a cheap thunderbolt 3 device i can buy? then i can debug it.

Share this post


Link to post
Share on other sites

can you suggest a cheap thunderbolt 3 device i can buy? then i can debug it.

 

 wmchris,

if you have any thunderbolt 1 or 2 device already startech's thunderbolt 2 to thunderbolt 3 adapter works nicely (at least it was working nicely on windows 10 tested, default OS)

I dont have any thundebrolt 3 device all the devices are thunderbolt 2 but all the devices worked under windows with that startech adaptor ( I was using these on my 2011 macbook pro)

 

besides this most of the external HD's claim they have thunderbolt 3 compatibility but they are actually USB-C  $149 glyph black box on amazon.

 

 

 

 

also as a side note, 

the only thing I couldnt get going is 

sudo mv /System/Library/Extensions/AppleACPIPS2Nub.kext /System/Library/Extensions/AppleACPIPS2Nub.bak

sudo mv /System/Library/Extensions/ApplePS2Controller.kext /System/Library/Extensions/ApplePS2Controller.bak

 

beacuse i just dont have these kexts inside my sierra do I have to download it from somewhere 

Share this post


Link to post
Share on other sites

 

 

Has anyone made any progress on this yet? I'm at a stale mate, just can't get it too work.

I have a feeling that Apple are not using cmd+left arrow/ cmd+right arrow for back/forth where the screen "slides in and out", but rather another command.

It might be possible that the same underlying issue is behind my inability to change the volume with the Fn keys... I haven't found a fix yet, but if/ when I do, I'll see what potential there is for fully enabling multitouch gestures

 

Also, any laptop system definitions I try will boot and then I'll get a KP and crash after about 3-5 minutes. I don't want to attempt any more system definition tweaks until I know of one that will work, since I've already fixed iMessage and stabilized everything 100 times better than El Capitan on my machine with the included iMac definition. I don't know how some of the patches work, but maybe there's some commands that operate differently behind the scenes on an iMac vs. a MacBook. 

 

Edit: I'm using MacOS software version 10.12 and I saw that 10.12.2 fixed the volume button mapping issues. Has anyone performed an update without problems and is it worth risking breaking the system by upgrading just for the sake of having volume control? I understand software updates have other benefits as well, but I'm a bit nervous to upgrade just because I use this computer for school.

Share this post


Link to post
Share on other sites

Hey,  wmchris

 

Here is what I did. 

 

I enabled thunderbolt boot and thunderbolt support on BIOS. 

I have the startech and apple thunderbolt 2 to 3 adapter. 

 

startech adapter does not come up when booted to the OS but the apple thunderbolt adapter shows up as USB 3.1 device is connected (it does not boot the drive since it is a thunderbolt drive) interesting thing is that startech is natively supported by xps 9550 windows. 

 

do you think because imac 17 does not have a thunderbolt 3 there is no support on it ?

 

maybe new macbook pro modeled bios would make the thundebrolt 3 work? 

Share this post


Link to post
Share on other sites

 wmchris,

if you have any thunderbolt 1 or 2 device already startech's thunderbolt 2 to thunderbolt 3 adapter works nicely (at least it was working nicely on windows 10 tested, default OS)

I dont have any thundebrolt 3 device all the devices are thunderbolt 2 but all the devices worked under windows with that startech adaptor ( I was using these on my 2011 macbook pro)

 

besides this most of the external HD's claim they have thunderbolt 3 compatibility but they are actually USB-C  $149 glyph black box on amazon.

 

 

 

 

also as a side note, 

the only thing I couldnt get going is 

sudo mv /System/Library/Extensions/AppleACPIPS2Nub.kext /System/Library/Extensions/AppleACPIPS2Nub.bak

sudo mv /System/Library/Extensions/ApplePS2Controller.kext /System/Library/Extensions/ApplePS2Controller.bak

 

beacuse i just dont have these kexts inside my sierra do I have to download it from somewhere 

nope. if you dont have them then everything is fine :)

Share this post


Link to post
Share on other sites

wmchris,

nope. if you dont have them then everything is fine :)

I think the computer needs to be macbook pro 13.3 to be able to understand thunderbolt 3 since there is no imac yet that has thunderbolt 3. 

every time i change the smbios my hackintosh gets broken and stops booting and i replace the config and everything is back to normal. 

 

imsg supoort needs changing smbios so if i get that to work (if i understand how to do this thing) i guess i can figure how to switch to mbp 13.3 smbios and get back to making music. 

Share this post


Link to post
Share on other sites

Hey everybody, 

 

i can report that i have a dual boot macOS 10.12.2/Windows 10 working very well so far.

 

As i asked about wifi a few days ago: For now i stay with the "D-Link DWA-131 - Revision E" external USB-Wifi. D-Link provides official 10.12 drivers which work very well.

 

 

@wmchris

 

Only i'm a little worried about the usage of the NVMe SSD (THNSN5512GPUK NVMe TOSHIBA 512GB) although it works very well.

 

Is your warning about "reported multiple data losses" in the "Afterword and fixes" section due to the usage of the NVMe SSD?

I closely followed your install instructions and read the articles (1, 2) about NVMe SSD but i did not understand very much to be honest.

 

Can i somehow check if the provided patch and kext are still working properly after updating? 

I would be very kind if you could elaborate about the current status of the usage of a NVMe SSD.

 

Thank you for all you effort.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By tlefko
      Site
      checkout our official site! https://twortech.wixsite.com/pcmac Version Info
      This build is compatible up to Big Sur Beta
      Now Compatible with macOS 11 Please leave feedback with issues or w/o Comitted to Updating up to OS 11 Latest Release Notes
      Fixed Bluetooth and Wifi Stability Issues Improved Preformance and Power Managements Can Provide Files for Display Overrides Additional Patches for 4K Display updated for Big Sur if using unsupported wifi card disable it in bios use config.plist FIXED SLEEP WAKE BUG Exact same functionality as Catalina What Works / Does Not
      Everything works minus in-built mic Some displays may be detected as 40hz (working on fix) Notes
      Never tested USB C over Display Output, everything else works flawlessly USB devices eject on sleep (not really an issue) POST
      run sudo pmset -a hibernatemode 0 If no mouse, install all voodoo kexts using Kext Utility Description
      This esentially an ultra-simplistic version that is stable without the use of a deploy or complicated file installations and copies. You can easily view all the SSDT patches along with configuration files for the bootloader as they are all documented clearly in the files. This does include a copy of Clover, which of course I do not contribute to and am only responsible for the provided files, patches, and kext placements This guide provides a working setup with little knowledge of the topic and without "optimization" (because often they can break things). But, it is fully functional and preforms properly and is stable Make sure you are using DW1560 for wifi or else KP. If not using remove BRCM kexts from CLOVER>kexts>other. BIOS Setup
      Disable Secure Boot INSTALL (VERY IMPORTANT)
      Due to structural changes in the setup of apple's Big sur, this EFI cannot boot the installer it can only boot into a system / device that has already been created and setup. To do this, you need to install Big Sur to a virtual machine (lots of guides online) and then create an dmg of that system, and restore it onto your HDD using the 'dd' command There are various guides online how to get this virtual machine setup complete. You can then use the attached EFI folder to boot and use macOS big Sur You can use this video to show you how to get your macOS pre-installed onto your hard drive https://www.youtube.com/watch?v=HMU3nhcbWHw Boot Entry Setup
      Due to the fact this BIOS is locked down pretty heavily, reccomended to use Windows to find a free tool to add UEFI boot entries Messages and Facetime
      Gnerate your own Serials, Board Numbers, MLB There are various guides online to do this and as default they're set to essentially Null (Fakeserial) This is fairly straightforward and there is lots of external recourses, or you can contact me for support. Headphones and Audio
      All audio from speakers should work perfectly along with Bluetooth and USB audio no internal mic Credits
      MaLd0n for DSDT Patches (HUGE SHOUTOUT) Original Kext Authors Clover Team Finished!
      Congratulations, there really aren't any more steps that are required. Feel free to contact me with any questions. Donations
      Send me a coffee/beer lefkotyler@gmail.com  
       
      *check GitHub for latest releases and faster support https://github.com/tlefko/HP-Envy-13-Big-Sur
      EFI.zip
    • By ngochoaic3
      Hi everyone, 
      I hava a dell precision m4700 with option dgpu amd firepro m4000, The Intel HD4000 Graphic is disable, i can't enable it on to install Hackintosh
      I'd like to enable it on and ask you for setting custom connectors to get the internal display to work, and enable the iGPU in order to get things like AirPlay screen mirroring to work
      Could you help me?
    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the SSDT-UIAC.aml in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet Auto-sensing headphone jack automatically switches to internal speaker when headphones removed  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers AptioMemoryFix Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.6 Clover (UEFI) r5119 Lilu.kext 1.4.5 WhateverGreen.kext 1.4.0 AppleALC.kext 1.5.0 IntelMausi 1.0.3 (Not IntelMausiEthernet)  
      Credits To be provided
       
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
       
      EliteDesk800 G4 Mini - Rev 1.0.zip
    • By tlefko
      News
      In light of the recent WWDC, we will begin testing the functionality of our EFI on macOS 11 for this device with the latest developer preview Version Info
      Features and Overview
      Now Compatible with 10.15.6 Please leave feedback with issues or w/o Comitted to Updating up to OS 11 Multitouch Trackpad Support 4K @60 Hz Fixed Bluetooth and Wifi Stability Issues Preformance and Power Management Additional Patches for 4K Display updated for 15.6 rev 1 Sleep Wake is functional for some models ----if screen glitches on wake or reopen lid. If this is a bother just disable sleep. This is issue is resolved in Big Sur Bugs
      Some models may experience screen split in half. If so disable. USB devices eject (external) No Internal Mic What Works
      Everything minus sleep issue above, internal microphone. (audio is fine, headphones / usb mic fine, just not laptop mic) POST
      run sudo pmset -a hibernatemode 0
      Description
      This esentially an ultra-simplistic version that is stable without the use of a deploy or complicated file installations and copies. You can easily view all the DSDT patches along with configuration files for the bootloader as they are all documented clearly in the files. This does include a copy of Clover, which of course I do not contribute to and am only responsible for the provided files, patches, and kext placements This guide provides a working setup with little knowledge of the topic and without "optimization" (because often they can break things). But, it is fully functional and preforms properly and is stable.
      Unsupported Wifi
      Make sure you are using DW1560 or 1820a for wifi or else there is a risk of KP. If not using remove BRCM kexts from CLOVER>kexts>other Styling
      This guide is designed to be literally as thorough as possible to appeal all types of users. It does not cover complex topics like undervolting etc etc only to provide a completely functional system
      Notes
      Never tested USB C except for charging, USB, works great (not sure about DispOut) 4K model has sleep wake issues occasionally, 1080P is fully functional BIOS
      Disable Secure Boot Disable Vt-d Recommended: Clean Install (Preinstall steps)
      Format a USB (16GB) as Journaled and then proceed to download the latest Catalina Installer Patcher Application. Download the latest Catalina installer from within the Patcher App, and select to download a new copy and install to your USB device Download the clover configurator application and mount the EFI of the USB partition, then copy the contents of the Files linked above to A new EFI Folder (that you create) within the EFI partition. ** This is because the App Store installers will often not download a full installer, just an truncated version that downloads the installer files from the interent while installing. Thus, they're not bootable from a USB as they're not complete. That is why you should use this method to make sure the installer is usable for bootable media.
      Boot From USB
      Use f9, copy EFI folder to efi partition of your usb. after installation complete copy EFI to your ssd. Boot Entry Setup
      Reccomend using windows to find a tool to add a UEFI bios entry to boot EFI/Boot/bootx64 Credits
      @MaLd0n for DSDT Patches and support (HUGE SHOUTOUT) Original Kexts Authors Clover Headphones and Audio
      All audio from speakers should work perfectly along with Bluetooth and USB audio Finished!
      Congratulations, there really aren't any more steps that are required. Feel free to contact me with any questions.
      Donations
      Send me a coffee lefkotyler@gmail.com
      EFI Catalina.zip
       
      **for latest releases and faster replies please refer to GitHub https://github.com/tlefko/HP-ENVY-13-2020-Catalina
    • By ISmokeAir
      I am using opencore. I have an asrock z270 și killer and a core i7 7700k. I don't have a dgpu. I am using the integrated igpu(UHD 630). After booting up I get this kernel Panic.
       
×