Jump to content
wmchris

[GUIDE] Dell XPS 15 (9550) Mojave 10.14 / 10.15 Quick Installation

1,534 posts in this topic

Recommended Posts

9 hours ago, wmchris said:

i was in contact with the original author @alex.daoud before, and it was quite the opposite of a friendly chitchat. i think his problem is, that he doesnt like to fiddle with any bug reports (quote: "i know all existing bugs") and this binary triggers the usage by people without much knowledge.

but this is the opposite of an open development, which is very sad.

i fixed some of the (what the original autor told me as "very hard to fix") bugs like the physical click errors, but i was unable to fix the random crashes. The native and the master branch kexts should be considered as highly unstable and i suggest everyone to stick to VoodooPS2 for now.

Before someone asks: I didnt push my changes back to the repo, because of the hostile enviroment...  still, if someone is interested in the changes, contact me.

I apologise that I was rude to you in the first instance. I certainly do not mean to imply that your contributions are not welcome. What you must understand is that we have had many people come "eager" to contribute. Then in the end, it turns out they just wanted as much as my (or others') help as was possible to fix a situation for their own problems and then leave the code half-assed and unabled to be merged. This is the situation with the following fork: https://github.com/shdkpr2008/VoodooI2CHID where the guy needed keyboard support and leeched off of me helping him until he sorted it out and then disappeared saying "well it works for me, so i'll just leave it like that".

 

In the end I just stick to my close core of collaborators who have proven to me that they care about the development of the project rather than just "making it work for them". If someone wants to contribute then I am very eager to see their work but I try to be wary of my time being wasted. I am a full-time PhD student and I have very little free time for anything, let alone VoodooI2C as it is. When I do work on VoodooI2C I would like to maximise the good I do for the project in the short time that I can afford. Hence if someone appears saying they want to contribute I'd rather just watch them and see what they can do rather than have any kind of high expectations.

Share this post


Link to post
Share on other sites
Advertisement
5 hours ago, wmchris said:

ofc, thats why most people dont offer chat support and use either bug reports or add a readme with common bugs or a big warning, but if you dont add anything, people can be missleaded. for ex. the current readme file for the NATIVE branch contains:

how should anyone know that these are highly unstable pre-alpha debug code with major system compromising and os crashing flaws without reading +100 pages of chatlogs?
so i cant understand why @alex.daoud got so upset from the release of the compiled files by @hvolkoff

however this is highly off-topic, but VoodooI2C itself is not.

VoodooI2C has high potential, but it's not ready yet. Whenever i see a (semi-)stable release, i'll consider adding it to this tutorial. till then i can just repeat: VoodooPS2 has its flaws, too, but its much more stable and feature rich right now

 

--- Report of March, 21st 2018 ---

Pro of VoodooI2C:

  • Much smoother scrolling
  • faster reaction time

Con of VoodooI2C:

  • no palm detection/rejection
  • very VERY sensitive to touch, accidental clicks every time
  • random crashes on bootup (with automatic reboot)
  • random crashes after sleep (with automatic reboot)
  • unable to customize
  • is only compatible with the touchpad, NOT the touchscreen of the Dell XPS 15

 

Report of Native, last commit from early March: https://github.com/alexandred/VoodooI2C/commit/3be7546fd95693330dc84aa3feb7da11d7c3621c

Pro of VoodooI2C Native:

  • Native Multitouch
  • Configurable like an original Apple Magic Trackpad 2
  • Everything from the Pro of the non native version

Con of VoodooI2C Native:

  • Physical Clicks are buggy - nearly impossible to use
  • Random Freezes
  • Random Kernel Panics
  • Random Crashes on Shutdown / unable to shutdown
  • Most touch gestures dont work as they should - if at all
  • hypersensitive
  • Non working drag and drop
  • Everything from the Con of the non native version
  • and many more

 

 

Chat support is fundamentally necessary for VoodooI2C due to the complicated nature of the driver. It is practically impossible to create a "one-step" guide and a "one-step" debugging process due to various issues arising with how macOS implements APIC interrupts. We are forced to "hack" GPIO interrupt support in which means a high level of manual patching is required. When this goes wrong, a static bug reporting format (such as in a forum thread) makes it very difficult to debug end user issues since the support team usually has to go back and forth with the user receiving many iterations of troubleshooting archives. It is far easier to debug something instantly than wait (potentially days) for a user to reply only to have forgotten what the issue was in the first place (not to mention the likely scenario of having many other posts from other users appearing since that user last posted).

 

It is a fair point regarding the readme of the native branch and I will update this accordingly. It would have been helpful, however, for you to point this out to me.

 

When it comes to your pros/cons list for your Dell XPS 9550, I have some issues. Namely that I, myself, have a Dell XPS 9550 and I develop specifically for this machine. That means that nothing is released if it doesn't work for me on this machine. I do not experience any crashes on boot nor on wake/sleep. My (USB) touchscreen also works beautifully with @blankmac's touchscreen driver which is baked into VoodooI2CHID. In future the HID part of the driver will be separated out so that it is agnostic from the I2C/USB protocol. For the moment, however, USB touchscreens and trackpads required VoodooI2C.kext and VoodooI2CHID.kext installed.

 

If you experience issues with the kext as you listed then you should have submitted your troubleshooting archives to us. That's the process everyone goes through and I guarantee VoodooI2C v2.0.1 is far more stable than you make it out to be.

 

Edit:

Finally, I should also point out one last very important thing regarding the native branch. I have not yet done the due diligence in determining to what extent the legality of simulating the magic trackpad 2 is. This issue requires more careful thought. It could be in the end that I deem it not a good idea for such a thing to be in the public domain. This is one of the reasons for which I cannot approve of any build of the native branch going out.

Edited by alex.daoud

Share this post


Link to post
Share on other sites

Apologies if this has already been discussed before.

I bought a Gigabyte AORUS 1080 Gaming Box-- essentially a Thunderbolt 3 external Nvidia GPU, which has 3 USB 3.0 ports and 100W of power delivery so it also makes a decent docking station.

Good news: I had to make some tweaks to my SSDT-TB and install the Nvidia web drivers, but when plugged in at boot, the box works flawlessly. The built-in laptop display is the main display, external displays pop up (I attached a 4K DisplayPort and 2560x1440 HDMI monitor and both were full res), and the USB ports and power delivery work great. Curiously it doesn't show up under the NHI0 device, but on a different bus.

Bad news: If you want to turn off the laptop display, you can't just close the lid, it does nothing. I have to turn off Intel graphics injection and set a FakeID, essentially disabling the built-in display. Gonna look for a work-around as this is annoying.

Worse news: Hot-plugging does not work. Unplugging the box crashes the laptop. If I build an ACPI device tree and set the bus/devices as removable, I get a PCI-Express icon in the menu bar, with the option to turn off the display controller, audio controller, or USB controller. Picking any option crashes the laptop. Booting and then plugging in the box brings up the PCI-Express icon with the same three choices, but no drivers load for the Nvidia card or USB controller.

Okay news: Apple is set to include better eGPU support in 10.3.4, so I may be able to make this work. Of course, they're only supporting Radeon cards but maybe we'll get lucky.

Screen Shot 2018-03-22 at 10.18.35 PM.png

Edited by dpassmor

Share this post


Link to post
Share on other sites
On 21/03/2018 at 10:13 PM, alex.daoud said:

Thank you. The license acts as a deterrent for companies like touch-base from appropriating code from VoodooI2C. Legally speaking, however, Apple's EULA nullifies any open source license that is applied to kernel level software developed for OS X. The license is merely the illusion of rights applied.

That being said I have always and will always be 100% committed to the open-source development of VoodooI2C. However, it is typically well-recognised that OSS that does not start as a form of collaboration between many people (i.e that was only really started and worked on for a large amount of time by one or two people) will develop a group of people that is known as the "benevolent dictator for life"(https://en.wikipedia.org/wiki/Benevolent_dictator_for_life). Linux is a famous example of this whereby Linus Torvalds effectively has the final say as to what is merged into the master branch of the Linux kernel. Currently myself and @coolstar exercise our rights to this kind of control over the project due to the vast amount of man-hours we have put into it. We have recently (within the last year and a half or so) seen new people eagerly contributing and helping out and, gradually, they will also be able to exercise the same rights over the project.

 

One day I will officially leave this project fully to the community (and cease development myself) but that day cannot come until people realise that this whole idea of making some small changes, bundling them up in a new buggy kext and spreading these kexts around the internet severely undermines the hackintosh community as a whole. This is why the hackintosh community is so unpolished as compared to the iOS jailbreak community. There is very little attention to quality control and what is appropriate to be released as a "beta". This is also why we get so many of the same boring old questions over and over again - its because the internet is full of old junk kexts which people continue to download then complain about when they don't work. You can see this easily with VoodooI2C. We had someone called macforceone create a fork with a certain fix for Elan1200 back in the days of v1.0.0. It was a buggy fix and has long since been superseded - yet I still get questions about why this kext isn't working for people and whether its better to use than v2. The existence of these things undermines the very goal of this project: to provide super fluid (someday native) input on I2C devices. I spent 3 long months working very hard full-time to rewrite VoodooI2C from the ground up officially finishing it in September 2017. I held off on releasing until January 2018 after months of extensive private and then public beta testing. As a result, something that was written in 3 months is almost up to scratch to (and even often outperforms) VoodooPS2 which has been around (and not been rewritten since) in various iterations for close to 13 years. I remember using the predecessor to VoodooPS2 back in 2005 when I first started hackintoshing and the performance has not drastically improved since then.

 

It is for this reason that I do not approve of anything that isn't on the Release page being posted anywhere. It really is for the good of the development of VoodooI2C.

Hey man,
I completely understand your point (even though I disagree with some of what you said about the license and the iOS Jailbreak community, but that is off-topic...). However I do want to clarify that when I released the binary of the native branch my only intention was to bring awareness of the future capabilities of VoodooI2C. Even though I have to agree that it was wrong of me to put a beta label on it when it was not even close to a minimum stable version. Anyway thank you for all the work you have done on it and I hope it get's event better in the future.

Share this post


Link to post
Share on other sites
3 hours ago, TheRacerMaster said:

For those interested in working on Thunderbolt, some ACPI/UEFI stuff was recently open-sourced (part of EDK2 MinPlatformPkg): https://github.com/tianocore/edk2-platforms/commit/62f1e1e58965702030f722dcdf6de58998cf08a1

Hmm, very interesting. Big tnx for pointing on this! Will try to check on free hours.

Share this post


Link to post
Share on other sites

When updated to 10.13.4 it show 2 Intel GPU in system preferences panel.

How to deal with it.

 

QQ20180330-132615@2x.thumb.png.1382931cf3731426dc8ee5c708d0ea08.png

Edited by gujiangjiang

Share this post


Link to post
Share on other sites
Update Clover. I believe this was fixed in r4414.


Much thanks to you and thanks for you to help with CoreDisplayFixup to deal with 10.13.4.


从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites
CoreDisplayLocation="/System/Library/Frameworks/CoreDisplay.framework/Versions/A/CoreDisplay"
sudo perl -i.bak -pe '$oldtest1 = qr"\xE8\x37\x02\x00\x00\xBB\xE6\x02\x00\xE0\x85\xC0\x0F\x85\x9C\x00\x00\x00"s;$newtest1 = "\xE8\x37\x02\x00\x00\xBB\xE6\x02\x00\xE0\x31\xC0\x0F\x85\x9C\x00\x00\x00"; $oldtest2 = qr"\xE8\x65\x00\x00\x00\x85\xC0\xBB\xE6\x02\x00\xE0\x0F\x85\xCA\xFE\xFF\xFF"s;$newtest2 = "\xE8\x65\x00\x00\x00\x31\xC0\xBB\xE6\x02\x00\xE0\x0F\x85\xCA\xFE\xFF\xFF";s/$oldtest1/$newtest1/g;s/$oldtest2/$newtest2/g' $CoreDisplayLocation
sudo touch /System/Library/Extensions
sudo codesign -f -s - $CoreDisplayLocation
sudo update_dyld_shared_cache

Required patch for 10.13.4 UHD

EDIT:

@PMheart published the updated CoreDisplayFixup 30 minutes ago, so you can just use his release for easier usage.

 

Edited by wmchris

Share this post


Link to post
Share on other sites

Im trying to install update from 10.12.2 to 10.12.3 from DMG file downloaded from Apple website. Everything goes smooth but after reboot I'm still on 10.12.2. any solution?

Share this post


Link to post
Share on other sites
2 hours ago, Diwad said:

Im trying to install update from 10.12.2 to 10.12.3 from DMG file downloaded from Apple website. Everything goes smooth but after reboot I'm still on 10.12.2. any solution?

which smbios are you using? the combo updater also contain updates for the hardware, if these fail to install, the upgrade will be stopped.

Share this post


Link to post
Share on other sites

I'm using MacBook pro 2014 I think. So the procedure is to update bios, apply fix for trucating smbios, change smbios and update?

Share this post


Link to post
Share on other sites
13 hours ago, Diwad said:

I'm using MacBook pro 2014 I think. So the procedure is to update bios, apply fix for trucating smbios, change smbios and update?

nope. procedure is either setting different smbios data or "updating" the smbios data to represent a newer version.... or install the update manually with "pacifist".

Share this post


Link to post
Share on other sites

Ok. I've set smbios to newest MacBook pro and it booted correctly. I'm surprised that it booted normally because I thought there will be a sell firmware truncation problem.

I also have strange clover update problem. Installer went smoothly but when I boot up I still have 2.3k 3xxx version instead of 2.4k 4xxx. I'm sure Im installing it on esr.
Edit:

I've used MacBook pro 9.1 smbios, generated serial numbers and made sure they are not valid. Saved smbios but still no luck with the update. Same with updating clover. Installation is successful but clover version still same version

 

EDIT2: Allright, Windows was messing up in EFI somehow. I removed it and it is fine now. Will be updting to HS soon. Thaks once again for great tutorial @wmchris

Did you guys feel any performance upgrade after 10.13 update compared to 10.12? I see High sierra supports NVME natively.

Wysłane z mojego SM-G965F przy użyciu Tapatalka
 

Edited by Diwad

Share this post


Link to post
Share on other sites
On 1/22/2018 at 3:11 AM, golimpio said:

This is a bit off topic, but it might be useful for some people.

Last week my laptop's battery was swelling at a point that I couldn't even use the trackpad.

I was browsing for a new battery when I came across people telling that Dell is replacing XPS 15 9550 batteries for free, since this is a known issue. I can confirm that this is true for Australia, I got a new battery for free and a technician came to my place to replace it (but if your battery is not swelling yet, they will send the battery by mail and you can replace it yourself).

Have a look at Dell Product Bulletin website for more information (need your service tag):
https://www.dellproduct.com/

From their product bulletin:
 

 

This also just happened to me! My battery swell and I need immediate replacement! If you notice an weird clicking behavior of your touchpad, please take the time open the case of your XPS and check for a swelling battery, this is very dangerous, especially for such a powerful battery.

Share this post


Link to post
Share on other sites

I have been searching for this one for a while but I have been unable to get my HDMI out to work for video. I am not sure what I could be missing. Not sure if I am missing the right .kext or something. I do not feel comfortable installing the NVIDIA Web Drivers for this since I am under the assumption that works for Hackintosh desktops but not the laptop in this case the delicate Dell XPS 15. I am a noob and followed this tutorial just fine. Everything works except HDMI Video Out and wondered whats going on there.

Share this post


Link to post
Share on other sites

I think you should try different smbios. Copy your config.plist and name it differently. Then modify it with clover configurator, save and choose when booting.

Wysłane z mojego SM-G965F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
1 minute ago, Diwad said:

I think you should try different smbios. Copy your config.plist and name it differently. Then modify it with clover configurator, save and choose when booting.

Wysłane z mojego SM-G965F przy użyciu Tapatalka
 

I will try this, right now I am using iMac17,1 so perhaps a MacBook model will suffice?

Share this post


Link to post
Share on other sites

Yes, you can try macbook13.1 for example. It works well for me, but I didn't test HDMI.

Wysłane z mojego SM-G965F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
8 hours ago, brackguy said:

I have been searching for this one for a while but I have been unable to get my HDMI out to work for video. I am not sure what I could be missing. Not sure if I am missing the right .kext or something. I do not feel comfortable installing the NVIDIA Web Drivers for this since I am under the assumption that works for Hackintosh desktops but not the laptop in this case the delicate Dell XPS 15. I am a noob and followed this tutorial just fine. Everything works except HDMI Video Out and wondered whats going on there.

For HDMI require FakeHDMI.kext, AppleGraphicsControl.kext patch and HDMI intel audio enable in clover config. I am using macbook 13.3 and everything working perfect. 

Share this post


Link to post
Share on other sites
On ‎12‎/‎31‎/‎2016 at 2:37 AM, wmchris said:

Sadly i got banned on tonymacx86.com for the mentioning of "Pandoras Box" in this tutorial (reason: "Blatant Disregard of Forum Policies on Piracy"). Thats why i post and update it here
 

 

 

Dell XPS 15 (9550, Version of 2016) Sierra 10.13.1 Tutorial

post-19619-0-96849400-1486167401_thumb.png

 

 

 

Please use the GITHUB version of this text, because this tutorial got too fragmented for a simple forum thread - thanks to the latest Dell Firmware 1.2.25 which requires multiple different versions and tutorials and made the installation of OSX much harder for newbies :(

 

 

 

 

 

 

Before we start:
this installation includes real time DSDT/SSDT patching from within clover. This is pretty easy to install. But it is NOT suited for people with no or only few knowledge in Hackintosh Systems. If you only know how to copy commands in your shell and you dont know what they're doing, then stop the tutorial and revert to windows or buy a real mac. Even if you get it running: this system is not failsafe and will be broken multiple times in its usage time, where you have to fix it without a tutorial.
Optional steps are marked in GREEN, System dependent steps are BLUE

English is not my mother-tongue and i'm writing this without proof reading, so please forgive my bad spelling :)

If you've questions or something doesn't work: first check if you've done all steps of this tutorial! If yes: please read the whole thread (doesn't matter how long it is) before asking to prevent multiple questions. Additionally do a search in google and this forum.


Credits:
Many knowledge of "how to hackintosh a dell in the first place" by the tutorial of @Gymnae http://www.insanelymac.com/forum/topic/319766-dell-xps-9550-detailled-1011-guide/
Using many kexts and solutions from @RehabMan


What's not working:

  • Hibernation (works somehow, but high chance to destroy your whole data), Sleep works fine!
  • SD-Card reader
  • Killer 1535 Wifi (rarely used, need replace)
  • nVidia Graphics card (Intel works)
  • FileVault 2 (full HDD encryption)

Requirements:

  • one working MAC OS X Enviroment
  • 16GB USB Stick (larger is sometimes not bootable and/or requires advanced partitioning)
  • MacOS High Sierra 10.13.1 installation file from the app store (redownload, just in case)
  • Knowledge in PLIST editing
  • USB Harddrive for backup - you'll loose all data on your computer!

Step 1: Prepare Installation
Use the existing Mac to download the Sierra installer from the App Store and create a bootable USB stick with CLOVER. You can do this with the App "Pandora's Box" of insanelymac (use google for download link), which is pretty easy to use.
Optional: check if your SSD can be switched to 4k sector size. This prevents NVMe corruption. See https://github.com/wmchris/DellXPS15-9550-OSX/blob/10.13/4k_sector.md

After you've finished you need to download the Dell XPS 15 specific configurations for clover.
Link: https://github.com/wmchris/DellXPS15-9550-OSX/archive/10.13.zip
and unzip this file or checkout git directly:


git clone https://github.com/wmchris/DellXPS15-9550-OSX.git

You only need the folder 10.13, you can delete the 10.11. I'll refer to this folder by "git/"
Now mount the hidden EFI partition of the USB Stick by entering


diskutil mount EFI

Inside the terminal. Mac OS will automaticly mount the EFI partition of the USB stick, but just in case: make sure it really is
Overwrite everything in the CLOVER folder of the partition EFI with the content of git/10.13/CLOVER.
If your PC has a Core i5 processor, you'll have to modify your config.plist in EFI/EFI/CLOVER/: search for the Key ig-platform-id: 0x191b0000 and replace it with 0x19160000.

If you could use the 4k sector patch, replace the config.plist with the 4kconfig.plist. 
If you use a hynix device and you didnt do the 4k sector switch, you'll have to add the following patch to your config.plist


<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Hynix SSD patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>9sEQD4UcAQAA</data>
<key>Name</key>
<string>IONVMeFamily</string>
<key>Replace</key>
<data>9sECD4UcAQAA</data>

Go into the EFI Configuration (BIOS) of your Dell XPS 15:

 

Also disable the SD-Card Reader to reduce the power consumption drastically. Insert the stick on the Dell XPS 15 and boot it up holding the F12 key to get in the boot-menu and start by selecting your USB-Stick (if you've done it correctly it's named "Clover: Install macOS Sierra", otherwise it's just the brandname of your USB-Drive). You should get to the MacOS Installation like on a real mac. If you're asked to log-in with your apple-id: select not now! Reason: see Step 5.


Step 2: Partition and Installation
INFORMATION: after this step your computer will loose ALL data! So if you haven't created a backup, yet: QUIT NOW!

Dont install macOS yet. Select the Diskutil and delete the old partitions. Create a new HFS partition and name it "OSX". If you want to multiboot with Windows 10, then you'll have to create a second partition, too (also HFS! Dont use FAT or it will not boot! You have to reformat it when installing Windows). Make sure to select GUID as partition sheme.
Close the Diskutil and install OSX normally. You'll have to reboot multiple times, make sure to always boot using the attached USB stick. So dont forget to press F12. After the first reboot you should see a new boot option inside clover, which is highlighted by default. Just press enter. If you only see one, then something went wrong.



Step 3: Make it bootable
After a few reboots you should be inside your new macOS enviroment. You can always boot into it using the USB stick. Remove the USB drive after successful bootup. Enter

 


diskutil mount EFI

in your terminal, which should mount the EFI partition of your local installation.

install git/Additional/Tools/Clover_v2.4k_r4003.pkg. Make sure to select "Install Clover in ESP". Also select to install the RC-Scripts. This should install the Clover Boot System. Now copy everything from git/10.13/CLOVER to EFI/CLOVER like you did before by creating the usb stick. (if you had to modify the config.plist in step 1, do it here, too). Your system should be bootable by itself. Reboot and check if your system can boot by itself.


 
Step 4: Post Installation
Because all DSDT/SSDT changes are already in the config.plist, you dont need to recompile your DSDT (albeit i suggest doing it anyway to make your system a lil bit more failsafe, see gymnaes El-Capitan tutorial for more informations). So we can skip this part and go directly to the installation of the required kexts. Open a terminal and goto the GIT folder.


sudo cp -r ./Post-Install/LE-Kexts/* /Library/Extensions/
sudo mv /System/Library/Extensions/AppleACPIPS2Nub.kext /System/Library/Extensions/AppleACPIPS2Nub.bak 2> /dev/null
sudo mv /System/Library/Extensions/ApplePS2Controller.kext /System/Library/Extensions/ApplePS2Controller.bak 2> /dev/null
sudo ./AD-Kexts/VoodooPS2Daemon/_install.command

Now you'll have to replace the config.plist. Because you'll install modified kexts you'll HAVE TO replace the config.plist in your installation. Otherwise your PC will not boot anymore.


diskutil mount EFI

replace EFI/CLOVER/config.plist with git/Post-Install/CLOVER/config.plist. Again: if your PC has a Core i5 processor, search the config.plist for the Key ig-platform-id: 0x191b0000 and replace it with 0x19160000.

OPTIONAL (in case you've audio problems):
AppleHDA has some problems after Wake-Up. You'll have to plug in a headphone to get your speakers working again. You can use VoodooHDA instead, which breaks the headphone jack most of the time, but makes the rest much more stable.


sudo rm -r /Library/Extensions/CodecCommander.kext
sudo rm /EFI/EFI/CLOVER/ACPI/patched/SSDT-ALC298.aml

then remove from your config.plist from the key "KextsToPatch" the elements "AppleHDA#1" to "AppleHDA#7". Install the package: git/Post-Install/AD-Kexts/VoodooHDA-2.8.8.pkg
i also suggest moving some of the kext from EFI/CLOVER/kexts/10.13 to /Library/Extensions. It's just more stable.

Finalize the kext-copy by recreating the kernel cache:


sudo rm -rf /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache
sudo rm -rf /System/Library/PrelinkedKernels/prelinkedkernel
sudo touch /System/Library/Extensions && sudo kextcache -u /

sometimes you'll have to redo the last command if your system shows "Lock acquired".
OSX 10.12.2 removed the posibility to load unsigned code. You can enable this by entering


sudo spctl --master-disable

If you're using the 4K monitor, you'll have to copy the UHD enabling kexts to your clover directory:


sudo cp ./Post-Install/AD-Kexts/UHD-Kexts/* /EFI/EFI/CLOVER/kexts/10.13/

To enable GPU acceleration: Edit your clover config file again and remove the following block from it:

 

To prevent getting in hibernation (which can and will corrupt your data), just set the default sleep mode to "suspend to ram" (sleep) instead of "suspend to disk" (hibernation)


sudo pmset -a hibernatemode 0

To get HDMI Audio working:
Search for your Boarrd-ID in the config.plist and open /S/E/AppleGraphicsControl.kext/contents/plugin/AppleGraphicePolicy.kext/contents/info.plist with a texteditor. Search for your board-id in there and change the value of it from "Config2" to "none"
 
OPTIONAL (alternative power management):
the whole power management is done by intels speed step technology (HWP), which is enabled in the clover config. If you want to let OSX manage the power management, you'll have to do these steps:


sudo cp ./Post-Install/CLOVER/ACPI/optional/SSDT.aml /EFI/EFI/CLOVER/ACPI/patched/

then open the config.plist (/EFI/EFI/CLOVER/config.plist) and change <key>HWPEnable</key><true/> to <key>HWPEnable</key><false/>.
 
Step 5: iServices (AppStore, iMessages etc.)
 

WARNING! DONT USE YOUR MAIN APPLE ACCOUNT FOR TESTING! It's pretty common that apple BANS your apple-id from iMessage and other services if you've logged in on not well configured hackintoshs!

If you want to use the iServices, you'll have to do some advanced steps, which are not completly explained in this tutorial. First you need to switch the faked network device already created by step 4 to be on en0. Goto your network settings and remove every network interface.


sudo rm /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

Reboot, go back in the network configuration and add the network interfaces (LAN) before Wifi.

You also need to modify your SMBIOS in the config.plist of Clover in your EFI partition with valid informations about your "fake" mac. There are multiple tutorials which explain how to do it like "http://www.fitzweekly.com/2016/02/hackintosh-imessage-tutorial.html".

It's possible you have to call the apple hotline to get your fake serial whitelisted by telling a good story why apple forgot to add your serial number in their system. (aka: dont do it if you dont own a real mac). I personally suggest using real data from an old (broken) macbook.



Step 6: Upgrading to macOS 10.13.2 or higher / installing security updates
Each upgrade will possibly break your system!
(Update: after the latest updates in this tutorial the system should be update-proof.) 

 

Step 7: Fixes / Enhancements / Alternative Solutions / Bugs

See: https://github.com/wmchris/DellXPS15-9550-OSX/blob/10.13/Tutorial_10.13_Step7.md

 

Afterword and fixes
as i said before: this is not a tutorial for absolute beginners, albeit it's much easier then most other tutorials, because most is preconfigured in the supplied config.plist. Some Dells have components included, which are not supported by these preconfigured files. Then i can only suggest using Gymnaes tutorial which explains most of the DSDT patching, config.plist editing and kexts used in detail and use the supplied files here as templates.

Tutorial Updates

  • 27. March 2017: UHD Kexts added, replaces perl command
  • 23. March 2017: 4k sector tutorial against NVMe corruption added  
  • 7. March 2017: Suggestion to disable the SD Card Reader for reduced power consumption
  • 4. February 2017: Dell SMBIOS Truncation workaround added
  • 23. January 2017: Hynix SSD fix added
  • 31. December 2016: USB-C Hotplug Fix and USB InjectAll Removed
  • 28. December 2016: NVMe SSDT Spoof precreated, FakeID already preset in installation config.plist. VoodooHDA added as alternative to SSDT-ALC298 patch as well as color coding in tutorial
  • 22. December 2016: FakeSMBios added

Accessories Appendix:

  • The official Dell adaptor DA200 (http://accessories.euro.dell.com/sna/productdetail.aspx?c=at&l=de&s=dhs&cs=atdhs1&sku=470-abry) works completly on Sierra 10.2.2. You can use the Network, USB, HDMI and VGA. Everything is Hot-Pluggable
  • a cheap 3rd party noname USB-C -> VGA adaptor didnt work
  • you can charge the Dell with a generic USB-C Power Adaptor, but USB-C has only a maximum power of 100W, so it's either charging OR usage, not both. Dont forget you need a special USB-C cable (Power Delivery 3.0) for charging.

<key>Comment</key>
<string>IONVMeFamily Pike R. Alpha Hynix SSD patch</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>9sEQD4UcAQAA</data>
<key>Name</key>
<string>IONVMeFamily</string>
<key>Replace</key>
<data>9sECD4UcAQAA</data>

where in config.plist sdould I put in..???can you give more specific locataion

Share this post


Link to post
Share on other sites
17 hours ago, hotpapa1 said:

where in config.plist sdould I put in..???can you give more specific locataion

why do you quote the whole first post? please dont do this.

you put it in the kext patches.

Share this post


Link to post
Share on other sites

After updating to 10.13.4, when booting up every now and then I get a spinner before my user account shows up that doesn't go away. Has anybody else experienced this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DerNuntius
      Hi,
       
      Finally I finished the installation of 10.14.6 on my Dell E5440. Everything works just fine, but HDMI will not work. Every time I plug it in, it causes a grey screen on my laptop monitor. Also on boot up. I attached my EFI Folder, maybe someone can help me. I searched a bit and read something about Azul Framebuffer Kext.
       
      Thank you for helping.
      Greedings,
      Hugo
       
       
      CLOVER.zip
    • By benmills1
      Hi, i can someone help me with installing mac OS Mojave on my HP ENVY - 15-as102na?
      I have an imac to use for setting up my usb & installing MacOS Mojave.There are various kext files etc that i'm not sure about and need some help as some are hardware specific.
      I tried previously but got stuck on an apple logo and couldn't get past that, and tried today and had problems with Clover.
      Once i get mac os on my 128gb m.2 ssd ( which i'll upgrade to either a 256gb or 512gb depending on how well this hackintosh works)
      I have a free 2.5" inch hdd bay where i'd like to install windows on in the future.
      I think i may have to replace my wireless card ( based on a few google results) which i'm fine with as long as i can see it working without just so i know i won't waste money
      Specs:
      Cpu: i5 7200u
      GPU: HD 620
      8GB ram
      Wifi card- Intel Wireless 7265 ( Intel® 802.11ac (2x2) )
      Motherboard - HP 81D2 & BIOS version is f.56
      https://support.hp.com/gb-en/document/c05311862
      Thanks
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/forum/download/file.php?id=25033
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware
       
      CPU's
      8700k, 9600k, 9700k, 9900k
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
      There Is No Better Guide Then The One That @glasgood Has Already Written So Just Follow He's Guide For a Perfect Install.     
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 ( connected to monitor with DisplayPort )
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit
      • Coolermaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Mojave
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM943602CS 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
       
       
      CLOVER  FOLDER
      Use this folder with fully patched DSDT
      Z390 Pro DSDT EFI.zip   (Updated 21 July 2019)
       
       
      ADDITIONAL DSDT's  (A big thanks to @MaLd0n for compiling these extra DSDT's)
      If your using a Vega 56/64 or Radion VII then use this DSDT (already installed in my EFI)
      DSDT.VEGA.VII.zip
      If your using a RX Series or Nvidia GPU then use this DSDT
      DSDT.RXxxx.NVIDIA.zip
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://olarila.com/forum/viewtopic.php?f=19&amp;t=1131 
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      AirportBrcmFixup.kext    (If your Wifi Card isn't working after installing my EFI then add the AirportBrcmFixup.kext to your clover kext folder and reboot)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
      BIOS SETTINGS (Bios Revision F10)
       
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → Enabled  (Can be set to disabled depending on what GPU you use)
       
      • MIT → Advanced Memory Settings  → Extreme Memory Profile (X.M.P) → Enabled  
       
      • Peripherals → Initial Display Output → PCIe 1 Slot
      • Peripherals → Trusted Computing → Security Device Support →  Disable
      • Peripherals → Intel(R)Bios Guard → Intel BIOS Guard Support →  Disable
      • Peripherals → USB Configuration → Legacy USB Support →  Enabled
      • Peripherals → USB Configuration → XHCI Hand-off →  Enabled
      • Peripherals → Network Stack Configuration → Network Stack →  Disabled
      • Peripherals → SATA And RST Configuration → SATA Mode Selection →  AHCI
       
      • Chipset → Vt-d → Enabled  (can be enabled or disabled, your choice)
      • Chipset → Internal Graphics → Disabled
      • Chipset → Audio Controller → Enabled
      • Chipset → Above 4G Decoding → Disabled 
       
      • Power → Platform Power Management → Enabled
      • Power → ErP → Enabled  (can be enabled or disabled, your choice)
      • Power → RC6 (Render Standby) → Disabled
       
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS
       

       

       

       

       

       

       

       

       

       

       

       

×