Jump to content
Sign in to follow this  
Followers 0
daccko

Need Help about kexts for El Capitan - AMD Computers

5 posts in this topic

Recommended Posts

Hi everyone,

 

I have been using osx86 some years ago.

Now I have new pc and laptop and want to install el capitan on them, I need help about kexts for them, please help me out,

 

PC

-Athlon X2 3ghz (found kernels for it)

-AMD 970 Chipset - I need kexts

-Etron USB 3.0 Controller - I need kexts

-ATI Radeon HD 5570 - I have kext

-ASUS Xonar D1 - if there's a kext please help me out

-VIA VT 2021 - I have kexts

-Realtek GBe RTL8168/8111 (PHY: RTL8211/8212)

 

Laptop - Acer Aspire ES1-520

-AMD E1 2500 CPU 1.4GHz Dual-Core with ATI Radeon HD 8240 - I'm not sure which kernel will work, and which/if there's a kext for the GPU

-AMD Hudson 2 FCH Sata Ahci controller - I need kexts

-AMD USB 3.0 Controller - I need kexts

-Realtek Alc235 - I need Kexts

-Qualcomm Atheros ar956x - I need kexts

-Realtek rtl8168/8111 gbe - I need kext

-Bluetooth - I am not sure which vendor & model - I couldn't find any info - Broadcom drivers didn't found any broadcom bluetooth device - so it's probably Realtek Bluetooth

-Realtek usb 2.0 cardreader

 

 

Also please help me out about other kexts that are needed for usage, and for laptop battery-wake-sleep etc.

 

 

Thanks in advance,

Share this post


Link to post
Share on other sites
Advertisement

ASUS Xonar D1 - After a google search it looks like no one has gotten it working. I don't see anyone trying VoodooHDA with it so you can try that. No guarantee that you'll get it working.

 

AMD 970 Chipset - you don't install kexts for generic southbridge chipset support.

 

Etron USB3 - looks like people have used GenericUSBXHCI for OS X 10.10 and older though USB support changed in 10.11+ so I'm not sure if you can use it for Etron support in those newer versions. I am reading that Rehabman's build has gotten some specific USB3 chips supported though so you can try using it in 10.11. Link: https://bitbucket.org/RehabMan/os-x-generic-usb3/downloads/RehabMan-Generic-USB3-2015-1215.zip

 

As for the laptop, it looks like someone got the AMD E1 2500 APU working with graphics: http://www.insanelymac.com/forum/topic/285110-amd-working-builds/page-10?do=findComment&comment=2058854I usually don't recommend installing on AMD laptops because you usually cannot get graphics working but it looks like you have a chance here.

 

AHCI - You don't need special kexts for AHCI support. 

 

ALC235 - it seems it's supported in AppleALC but this is on an AMD chipset so that will change things. I'm sure you can use something like VoodooHDA and get it working.

 

AR956x - I assume AR9565 - I usually recommend to replace it with a better supported card but it looks like someone got it working in 10.11. You can give it a try - http://www.insanelymac.com/forum/topic/312045-atheros-wireless-driver-on-os-x-el-capitan-1011-for-unsupported-cards

 

Realtek rtl8168/8111 gbe - try http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/

 

Bluetooth - AR9565 is a wifi/bt combo card so that's where your bluetooth most likely is at.

 

Realtek card reader - need specifics. If it's not connected to the USB bus on the laptop then you might have issues. If it is USB then yes it will probably work. I'm reading people have had problems with realtek card readers that connect through pcie with the various 3rd party card reader kexts. You could always buy a cheap USB card reader that will work fine in OS X.

Share this post


Link to post
Share on other sites

Thank you nawcom,as for the card reader, I think it is usb connected.

 

Also I need help for El Capitan about fakesmc, NullCPUPowerManagement and battery managment. Thanks

Share this post


Link to post
Share on other sites

Looking into how spakk got his HD8240 working, it seems he's not giving his EFI string away. Also in another thread he says he couldn't get graphics acceleration working - he just got the max resolution detected: http://www.insanelymac.com/forum/topic/311336-amd-radeon-hd-8240-r3-series-on-el-capitan-1011/ SoI think you'll have to send him a message and see if he can explain where he's at with that.

 

For FakeSMC you can use the latest one - this version will work: https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads

 

NullCPUPowerManagement: http://files.nawcom.com/NullCPUPowerManagement.kext.zip

 

There are a couple kexts you can try for battery support, like https://bitbucket.org/RehabMan/os-x-acpi-battery-driver/downloadsand you may need a DSDT mod but let's try to get the OS working before worrying about that

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fusion71au
      Clover r4542 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 14 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4542 for VMware.zip". Mount Clover-v2.4k-4542-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By fantomas1
      hi people  
       
      you can use this thread to link / talk about of the future Nvidia Web Driver updates for El Capitan
       
      10.11.6
      Nvidia Web Driver - 346.03.15f15 --> build 15G21013 (thanks to BreBo)  New!
      Nvidia Web Driver - 346.03.15f14 --> build 15G20015 (thanks to DMCrimson)
      Nvidia Web Driver - 346.03.15f13 --> build 15G20015 (thanks to Louvier)
      Nvidia Web Driver - 346.03.15f12 --> build 15G19009 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f11 --> build 15G18013 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f10 --> build 15G17023 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f09 --> build 15G1611 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f08 --> build 15G1510 (thanks to Badruzeus)
      Nvidia Web Driver - 346.03.15f07 --> build 15G1421 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f06 --> build 15G1217 (thanks to bb1045)
      Nvidia Web Driver - 346.03.15f05 --> build 15G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 346.03.15f04 --> build 15G1108 (see this post)
      Nvidia Web Driver - 346.03.15f03 --> build 15G1004 (thanks to BreBo)
      Nvidia Web Driver - 346.03.15f02 --> build 15G31 (thanks to Moviemakergr)
      Nvidia Web Driver - 346.03.15f01 --> build 15G31 (thanks to WeBeRiO)
      [uPDATE_3]Nvidia Web Driver - 346.03.15b01 --> build 15G24b (thanks to DMCrimson)
       
      10.11.5
      Nvidia Web Driver - 346.03.10f02 --> build 15F34 (thanks to marcozardi)
      Nvidia Web Driver - 346.03.10f01 --> build 15F34 (thanks to WeBeRiO)
      [uPDATE_2] Nvidia Web Driver - 346.03.10b01 --> build 15F31a (see this post)
       
      10.11.4
      Nvidia Web Driver - 346.03.06f01 --> build 15E65 (see this post)
      Nvidia Web Driver - 346.03.06b01 --> build 15E (see this post)
       
      10.11.3
      Nvidia Web Driver - 346.03.05f02 --> second release for build 15D21 (thanks to Fljagd)
      Nvidia Web Driver - 346.03.05f01  --> build 15D21 (see this post)
      Nvidia Web Driver - 346.03.05b02 --> build 15D (see this post)
       
      10.11.2
      Nvidia Web Driver - 346.03.04f02 --> second public release (see this post)
      Nvidia Web Driver - 346.03.04f01 --> build 15C50 (see this post)  
      Nvidia Web Driver - 346.03.04b02 --> build 15C48a (see this post) 
      Nvidia Web Driver - 346.03.04b01 --> build 15C47a (see this post)
       
      10.11.1
      Nvidia Web Driver - 346.03.03f02 --> second public release (see this post) 
      Nvidia Web Driver - 346.03.03f01 --> build 15B42 (thanks to jperkins909)
       
      10.11.0
      Nvidia Web Driver - 346.03.02f02 --> build 15A284 (thanks to MTWomg)
      Nvidia Web Driver - 346.03.02f01 --> build 15A284 (see this post)
       
      DP
      Nvidia Web Driver - 346.03.01b07 --> GM/DB/PB6/DB7/PB5 (thanks to BreBo) 
      Nvidia Web Driver - 346.03.01b06 --> build 15A (thanks to MTWomg) 
    • By rio2
      How to make AppleHDAController load on Ryzen boards?
      Rename(/add) your audio controller to your DSDT/SSDT as HDEF Add a _DSM method to your HDEF device with layout id 1 Patch the AppleHDAController binary, because it has a static table containing the supported PCI Vendor/DeviceID pairs and it also checks the VendorID against known values. As an example I provide a dif file and patched 10.13.3 binary, but if you want to I can patch the binary for other versions.  
      After AppleHDAController loads to actually get sound working you need to patch AppleHDA.kext for the codec on your board. First I tried to use Lilu+AppleALC for this task, but for some reason it refused to work. (I might look into it later why) But for the time being it was easier to use toleda's cloverALC script for that, but to make it work I had to change(/remove) the specified location of the HDEF device from the script. And for some reason it also required me to mount the EFI partition manually.
       
      Change this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF@1") != 0 ]]; then Into this:
      if [[ $(cat /tmp/HDEF.txt | grep -c "HDEF") != 0 ]]; then  
      AppleHDAController_Patched10.13.3
      AppleHDAController-10.13.3-AMD.bdiff
    • By Teress
      Hi, I tried during last 4 days almost everything but now I call for help. I have RX560 running on 10.13.4. Previously I was running it on 10.12.6 and had the same problem, but after waking from sleep my thiord display came to life, but it is not working anymore on 10.13.4. Without or with Lilu & Whatewergreen my system correctly recognize my gpu as RX560 but only 2 of 3 displays are displaying content, third display is black but recieving some signal. When I change cabling and connect only two, any combination of 2 displays is working. System profiller and system preferences are sayin I have 3 displays connected.

      Please can somebody help me to figure it out?
      Thanks a lot in advance. Tried to upload my ioreg but it is greater than 10MB allowed for me :(



    • By verymilan
      Hi, i recently set up High Sierra on my AMD computer with the help of the amdosx community (i actually used an installer just to confirm that something would work in the first place before i spend hours for nothing, i can and could have downloaded High Sierra the "legal" way).
      However the graphicscard is recognized properly, the 6gig are recognized and i have no artifacts and no screen tearing with the official nvidia webdriver,
      but unfortunally, dark colors have horizontal dark stripes in them and specific bright colors like on left bar of system windows such as settings do flicker like low fps.

      I only used the clover on the flash drive for now and i'd like if it's worth digging deeper of if i should just forget about it as it is a common nvidia problem on macOS.
      Would be amazing to know.
       
      Closer machine infos:
      * High Sierra (misses a recent minor patch as my network is veeeery slow and i got this nvidia issue anyway so i mainly jumped back to linux)
      * AMD fx8350
      * Asus Sabertooth 990fx Ref. 2.0
      * NVIDIA GeForce GTX 1060 6GB
       
×