Jump to content
JahStories

[Guide] XiaoMi Mi Notebook Air 13"

663 posts in this topic

Recommended Posts

Advertisement

There is : all my uab booting drives tools are rendered useless cause they don't work with UEFI..!!

 

Anyway I just tried reinstall using UEFI. All good! Apart battery..? You said better in macOS, I loose 1%\min..!!

 

Sent from my Redmi 3s

Share this post


Link to post
Share on other sites

There is : all my uab booting drives tools are rendered useless cause they don't work with UEFI..!!

 

Anyway I just tried reinstall using UEFI. All good! Apart battery..? You said better in macOS, I loose 1%\min..!!

 

Sent from my Redmi 3s

Jeez.. you can boot legacy efi drives with uefi... use google.

 

And the battery-life is good. It's one of the few things that are stellar in this hackbook (compared to win).

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

That's why I'm wondering what's missing in mine! I followed and succeeded 100% of the instructions..

 

Sent from my Redmi 3s

Share this post


Link to post
Share on other sites

I realised I made a mistake when following the guide so I corrected. I end up with about ~4h battery life starting from 100%.

 

Doesn't matter which hpw mode I use. As far as I recall, Window's more on the ~6h side.. So I'm wondering still!

 

Sent from my Redmi 3s

Share this post


Link to post
Share on other sites

https://www.aliexpress.com/store/product/Mini-PCIe-to-NGFF-adapter-mini-PCI-e-convertor-For-M-2-Wifi-Bluetooth-GSM-HSPA/710969_2044204405.html?spm=2114.12010612.0.0.TW0Iiy (wrong adapter)
http://s.aliexpress.com/aMFzaYfy
https://www.benl.ebay.be/itm/191573387476

maybe something like this can make the A/E-key BCM94352Z compatible in the first PCIe M-key SSD slot, can someone confirm?

This video states that the first SSD slot is a PCIe slot at 0:40:

 

edit: wrong card

Share this post


Link to post
Share on other sites

@goja

what?!?! 6 hours??

doing what kind of web browsing? I mean if you just read stuff maybe but just playing a couple of videos on youtube you'll never get 6 real hours on battery!!

 

@dodvip123

Maybe that could work!

Btw we should remove the nvme drive... pretty sad!

But with a 1tb data drive partitioned on 2 parts one for each OS, should be enought!

Let us know if you are willing to try!!

Share this post


Link to post
Share on other sites

@goja

what?!?! 6 hours??

doing what kind of web browsing? I mean if you just read stuff maybe but just playing a couple of videos on youtube you'll never get 6 real hours on battery!!

 

@dodvip123

Maybe that could work!

Btw we should remove the nvme drive... pretty sad!

But with a 1tb data drive partitioned on 2 parts one for each OS, should be enought!

Let us know if you are willing to try!!

Yes if that works then Windows and macOS can be installed on the same SSD in the second slot.

I would try it if I had the laptop but I don't... And I will only buy it if this works.

Maybe someone who owns it can try

Share this post


Link to post
Share on other sites

Did you see any report from people with first rev (including soldered mpcie slot) who tried compatible WLAN card successful? I read different thread here and there, lots of questioning but strangely no reports..

 

Sent from my Redmi 3s

Share this post


Link to post
Share on other sites

Okay, i took the risk... bought both the laptop and the adapter from eBay (Germany) and they will arrive next Thursday. I will post any updates here.

Share this post


Link to post
Share on other sites

Nice, let us know!

it did not work... I bought a M key to A key adapter (only Wifi should work then in theory) but Windows did not recognize the BCM94352Z

I tried installing the drivers for Dell 1560 in Windows but still no go... I think both wifi and bluetooth need to work to make Windows recognize it.

 

For now, I'm using my iPhone and TetherMe (jailbreak app) to share my wifi connection through USB. Maybe in the future we might see support for the Intel 8260AC or someone comes up with a motherboard solution.

 

Which patches did you apply to the DSDT? I would like to patch my native DSDT myself.

 

Great laptop so far!

Share this post


Link to post
Share on other sites

oh, sad thing... maybe it's a problem related to the adapter, who knows...

btw I can't list you all the patched done on the tables, really a lot, not only on the dsdt and to make everything work, you'll have to use the full set provided!

I should update the package soon, cause I discovered a fix for the lid bug, but can't provide you a date yet...

Share this post


Link to post
Share on other sites

oh, sad thing... maybe it's a problem related to the adapter, who knows...

btw I can't list you all the patched done on the tables, really a lot, not only on the dsdt and to make everything work, you'll have to use the full set provided!

I should update the package soon, cause I discovered a fix for the lid bug, but can't provide you a date yet...

You found the issue?? Great man! Could you please tell me/us/pm what you found out?

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

using an ssdt disable the more efficient HWP...

Not suggested at all...

Could you find a source for that? Have you made some measurements? Cause according to Rehabman and to my personal findings, this isn't the case. Not for the same clock profile at least.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

I mean, just to explain, these are two different methods of scaling cpu frequency and it's not possible to use both (piker [or a simple research about HWP] confirms) and yes, lid bug is related to correctly enabling HWP without an SSDT and injecting correct sleep informations with a different ssdt...

Share this post


Link to post
Share on other sites

Hmm, I'm going with the SSDT way... I also patched my own ACPI files.

Btw I found my old Wifi USB RTL8192EU lying around and it works after installing this: http://www.insanelymac.com/forum/topic/311312-drivers-alternativi-1011-per-d-link-dwa-131-usb-wireless-n-nano/

 

one issue; lid sleep does not seem to work and USB devices won't work after sleep. This only occurs when closing the lid, sleep from apple menu or scheduled sleep works fine.

Share this post


Link to post
Share on other sites

From the Main post:

 

Don't use bios mods, other files with different patches or you'll get no help.

 

You are free to do whatever you want with your device, but obviously you'll have different issues using your own files instead of the provided one...

You'll still gonna have dedicated gpu active... no proper sleep... the lid bug(it's caused by not having correctly HWP enabled) plus tons of other small improvement made on more than 10 FilesPack upgrade.

 

And you'll gonna get no help!

 

:)

Share this post


Link to post
Share on other sites

 

 

From the Main post:

Don't use bios mods, other files with different patches or you'll get no help.

You are free to do whatever you want with your device, but obviously you'll have different issues using your own files instead of the provided one...

You'll still gonna have dedicated gpu active... no proper sleep... the lid bug(it's caused by not having correctly HWP enabled) plus tons of other small improvement made on more than 10 FilesPack upgrade.

 

And you'll gonna get no help!

 

:)

I patched the DSDT and SSDT myself because it is advised by RehabMan to always patch your own ACPI files. My Nvidia gpu is also disabled and iirc you also have the same issue as i have. If you find the sleep issue, can you share the patch you did?

Share this post


Link to post
Share on other sites

I don't have any sleep issue. (I had the lid bug but I fixed it)

 

Btw as said before, I'll not provide any help if you are using different files, if you wanna discuss about this, do it on another thread!

 

Respect the work of others and the thread rules.

 

P.s. 

I already told that the lid bug is related to wrong power managnment... and you are still saying you want to use that so... :/

Share this post


Link to post
Share on other sites

I don't have any sleep issue. (I had the lid bug but I fixed it)

 

Btw as said before, I'll not provide any help if you are using different files, if you wanna discuss about this, do it on another thread!

 

Respect the work of others and the thread rules.

 

P.s.

I already told that the lid bug is related to wrong power managnment... and you are still saying you want to use that so... :/

I must have misinterpreted the sleep issue, i thought it was related to a lid issue and not to the power management.

 

I do respect your work and I'm sorry if i offended you. I just try to follow RehabMan's advice on patching the ACPI files.

Share this post


Link to post
Share on other sites

When is the new Filepack coming? I'm really surprised that you managed to fix the lid bug that way! How did you even come to that conclusion?? I never would have thought of that.

 

Props to you my friend! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MardukPVP
      Hello guys,

      recently I have tried to install macOS mojave on my Mi Notebook pro (i5 - 8250u model) but have faced one big problem.
      My guide was from Razorkey (https://www.tonymacx86.com/threads/guide-xiaomi-mi-notebook-pro-high-sierra-10-13-6.242724/). As a newbie I have almost no experience in installing macOS on a PC / Laptop... so I hope you can help me .

      But first things first I configurated the BIOS settings on my Mi - Notebook Pro. Therein I just disabled secure boot (because there are quite few options to tick).

      After that I headed over to my secondary Windows - PC and installed a High Sierra virtual machine (thanks to this tutorial: https://techsviewer.com/install-macos-high-sierra-vmware-windows-pc/). At that point everything worked fine.

      Then I downloaded the Mojave patcher and downloaded the full 6GB macOS Installer, put it into applications and formatet my 16GB USB Stick into the journaled + GUID with the name USB meanwhile.
      Next I typed 
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB 
      into the terminal and at that point everything looked like it would work pretty fine. I downloaded Clover Config, mountet the EFI partition and pushed the EFI folder from this site: https://github.com/daliansky/XiaoMi-Pro to the EFI partition on my 16GB USB drive.

      In the folloing I restarted my Notebook, selected the MacOS installer and it bootet into the MacOS installer. By doing that I only noticed that the progress bar turned green at a certain time (attatchment). Even though everything bootet pretty fine, i formattet my only ssd (Samsung) into APFS + GUID and startet the installation.
      At the point of two minutes my notebook suddenly rebootet and it brang me into the same clover selection menue as before (with only one method [macOS Installation]). Unfortunately there was no further installation method.

      When I was trying to reboot the laptop into the installer i got a error [your computer restarted because of a problem...] and i would have to do everything again.


      I hope someone can help me fixing this problem  . Thanks in advance.




    • By ltooz_audis
      I got the perfect working macBook Air 7,2 working with Mojave - Everything is working - I do mean even the SD card reader - audio - backlight controlled with keyboards... I'll write up the full tutorial and video how to soon. Love the Mojave, High Sierra was nothing compared to this.
      Cheers,
      Louis
       
       
       
    • By Cerv4nteZ
      Hi,
       
      i just let my sierra installation on a skylake xiaomi air laptop update. after the obligatory reboot i was greeted with a kernel panic regarding com.apple.iokit.IOAHCIBlockStorage. Now booting into osx doesnt work anymore
       
      Anyone else run into this? Is there a way to make clover save the boot log on this or do you guys salvage the logs from the hfs volume osx resides on?
    • By JahStories
      Files Package For Xiaomi Mi Notebook Air 13” 2.1
      Bios vers A05 — CPU i5 6200U (confirmed working even on A06 bios)
       
      2.1 PACK FOR HIGH SIERRA ONLY, FOR SIERRA USE 2.0
       
      Discussion's thread.
       
      Not working:
      Wi-fi / Bluetooth. (Bluetooth works if using a VM to inject the FW)
      Nvidia Optimus 940MX GPU. (Optimus does not work on macOS at all)
       
      Issues:
      Excessive battery draining while on sleep.
       
      For 2.0 Steps check the discussion thread
      Steps:
       
       
       
      When updating to new versions of the filepack:
      Remove all old files and install the new ones following the ReadMIs.
      Just remember to use the same serials you used before.
       
      Don't use bios mods, other files with different patches or you'll get no help.
      Special thanks to:
      Jolly, gengik84, and RehabMan.
       
      By Jahstories on InsanelyMac a.k.a. EliJah on macos86.com
       

      HELP NEEDED?



      Please don't post a comment, use
      this thread !


      Thanks!


×