Jump to content
JahStories

[Guide] XiaoMi Mi Notebook Air 13"

662 posts in this topic

Recommended Posts

22 hours ago, dpunx said:
On 7/26/2018 at 9:47 PM, IS06DMX said:

EDIT:

I followed @sakoula's guide on page 21 without downloading kexts and used clover.xiaomi.4392.20180129.zip folder as EFI.

It works and I can boot and use macOS normally, but with a few problems.

First it doesn't shutdown properly, when I click shut down it shows texts as -v and stops at systemwillshutdown then hangs. 

Screensavers don't work, they are glitched, even as preview they are glitched as hell.

Launchpad is laggy and refreshes by blocks of lines, welcome screen refreshes numerous times (same block effect) and iTunes has some glitches at the top.

Audio works fine, at max it's a bit distorted, brightness doesnt work, bluetooth doesn't work even if it's VMware based download.

 

got some fixes?

 

 

Can someone help me out? (installation hang + kec.corecrypto)


 

  Reveal hidden contents

 

I downloaded macos using the patch tool (high sierra 13.6.02) on el capitan vmware, then formatted and installed on the usb via terminal.

then I installed Clover, using uefi only, clover esp, themes, drivers64uefi, rc scripts target volume.

Finally I copied all 2.1 filespack files on the EFI partition.

 

But I can't manage to start the installer, it gets stuck just after kec.corecrypto when it automatically restarts without launching the installer.

I tried with fakeid 0x123456789 but nada, then tried in pci options to enable both USB ownership and injection, but still nothing

 

My machine is i5 6200u 940mx BIOS A07 with standard nvme on windows and 120gb wd green for macos.

 

Any ideas why it's happening?

 

I uploaded my EFI and screenshot

 

Im new to this :)

 

thanks!

Screenshot_20180726-182452~2.png

EFI.zip

 

 

 

If your launchpad is laggy and the screensaver work with glitches seeems that not has graphic acceleration. See on "About this Mac" the graphic memory.

 

About shutdown, yes, not fix yet. At lest I've not found the patch.


@Elijah no new updates for 10.13.6 or 10.14? :P Really thanks for your job

Under "about this mac" there's only Intel HD graphics 520 7 MB

Can you help me out?

Edited by IS06DMX

Share this post


Link to post
Share on other sites
Advertisement
On 7/30/2018 at 5:32 PM, IS06DMX said:

Under "about this mac" there's only Intel HD graphics 520 7 MB

Can you help me out?

 

Update this kext --> IntelGraphicsDVMTFixup, IntelGraphicsFixUp and AppleIntelSKLGraphicsFramebuffer.

 

And the other option. Patch this on clover:

  • Kext: com.apple.driver.AppleIntelSKLGraphicsFramebuffer
  • Find: 764048FF 0561E907
  • Repl: EB4048FF 0561E907

Share this post


Link to post
Share on other sites

Hi everyone,

 

Is there someone that can give me the A06 BIOS ACPI tables for the Xiaomi 13.3 i5-6200U? (use F4 on clover bootscreen and send me the CLOVER/ACPI/origin directory) Currently I run A05 and would like to see what are the differences with A06 and whether it is worth upgrading.

Share this post


Link to post
Share on other sites

Thanks, works really well on the 2018 model too! :)

 

Here is my 2018 Xiaomi Air 13 running High Sierra

 

 

Edited by Original

Share this post


Link to post
Share on other sites

Hello! finally i installed high sierra in my xiaomi air 13" intel 8th, but, usb´s are not working, only work if i boot the system with the usb drive already connected, can you help me to fix this please?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Finally installed HS 10.13.6 using (clover.xiaomi.4392.20180129.zip) all works as expected, but audio does not wake from sleep (although it does start to work again if you insert 3.5mm headphones in then remove them and BTW headphones work fine).  Do I need to use CodecCommander.kext (edited)? But i have ALC 255 which does not appear in that kext - does it matter? Any suggestions greatly appreciated.

Edited by magicthighs

Share this post


Link to post
Share on other sites

This is my all jobs.. Running Mojave

https://github.com/johnnync13/Xiaomi-Notebook-Air-6200u (6200u 6500u)

https://github.com/johnnync13/EFI_XIAOMI_NOTEBOOK_AIR_SKYLAKE(m3-6y30)

https://github.com/johnnync13/XiaomiGaming(i7-8750h)

https://github.com/johnnync13/Xiaomi-Mi-Air(i5-8250u i7 8550u)

Edited by johnnynuca14

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

 

I have a Xiaomi Mi Air 13.3 Skylake-U 2016 (first generation) and I have created a repository with a very detailed guide on how to configure your system in order to run High Sierra and Mojave based on this excellent work of JahStories! I tried to keep the configuration lean and clean and justify everything that I have been doing and document everything as much as I could. It is located on github at https://github.com/sakoula/XiaoMi-Air-6200U

 

I hope it may be useful to some of you.

 

Thanks

sakoula

Edited by sakoula
formatting

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ltooz_audis
      I got the perfect working macBook Air 7,2 working with Mojave - Everything is working - I do mean even the SD card reader - audio - backlight controlled with keyboards... I'll write up the full tutorial and video how to soon. Love the Mojave, High Sierra was nothing compared to this.
      Cheers,
      Louis
       
       
       
    • By Cerv4nteZ
      Hi,
       
      i just let my sierra installation on a skylake xiaomi air laptop update. after the obligatory reboot i was greeted with a kernel panic regarding com.apple.iokit.IOAHCIBlockStorage. Now booting into osx doesnt work anymore
       
      Anyone else run into this? Is there a way to make clover save the boot log on this or do you guys salvage the logs from the hfs volume osx resides on?
    • By JahStories
      Files Package For Xiaomi Mi Notebook Air 13” 2.1
      Bios vers A05 — CPU i5 6200U (confirmed working even on A06 bios)
       
      2.1 PACK FOR HIGH SIERRA ONLY, FOR SIERRA USE 2.0
       
      Discussion's thread.
       
      Not working:
      Wi-fi / Bluetooth. (Bluetooth works if using a VM to inject the FW)
      Nvidia Optimus 940MX GPU. (Optimus does not work on macOS at all)
       
      Issues:
      Excessive battery draining while on sleep.
       
      For 2.0 Steps check the discussion thread
      Steps:
       
       
       
      When updating to new versions of the filepack:
      Remove all old files and install the new ones following the ReadMIs.
      Just remember to use the same serials you used before.
       
      Don't use bios mods, other files with different patches or you'll get no help.
      Special thanks to:
      Jolly, gengik84, and RehabMan.
       
      By Jahstories on InsanelyMac a.k.a. EliJah on macos86.com
       

      HELP NEEDED?



      Please don't post a comment, use
      this thread !


      Thanks!


×