Jump to content
JahStories

[Guide] XiaoMi Mi Notebook Air 13"

662 posts in this topic

Recommended Posts

when i try to create from scratch a new USB stick with TERMINAL it' also NO WAY with CMD NOT FOUND!

 

Last login: Fri Feb  2 11:09:56 on ttys000

MacBook-Pro-de-BG:~ babaorum$ sudo /Applications/Installer\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/clemacos --applicationpath /Applications/Installer\ macOS\ High\ Sierra.app --nointeraction &&say Done

Password:

sudo: /Applications/Installer macOS High Sierra.app/Contents/Resources/createinstallmedia: command not found

MacBook-Pro-de-BG:~ babaorum$

It's Install macOS High Sierra.app not Installer macOS High Sierra.app

 

Boot with -v and debug = 0x100 to prevent reboot on error

Share this post


Link to post
Share on other sites
Advertisement

hello,

 

YES it's INSTALL instead of INSTALLER...

Also i used DISKMAKER X and it worked great to build a new fresh USB Stick installer.

 

YES i also Boot with -v and debug = 0x100 to prevent reboot on error.

 

This new made installer seems to perform much better than the previous one but it also finish with a frozen screen;

com.apple.xpc.launchd(1) service exited with abnormal code :1

service only ran for 0 seconds Pushing respawn out by 10 seconds.

 

Then nothing more happens and i have to press the Power BTN until Shutdown since no Other Cmd lets me Restart properly...

Pushing the Power BTN until STOP is no good since it regularily corrupt the desktop of the Mac Disk...

 

I don't know what to do now but i will try with less kexts in the Other folder...

 

I just check my MacOs HS Install app: it's version 13.2.07...

Maybe it's the reason why i cannot finnish the installation...?

So i will try to download the latest one 13.3.3 and check if everything works better

 

UNFORTUNATELY it's very difficult to find HS 13.3 for download... i have only get the combo {censored}... 

 

Thanx for your help

Share this post


Link to post
Share on other sites

Hi bergui45

 

1. format (reinitialize) the usb stick

2. install high sierra 10.13.3 on it

3. download clover `Clover_v2.4k_r4392`

4. install clover as in the attached screenshots

5. mount the EFI partition of the stick

6. delete EFI/CLOVER/config.plist and copy that file from my provided zip

7. delete EFI/CLOVER/ACPI and copy this directory over from my provided zip

8. delete EFI/CLOVER/drivers64UEFI and copy this directory over from my provided zip

9. delete EFI/CLOVER/kexts and copy this directory over from my provided zip

10. boot with the stick

12. on the clover boot screen goto Options > Graphics Injector > FakeID: 0x123456789 

13. go back to the main screen boot and report back

 

These steps worked for me on my laptop. The only difference that I have the BIOS version (I have A05). However urashimataro has A06 as you and it worked for him.

 

sakoula 

sorry but i'm STUCK since i cannot find anywhere High sierra 10.13.3 but only this piece of {censored} COMBO updater...

My High Sierra Installer is version 13.2.07...

;-(

Share this post


Link to post
Share on other sites

hello sakoula,

 

Let me know how to use successfully my version 10.13.2.07 instead of the 10.13.3 since i'm unable to get it from the Apple store...

Share this post


Link to post
Share on other sites

Héy there, this pack would work for the last version of the Mi Air 13? I'd pick the one with i7.

 

Sent from my Redmi 3S using Tapatalk

Share this post


Link to post
Share on other sites

Héy there, this pack would work for the last version of the Mi Air 13? I'd pick the one with i7.

 

Sent from my Redmi 3S using Tapatalk

 

@Goja not sure. Possibly no as it is, it requires some changes. It is a different processor. This thread is dedicated only to the 2016 version. 

hello sakoula,

 

Let me know how to use successfully my version 10.13.2.07 instead of the 10.13.3 since i'm unable to get it from the Apple store...

 

What do you mean? Up to now I assumed that you had a USB stick with 10.13.3 on it, clover installed and the files of the zip I provided. Is this the case?

 

To get the latest macOS from the appstore, delete the current version from /Applications , empty the recycle bin and then download it again.

Share this post


Link to post
Share on other sites

hello sakoula,

 

You said:

What do you mean? Up to now I assumed that you had a USB stick with 10.13.3 on it, clover installed and the files of the zip I provided. Is this the case?

 

To get the latest macOS from the appstore, delete the current version from /Applications , empty the recycle bin and then download it again.

After doing your prescription i went back in the appstore and re downloaded the wanted HS 10.13.3

But i got a 10.13.3.02 instead???

Share this post


Link to post
Share on other sites

I'm confused with USB & Sleep : is it still supposed to work after wake? It doesn't here.. What did I do wrong?

 

Sent from my Redmi 3S using Tapatalk

Share this post


Link to post
Share on other sites

In the Finder i get application: 5,21 GO

Creation 18/01/18

Version 13.3.02

 

Yes it is right. Mine is saying the same. Use this.

If you find a thread detailing about install on the 2017 version, let us know ;)

 

Sent from my Redmi 3S using Tapatalk

 

@Goja check this thread https://www.tonymacx86.com/threads/xiaomi-mi-notebook-air.198598/page-30#post-1659599

Share this post


Link to post
Share on other sites

hello Sakoula,

 

IT DOESN’T WORK!

It sounds using the same serials in your config.plist is not a wize idea!

 

OK it works on your computer with your serials…

ACPI exception : AE_ALREADY_EXISTS…

AMFILOadTrustedKeys from NVRAM failed getting NVRAM

 

So I will try using my old serials that worked on Sierra instead…

Alternatively I may generate my own new serials with Clover configurator…


post-2077932-0-30736800-1517999349_thumb.jpg

 

obviously like M.Banjo said " Copy previous SMBIOS informations to the config.plist included in the 2.1 download and add to EFI volume...

Share this post


Link to post
Share on other sites

bergui45, the serials do not matter during installation. This is NOT a config.plist problem.

 

I think it is more of an NVRAM issue of the BIOS. Since you have been using macOS Sierra most likely macOS have been writing on the 'nvram segment'. For some reason now it cannot read it any more.

 

Try the following:

 

1. get into the BIOS and reset your BIOS settings to default/factory setting. I hope that this will reset the nvram area as well. Make sure that you know what settings you have change in order to make the changes again. I think this is more likely your problem. If this will not work:

 

2. let clover handle the NVRAM on a software layer: reinstall clover on the stick using the following options

 

```

Install for UEFI booting only

Install Clover in the ESP

Drivers64UEFI > EmuVariableUefi-64

Drivers64UEFI > OsxAptioFix2Drv-64

Drivers64UEFI > OsxFatBinaryDrv-64

Install RC scripts on target volume

```

 

After doing this copy from my latest zip the CLOVER folder but DO_NOT_OVERWRITE the drivers64UEFI directory. 

 

see if it boots.

Share this post


Link to post
Share on other sites

hello Sakoula,

Booting while pressing F2 then you are in the BIOS

The only thing i find is F9 = Setup Defaults

 

Let me know should i do that : hitting F9 ?

 

DO_NOT_OVERWRITE the drivers64UEFI directory. 

 

But it is what i've done while copy & paste from your folder...?

Share this post


Link to post
Share on other sites

I apologize for my prolonged silence but there is nothing I can contribute. I was successful simply following instructions, but I don’t really understand what is happening. What I can say is that I have reinstalled HS three times, always with the same serial number (my own), adding kexts and doing more experimenting. Always worked perfectly, quickly and without a hitch. Why should Bergui have so many problems beats me.

Share this post


Link to post
Share on other sites

your latest clover zip has all the kexts subfolders such as 10.6, 10.7,10.8, 10.9, 10.10, 10.11, 10.12, 10.13 + other?

That's the unmodified result of a fresh clover installation?

I REMOVED ALL EXCEPT OTHER...

 

Let me know why Claude Tech is like dead from the flu on this forum...?

Recently however, he asked me how have i managed to update my BIOS from A05 to A06...

Share this post


Link to post
Share on other sites

I apologize for my prolonged silence but there is nothing I can contribute. I was successful simply following instructions, but I don’t really understand what is happening. What I can say is that I have reinstalled HS three times, always with the same serial number (my own), adding kexts and doing more experimenting. Always worked perfectly, quickly and without a hitch. Why should Bergui have so many problems beats me.

Please could you kindly give full details of the instructions you followed to have success?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MardukPVP
      Hello guys,

      recently I have tried to install macOS mojave on my Mi Notebook pro (i5 - 8250u model) but have faced one big problem.
      My guide was from Razorkey (https://www.tonymacx86.com/threads/guide-xiaomi-mi-notebook-pro-high-sierra-10-13-6.242724/). As a newbie I have almost no experience in installing macOS on a PC / Laptop... so I hope you can help me .

      But first things first I configurated the BIOS settings on my Mi - Notebook Pro. Therein I just disabled secure boot (because there are quite few options to tick).

      After that I headed over to my secondary Windows - PC and installed a High Sierra virtual machine (thanks to this tutorial: https://techsviewer.com/install-macos-high-sierra-vmware-windows-pc/). At that point everything worked fine.

      Then I downloaded the Mojave patcher and downloaded the full 6GB macOS Installer, put it into applications and formatet my 16GB USB Stick into the journaled + GUID with the name USB meanwhile.
      Next I typed 
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB 
      into the terminal and at that point everything looked like it would work pretty fine. I downloaded Clover Config, mountet the EFI partition and pushed the EFI folder from this site: https://github.com/daliansky/XiaoMi-Pro to the EFI partition on my 16GB USB drive.

      In the folloing I restarted my Notebook, selected the MacOS installer and it bootet into the MacOS installer. By doing that I only noticed that the progress bar turned green at a certain time (attatchment). Even though everything bootet pretty fine, i formattet my only ssd (Samsung) into APFS + GUID and startet the installation.
      At the point of two minutes my notebook suddenly rebootet and it brang me into the same clover selection menue as before (with only one method [macOS Installation]). Unfortunately there was no further installation method.

      When I was trying to reboot the laptop into the installer i got a error [your computer restarted because of a problem...] and i would have to do everything again.


      I hope someone can help me fixing this problem  . Thanks in advance.




    • By ltooz_audis
      I got the perfect working macBook Air 7,2 working with Mojave - Everything is working - I do mean even the SD card reader - audio - backlight controlled with keyboards... I'll write up the full tutorial and video how to soon. Love the Mojave, High Sierra was nothing compared to this.
      Cheers,
      Louis
       
       
       
    • By Cerv4nteZ
      Hi,
       
      i just let my sierra installation on a skylake xiaomi air laptop update. after the obligatory reboot i was greeted with a kernel panic regarding com.apple.iokit.IOAHCIBlockStorage. Now booting into osx doesnt work anymore
       
      Anyone else run into this? Is there a way to make clover save the boot log on this or do you guys salvage the logs from the hfs volume osx resides on?
    • By JahStories
      Files Package For Xiaomi Mi Notebook Air 13” 2.1
      Bios vers A05 — CPU i5 6200U (confirmed working even on A06 bios)
       
      2.1 PACK FOR HIGH SIERRA ONLY, FOR SIERRA USE 2.0
       
      Discussion's thread.
       
      Not working:
      Wi-fi / Bluetooth. (Bluetooth works if using a VM to inject the FW)
      Nvidia Optimus 940MX GPU. (Optimus does not work on macOS at all)
       
      Issues:
      Excessive battery draining while on sleep.
       
      For 2.0 Steps check the discussion thread
      Steps:
       
       
       
      When updating to new versions of the filepack:
      Remove all old files and install the new ones following the ReadMIs.
      Just remember to use the same serials you used before.
       
      Don't use bios mods, other files with different patches or you'll get no help.
      Special thanks to:
      Jolly, gengik84, and RehabMan.
       
      By Jahstories on InsanelyMac a.k.a. EliJah on macos86.com
       

      HELP NEEDED?



      Please don't post a comment, use
      this thread !


      Thanks!


×