Jump to content
JahStories

[Guide] XiaoMi Mi Notebook Air 13"

647 posts in this topic

Recommended Posts

On what bios version are you currently?

 

A06

 

I'll describe some problems that I noticed on 10.13 with pack 2.1:
1. Problems with the display of the battery (after installing ACPIBatteryManager.kext from 10.01 everything works well)
2. Artifacts when the system boots
3. Sound does not work through headphones (strong distortion)
? - the minimum level of brightness is completely different from the display backlight (I'm not sure if this is a problem, but if it's possible to fix it - let me know)

 

I have the same problems too. 

Regarding to sound problem there is a not so well workaround: move sound balance to the left or to the right

Share this post


Link to post
Share on other sites
Advertisement

A06

I have the same problems too. 

Regarding to sound problem there is a not so well workaround: move sound balance to the left or to the right

I confirm that it works correctly if you change the sound balance. Thank you.

Share this post


Link to post
Share on other sites

I tried everything without luck.

 

1. Reseted BIOS settings

2. Two USB drives

3. Image using RDrive, DiskMaker and OSX Terminal

4. Original package + nayzebo 

5. Different configs with differente serial numbers, board numbers and Chasis (The one in the package says iMac not Macbook Alluminum)

 

My Xiaomi has a A06 BIOS, working great with Sierra.

Share this post


Link to post
Share on other sites

I tried everything without luck.

 

1. Reseted BIOS settings

2. Two USB drives

3. Image using RDrive, DiskMaker and OSX Terminal

4. Original package + nayzebo 

5. Different configs with differente serial numbers, board numbers and Chasis (The one in the package says iMac not Macbook Alluminum)

 

My Xiaomi has a A06 BIOS, working great with Sierra.

Same with me

Share this post


Link to post
Share on other sites
Hi, I've followed the guide and installed successfully macOS.
I've also enabled the bluetooth via the VM, my question is: 

 

Is it possible to enable handoff?

Share this post


Link to post
Share on other sites

i`ve done a reset on bios to the default.

After that worked for me .

Know i have 10.13 and it`s working , but first install failed because of new APFS file system that i formatted to see if it`s working :)

Share this post


Link to post
Share on other sites

Facing some graphic issues, I don't know if you guys have them, 

 

Kext installation was successful and almost everything is working , however I hdmi is not working , animations are luggy (same thing happened in Sierra fixed with the SKLGraphics kext) however after 2 tries is still not working, what I did is just drag and drop from folder to easy kext pro.

 

Any ideas?

 

Thanks

Share this post


Link to post
Share on other sites

Facing some graphic issues, I don't know if you guys have them, 

 

Kext installation was successful and almost everything is working , however I hdmi is not working , animations are luggy (same thing happened in Sierra fixed with the SKLGraphics kext) however after 2 tries is still not working, what I did is just drag and drop from folder to easy kext pro.

 

Any ideas?

 

Thanks

Easy kext pro is having graphic issues. It looks in a strange way weird, but furthermore my MiBook works great :)

about HDMI I honestly don't know, but maybe I'll test it tomorrow.

 

oh.. and btw: I also have issues with sound. But fixed them as described above.

Share this post


Link to post
Share on other sites

Easy kext pro is having graphic issues. It looks in a strange way weird, but furthermore my MiBook works great :)

about HDMI I honestly don't know, but maybe I'll test it tomorrow.

 

oh.. and btw: I also have issues with sound. But fixed them as described above.

 

Does System preferences get the right size of the display? mine says 30 inches...and yeah easy kext has some graphic errors, for me sound works same as in windows...

Share this post


Link to post
Share on other sites

It would be cool if you can credit everyone's kexts used?

not gonna say anything more 

I'm sure nothing in the package is your work, everyone who contributed to it is well credited, don't worry mr. no one.

Share this post


Link to post
Share on other sites

Hello Jah, 

 

I tried to fix the graphic issues without success, however after I tried to rebuild the kext with

 

sudo touch /System/Library/Extensions && sudo kextcache -u /

AppleIntelSKLGraphicsFramebuffer.kext is not valid; omitting.

 
It says that the Intel kext is not valid...
 
everything is where it should be but no hdmi, it says 30 inch display and some apps like Spotify do not work (plus the lags on animations)
 
any idea how to fix this?
 
I had errors while moving the DisplayVendor file (it said no such file or directory) after reading on internet it was probably because of SIP so I disabled it with clover configurator, tried to copy it, it worked, restarted , nothing, tried to reinstall the kext, nothing.
 
I don't know what else I can do.

Share this post


Link to post
Share on other sites

any idea how to fix this?

 

1. You don't need to install AppleIntelSKLGraphicsFramebuffer.kext at all. If you have installed it into Clover directory then just remove it, if into /System/Library/Extensions then you need to restore original kext.

2. There is a mistake in Readme. You need to copy config file into /System/Library/Displays/Contents/Resources/Overrides/DisplayVendorID-4d10/DisplayProductID-1447

Share this post


Link to post
Share on other sites

1. You don't need to install AppleIntelSKLGraphicsFramebuffer.kext at all. If you have installed it into Clover directory then just remove it, if into /System/Library/Extensions then you need to restore original kext.

2. There is a mistake in Readme. You need to copy config file into /System/Library/Displays/Contents/Resources/Overrides/DisplayVendorID-4d10/DisplayProductID-1447

 

Nothing...Tried what you did

 

Do you see anything wrong?

post-2048879-0-67623900-1507757850_thumb.png

post-2048879-0-74291600-1507757855_thumb.png

Share this post


Link to post
Share on other sites

Do you see anything wrong?

 

Yes, your file named ProductID-1447 instead of DisplayProductID-1447, but it shouldn't be the reason of animation lags.

Attach you config.plist and boot log (you can create it by CloverConfigurator from left menu Boot.log)

Share this post


Link to post
Share on other sites

For those upgrading from 2.0 to 2.1, these are the steps I took and it worked fine to upgrade directly:

 

  1. I upgraded my Clover version to the latest version using the Settings preference pane.
  2. Copy new folder structure and items from 2.1 Filespack Download to existing EFI volume, making sure they match.
  3. Copy previous SMBIOS information to the config.plist included in the 2.1 download and add to EFI volume
  4. Download and install High Sierra upgrade from App Store.
  5. When PC reboots, make sure you select the macOS Install boot options twice, and then the macOS volume to complete the setup.
  6. Install the two kernel extensions again (I use the manual method, not EasyKextPro because that always bricks my machine).
  7. I needed to hide the volume "Preboot" from the boot menu using Clover Configurator -> GUI tab. While you're there, change the default language from "it" to "en" for English.
  8. Done. Very happy the existing hard drive is now natively supported and loving APFS.

 

Added a patch for solving external disk 10.13 in the post

 

Awesome! Was my only issue.

Share this post


Link to post
Share on other sites

4. Sleep (does not wake up, the indicator on the power button is constantly on);

 

Hi angry.cheburashka!

Did you try to wake up a notebook by power button? It should work.

Share this post


Link to post
Share on other sites

Hey,

i have read the complete thread. Because I buyed a Xiaomi Air 13.3 (2017 Version) and I want WLAN and Bluetooth without any ugly mini usb stick looking out of my book...

I understand that the 13.3 Inch (2016) have in the first revisions a M.2-Port (NGFF) with B-Key. Soo, I have read from another forum, that a guy tested a M.2 adapter and put a Broadcom-WLAN-Bluetooth-Card on it. But it doesn't appear in Windows.. That's because the Bluetooth on the card needs USB, that doesn't provide from the third WWAN-M.2-Slot in the Air 13.3..

So, my idea..
And I have no idea, if a third WWAN-M.2-Slot in the Air 13" 2017 Version longer exists (or a second with PCIe). Because there is no picture on the whole internet, only disasembly videos for the 2016-Version, where the hype came.. 

But when it have a second M.2 PCIe-Slot, I want to try following.
You buy following stuff (it's in german, but you can see what I mean.. clear.png)

http://www.ebay.de/itm/USB-3-0-Verl...553593?hash=item1ecdd8c1f9:g:~CEAAOSw9DVZsRhW

http://www.ebay.de/itm/USB-3-0-Adap...&sd=132302553593&_trksid=p2047675.c100623.m-1
https://www.amazon.de/dp/B01N23UMRB/?tag=tonymacx8603-21

You put it all together and then add Hackintosh-compatible USB-WLAN and Bluetooth-Sticks. Maybe you find a U.FL-Pigtail to SMA-Adapter and connect the USB-WLAN with the original Xiaomi-WLAN-Antenna.

The only problem I see:

The space in the notebook. Maybe you must cut off the plastic from the M.2-USB-Adapter to fit in. But it is worth a try!
Sorry for my english, I hope you can unterstand my idea. clear.png

I hope, I get an answer - maybe a pic on the open backside from a 2017-Version? clear.png
When I get my from china in a few days (hopefully), I can say you more!

Greetings,
Robin

Share this post


Link to post
Share on other sites

Hi angry.cheburashka!

Did you try to wake up a notebook by power button? It should work.

Hello! 

Hm, strange, I do checked sleep on my laptop and it does not respond to a power key ... But now it works, though the computer still does not sleep well. Thanks for the answer

I updated my post

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Cerv4nteZ
      Hi,
       
      i just let my sierra installation on a skylake xiaomi air laptop update. after the obligatory reboot i was greeted with a kernel panic regarding com.apple.iokit.IOAHCIBlockStorage. Now booting into osx doesnt work anymore
       
      Anyone else run into this? Is there a way to make clover save the boot log on this or do you guys salvage the logs from the hfs volume osx resides on?
    • By JahStories
      Files Package For Xiaomi Mi Notebook Air 13” 2.1
      Bios vers A05 — CPU i5 6200U (confirmed working even on A06 bios)
       
      2.1 PACK FOR HIGH SIERRA ONLY, FOR SIERRA USE 2.0
       
      Discussion's thread.
       
      Not working:
      Wi-fi / Bluetooth. (Bluetooth works if using a VM to inject the FW)
      Nvidia Optimus 940MX GPU. (Optimus does not work on macOS at all)
       
      Issues:
      Excessive battery draining while on sleep.
       
      For 2.0 Steps check the discussion thread
      Steps:
       
       
       
      When updating to new versions of the filepack:
      Remove all old files and install the new ones following the ReadMIs.
      Just remember to use the same serials you used before.
       
      Don't use bios mods, other files with different patches or you'll get no help.
      Special thanks to:
      Jolly, gengik84, and RehabMan.
       
      By Jahstories on InsanelyMac a.k.a. EliJah on macos86.com
       

      HELP NEEDED?



      Please don't post a comment, use
      this thread !


      Thanks!


    • By firefly_can_fly
      Gizmochina say, that china's headliner smartphone company goes deeper, and want to be Chinese Apple. They started to assemble  notebooks, that look like made by apple, but with slightly cheaper price and on steroids:
       
      Operating System: Linux Processor: CPU series Intel Core i7 4-generation family RAM: 8GB Screen size: 15.6-inches Screen Resolution: 1920×1080 Screen technology: LED backlight Graphics chip: NVIDIA GeForce GTX 760M Memory capacity: 2GB Price: 2999 Yuan ($466) And it looks like this:
       
       
      They start in april. As for me, I'm waiting for this to try, and install there Hackintosh. If it would be possible with Ozmosis, then it would be my daily driver laptop. 
×