Jump to content
JahStories

[Guide] XiaoMi Mi Notebook Air 13"

662 posts in this topic

Recommended Posts

Advertisement

Delete intelBacklight.kext and try again

am I correct by mounting the EFI on the desktop by Clover and then copy all the files EFI/CLover in the filepack2.0 to the EFI on the desktop? what about other kext in the filepack 2.0, how can I installed them? Can I use kext utility for installing kext?

 

 

Thank you,

I try to delete the intelbacklight.kext and then reboot, other error come up. 

 

photo6116359783050225663.jpg

 

It is not working.  Can anyone explain thouroughly what should I do exactly after install the Mac OS on the harddisk, and where and by what way the files from filepack2.0 should be copied to?  I am so confused.  I mount the Clover once I have the Mac OS installed on the harddisk, and it mounted the EFI.  Do I just drag across all the files in the EFI/Clover in the filepack 2.0 to the EFI/Clover on the desktop? But then, the Mac will say it is not the same version it was running when it was reboot? 

 

I am sorry I am so confused and don't know what to do.  Please help thank you. 

Share this post


Link to post
Share on other sites

1 Put all EFI clover from the pack to EFI Clover pm your harddisk.

Then Open clover configurator and mount your hdd EFI. Then go to EFI Clover config.plist.

Open the plist into clover configurator.

Go to SMBIOS. Choose One (MacBook Pro )

After u set the smbios, change the Name to MACBOOK PRO 13,1

Save reboot!

(If dont boot, at boot choose settings,graphics tuning, and set 0x123456789 to IntelFakeID) If u miss the passages It wont boot.

If u still Cant boot i Cant help u more, u should Ask in the Xiaomi Tread If someone gives u the KextPatches For Nvme for Clover.

Share this post


Link to post
Share on other sites

Thx Allan :)

But that kext is already in the 2.0 filepack! :yes:  ^_^

I added it thanks to a suggestion from Gengik84, this is from 2.0 changelog:

New kext (DisableTurboBoostBattery.kext) to disable CPU Turbo on battery mode.

Share this post


Link to post
Share on other sites

Thx Allan :)

But that kext is already in the 2.0 filepack! :yes:  ^_^

Yeah I know. I just answered @axel question.
 
Maybe now he'll use your pack, and install it.
 

Congrats for your good job  ;)

Share this post


Link to post
Share on other sites

Yeah good job i mean but idont knwo what the kext do before!.. Hmm so its fine without turbo while rendering.. Im saying this cause ive found the Xiaomi with battery drain, also with the kext! I reccomend use the kext so guys! 

Share this post


Link to post
Share on other sites

Hi, I've tried to install 12.5 but had a problem with nvme and use my clone to re-create my old system, but I needed to reinstall the AppleIntelSKLGraphicsFramebuffer.kext as said in the guide then.. And I had a problem like this a long time ago, and still need to reinstall it.. Is it normal ? 

 

(Well I will try 12.5 again) 

Share this post


Link to post
Share on other sites

The only way to adjust brightness, for me, is using Brightness slider app from App Store

 

 

 

 

Edit:  Brightness slider app doesn't adjust brightness. Only put a smoked layer on top...

         No brightness control for me.

Share this post


Link to post
Share on other sites

Link to unsupported thread have been removed and btw are not related to the now bypassed lid bug....

And i dont know what are you guys doing but the only issue caused by not using the now not supported intelbacklight kext is having less backlit steps...

Using the package i can adjust brightness both from keyboard hot keys and from macos system preferences.

Share this post


Link to post
Share on other sites

McBanjo: I will try again soon; When I tried a week ago, I thing I messed up with Nvme; if you don't have macOS install on a nvme and you try it, it would be interesting to me to know if it is working. 

 

Apparently it shouldn't be a problem to do the update... Well, I really don't know.

 

For the backlight; You shouldn't have this problem if you have removed intelbacklight.kext; maybe you installed an other trackpad drivers that change the keyboard... Or you can try AppleBacklightInjector.kext it works;. (you need to follow a guide).

Share this post


Link to post
Share on other sites

Hey everyone, just bought myself a Samsung 850 EVO SSD for my laptop to install Sierra on it. I was confused with a fact that it wasn't shown in Disk Utility while macOS installation process. Any help or ideas?

Share this post


Link to post
Share on other sites

Guys i have a serius problem and i dont know If its related to the Turbo Boost kext.

When i draw into photoshop, i have serius Huge lags. Do u have any fix?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MardukPVP
      Hello guys,

      recently I have tried to install macOS mojave on my Mi Notebook pro (i5 - 8250u model) but have faced one big problem.
      My guide was from Razorkey (https://www.tonymacx86.com/threads/guide-xiaomi-mi-notebook-pro-high-sierra-10-13-6.242724/). As a newbie I have almost no experience in installing macOS on a PC / Laptop... so I hope you can help me .

      But first things first I configurated the BIOS settings on my Mi - Notebook Pro. Therein I just disabled secure boot (because there are quite few options to tick).

      After that I headed over to my secondary Windows - PC and installed a High Sierra virtual machine (thanks to this tutorial: https://techsviewer.com/install-macos-high-sierra-vmware-windows-pc/). At that point everything worked fine.

      Then I downloaded the Mojave patcher and downloaded the full 6GB macOS Installer, put it into applications and formatet my 16GB USB Stick into the journaled + GUID with the name USB meanwhile.
      Next I typed 
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB 
      into the terminal and at that point everything looked like it would work pretty fine. I downloaded Clover Config, mountet the EFI partition and pushed the EFI folder from this site: https://github.com/daliansky/XiaoMi-Pro to the EFI partition on my 16GB USB drive.

      In the folloing I restarted my Notebook, selected the MacOS installer and it bootet into the MacOS installer. By doing that I only noticed that the progress bar turned green at a certain time (attatchment). Even though everything bootet pretty fine, i formattet my only ssd (Samsung) into APFS + GUID and startet the installation.
      At the point of two minutes my notebook suddenly rebootet and it brang me into the same clover selection menue as before (with only one method [macOS Installation]). Unfortunately there was no further installation method.

      When I was trying to reboot the laptop into the installer i got a error [your computer restarted because of a problem...] and i would have to do everything again.


      I hope someone can help me fixing this problem  . Thanks in advance.




    • By ltooz_audis
      I got the perfect working macBook Air 7,2 working with Mojave - Everything is working - I do mean even the SD card reader - audio - backlight controlled with keyboards... I'll write up the full tutorial and video how to soon. Love the Mojave, High Sierra was nothing compared to this.
      Cheers,
      Louis
       
       
       
    • By Cerv4nteZ
      Hi,
       
      i just let my sierra installation on a skylake xiaomi air laptop update. after the obligatory reboot i was greeted with a kernel panic regarding com.apple.iokit.IOAHCIBlockStorage. Now booting into osx doesnt work anymore
       
      Anyone else run into this? Is there a way to make clover save the boot log on this or do you guys salvage the logs from the hfs volume osx resides on?
    • By JahStories
      Files Package For Xiaomi Mi Notebook Air 13” 2.1
      Bios vers A05 — CPU i5 6200U (confirmed working even on A06 bios)
       
      2.1 PACK FOR HIGH SIERRA ONLY, FOR SIERRA USE 2.0
       
      Discussion's thread.
       
      Not working:
      Wi-fi / Bluetooth. (Bluetooth works if using a VM to inject the FW)
      Nvidia Optimus 940MX GPU. (Optimus does not work on macOS at all)
       
      Issues:
      Excessive battery draining while on sleep.
       
      For 2.0 Steps check the discussion thread
      Steps:
       
       
       
      When updating to new versions of the filepack:
      Remove all old files and install the new ones following the ReadMIs.
      Just remember to use the same serials you used before.
       
      Don't use bios mods, other files with different patches or you'll get no help.
      Special thanks to:
      Jolly, gengik84, and RehabMan.
       
      By Jahstories on InsanelyMac a.k.a. EliJah on macos86.com
       

      HELP NEEDED?



      Please don't post a comment, use
      this thread !


      Thanks!


×