Jump to content
About Just Joined group Read more... ×
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.


  • Similar Content

    • By MardukPVP
      Hello guys,

      recently I have tried to install macOS mojave on my Mi Notebook pro (i5 - 8250u model) but have faced one big problem.
      My guide was from Razorkey (https://www.tonymacx86.com/threads/guide-xiaomi-mi-notebook-pro-high-sierra-10-13-6.242724/). As a newbie I have almost no experience in installing macOS on a PC / Laptop... so I hope you can help me .

      But first things first I configurated the BIOS settings on my Mi - Notebook Pro. Therein I just disabled secure boot (because there are quite few options to tick).

      After that I headed over to my secondary Windows - PC and installed a High Sierra virtual machine (thanks to this tutorial: https://techsviewer.com/install-macos-high-sierra-vmware-windows-pc/). At that point everything worked fine.

      Then I downloaded the Mojave patcher and downloaded the full 6GB macOS Installer, put it into applications and formatet my 16GB USB Stick into the journaled + GUID with the name USB meanwhile.
      Next I typed 
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB 
      into the terminal and at that point everything looked like it would work pretty fine. I downloaded Clover Config, mountet the EFI partition and pushed the EFI folder from this site: https://github.com/daliansky/XiaoMi-Pro to the EFI partition on my 16GB USB drive.

      In the folloing I restarted my Notebook, selected the MacOS installer and it bootet into the MacOS installer. By doing that I only noticed that the progress bar turned green at a certain time (attatchment). Even though everything bootet pretty fine, i formattet my only ssd (Samsung) into APFS + GUID and startet the installation.
      At the point of two minutes my notebook suddenly rebootet and it brang me into the same clover selection menue as before (with only one method [macOS Installation]). Unfortunately there was no further installation method.

      When I was trying to reboot the laptop into the installer i got a error [your computer restarted because of a problem...] and i would have to do everything again.

      I hope someone can help me fixing this problem  . Thanks in advance.

    • By ltooz_audis
      I got the perfect working macBook Air 7,2 working with Mojave - Everything is working - I do mean even the SD card reader - audio - backlight controlled with keyboards... I'll write up the full tutorial and video how to soon. Love the Mojave, High Sierra was nothing compared to this.
    • By Cerv4nteZ
      i just let my sierra installation on a skylake xiaomi air laptop update. after the obligatory reboot i was greeted with a kernel panic regarding com.apple.iokit.IOAHCIBlockStorage. Now booting into osx doesnt work anymore
      Anyone else run into this? Is there a way to make clover save the boot log on this or do you guys salvage the logs from the hfs volume osx resides on?
    • By JahStories
      Files Package For Xiaomi Mi Notebook Air 13” 2.1
      Bios vers A05 — CPU i5 6200U (confirmed working even on A06 bios)
      Discussion's thread.
      Not working:
      Wi-fi / Bluetooth. (Bluetooth works if using a VM to inject the FW)
      Nvidia Optimus 940MX GPU. (Optimus does not work on macOS at all)
      Excessive battery draining while on sleep.
      For 2.0 Steps check the discussion thread
      When updating to new versions of the filepack:
      Remove all old files and install the new ones following the ReadMIs.
      Just remember to use the same serials you used before.
      Don't use bios mods, other files with different patches or you'll get no help.
      Special thanks to:
      Jolly, gengik84, and RehabMan.
      By Jahstories on InsanelyMac a.k.a. EliJah on macos86.com


      Please don't post a comment, use
      this thread !