Jump to content
Sign in to follow this  
Followers 0
darrellw

Trim problems with yosemite/El Capitan/Sierra

8 posts in this topic

Recommended Posts

Hi Folks,


I am run out of ideas trying to get trim working on my Hackintosh.


My specs are :


Asus P5G41TM LX

Dual Core 7500 CPU

8 Gb DDR 3 Ram

Asus EN 210 1024Mb Graphics card

SanDisk SDSSDHII120G

Yosemite 10.10.5 created with #####


Other SSD Drives ( borrowed from friends ) tried include :

120 GB Patriot Blaze/120 GB SSD Integral/120 GB Intel 520 Series

Other OSX include El Capitan and Sierra ( both too unstable at this time, but hope to sort out later )

Screen Shot is as follows:

179664-0a13849f655529bd47b46820446d4e43.

 

Tried "Sudo Trimforce enable :



I have also tried options 2 and 4 in this guide on a previously unstable install

http://www.insanelymac.com/forum/topic/298507-enable-trim-on-non-apple-ssd/


Darrell
Any advice most gratefully accepted

Share this post


Link to post
Share on other sites
Advertisement

remove all and use only one 

 

use Clover Configurator

 

Work fine

Name
IOAHCIBlockStorage

Find
4150504C452053534400

Replace
00000000000000000000

Comment
TRIM function for non-Apple SSDs

Share this post


Link to post
Share on other sites
Even enabling TRIM you'll don't get all proper speed of this SSD.

 

Your motherboard only have SATA 3GBs ports, and for get full speed you'll need an SATA 6GBs port.

Share this post


Link to post
Share on other sites

Yes, but is great too. My SATA 3 HD in SATA 3 port write 109 MB/SEC.

 

My SSD in SATA 2 port...  :drool:  :w00t:

 

amazing as usual  :lol:  :P  :yes:

Captura de Tela 2016-12-20 às 1.32.29 PM.png

Captura de Tela 2016-12-20 às 1.32.06 PM.png

Share this post


Link to post
Share on other sites

It seems everyone missed a major point: the OP's drive does not operate in AHCI mode. In ATA/IDE mode, no SSD recognition (it's seen as a legacy mechanical HDD) and, of course, no Trim! If the mobo has an old I/O controller like, say, ICH7, you can forget about it. It really is that basic...
 
SSD trim can only be activated with disk mode in AHCI and, then, Terminal command sudo trimforce enable (in that exact syntax) works perfectly.
 
This very matter has been mentioned umpteen times on the forum. Think of using the Search facility.
http://www.insanelymac.com/forum/topic/310396-ssd-trim-issues-tried-a-few-things/
http://www.insanelymac.com/forum/topic/298507-enable-trim-on-non-apple-ssd/page-8
 
If you want/need AHCI (and SATA-III speed), install a PCIe compatible controller in your desktop. There are several models available, though speed will be somehow limited if your desktop runs older PCIe v1.x (250MB/s per PCIe lane). More details here.

Share this post


Link to post
Share on other sites

Many thanks for all the replies,

 

Sorry Herve, for not finding any reference to the controller issues, but i did spend several days looking through posts with regard to successful installs of Yosemite/El Capitan on this motherboard with a SSD drive, but did not come across anyone who mentioned trim not working.

 

I also generally researched trim problems but again never found any mention of ICH7 controller limitations.

 

My main aim is to try and get a stable install with trim working just to have a play with OSX. I have a number of older parts lying around, all socket 775/AMD so i was hoping to use them in my hackintosh build.

If i use the setup without trim will it cause any issues?

Due to long term health problems money is tight so i am unable to splash out on a more up to date setup.

 

I do however have a Startech pexsata221 controller card which shows trim enabled when attached as a secondary drive but fails to boot when attached to the primary SSD drive.

It seems like more research is on the horizon.

 

Sata III would be nice to try but is not critical at this time.

 

If i cannot get this card working can you suggest an alternative sata controller card or would this board solve the problem.?

 

http://www.gigabyte.com/products/product-page.aspx?pid=2728#sp

I can pick one up for £ 25.00 though i do realise the board is only sata ii and is not really a step forward.

 

Thanks again for all the replies and advice.

 

Darrell

Share this post


Link to post
Share on other sites

There are several/many existing threads on this forum about add-on PCIe SATA-III controllers. You should find them with a search. I've posted my own personal experiments on the matter here. There are also several references to supported controllers in the threads I linked above; please read them.

 

Your motherboard is based on Q35 chipset so your PCIe slots are version 1.1 and therefore each lane limited to 250MB/s.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×