Jump to content
qrzx

10.12.1 - Display blank on boot with NVIDIA Web Driver

12 posts in this topic

Recommended Posts

Hi insanelymac friends!

 

I had a near-perfect build with El Cap, but after I decided to update to Sierra some problems came up.

 

Specs:

  • i7-6700k
  • ASUS Z170-E mobo
  • EVGA GTX 960

And here's my config.plist

 

With iMac17,1 SMBIOS, my display sleeps on boot. I can boot okay with nv_disable=1.

I have done the AGDP patch (AGDPfix.app by shilohh).

 

I should also note, I have two monitors connected to my GPU, one with DVI, one on DisplayPort.

If I only plug in the DVI monitor and use an iMac14,2 SMBIOS, I can boot okay with NVIDIA drivers. But this doesn't work if the DP monitor is plugged in.

 

Also, I've set BIOS graphics to PCI-E, and the new NvidiaWeb thing is set in Clover.

 

Any suggestions are welcome!!!  :yes:

 

Thanks!  ^_^

Share this post


Link to post
Share on other sites
Advertisement

 

Try boot without nvda_drv=1, and use just:

<key>SystemParameters</key>
<key>NvidiaWeb</key>
<true/>

 

Thanks, but I've tried that (removed nvda_drv=1 from config.plist), I forgot to update the pastebin entry  :blush:

Here's my current config.plist: http://pastebin.com/vmGVrFZp

Share this post


Link to post
Share on other sites

Try change Nvidia to True.

 <key>Graphics</key>
    <dict>
        <key>Inject</key>
        <dict>
            <key>NVidia</key>
            <true/>
        </dict>

Share this post


Link to post
Share on other sites

Try to switch to SMBIOS iMac14,2...

 

as I mentioned in my post, iMac14,2 works only if I disconnect my main DisplayPort monitor... :(

Share this post


Link to post
Share on other sites

with me enable CSM on BIOS to fix this, anw. its not about SMBIOS profile after u ready had AGDPfix, this bug come when 2 display connected when boot !

Share this post


Link to post
Share on other sites

^^^ yes, it might be that. currently have CSM turned off

though I don't have the enthusiasm to try installing sierra again...

will keep this in mind for later though

 

thanks!!  :yes:

 

at least I hope somebody else will benefit from this  :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By brerackl
      Good evening,
       
      I used to mess around with iATKOS back in 2011, I since have been out of the loop and have gone through several different PC's.
      Now I have built a new PC and would like to install High Sierra to my external SSD.
      I have gotten as far as installing clover and the .raw image to my USB stick but I am getting stuck on the +++++++++++ then reboot problem.
      I realize a LOT has changed and I am having a bit of trouble figuring it out. 
       
      My PC's specs are as follows:
       
      CPU:
                  Intel Core i7 7820X
       
      RAM:
                  32GB Ballistix RGB Tactical Tracer (by Micron)
       
      Motherboard:
                  EVGA X299 FTW K
       
      Graphics:
                  NVIDIA RTX 2070 (EVGA)
       
      Storage:
                  4TB Western Digital HDD
                  1TB Samsung SSD 970 EVO 1TB
                  480GB Micron SSD
       
      If someone can help point me in the right direction that would be amazing, I have tried using some of the efi files for different x299 setups and such but no luck same results, played with different boot flags and options but everything is so much different I don't really know what does what. 
      I would very greatly appreciate if anyone can point me to some reading or a specific set of files to get me past this error as I haven't the slightest why it is even doing this. Mind you the last time I played around with this was back in 2011 with iATKOS and CD's, I have no CD drive in this build and need to do this via USB and as I understand this is 100% possible I just need the right boot setup and settings.
       
      Thank you in advance,
      Brett
    • By DSA2
      Salve a tutti
      Fin' ora non mi sono informato molto su come sistemare il boot , prima schermata di avvio.
      In pratica ogni volta devo spostare con freccetta e selezionare mio Hard disk .
      Allego foto fatte da cell. della schermata boot .
      Bisognerebbe cancellare le entries ?
      E nel caso in cui vorrei modificare la grafica clover ?
      Grazie in anticipo per le delucidazioni.

       





    • By shinho73
      Can someone help me fix reboot issue? Actually it reboots, but sometimes the hackintosh just hangs with screen off. Here is the Extra folder containing org.chameleon.boot.plist. https://drive.google.com/drive/folders/1MX8-DpQk9kaRUfjPcToxf-ElWh-bN6EY?usp=sharing  and the spec of the PC. https://drive.google.com/drive/folders/1NlcUNK5DBzJFxeFeuyt92eRjQqwO5T32?usp=sharing Can someone look at it? I might be doing something wrong. Any help will be greatly appreciated. Thank you. 

    • By fusion71au
      Clover r5051 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r5051 for VMware.zip". Mount Clover-v2.5k-5051-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×