Jump to content
InsanelyMac Forum
netgear

Triple/Dual/Quad Boot UEFI + Custom Entries

Recommended Posts

Advertisement

Salve,

 

vorrei installare Windows 10 su un secondo SSD, ma non riesco a farlo, si blocca sempre allo schema di partizioni. Crea le 4 necessarie, ma l'errore è sempre lo stesso:

"Non sono riuscito a creare una nuova partizione o a individuarne una esistente. Per ulteriori informazioni, vedi i file di log del programma di installazione."

 

 

La configurazione: 

Scheda madre Gigabyte GA H270 Gaming 3, i7 7700, due SSD (su uno - disco 1 - c'è installato Clover & OSX). Il disco 2 sarebbe quello destinato ad assumersi il compito di far girare Windows. Poi c'è un disco sata tradizionale per stoccaggio file/lavori.

 

Ho cercato tutte le guide, ma senza risultati. Al che mi sono detto: «provo ad installarlo come se fosse un assemblato normale». Macché!

 

Tentativi (falliti):

Attivazione del supporto (sulla scheda madre) a Windows 8/10

Creazione USB con EFI+Clover (Rufus + Clover)

Creazione USB pulita da ISO senza Clover (Rufus)
Chiavetta formattata FAT32 e NTFS (Rufus)

Schema partizione MBR per UEFI (Rufus)

Schema partizione MPT per UEFI (Rufus)

Schema partizione MBR per BIOS e UEFI (Rufus)

 

 

Credo di averle provate tutte, ma evidentemente mi sfugge qualcosa. Eventualmente non mi interesserebbe la possibilità di selezionare all'avvio di Clover anche Windows, posso sopportare anche il cambio da boot da UEFI (da scheda madre).

 

 

Cosa sbaglio?

Share this post


Link to post
Share on other sites

Devi usare Rufus schema GPT per UEFI e poi ovviamente avviare la Chiavetta USB in UEFI, azzera il disco come l'esempio all'inizio della mia guida con GParted Live.

 

Il disco risulta da inizializzare e puoi far fare tutto a Windows.

Share this post


Link to post
Share on other sites

Ma non è la stessa cosa se lo faccio fare all'installer di Windows (con diskpart, erase)?

 

Però mi confermi che l'installazione di Windows su un secondo SSD ha nulla a che vedere con OSX/Clover? Posso, per assurso, sbarbare l'SSH con OSX e continuare come se nulla fosse?

Share this post


Link to post
Share on other sites

L'installazione di Windows non ha nulla a che vedere con il resto, se vuoi avere la situazione più chiara disabilita da BIOS gli altri dischi tranne quello su cui installerai Windows.

 

Azzera il disco con GParted così siamo sicuri, l'installazione di Windows non deve creare nessun problema.

Share this post


Link to post
Share on other sites

Risolto: ho disabilitato da Bios i dischi che non servivano ed è andato tutto come doveva andare. Evidentemente, anche se gli dici di installarlo nel posto "A" lui pensa «Ma sarà sicuro? Non è che voleva dirmi "B" o "C"? Quasi quasi mi blocco così ci sta attento!».

 

Sinceramente non ci avrei mai pensato, grazie per la dritta!

Share this post


Link to post
Share on other sites

Grazie, ma è una lotta impari.

 

 

Un'altra domanda: sto cercando di sistemare l'avvio di Clover nascondendo le 3 partizioni di Windows che non servono. E ci sono riuscito. 

Mi era venuta la voglia di cambiare anche le icone, ma non accetta variazioni. Mi cambia i nomi, ma non le immagini.

 

Ho provato ad avviare sia con il flag su "Custom Icons" (a fianco di Theme, sotto la risoluzione) che senza, ad impostare il percorso con due "\EFI" davanti, usare o no il flag "Custom Logo", ... Nessuna variazione.

 

 

 

grazie

post-1989264-0-12830300-1490629144_thumb.png

post-1989264-0-03398900-1490629146_thumb.png

post-1989264-0-17301200-1490629148_thumb.png

post-1989264-0-23596800-1490629149_thumb.png

post-1989264-0-65823600-1490629150_thumb.png

Share this post


Link to post
Share on other sites

Prova a caricare un icona diversa all'interno del tema scelto, sinceramente i temi nell'impostazione UEFI sono già abbastanza a posto, non sempre digerisce icone diverse, controlla bene i percorsi è facile sbagliarsi.

 

Per nascondere le partizioni che non vuoi nella GUI dovevi lasciare le voci in Hide Volume, ti semplificavi la vita, cmq si possono nascondere anche in altri modi....

Share this post


Link to post
Share on other sites

Ragazzi ho un SSD su cui è installato Sierra, ora vorrei utilizzare l'altra metà del disco per installare Windows 10, nel momento in cui installo il sistema sull'altra partizione, riavvio con Clover da USB ma non vedo la cartella Windows dentro EFI....potreste aiutarmi?

Share this post


Link to post
Share on other sites

Ma stiamo parlando di un installazione UEFI, disco preparato da OS X, Windows 10 installato con la preparazione della USB in UEFI e relativa installazione, come nella guida...

Share this post


Link to post
Share on other sites

Ma stiamo parlando di un installazione UEFI, disco preparato da OS X, Windows 10 installato con la preparazione della USB in UEFI e relativa installazione, come nella guida...

Allora macOS è installato in uefi insieme a Clover, poi ho preparato su un PC Windows la chiavetta con Windows 10 ma non come da guida (perché se metto partizione guid in Rufus quando avvio da USB per installare Windows mi dice che manca il bootx64 quindi non parte proprio)...il BIOS è impostato in UEFI...se installo Windows lasciando le impostazioni predefinite in Rufus, il sistema si installa ma non vedo poi la cartella EFI\Microsoft\Boot per continuare la configurazione

Share this post


Link to post
Share on other sites

E quindi hai installato Windows in MBR, in questo modo non può crearti la cartella Microsoft nella EFI.

 

La chiavetta USB deve essere preparata in quel modo, il bootx64 c'è, se stiamo parlando di un portatile guarda se ci sono opzioni nel BIOS, ma la chiavetta in quel modo deve partire...

 

Potresti sempre "piazzare" la cartella Microsoft copiandola dalla mia EFI e poi modificare il BCD con easyBCD, ma se uno non ha un po' di dimestichezza...


Comunque sul config.plist prova a spuntare in GUI Scan Custom (Entries Tool e Legacy) vedi se ti vede Windows e se parte.

 

Ci sarà qualche icona di troppo, ma giusto per capire...

Share this post


Link to post
Share on other sites

E quindi hai installato Windows in MBR, in questo modo non può crearti la cartella Microsoft nella EFI.

 

La chiavetta USB deve essere preparata in quel modo, il bootx64 c'è, se stiamo parlando di un portatile guarda se ci sono opzioni nel BIOS, ma la chiavetta in quel modo deve partire...

 

Potresti sempre "piazzare" la cartella Microsoft copiandola dalla mia EFI e poi modificare il BCD con easyBCD, ma se uno non ha un po' di dimestichezza...

Comunque sul config.plist prova a spuntare in GUI Scan Custom (Entries Tool e Legacy) vedi se ti vede Windows e se parte.

 

Ci sarà qualche icona di troppo, ma giusto per capire...

possiamo provare ;)

Share this post


Link to post
Share on other sites

Prima o dopo non è il problema, il problema e che deve bootare UEFI dalla USB di Windows. Che poi a questo punto avendo scritto l'MBR probabilmente anche se riesce a bootare UEFI lui non vedrà più installabile la partizione non riconoscendo il disco come GPT.

 

Insomma sì, forse è più semplice ripartire dall'inizio azzerando la tabella delle partizioni con GParted ad esempio...


Jolly ti volevo chiedere: hai mica capito quello che diceva MaLdOn, su come usare le patch DSDT per i nuovi chipset serie 100 e 200, a parte lui vedo che nessuno le usa...

Share this post


Link to post
Share on other sites

possiamo provare ;)

 

Se ti vuoi cimentare:

 

Scarica la cartella Microsoft e piazzala nella EFI, rinomina bootmgfw.efi” in “bootmgfw-orig.efi.

 

Clover ora vedrà Windows ma l'avvio fallirà per via del BCD non corretto.

 

Ripara il BCD, segui questa guida, per gli strumenti automatici bisogna avere una USB W10 bootable UEFI.

 

In sostanza riassumendo la guida:

Avvia Windows 10 USB UEFI, alla prima schermata "Maiuscola F10" per aprire il terminale
diskpart
sel disk 0
list vol

sel vol X

assign letter=w:

exit

DIR W:

cd  /d  W:\EFI\Microsoft\Boot\
bootrec /fixboot

bcdboot  C:\Windows  /l  it-it  /s  W:  /f  ALL

Puoi provare prima a riparare il BCD con gli strumenti automatici di Windows.

 

Riavvia ora Windows 10 è bootable UEFI.

 

Dovrai ripetere l'operazione rinomina bootmgfw.efi” in “bootmgfw-orig.efi, oppure semplicemente cancellare la nuova  bootmgfw.efi che la riparazione (quella automatica) di Windows avrà ricreato.

In sostanza se uno ha un backup (immagine di sistema), oppure un sistema già installato, può farlo bootare a piacimento sia MBR che UEFI, l'installazione ovviamente facilita tutta una serie di compiti che altrimenti vanno fatti manualmente.

 

Io ad esempio installo il sistema una solo volta, faccio l'immagine di sistema e da quella creo tutti i dischi che voglio.

Share this post


Link to post
Share on other sites

Ho di sicuro qualche problema con la mia ISO di Windows 10, non si avvia l'installazione in UEFI, ho installato il tutto con Rufus impostato come da guida...

Share this post


Link to post
Share on other sites

Probabilmente hai qualcosa di impostato male per l'avvio UEFI da BIOS, Secure Boot, CSM ecc.

 

Non è che hai Windows 10 a 32 Bit :) ...

Share this post


Link to post
Share on other sites

Probabilmente hai qualcosa di impostato male per l'avvio UEFI da BIOS, Secure Boot, CSM ecc.

 

Non è che hai Windows 10 a 32 Bit :) ...

No la ISO è a 64bit, il secure boot è disattivato e il CSM pure...non capisco dove sbaglio

Forse la penna da 16GB è troppo? booo...ho provato diverse pennette e diverse porte USB

Share this post


Link to post
Share on other sites

Il CSM funziona al contrario, ma trattandosi di Windows dovrebbe partire in entrambi i modi, fai una prova.

 

Se Clover parte in UEFI sembra un problema di avvio del supporto, magari usa un altro metodo, prova con l'ultima versione di Rufus, puoi anche abilitare come file system NTFS sulla chiavetta, non ha molto senso, ma ora Rufus lo permette per le ISO che superano le possibilità della FAT32.

 

Controlla i percorsi sulla chiavetta USB (USB)/efi/boot/bootx64.efi.

 

Non dovrebbe essere tutto questo problema fare un avvio UEFI......................................

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



×