Jump to content
vit9696

FileVault 2

355 posts in this topic

Recommended Posts

Should I be able to update Clover that is installed to the ESP once FV2 is enabled as currently when I try it installs it to the root of the booted drive?

Share this post


Link to post
Share on other sites
Advertisement

Should I be able to update Clover that is installed to the ESP once FV2 is enabled as currently when I try it installs it to the root of the booted drive?

It is a completely different volume, so yes.

Share this post


Link to post
Share on other sites

I have found the same issue too. The Clover installer when run on an encrypted FV2 volume installs to the root partition and not the EFI partition...

Share this post


Link to post
Share on other sites

Yes.

 

EDIT: Do I see it wrong or is UsbKbDxe placed in drivers64 for legacy boot? What sense does that make? Just replace the TianoCore one in the DUET image, that will solve the issue of having to reconnect the keyboard on every boot...

The work in progress. Legacy boot Clover contains a driver BiosKeyboard witch is not ready yet for FV2.

But I didn't propose to replace it with UsbKbDxe because the last one is not working with PS2 keyboard.

Share this post


Link to post
Share on other sites

The work in progress. Legacy boot Clover contains a driver BiosKeyboard witch is not ready yet for FV2.

But I didn't propose to replace it with UsbKbDxe because the last one is not working with PS2 keyboard.

 

Nevermind, it has been done by now, seems like the users were using an old Clover build.

Share this post


Link to post
Share on other sites

So, just to clarify to be sure that I understand everything right: in case I have Clover in legacy mode (BIOS + clover on ESP) on my laptop (PS2 kb) , do I need to install UsbKbDxe&HashServiceFix-64.efi?

Share this post


Link to post
Share on other sites

So, just to clarify to be sure that I understand everything right: in case I have Clover in legacy mode (BIOS + clover on ESP) on my laptop (PS2 kb) , do I need to install UsbKbDxe&HashServiceFix-64.efi?

 

HashFix is only for AMI Aptio... for UsbKbDxe, if I'm reading the code right, you should not need to install it separately, but I am not using Clover, so cannot confirm.

 

EDIT: Nvm, HashFix is for any firmware not implementing the Hash protocol for SHA1.

Share this post


Link to post
Share on other sites

At this point HashServiceFix is indeed optional. What it does is:

a) Overwrites broken SHA1 hash implementation if it finds it;

B) Installs new SHA1 hash implementation if nothing is found.

 

This allows boot.efi to access more files in FirmwareVolume and thus request SHA1(ArrowCursor_2x) file, which is for HDPI screens.

If no file was found, then the default cursor image will be used. For this reason it is currently optional, however, there is no proof that it is not going to change soon.

Share this post


Link to post
Share on other sites

Unfortunately, on my laptop USB kb is not working - tried Logitech and A4tech standart keyboards: not possible to enter the pass.

But caps lock and num lock work: indicators on my laptop are changing, so kb is connected...

Share this post


Link to post
Share on other sites

Unfortunately, on my laptop USB kb is not working - tried Logitech and A4tech standart keyboards: not possible to enter the pass.

But caps lock and num lock work: indicators on my laptop are changing, so kb is connected...

Did you use this new UsbKbDxe?

Share this post


Link to post
Share on other sites

I'm using UsbKbDxe from Clover 3882 package. The same clover 3882 legacy is installed on my hackintosh PC and it works fine - I unlock FV2 w/o any problems.

 

P.S. Additionally Ctrl-Alt-Del works - it reboots my laptop :)

Share this post


Link to post
Share on other sites

Added a new AptioInputFix version:

— fixed numpad keys (might require enabled numlock in bios);

— added a workaround for keyrepeat and missed keys, should work with Clover's AppleKeyAggregator now (will require at least Partial Usb Initialisation in Fast Boot section);

— fixed rare system startup freezes;

— improved z87 mouse behaviour.

Share this post


Link to post
Share on other sites

I'm using UsbKbDxe from Clover 3882 package. The same clover 3882 legacy is installed on my hackintosh PC and it works fine - I unlock FV2 w/o any problems.

 

P.S. Additionally Ctrl-Alt-Del works - it reboots my laptop :)

I tried all of these efis above, and UsbKbDxe found in clover work for my external keyboard, you have to unplug and plug in again to make it work

still waiting for internal ps2 keyboard working

Share this post


Link to post
Share on other sites

With AptioInputFix do I just need to remove UsbKbDxe-64.efi or I can have both in drivers64UEFI?  If I need to remove it are there any others to remove that the newer versions of clover installs.  Not using FV

 

Thanks

Share this post


Link to post
Share on other sites

With AptioInputFix do I just need to remove UsbKbDxe-64.efi or I can have both in drivers64UEFI?  If I need to remove it are there any others to remove that the newer versions of clover installs.  Not using FV

 

Thanks

You should remove UsbKbDxe and only that.

 

With new version of AmiShim, I got to work all hotkeys (cmd+s/cmd+r/cmd+v/shift)

Nice, looks like it was accidentally broken in the previous one.

Share this post


Link to post
Share on other sites

I tried all of these efis about, and UsbKbDxe found in clover work for my external keyboard, you have to unplug and plug in again to make it work

still waiting for internal ps2 keyboard working

I've unplugged and plugged it many times: tried different usb ports, even via usb hub :) Caps lock, num lock, Ctrl alt del work thats it.

Can it happen because my laptop has Phoenix TrustCore bios?

In Clover GUI this usb kb works fine.

Share this post


Link to post
Share on other sites

I've unplugged and plugged it many times: tried different usb ports, even via usb hub :) Caps lock, num lock, Ctrl alt del work thats it.

Can it happen because my laptop has Phoenix TrustCore bios?

In Clover GUI this usb kb works fine.

AppleImageCodec-64.efi     

HashServiceFix-64.efi

NTFS.efi

AppleKeyMapAggregator.efi 

OsxAptioFix2Drv.efi

AppleUITheme-64.efi        

OsxFatBinaryDrv-64.efi

AptioInputFixB2.efi        

PartitionDxe-64.efi

DataHubDxe-64.efi         

SMCHelper-64.efi

UsbKbDxe-64.efi

FSInject-64.efi            

FirmwareVolume-64.efi      

HFSPlus.efi

i put all of these efis into clover, and it works.....

it won't work without usbkbdxe though

i don't know if there're conflicts, but my internal keyboard cannot work properly

BTW, my laptop is Phoenix BIOS too

Share this post


Link to post
Share on other sites

AppleImageCodec-64.efi

HashServiceFix-64.efi

NTFS.efi

AppleKeyMapAggregator.efi

OsxAptioFix2Drv.efi

AppleUITheme-64.efi

OsxFatBinaryDrv-64.efi

AptioInputFixB2.efi

PartitionDxe-64.efi

DataHubDxe-64.efi

SMCHelper-64.efi

UsbKbDxe-64.efi

FSInject-64.efi

FirmwareVolume-64.efi

HFSPlus.efi

i put all of these efis into clover, and it works.....

it won't work without usbkbdxe though

i don't know if there're conflicts, but my internal keyboard cannot work properly

BTW, my laptop is Phoenix BIOS too

I have the same except for NTFS.efi.

BTW on my PC the same config with the same USB kb works fine with FV2.

Looks like Phoenix and Phoenix TrustedCore are really different things.

Share this post


Link to post
Share on other sites

[GUIDE] How to revert FileVault 2 if you are not able to enter your password: for example, USB keyboard is not working.

 

1. Boot into Recovery HD (where you can restore macOS, have Disk Utility)

2. Select Terminal (top menu)

3. diskutil corestorage list

4. Look for Logical Volume XXXXXXXX-XXXX-XXXX-XXXXXXXXXXXXXXXX and copy XXX...XXXX (NOT from Logical Volume Family!)

5. diskutil corestorage unlockVolume UUID (paste copied UUID from step 4)

6. diskutil corestorage revert UUID (paste copied UUID from step 4)

7.

7.1) If it's your first boot after you've enabled FileVault 2, then type reboot in Terminal and boot macOS as usual.

7.2) If it's NOT the first boot after you've enabled FileVault 2, then diskutil corestorage list and check conversion status, type reboot ONLY when diskutil corestorage list shows you NO encrypted volumes!

 

Done

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By KyleGP
      Hi all,

      I have 5 disks including four SSDS and a 4TB HDD configured in a CoreStorage (Fusion drive) volume.

      I have Filevault enabled also.

      When I turn on my hackintosh, I am presented with the Filevault screen to select my user, enter my password and continue to decrypt and boot macOS. This works around 80% of the time with no issues at all.

      Sometimes with seemingly no identifiable pattern, after I enter my password it just hangs on the Filevault screen with the loading bar and does not progress. There is no disk activity either. After a while of the hanging, it will just display the prohibitory sign against a black background.

      I have to force shut the hackintosh off with the power button and try to boot again. Usually after I do this, it will boot the second time.

      I'm currently running Sierra 10.12.6 but this has also happened when I tried 10.13 too.

      Clover is fully up to date as of today (r4380). 

      Does anyone know why this might occur?

      The only thing I have picked up on is the drives change disk identifiers and move themselves around (eg. /dev/disk1) during different boot ups so maybe it's getting confused when trying to decrypt and boot as a corestorage volume. I have no idea how to prevent this from happening either.

      Any help or suggestion would really be appreciated.

      My specs are:

      Motherboard: GA-Z97X-UD7 TH
      RAM: 16GB Corsair 1866MHZ Memory
      GFX: 2x Nvidia GTX 760
      CPU: Intel Core i7-4790K 4GHZ
    • By Hunk89
      Hey,
       
      i am a newbie here. I want to build a hackintosh soon and i would like to know if anyone has successfully implemented Filevault 2 with Clover yet?
       
      Can it be done?
      Thanks,
      Hunk
       
    • By Alien::X
      Is there Any Way to Get boot into FileVault and Recovery HD ?
       
       
      1st Ans. >>>>    As I know Recovery HD works After Rebuild Caches of that volume (Partition)
       
       
      2nd Ans. >>> ???(FileVault)
×