Jump to content
vit9696

FileVault 2

478 posts in this topic

Recommended Posts

Advertisement

:thumbsup_anim:  Great work everyone, many thanks I am excited to try it  :thumbsup_anim:

 

Can I please ask at what point of reboot is the password requested as I generally skip the Clover GUI (Login = 0 in Config.plist), would this be a problem?

 

I also use the Apple bluetooth Keyboard, Mouse and Trackpad which work fine both in the BIOS and Clover GUI as they connect with the Apple Broadcom Bluetooth would they be compatible?

Share this post


Link to post
Share on other sites

The pw is requested by boot.efi, clover ui has nothing to do with it. You should choose the right boot entry at least once though.

(Boot macOS from Recovery HD)

 

As for your input devices that needs testing. I would say that they should work almost certainly though.

Share this post


Link to post
Share on other sites

Thanks vit9696, it has been a while since FileVault was first tested with Clover (Back on ProjectOSX and it didn't work) so I will have to familiarise myself with the process again at the weekend when I get home.

Share this post


Link to post
Share on other sites

Thanks vit9696, it has been a while since FileVault was first tested with Clover (Back on ProjectOSX and it didn't work) so I will have to familiarise myself with the process again at the weekend when I get home.

Yes, it never worked before.

Share this post


Link to post
Share on other sites

Just wanted to say thanks to everyone involved here for reaching this milestone. Fantastic work! FV2 up and running here

Cheers!

Share this post


Link to post
Share on other sites

If anyone can spare the time would you be able to document the process of enabling it please (Nothing too fancy obviously) for example which of the options did you choose etc?

Share this post


Link to post
Share on other sites

I just tested it. It works as described.

You should choose recovery HD on that drive to be able to boot, which make sense if you think how file vault works.

One minor issue is, I had to replug my usb keyboard to be able to type my password, even though I've booted via legacy clover, as described in recommendation. I'll try the AppleKeyAggregator from Apple Firmware, just for test (I mean who would use closed source programs and want to encrypt the drive with it or better decrypt with that?!).

 

Everything else is perfect. Thanks again to all who contributed...

 

Edit: I've tried the original AppleKeyMapAggregator from Apple firmware, even the AptioInputFix. Nothing changed though, I still have to replug my keyboard :(

 

Edit2: Just had the idea, locking from find my mac should theoretically work, right?

Share this post


Link to post
Share on other sites

with legacy Clover, remove the EDK2 UsbKbDxe driver and use mine... also best to use Apple's AppleKeyMapAggregator.

Do not use AmiShim.

Is there a guide to build your UsbKbDxe?

Share this post


Link to post
Share on other sites

I'm using Intel+AMD (black screen during boot) solution for a working sleep. When I enable FV2 Will I have black screen while typing password ?

Share this post


Link to post
Share on other sites

I'm using Intel+AMD (black screen during boot) solution for a working sleep. When I enable FV2 Will I have black screen while typing password ?

Yes, you will have black screen while typing password.

Moreover, there can be one caveat. I initially have two users on the screen and I have to choose one of them by mouse and only then type password.

But you can't use mouse on black screen.

I also using Intel+AMD for working sleep. And I have a monitor with two entry. First entry for Intel, second for AMD with a simple switch between two screens.

Share this post


Link to post
Share on other sites

Does Clover now install all the files required in Drivers64UEFI meaning I just have to enable FileVault via System Preferences > Security and Privacy and reboot letting Clover do it's thing?

 

Files currently in Drivers64UEFI:

post-499606-0-83368100-1477804460.png

Share this post


Link to post
Share on other sites

Does Clover now install all the files required in Drivers64UEFI meaning I just have to enable FileVault via System Preferences > Security and Privacy and reboot letting Clover do it's thing?

 

Files currently in Drivers64UEFI:

attachicon.gifScreen Shot 2016-10-30 at 05.19.07.png

No, UsbKbDxe or other special keyboard driver needed.

FV2 uses own keyboard interface and can't use UEFI BIOS keyboard driver.

Share this post


Link to post
Share on other sites

Good morning Slice and thanks, I added this one...

 

post-499606-0-90159300-1477805476.png

 

 

If I have a password enabled when logging into Sierra, will I get two password prompts when FileVault is enabled?

Share this post


Link to post
Share on other sites

Ok, that didn't go so well. I can't get past the Recovery screen now having let FileVault reboot the computer.

 

How do I access the Clover GUI if timeout is set to 0 please?

Share this post


Link to post
Share on other sites

How does it work with Bluetooth keyboards (for example Apple Magic Keyboard)?

 

You have to have AptioInputFix.efi present for Apple Bluetooth Keyboards to work, I just tested this (Not tested the alternative keyboard driver).

 

Once FV2 is enabled do you have to always boot from the "Boot macOS from Recovery HD" option that appears in the Clover menu?

Share this post


Link to post
Share on other sites

Once FV2 is enabled do you have to always boot from the "Boot macOS from Recovery HD" option that appears in the Clover menu?

 

Yes.

 

EDIT: Do I see it wrong or is UsbKbDxe placed in drivers64 for legacy boot? What sense does that make? Just replace the TianoCore one in the DUET image, that will solve the issue of having to reconnect the keyboard on every boot...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By KyleGP
      Hi all,

      I have 5 disks including four SSDS and a 4TB HDD configured in a CoreStorage (Fusion drive) volume.

      I have Filevault enabled also.

      When I turn on my hackintosh, I am presented with the Filevault screen to select my user, enter my password and continue to decrypt and boot macOS. This works around 80% of the time with no issues at all.

      Sometimes with seemingly no identifiable pattern, after I enter my password it just hangs on the Filevault screen with the loading bar and does not progress. There is no disk activity either. After a while of the hanging, it will just display the prohibitory sign against a black background.

      I have to force shut the hackintosh off with the power button and try to boot again. Usually after I do this, it will boot the second time.

      I'm currently running Sierra 10.12.6 but this has also happened when I tried 10.13 too.

      Clover is fully up to date as of today (r4380). 

      Does anyone know why this might occur?

      The only thing I have picked up on is the drives change disk identifiers and move themselves around (eg. /dev/disk1) during different boot ups so maybe it's getting confused when trying to decrypt and boot as a corestorage volume. I have no idea how to prevent this from happening either.

      Any help or suggestion would really be appreciated.

      My specs are:

      Motherboard: GA-Z97X-UD7 TH
      RAM: 16GB Corsair 1866MHZ Memory
      GFX: 2x Nvidia GTX 760
      CPU: Intel Core i7-4790K 4GHZ
    • By Hunk89
      Hey,
       
      i am a newbie here. I want to build a hackintosh soon and i would like to know if anyone has successfully implemented Filevault 2 with Clover yet?
       
      Can it be done?
      Thanks,
      Hunk
       
    • By Alien::X
      Is there Any Way to Get boot into FileVault and Recovery HD ?
       
       
      1st Ans. >>>>    As I know Recovery HD works After Rebuild Caches of that volume (Partition)
       
       
      2nd Ans. >>> ???(FileVault)
×