Jump to content
Matgen84

Wifi: aucun matériel installé

15 posts in this topic

Recommended Posts

La mise à jour vers 10.12.1 est presque nickel

 

 

Jusqu'ici ma carte wifi ASUS PCE-AC68 Broadcom BCM94360 était reconnue nativement sous macOS Sierra 10.12. Mais là, après la mise à jour, j'ai la fameuse note "Wifi: aucun matériel installé" dans la barre de menu. Bien évidemment, je ne peux activer le wifi dans paramètres/ réseaux.

 

 

 

 

 

​Désolé si je ne suis pas clair dans mes explications.

 

Des pistes?

post-1110743-0-01270100-1477503491.png

Share this post


Link to post
Share on other sites
Advertisement

Tu peux utiliser la commande dmesg pour visionner ton syslog. Sinon, tu ouvres l'appli Console.

 

Tu as bien vérifié que la carte n'est pas désactivée ou quoique ça soit? Tu peux tenter de rebooter sans le cache, puis de le reconstruire à la mano pour voir. Sinon, la carte est-elle bien listée dans le matériel PCI? Eg: via DPCIManager ou commande lspci -nn.

 

Pour la commande lspci, tu auras besoin d'installer les binaires + le kext comme expliqué ici.

 

Si la carte n'est plus reconnue nativement, tu peux peut-être essayer de la déclarer comme compatible avec un BCM4360 d'Apple, par exemple la 14e4:43a0. Il te faudrait alors identifier ta carte dans IOReg et patcher ta DSDT pour injecter la compatibilité.

 

J'ai installé une BCM94360CD Apple dans mon E6230 avec un adaptateur et c'est naturellement supporté OOB sous OS X, 10.12.1 inclus.

E6230:~ admin$ lspci -nn
[...]
01:00.0 Network controller [0280]: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
[...]

Share this post


Link to post
Share on other sites

 

Tu peux utiliser la commande dmesg pour visionner ton syslog. Sinon, tu ouvres l'appli Console.

 

Tu as bien vérifié que la carte n'est pas désactivée ou quoique ça soit? Tu peux tenter de rebooter sans le cache, puis de le reconstruire à la mano pour voir. Sinon, la carte est-elle bien listée dans le matériel PCI? Eg: via DPCIManager ou commande lspci -nn.

 

Pour la commande lspci, tu auras besoin d'installer les binaires + le kext comme expliqué ici.

 

Si la carte n'est plus reconnue nativement, tu peux peut-être essayer de la déclarer comme compatible avec un BCM4360 d'Apple, par exemple la 14e4:43A0. Il te faudrait alors identifier ta carte dans IOReg et patcher ta DSDT pour injecter la compatibilité.

 

J'ai installé une BCM94360CD Apple dans mon E6230 avec un adaptateur et c'est naturellement supporté OOB sous OS X, 10.12.1 inclus.

E6230:~ admin$ lspci -nn
[...]
01:00.0 Network controller [0280]: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
[...]

Désolé de ne pas avoir répondu aux conseils mais j'étais hospitalisé.  :)

 

DPCImanager affiche bien BCM4360 d'Apple, avec  14e4:43A0 pour ma carte Asus PCE-AC68. Quand je boote sur la Recovery Partition, le wifi est bien fonctionnel.

 

Le problème survient en démarrage normal: ARPT XXX Failed PCieConfiguration. Mais impossible de retrouver le message précis.

 

EDIT: En démarrant en verbose, j'ai ces lignes dans kernel.log récupérées via DarwinDumper 

 

(IO80211Family) AirPort_Brcm4360::init AirPortFamily_kexts-1200.32 "AirPortFamily_kexts-1200.32"

2016-11-29 08:25:27.013621+0100 0x10e      Default     0x0                  0      kernel: (AirPortBrcm4360) ARPT: 0.935326: AirPort_Brcm43XX:probe:, this[0x5999bbd10f124ef5]  score[1110]

2016-11-29 08:25:27.013652+0100 0x10e      Default     0x0                  0      kernel: (AirPortBrcm4360) ARPT: 0.935355: AirPort_Brcm43XX::start: Failed PCIe configuration, this[0x5999bbd10f124ef5] vendor[0x000014e4] device[0x00000030], chip: vid[0x14e4] did[0x43a0] bar0[0xf7400004]

 

Dans LSPCI: 

 

03:00.0 Network controller [0280]: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

Subsystem: ASUSTeK Computer Inc. Device [1043:85df]

 

Merci  :) 

Si tu veux pas trop te prendre la tête à chercher, tu peux essayer d'installer le kext wifi de 10.12.

Où le trouver?

 

Merci 

 

 

Edit 1: le problème semble résolu pour l"instant: remplacement du IO80211family.kext (macOS Sierra 10.12.1) par celui de macOS Sierra 10.12. Pas encore regardé de près les différences de deux plugIns AiportBCM4360.

Share this post


Link to post
Share on other sites

Bon, je sais que je déterre un vieux sujet mais est-ce que finalement la PCE-AC68 est fonctionnelle dans Sierra 10.12.5?

 

Je pose la question car je viens d'en installer une sur mon hack El Capitan et elle fonctionne nickel. J'ai ajouté le kext "FAKEPCI BROADCOM WIFI de Rehabman afin qu'elle soit émulée comme Airport Extreme plutôt que tierce partie. Elle fonctionnait très bien sans ce kext mais je me demande si ce patch pourrait aider lors de la transition vers Sierra.

 

Merci,

 

Patrice

Share this post


Link to post
Share on other sites

Bon, je sais que je déterre un vieux sujet mais est-ce que finalement la PCE-AC68 est fonctionnelle dans Sierra 10.12.5?

 

Je pose la question car je viens d'en installer une sur mon hack El Capitan et elle fonctionne nickel. J'ai ajouté le kext "FAKEPCI BROADCOM WIFI de Rehabman afin qu'elle soit émulée comme Airport Extreme plutôt que tierce partie. Elle fonctionnait très bien sans ce kext mais je me demande si ce patch pourrait aider lors de la transition vers Sierra.

 

Merci,

 

Patrice

 

La PCE-AC68 fonctionne très bien sous Sierra 10.12.5 moyennant une réinstallation du kext Apple d'origine et non patché quand j'ai fait la mise à jour. 

 

Où trouver FAKEPCI BROADCOM WIFI de Rehabman?

Share this post


Link to post
Share on other sites

:whistle: Ben... au bout d'une recherche Google sur "Rehabman FakePCI" !

:D  :D  :D  :D  :D  :D  :D  :D  :D

Share this post


Link to post
Share on other sites

La PCE-AC68 fonctionne très bien sous Sierra 10.12.5 moyennant une réinstallation du kext Apple d'origine et non patché quand j'ai fait la mise à jour. 

 

Où trouver FAKEPCI BROADCOM WIFI de Rehabman?

 

Ben dans mon cas, elle fonctionne avec le kext d'origine... mais elle cause un "sleep wake failure" au retour de veille dans Sierra. J'ai même téléchargé la beta 10.12.6 pour voir. Pas de problème si mise en veille manuelle cependant, étrange!!!!

 

Là, j'essaye un autre truc: remplacer "AirPortBrcm4360.kext" à l'intérieur de IO80211Family.kext par celui d'El Capitan...

Share this post


Link to post
Share on other sites

Avec le kext d'El Capitan, pas de wifi. Je vais essayer autre chose: changer pour un SMBIOS iMac 15,1 (j'étais sur 14,2).

 

Pour infos, je suis avec un Bios patché Ozmosis.

 

Dans votre cas, Clover, quel SMBIOS?

 

Merci pour l'aide,

 

Patrice

Share this post


Link to post
Share on other sites

Retour: toujours ce "sleep wake failure" en retour de veille. Peut-être est-ce dû au fait que je travaille sur disque USB3 pour tester Sierra... Je vous reviens là-dessus.

 

Patrice

Share this post


Link to post
Share on other sites

Retour: toujours ce "sleep wake failure" en retour de veille. Peut-être est-ce dû au fait que je travaille sur disque USB3 pour tester Sierra... Je vous reviens là-dessus.

 

Patrice

J'utilise le SMBIOS Imac13,2 qui correspond le mieux à ma config (voir signature) mais aussi le SMBIOS macPro6,1 (plus difficile en raison du black screen). Quelle est votre config? Proc, CM....

Share this post


Link to post
Share on other sites

J'utilise le SMBIOS Imac13,2 qui correspond le mieux à ma config (voir signature) mais aussi le SMBIOS macPro6,1 (plus difficile en raison du black screen). Quelle est votre config? Proc, CM....

 

SMBIOS iMac 14,2, Ozmosis patché pour El Capitan, Gigabyte Z97X-UD3H, i7 4790, 16 GB de RAM, Samsung EVO 950 1TO, NVIDIA GTX950.

 

J'ai testé un clone El Capitan sur mon DD USB3 ce matin et aucun problème de retour de veille.

 

Donc, ça peut être dû à plusieurs choses quoique je suspecte principalement la PCE-AC68: CM, Ozmosis, etc...

 

J'ai fait une tentative en enlevant tous les kext tierce partie et j'ai obtenu le même résultat, sleep wake failure.

 

Merci,

 

Patrice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×