Jump to content
midi-sama

[GUIDE] [10.12] Sierra on Tab!

86 posts in this topic

Recommended Posts

On 9/18/2017 at 4:49 AM, erfoz said:

Well, i've just updated to High Sierra (latest Public beta and possible GM). Updated Clover to the last version (r4200) and the kexts in the Other folder (AppleAlc, etc so you have sound after the update). Of course no Wacom drivers yet, but everything else is working fine, APFS included. Noticeable faster for me, too.

Hey erfoz, Have you updated to 10.13.3 yet? How is APFS still working for you? I trying to decide if I should update to High Sierra. My ativ triple boots and runs great on Sierra thanks to midi-sama awesome guide. You mine uploading your clover folder to look at. Thanks, Cam

Share this post


Link to post
Share on other sites
Advertisement
3 minutes ago, Cameleer said:

Hey erfoz, Have you updated to 10.13.3 yet? How is APFS still working for you? I trying to decide if I should update to High Sierra. My ativ triple boots and runs great on Sierra thanks to midi-sama awesome guide. You mine uploading your clover folder to look at. Thanks, Cam

On my experience with HS on HD4000 systems similar to ATIV, I think it's ok to upgrade, you will still need to fix brightness after the upgrade. I recommend you TO NOT USE APFS. Skip the conversion, as it creates many issues (I dont have the tablet with me, but I do have many SSDs at home, some work fine with APFS, others dont, as they show slowness and corrupt data), so the safest way is to upgrade without converting (you can google for rehabman's guide on how to do it). Also, make a full TM backup before upgrading, because HS has introduced many graphical issues and instabilities.

As of now, I'm using a Thinkpad P50, and even with that powerful iGPU (with Xeon CPU), HS managed to mess up and I went back to Sierra. Same goes with the VAIO. If you're ok with installing the HS then restoring it if anything happened, let us about the result.

Share this post


Link to post
Share on other sites
20 hours ago, Cameleer said:

Hey erfoz, Have you updated to 10.13.3 yet? How is APFS still working for you? I trying to decide if I should update to High Sierra. My ativ triple boots and runs great on Sierra thanks to midi-sama awesome guide. You mine uploading your clover folder to look at. Thanks, Cam

I'm now on a Lenovo Yoga 700, wife is using the tab so i installed Windows 10 again for her. But i must say that it started to act weird after a couple of days when installed High Sierra and had to restore my backup of Sierra. I don't know if it was apfs related or not, but i would listen to @midi-sama advice. Backup your system with Clonezilla, try it and then tell us :)

Anyway, i'm having troubles with HS even on the Yoga. I'm running Sierra flawlessly, power management, trackpad gestures, etc, working great. But i cannot fresh install or even update to 10.13.3, installer/updater always reboots when it starts copying files, apfs or hfs+.

TL;DR update and try, keep a backup at hand.

Edited by erfoz

Share this post


Link to post
Share on other sites

im having a problem with making right config.plist, clover not booting...maybe someone can upload working config.plist or efi folder for xe700t1c-ao1us?

Share this post


Link to post
Share on other sites
On 5/23/2018 at 10:21 AM, angrynewb said:

im having a problem with making right config.plist, clover not booting...maybe someone can upload working config.plist or efi folder for xe700t1c-ao1us?

Same thing. Following the guide step by step but clover doesn't boot.

 

I've also noticed that midi mentions TRIM SSD when making a config.plist. However there is no TRIM SSD part in the original config.plist... am I missing something?

Share this post


Link to post
Share on other sites
On 9/18/2017 at 12:27 PM, erfoz said:

 

I can upload a copy of my Clover folder if you want it.

I would appreciate it if you still have it!

Share this post


Link to post
Share on other sites

Sorry guys for not updating the guide, I guess by now a lot of things changed (and it did change) and my tablet died. I just got a new HP Elite X2 G2 that I'm trying to hackintosh. If I ever find a free time I'll probably update the 2nd post as it will have some minor updates that will all be theoretical, so no real experimenting will be done. Sorry again. 

Share this post


Link to post
Share on other sites
36 minutes ago, midi-sama said:

Sorry guys for not updating the guide, I guess by now a lot of things changed (and it did change) and my tablet died. I just got a new HP Elite X2 G2 that I'm trying to hackintosh. If I ever find a free time I'll probably update the 2nd post as it will have some minor updates that will all be theoretical, so no real experimenting will be done. Sorry again. 

Thanks for still checking this thread out, sorry for your tablet!

Would really appreciate your help because I've read that no-one complained on installing the macOS here so I feel like I'm the chosen one to fail lol

 

Right now if I follow the guide and boot the macOS installation for the very first time I receive this (used -v to see):

 

Error allocating 0x4c05 pages at 0x0000000000c7b000 alloc type 2

Error loading kernel cache (0x9)

Boot failed, sleeping for 10 seconds before exiting...

 

It's the latest Sierra, Clover and FakeSMC.kext. I'm wondering, maybe I should use some older versions from around 2015-2016?

 

 

I've also tried the El Capitan from the How-To that you've been inspired with but got this error (in the attachment). Ito make it short it says: "Unable to find driver for this platform: "ACPI".

Maybe you could give a direction I should look into? Feeling pissed because none of the guides work for me. 

IMG_8118.JPG

Share this post


Link to post
Share on other sites

So I've managed to get a workable (hopefully stable) install of High Sierra. It was an exciting research! I'll return tonight to write down the steps that I've made.

Share this post


Link to post
Share on other sites
On 8/3/2018 at 9:09 AM, xealstorm said:

So I've managed to get a workable (hopefully stable) install of High Sierra. It was an exciting research! I'll return tonight to write down the steps that I've made.

I'm running Mojave on a Yoga 700, I don't have the EFI for the Tab anymore at hand. But I guess you don't need it anymore :)  Congrats on your successful hack!

Share this post


Link to post
Share on other sites
On 11/25/2016 at 2:32 AM, MrHomebrew said:

It seems as if the internal display is not detected by Os X. In os x setting I do not see the internal display itself as an option. Constantly forcing the Hdmi port to be the display for os x/external display.

 

Like I said the tablet display does stay black and acts as a trackpad for the Hdmi external display.

 

Overall I know there is a solution

 

Sent from my SM-G935F using Tapatalk

can you tell me the solution on how to fully enable the internal display/make sure it is recognized by os x itself.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Install MacOS with Olarila Image, Step by Step, Install and Post Install  
      https://www.olarila.com/topic/5794-hackintosh-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Install Sierra/High Sierra and boot into system!   Post Installation   --Paste my EFI folder into EFI partition  EFI GA H110M-S2.zip     --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.GA H110M-S2.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By Prasanth_1991
      I recently installed Hackintosh Sierra. I don't have dedicated graphics card so I just used Intel integrated graphics which is Intel HD 4600 but since the Mac OS Sierra graphics acceleration not supported by native VGA output I'm left out options. I tired many things but nothing works. It's 2020 I'm pretty sure many people probably have better solution for this, if yes please help me.   Details PC Spec  i7 4790k HD 4600 Motherboard Gigabyte B85M-D3H-A
    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
×