Jump to content
Whaka

demarrer osx avec chameleon sur un mac pro ?

3 posts in this topic

Recommended Posts

Salut,

 

que voilà une question saugrenue :D

certains se demanderont certainement pourquoi j'aimerai arriver à ce résultat. et bien je vais essayer d'expliquer court et simple.

 

dans les mac pro (les camions, evidemment. pas l'espece de poubelle hautement "design..."), on est nombreux à vouloir utiliser des cartes graphique du monde pc.

si c'est aujourd'hui possible sans grosse prise de tête, la contre partie, est qu'on ne peut pas avoir l'ecran de démarrage.

l'affichage arrive suelement quand osx est lancé. donc pour résoudre le probleme, le mieux est donc de flasher la carte avec une rom mac.

 

mais voilà, tout le monde ne sait pas faire, et tout le monde n'a pas non plus envie de dépenser des fortunes dans des carte flashées (et parfois loin d'être récentes)...

y'a donc une autre voie à laquelle j'ai reflechi, et qui me semble exploitable, et dont je suis surpris de ne pas en avoir entendu parlé avec tout les bidouilleurs qu'il y'a dans le monde :D

 

un mac, aujourd'hui, c'est rien de plus qu'un pc avec un EFI un peu custom... il en est même tellement proche, que son firmware peut  passer en mode "legacy bios pc"...

et si vous voyez où je veux en venir, dans ce mode, et bien... n'importe quel carte graphique "pc" est initialisée et permet donc un affichage avant le lancement d'un systeme d'éxploitation :)

 

et donc, chameleon peut forcer le mode "pc" sur un mac, et donc d'avoir l'ecran "pommé", et de pouvoir aussi, du coup, donner toute les choses utiles qu'on ne peut avoir sans carte flashée.

en résumé : de démarrer osx comme sur un hackintosh :)

 

mais voilà, si j'ai pu parfaitement verifier ma theorie en faisant un dvd de démarrage avec un chameleon exempt de toute options propre au hackintosh, dans la pratique... c'est évidemment tout de même éxplosif :D

voilà où j'en suis avec une GTX650 dont la rom ne contient même pas une micro ligne de code pour le mode uefi, donc 100% legacy :

 

post-1172354-0-69430900-1477362280_thumb.jpg

 

c'est donc un demi positif : ça affiche bien l'ecran de démarrage comme je le supposait, mais si ça pouvait ne pas finir en KP, ce serait quand même mieux :)

 

j'ai donc besoin d'aide... si quelqun a une idée de ce qui pourrait causer cette KP, je suis preneur. toute les idées sont bienvenues :)

je rappel donc :

 

c'est un chameleon (2.2 r2404) débarrassé de tout modules/kext, et de fichier de config. il est nu de chez nu.

et la version d'osx qui tente d'être démarré : 10.9.5

et la machine : mac pro 3,1

 

voilà :)

Share this post


Link to post
Share on other sites
Advertisement

T'as essayé avec un Clover de base ? Genre config.plist minimaliste et aucun kexts/drivers.efi ? Ça resterait quand même de l'UEFI et c'est peut-être préférable sur un Mac :unsure:

 

J'avais tenté de booter mon MacBook Air avec Clover pour voir ce que ça donnait et si je pouvais changer queqlues infos système au passage et à ma grande surprise, ça avait fonctionné. D'ailleurs, je me demande si ça ne serait pas une solution pour les Mac qui sont compatbiles Sierra matériellement mais où l'installeur refuse de se lancer à cause de leur SMBios justement…

 

Après, je ne sais pas si ça réglera le KP ou si ça te permettra d'avoir l'affichage sur ta GTX.

 

Enfin bon, juste une idée ;).

Share this post


Link to post
Share on other sites

ouip,

 

j'avais tenté clover en mode natif. il arrive a s'afficher si la carte a une rom avec la portion uefi (donc ne fonctionne pas avec ma 650) et une fois passé clover, l'ecran redevient noir jusqu'a que osx soit chargé.

j'aimerai bien essayé clover en mode legacy, mais sur mac j'ai pas encore compris comment on forcait ce mode avec clover.

 

et oui, c'est aussi une solution pour installer osx sur des mac plus supporté :)

c'est avec clover et un fichier boot.efi (je crois) que les mac pro 1,1 et 2,1 ont pu aller au delà du lion.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×