Jump to content
ptzulu

[Success] Asus X-99A II + i7-6800k + GTX980ti

46 posts in this topic

Recommended Posts

Hi there!
 
So, a quick build list:
 
Asus X-99 A II
i7-6800k
GTX980ti
32gb RAM
512gb Crucial SSDCorsair RM750x PSUCorsair H110i Cooling for CPU
Corsair Carbide 400Q (it was going to be a Fractal, but the cooler didn't fit)
 
This is the build right now!
 
I've already made 5 hackintosh: 2 for personal use, and 3 for work, all based on i5 / i7 Haswell.
All worked (kinda) straight out of the box, with minor hickups (audio mostly), and from time to time, one refuses to boot, but a quick checkdisk does the job.
Now, the problem is, this build right now, which is going to be mainly work, refuses to pass the first 3-5 lines of coding, which hangs at ++++++++ (plus signs).
I believe that is related to CPUID, since, maybe, this one is not supported out of the box, but, can't find any info on this.
 
I've tried multiple things, and install methods (uefi vs legacy, kext replacement as per various guides and posts, and nothing seems to work), but, i'll try everything again if posted.
 
The only thing that seems to take me further, is chaging cpuid, but hangs with something that i cannot see (the pause button doesn't seem to work).

 

EDIT:

 

Hi y'all!

So, two major Thanks: user Giacomoleopardo and rampagedev (i don't know what the rules of cross credits)

So, first, the build:

Corsair Carbide Series® 400Q Compact Mid-Tower Case (it started with a Fractal r4, then r5, because there was no define S, and then we found 400q "lost" in the warehouse)
ASUS X99-A II(it was supposed to be a x99-A, not II, but the store though it was the same, and called asking if a "revision 2.x" was a problem or not... It was, but i didn't find out sooner ahah)

Intel i7-6800K 3.4Ghz 15M Cache

Gskill NS DDR4-2133MHz 2x8GB x2 (32GB total with 4 rams) (in the near future is probable that is going to be replaced to 3000+ MHz)

Gigabyte GeForce GTX 980 Ti Xtreme Gaming Windforce

Corsair RM750x

Corsair Hydro Series H110i

SSD Crucial MX500 525Gb

SSD Crucial MX100 256Gb



So, first of all, i think it was sheer luck ( I'll attach the entire EFI both for install, and on the current working disk, because i think it wasn't supposed to work )

Working
USB 2.0 and 3.0
Audio (rear, front, and gpu hdmi)
2 Monitor setup (DVI+DVI - DVI+HDMI/DP gives reboot, but work if plugged after Mac boots up)
1Gb Network
Bluetooth (5 bucks chinese adapter, and so far, magic mouse didn't complain)

Speedstep (without boost, it only reaches 3.5ghz)


Not Working
USB 3.1
Sleep (i don't know if it's common, but in my home hackintosh it work rather fine, but, maybe, sheer luck)


 

If someone have suggestion to improve CPU management or anything, or even a question (that i can answer) please, proceed!

 

Also, found a bug: it rarely happens, but, after boot, and in the desktop, the computer suddenly reboots.

config.plist.zip

drivers64UEFI.zip

kexts.zip

post-1341857-0-37540100-1477558848_thumb.png

post-1341857-0-68605700-1477560971_thumb.png

post-1341857-0-78618200-1477560977_thumb.png

post-1341857-0-75379400-1477561489_thumb.png

Edited by ptzulu

Share this post


Link to post
Share on other sites
Advertisement

for first install use FakeCpuID 306E4 an NullCpuPowermanagement.kext.

 

When system is up an running, read xcpm threads and apply patches to disable msrs in Sierra, or one patch solution for 10.11.6.

Share this post


Link to post
Share on other sites

With that i can pass the first error, only to be stuck at another:

 

Config.plist attached, and only diference is the use of 0x0306e4 in cpuid (wich i didn't put on config.plist)

 

Current Kext in 10.12 folder:

 

FakeSMC

GenericUSBXHCI

NullCPUPowerManagement

VoodooTSCSync

 

I have try with the boot args on the plist, as well as only the following:

 

-v

 

-v npci=0x2000

 

-v -x npci=0x2000

 

-v PCIRootUID=0 (and 1 too)

 

 

I don't remember anything else... But, i await for your godly responses!

post-1341857-0-55359200-1476798532_thumb.jpg

config.plist.txt

Share this post


Link to post
Share on other sites

With that i can pass the first error, only to be stuck at another:

 

Config.plist attached, and only diference is the use of 0x0306e4 in cpuid (wich i didn't put on config.plist)

 

Current Kext in 10.12 folder:

 

FakeSMC

GenericUSBXHCI

NullCPUPowerManagement

VoodooTSCSync

 

I have try with the boot args on the plist, as well as only the following:

 

-v

 

-v npci=0x2000

 

-v -x npci=0x2000

 

-v PCIRootUID=0 (and 1 too)

 

 

I don't remember anything else... But, i await for your godly responses!

 

http://www.insanelymac.com/forum/topic/316516-macos-sierra-on-broadwell-eep-not-a-guide-but-maybe-a-working-in-progress/

 

try to follow this thread

or this

 

http://www.insanelymac.com/forum/topic/313296-guide-mac-osx-1012-with-x99-broadwell-e-family-and-haswell-e-family/page-1

and it is mandatory to start to have this:

 

<key>Boot</key>

<dict>
<key>Arguments</key>
<string>-v npci=0x2000 kext-dev-mode=1 nv_disable=1</string>

Share this post


Link to post
Share on other sites

Hi,

 

you have to use driver64UEFI fix for allocation because x99 systems has problem with allocation... I uploaded for you my backup with all of these drivers folders... The driver you need is Test2.efi which is driver to resolve this allocation issue by one of insanelymac users... 

 

I did not reat what is above, but the boot args are also right and usefull...

Share this post


Link to post
Share on other sites

Fake cupid is not good try 0x040670

 

I'll Try that, maybe i can get better performance, but, with 0x0306e4 worked just fine and it's working.

I edited the first post to the current configuration.

Share this post


Link to post
Share on other sites

Hi there!

 

So, everything is working as per your instructions:

 

CPU is recognised as 6-Core Xeon E5, everything is working,

Double Monitor GPU works (only with two DVI; if DVI+hdmi or display port results in constant boot reboot)

Intensive Work (renders was the most intensive thing I tested, with a AE render of 7hours, and it works :) )

 

Anything else to add...

Share this post


Link to post
Share on other sites

Do you mind sharing your efi folder I have been trying to install Sierra on my msi x99a with 6800k

Kext + Config + driver64 Shared

 

the rest was kinda big, and without useful info.

 

Ask anything or suggest!

Share this post


Link to post
Share on other sites

Kext + Config + driver64 Shared

 

I hope this is all what I need to secessfully install sierra over my elcapitan 10.11.6 on asus x99-a?

I just need to replace this files you provide on my sierra bootable _USB with clover?

Share this post


Link to post
Share on other sites

I hope this is all what I need to secessfully install sierra over my elcapitan 10.11.6 on asus x99-a?

I just need to replace this files you provide on my sierra bootable _USB with clover?

Is the CPU and GPU the same?

Also, X99-A or X99-A II (unfortunately they are different)

 

For X99-A this guy as specific Kext and config.plist, also, with little search you can find working builds for X99-A.

Share this post


Link to post
Share on other sites

Is the CPU and GPU the same?

Also, X99-A or X99-A II (unfortunately they are different)

 

For X99-A this guy as specific Kext and config.plist, also, with little search you can find working builds for X99-A.

I added files from the first post and sucessfully instal sierra ... YEAH ...thanks.

after that, i add the same files on my hard drive but it stuck at the begining on "something allocationg" error...

why is that do i need to change anything....sucessfully boot with same files from usb and can't boot from hdd...

 

thanks...

asus x99-a

nvidia 780gtx

intel i7 5960k

Share this post


Link to post
Share on other sites

So, bobenia, you're saying you can boot to the Sierra desktop, if you boot from USB. But can't, if you boot from Mac HDD, right? Is the clover version the same, and, .efi drivers? Also, my config has the wrong (I think) cpuID for your CPU. Try 306E4, and maybe iMac 14,1.

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

So, bobenia, you're saying you can boot to the Sierra desktop, if you boot from USB. But can't, if you boot from Mac HDD, right? Is the clover version the same, and, .efi drivers? Also, my config has the wrong (I think) cpuID for your CPU. Try 306E4, and maybe iMac 14,1.

 

 

Sent from my iPhone using Tapatalk

exactly that - with same files in efi clover...

i got this error

https://www.dropbox.com/s/cqd01hij2ahplxn/IMG_20161027_144322.jpg?dl=0

where do i need to change cpuid?

here: https://www.dropbox.com/s/6nec0k06eq1oh3b/01.jpg?dl=0

 

thanks for help

Share this post


Link to post
Share on other sites

That's the spot. Put in the value 0x0306E4 (for test purpose).

If I'm not mistaken that error is related to the OsxAptioFixDrv. There is one called OsxAptioFixDrv and one OsxAptioFix2Drv. Test with one, and then the other (never the two together).

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

OK I'll trys that now...

next question.

I add nvidia web driver after I boot from USB.

after that I remove nv_disable=1 string and add nvda_drv=1 string

and I have black screen on log-on screen while boot from USB... like my monitor is turned off...

how to avoid this error?


EDIT:

where I can find OsxAptioFix2Drv ?


still no lluck if I change cpuid to 0x0306E4

I can't find OsxAptioFix2Drv

 

also i found this thread I can't find the way to download files from this thread...there is some efi files to download....

link: https://nickwoodhams.com/x99-hackintosh-solving-osxaptiofixdrv-allocaterelocblock-can-not-allocate-relocation-block/

 

please help

Share this post


Link to post
Share on other sites

OK. Please help me to solve the first problem.

I can boot with usb to my sierra but only with nv_disable=1

I add nvidia web driver for my 780GTX but when I remove nv_disable=1 and add nvd_drv=1

my monitor is turned off on logon screen so I can't log in inside...

 

how to solve this...

 

NVIDIA 780GTX / I use files from the first post

 

 

EDIT:

 

I SOLVED my problem with nvidia driver by changing SMBIOS from 6.1 to 14.1

so I have nvda_drv=1 with web driver installed.

 

and now, I only need help with booting from my HDD...

I need OsxAptioFix2Drv If anyone can help me how to find it so I can try with that...

 

thanks

Share this post


Link to post
Share on other sites

Ok, let go one thing at a time:

 

https://mega.nz/#!A19wiL6R!xrh-VWpj89m3DoqQpWZDoA5VTWryxdi6B9ckDWwrx1E

 

Here's the two efi. Test with both, one at a time.

 

That being said, nvda_drv=1 does not work in Sierra, you have to use System Paramers -> [check] NvidiaWeb (use clover configurator as in the image attached)

post-1341857-0-51370500-1477662235_thumb.png

 

One thing is missing (my bad), and maybe it's needed, and it's the patch attached. That patches a system kext, so, in some system updates it may need to be used again.

 

Here's the reference and credit: PikeRAlpha - if you google AGDPfix in google, one site, that is not this one, has a detailed description and workaround.

 

There's the option to use Clover "on the fly" binary patch for the AppleGraphicsDevicePolicy.kext. Didn't test, so, I don't know.

 

Also, if more than one GPU, it doesn't seem to work, but, thats not my case or apparently yours.

<dict>
                <key>Comment</key>
                <string>AppleGraphicsDevicePolicy (board-id) Patch (c) Pike R. Alpha</string>
                <key>Find</key>
                <data>
                Ym9hcmQtaWQ=
                </data>
                <key>Name</key>
                <string>AppleGraphicsDevicePolicy</string>
                <key>Replace</key>
                <data>
                Ym9hcmQtaXg=
                </data>
            </dict>

So, if you can boot with nv_disable=1, what you need to do is, boot that way, install nVidia Web Drivers (latest ones), enable Nvidia web drivers, DON'T RESTART YET, apply the AGDPfix.app, and then reboot.

 

This time, boot without nv_disable=1, but with the parameter that is in the screenshot. Also, test with only one monitor first (it gives me reboots if I use anything other then DVI+DVI.).

 

Good luck! May the hack be with you :D

AGDPfix.zip

Share this post


Link to post
Share on other sites

I just erase partition on my HDD drives and I did a clean install, and not upgrade.

and everything works super fine with the clover files and kext from the first post.

I can boot from HDD also...

 

just to confirm that everything works for this configuration Asus x99-a / intel i7 5960k / Nvidia 780 GTX

THANKS SO MUCH!!!

Share this post


Link to post
Share on other sites

Today morning I updated to 10.12.1 (by mistake... still was thinking this was my "old" 2015 iMac) and screwed the boot again.

 

I had to update Nvidia Web Drivers, and apply the AGDPfix again (because I'm lazy to make a dsdt patch).

Still, I have the entire EFI folder backed up and a USB pen with the Sierra Install, just in case I need to make any adjustment.

 

Happy to se everything is working! Post some benchmarks :D

Share this post


Link to post
Share on other sites

Today morning I updated to 10.12.1 (by mistake... still was thinking this was my "old" 2015 iMac) and screwed the boot again.

 

I had to update Nvidia Web Drivers, and apply the AGDPfix again (because I'm lazy to make a dsdt patch).

Still, I have the entire EFI folder backed up and a USB pen with the Sierra Install, just in case I need to make any adjustment.

 

Happy to se everything is working! Post some benchmarks :D

 

good to know about 10.12.1 update

I'm not using AGDPix patch - I'm on 14.1 SMBIOS 

is it better to use 6.1 with this AGDPix patch?

 

also I'm not using any DSDT patch - I don't know how to do that yet.

 

 

thanks for help.

 

EDIT:

her his my benchmark with 14.1 smbios

 

https://drive.google.com/file/d/0B6AS3GlgY7ZFNUFPalU2YWs5QzQ/view?usp=sharing

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By glasgood
      GLASGOOD'S
       
      MOJAVE HACKINTOSH GUIDE 
       

       
       
       
      **FOR**  GIGABYTE Z390 AORUS PRO
       
       
       
       
      CREDITS & THANKS
       
      @MaLd0n
      His help with EFI configuration and DSDT
       
      CLOVER  TEAM
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, rehabman, Download-Fritz, Zenit432, cecekpawon Et al
       
      APPLEALC
      Acidanthera, vit9696
       
      VOODOOHDA
      autumnrain, slice2009, zenith432
       
      ESP PRO MOUNTER
      @Micky1979 
       
      HACKINTOOL
      @headkaze
       
      CLOVER CONFIGURATOR
      Mackie100
       
      THEME ENGINE
      Alex Zielenski
       
      INSANELYMAC
      OLARILA
       
      Hackintool Tutorial
      daliansky
       
      Hackintosh Vanilla Desktop Guide
      /r/Hackintosh - corpnewt
       
       
      MONITORCONTROL
      JoniVR & theOneyouseek
       
       
       
      ------------------------------------------------------------------------------------------------------------------------------------------------------------
       
      UPDATES
       
       
      ------------------------------------------------------------------------------------------------------------------------------------------------------------
       
       
      PART LIST
       
      • Intel I7 8700 
      • Gigabyte Z390 AORUS PRO
      • Gigabyte AORUS RADEON RX 580 8GB ( connected to monitor with DisplayPort )
       
      • Corsair Vengeance LPX 16GB ( 2 x 8GB ) 2666MHz – CMK16GX4M2A2666C16  In this build, both memory modules are installed in memory slots DDR4_A1  and DDR4_B1 
       
      • Corsair RM650x 80 Plus Gold Power Supply Unit
      • Corsair H100i V2 AIO Hydro/Water RGB LED CPU Cooler
      • Samsung EVO 500GB SSD (2.5) macOS Mojave
      • Samsung EVO 250 GB SSD (2.5) Windows 10 Pro
      • NZXT H500 Mid Tower ATX Case
       
      • RECOMMENDED WIFI CARD → ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS  
      OR
      • WIFI and Bluetooth with BCM94331CD with PCI-e adapter (but will require AirportBrcmFixup.kext for AirDrop.. )
       
      ** Avoid Samsung EVO 970 PLUS as Hackintosh has problem with that device **
       
       
      WORKING
       
      • Sound 
      • HDMI Port on AMD RX580 / 590 ( Ensure you disable BIOS CSM if using HDMI on RX580 / RX590 )
      • HDMI Port on Aorus Z390 Motherboard ( Ensure you have correct BIOS settings as per this guide for Intel only)
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Handoff
      • Continuity
       

       

       
       
       

       
       
       
       
       
      PREAMBLE - BEFORE YOU START 
       
      Here detailed, is all the  steps towards building a successful and stable Aorus Pro Z390 Hackintosh, if you are a first time Hackintosher, this guide will have you quickly up and running with the Aorus Pro Z390 Hackintosh. To rule out any problems from the go,
      only have the disc that you plan to install macOS Mojave connected to the Aorus Pro, disconnect any other Windows / Linux or data drives, external drives from your Aorus Pro. Windows / Linux and data drives can be connected after successful installation of macOS Mojave
      If you have more than 16 GB of memory, then install macOS Mojave with just 16GB, you can later add any additional memory. Install memory modules in slots DDR4_A1  and DDR4_B1. This build has the Wi-Fi combo PCI-e card installed in slot PCIEX1_3
      with its 9 pin USB cable attached to motherboard header F_USB2. 
       
      If using the Corsair H100i v2 AIO cooler with USB cable connected to motherboard header F_USB1, you will need to enable hot-patch ( explained in guide ) in config.plist for working sleep, wake from sleep will only work by pressing Power Button.
      However, If not using the Corsair H100i v2  USB cable, then you have wake from sleep using Keyboard / Mouse or Power Button.
      The Corsair USB cable is only required if using Corsair Link software in Windows for custom Fan or LED settings.
       
      Install macOS Mojave on its own physical drive, so do not try and install macOS Mojave onto a free partition on a disc that contains Windows.
      Remove any Thunderbolt cards, Thunderbolt card can be reinserted after installation.  Double check your BIOS settings are the same as this guide. 
       
      Following are unsupported / problematic
       
      • Intel Optane ( if you have this, remove it before installation of macOS Mojave )
       
      • Samsung EVO Plus drives ( firmware problem with macOS )
       
      • XFX Radeon RX 580
       
      • NVIDIA GTX / RTX not supported in macOS Mojave
       
      • Fenvi T919 Wireless Card, it seems Bluetooth is not working out of box for some users ( Maybe the USB port attached to Fenvi bluetooth is wrongly configured, or the SSDT-UIAC.aml port connector was not configured as Internal, or maybe some other reason )
         Save yourself a headache --->  RECOMMENDED WIFI CARD WORKING OUT OF BOX (OOB)  is ---> ABWB 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E) BCM943602CS 
       
       
       
      Q - WILL THIS GUIDE WORK WITH MY NON AORUS Z390 PRO MOTHERBOARD ?
      A - Possibly may work with other Z390 chipset motherboards. See very bottom of page for PRE & POST - INSTALL AORUS X 390 EFI's ( will require USB SSDT fix  )
       
      Q - I notice you have the Aorus Pro Z390 version, will this guide work with Aorus Pro Z390 WiFi version ?
      A - Yes, but onboard Intel / Intel CNVi WIFII /Bluetooth will not work with macOS and you will have to disable HS14 for Bluetooth to function properly on BCM943602CS or BCM94331CD WiFi/Bluetooth Combo cards ( more info at bottom of guide) .
       
       
       
       
       
       
      PART 1 - DOWNLOAD 
       
       
      Download the following:
       
      • CLOVER
       
      • PRE-INSTALL Aorus Pro Z390 EFI - RX580.zip
       
      •  POST-INSTALL Aorus Pro Z390 EFI - RX580.zip
       
       
      //OPENCORE EXPERIMENTAL EFI FOR RX580==> EFI.zip
       
       
       
       
       
       
      // INTEL UHD 630 EFI  Aorus Pro Z390 EFI's below. For those who do not have a Graphics Card Installed in PCIe Slot, requires Initial Display Output BIOS setting to be changed to IGFX  spoiler below!
       
      •  PRE-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip
       
      •  POST-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip
       
       
       
       
       
       
      • ESP MOUNTER PRO v1.9
       
      • macOS MOJAVE 
       
      • CLOVER CONFIGURATOR
       
      • EmuVariableUefi-64.efi  ( Used only to initialise iMessages. It then must be removed from Clover drivers64UEFI folder as will cause intermittent memory allocation errors on boot, explained in guide)
       
       
      OPTIONAL DOWNLOADS
       
      • Native Display Brightness with MonitorControl
       
      • VoodooHDA.kext.zip 

      • ThemeEngine 
       
      • Assets.car 
       
       
      // Not really needed but IF no sound on Wake from Sleep then use SSDT-ALC1220 and CodecCommander
      • SSDT-ALC1220.aml  ( Resolves Audio Sound on Wake, place in Clover / ACPI / Patched )
       
      • CodecCommander.kext.zip ( Resolves Audio Sound on Wake, place in Clover / Kexts / Other )
       
       
       
       
      PART 2 - BIOS SETTINGS (version F9 )
       
       
      Here is a list of the BIOS settings that I have used ( Screenshots in spoiler below )
       
      • Enter BIOS → Press F12 → Enter Setup
      • Save & Exit → Load Optimized Defaults
       
      • BIOS → Windows 8/10 Features → Other OS
      • BIOS → CSM Support → Enabled
       
      • Peripherals → Initial Display Output → PCIe 1 Slot
      • Peripherals → Trusted Computing → Security Device Support →  Disable
      • Peripherals → Intel(R)Bios Guard → Intel BIOS Guard Support →  Disable
      • Peripherals → USB Configuration → Legacy USB Support →  Enabled
      • Peripherals → USB Configuration → XHCI Hand-off →  Enabled
      • Peripherals → Network Stack Configuration → Network Stack →  Disabled
      • Peripherals → SATA And RST Configuration → SATA Mode Selection →  AHCI
       
      • Chipset → Vt-d → Enabled
      • Chipset → Internal Graphics → Enabled
      • Chipset → DVMT Pre-Allocated → 256M
      • Chipset → DVMT Total Gfx Mem → MAX 
      • Chipset → Audio Controller → Enabled
      • Chipset → Above 4G Decoding → Disabled 
       
      • Power → Platform Power Management → Disabled ( Change to enabled after macOS is installed )
      • Power → ErP → Disabled  ( Can be enabled if you have RGB lighting that you want to power off when shutting down Hackintosh. Thanks @AudioGod for flagging this up)
      • Power → RC6 (Render Standby) → Disabled
       
      // IF USING  CORSAIR H100i V2 AIO CPU WATER COOLER 
      • MIT → Smart Fan 5 Settings → CPU Fan Control mode → PWM 
       
      • Save & Exit → Save & Exit Setup
       
      SCREEN DUMP SPOILERS
       
       
       
       
       
      PART 3 – CREATE A MOJAVE USB FLASH INSTALLER
       
      Prepare USB Installer for Mojave ( Video below )
       
      • Insert USB drive
      • Launch /Applications/Utilities/Disk Utility
      • Disk Utility → View → Show All Devices
      • On Left-hand panel → External →(Identify your USB device in left hand panel)
      • Click and highlight your USB device in the left-hand panel.
      • Click erase button.
      • Name: USB
      • Format: Mac OS Extended (Journaled )
      • Scheme: GUID Partition Map
      • Click Erase button.
       
      • Place the downloaded MacOS Mojave app into Applications folder.
      • Open Terminal copy and paste:
       
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --nointeraction && say Mojave Drive Created  • Enter
       
       
       
       
       
       
       
       
       
       
       
      PART 4 – INSTALL CLOVER ON THE MOJAVE USB INSTALLER 
       
      Make Mojave USB flash drive installer bootable.( Video below )
       
      • Launch Clover application, double click.
      • Click Continue → Continue → Continue 
      • Click Change Install Location button.
      • Click Install macOSMojave USB installer → Continue
      • Click Customise button
      • Choose:
      Clover for UEFI booting only Install Clover in the ESP Themes UEFI Drivers • Click Install button
      • Installation Complete!
       
      Video:
       
       
       
       
       
       
      PART 5 – CUSTOMIZE MOJAVE USB INSTALLER FOR AORUS Z390 PRO
       
      Replace Clover EFI folder with PRE-INSTALL Aorus Pro Z390 EFI - RX580.zip  OR  if NO graphics card installed in PCIe slot, then use PRE-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip( Video below ) 
       
      • Install ESP Mounter Pro v1.9
      • Using ESP Mounter Pro, Mount ESP on disk2s1 ( Your disk name may be different )
       

       

       
       
       
      • Open mounted EFI partition found on desktop
      • Copy all the contents from Aorus 390 Pro EFI folder
      • Replace USB EFI folder with all the contents inside the Aorus 390 Pro EFI folder.
       
       

       
       
       
       
       
       
       
      PART 6 – INSTALL MAC OS MOJAVE ON INTERNAL DRIVE
       
      INSTALL NOTE
       
      ENSURE BIOS: Above 4G Decoding is set to Disabled 
      if Above 4G decoding is set to enabled then macOS Mojave install will freeze at 2 mins remaining and will not shut down properly!!!!
       
      Please be patient during install, so when install gets to 2 or 3 mins remaining then it may take extra time. Be ready to boot from UEFI USB installer by pressing F12 when install initiates restarts. 

      • INSERT USB INSTALLER INTO THE USB 2.0 PORT  
       
       
       Here is a walkthrough of the full process using the macOS Mojave USB Installer on the Aorus Z390 Pro. 
       
       
       
       
      • Power on PC and press F12• Choose bootable USB drive from boot menu.
       
       
       
      • Install macOS Mojave to internal solid state or hard drive.
       
       
       
      When system returns to the Clover boot menu choose:
       
      • Boot macOS Install from Macintosh
       
       
       
      At next restart, press F12 and boot from external UEFI USB device and choose:
       
      • Boot macOS Install from Macintosh
       
       
       
      Proceed with macOS Mojave install
       
       
      macOS Mojave is now installed, but it can only boot at this moment thanks to FakeSMC and Clover on the Mojave USB flash drive installer.
       

       
       
       
       
       
       
      PART 7 – MAKE AORUS Z390 PRO INTERNAL DRIVE BOOTABLE
       
      Make internal drive bootable ( Video below )
       
      So far, the Aorus Pro can only boot the internal system drive with the aid of the Mojave USB Installer.
      To boot from the internal system drive without the installer: 
       
      Download and install Clover with RC Scripts on target volume.  
      If your Aorus Pro Z390 has AMD RX 580 then copy the EFI folder from inside POST-INSTALL Aorus Pro Z390 EFI - RX580.zip  folder and paste it inside the the System Drive EFI partition.          OR
      If your Aorus Pro Z390 has no graphics card installed in PCIe slot, then copy the EFI folder from inside POST-INSTALL Aorus Pro Z390 EFI - Intel UHD630.zip  folder and paste it inside the the System Drive EFI partition.   
       

       
       
       
      • Remove USB Mojave installer and shut down and restart.
       
      Aorus Hackintosh should now be able to boot to macOS Mojave, Done, well almost ! 
       
       
       
       
       
      PART 8 – ENABLE IMESSAGES & FACETIME 
       
       
      // UPDATE 21st MAY 2019
       
      Possibly Clover Configurator now automatically populates correct values for working iMessages when you select an SMBIOS.  
       

       
      After selecting SMBIOS, example iMac19,1 for Aorus Pro with RX580 ( image above ) then go to Apple and ensure you have the "serial number is not valid " message. Done!
       
      If you still have problems connecting to iMessage, test and ensure that AirDrop is working, then follow instructions inside spoiler. 

       
       
      • Mount internal drive EFI/ESP partition
      • Go to folder CLOVER → drivers64UEFI 
      • Place both EMUVariableUefi-64.efi inside → drivers64UEFI
       
       
      Using Clover Configurator, add the following argument to config.plist using Clover Configurator.
       
      • Slide = 0
       

       
       
      Shutdown and then press power on button on PC.
       
      • You should now be able to Log into iCloud, iMessages and FaceTime
       
       
       
      • NOW delete EMUVariableUefi-64.efi from CLOVER → drivers64UEFI Folder 
      • Shutdown and restart Aorus Pro hackintosh. iMessages etc is now operational without EMUVariableUefi-64.efi ( EMUVariableUefi-64.efi only needed to initialise iMessages )
       
       
      // UPDATE 22nd May 2019 
       
      • It seems that there are no "Couldn't allocate runtime area"  errors when continuing to use EMUVariableUefi-64.efi since updating to macOS Mojave 10.14.5 and using Clover version r4920. 
      • It is important to delete EMUVariableUefi-64.efi, this will avoid very intermittent boot errors such as: “Couldn’t allocate runtime area”  post errors.
       
       
       
       
      PART 9 – ENABLE TRIM for Solid State Flash Drives
       
      Open Terminal and enter the following command:
      sudo trimforce enable  
       
       
       
       
      DEFAULT SSDT –  USB PORTS FIX CONFIGURATION WITH FRONT USB-C - SSDT USBPorts.kext ALREADY INSIDE AORUS Z390 EFI FOLDER  – Provided by @AudioGod  
       
       

       

       
      If you have USBC on Computer Chassis / Case, then SS01 and SS02 is mapped to that USB C port 
       

       
       
       
       
       
       
      ------------    GUIDE FINISHED YOU SHOULD NOW HAVE WORKING AORUS Z390 PRO HACKINTOSH  WITH SSDT USB FIX   ------------
       
       
       
      OPTIONAL: Set Wi-Fi Country Code
       
       
       
       
       
       
      OPTIONAL: System Information - PCI
       
       
       
       
       
       
       
      External USB Storage:  Fix "disk did not eject properly" message upon wake from sleep
       
       
       
       
       
       
       
      OPTIONAL:  Native Display Brightness - with MonitorControl

       
       
       
       
       
       
      OPTIONAL:  Dual Boot macOS Mojave & Windows 10 
       
       
       
       
       
       
       
       
      OPTIONAL:  Replace the default "About This Mac" Apple Logo with RED AORUS APPLE
       
       

       
       
       
       
      OPTIONAL - ALTERNATIVE SSDT 1 –  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 2 -  SSDT Ports configuration below - replace SSDT inside Clover /ACPI/PATCHED folder 
       
       
       
       
       

      OPTIONAL - ALTERNATIVE SSDT 3 – Create your own SSDT
       
       
       
       
       
      FRAMEBUFFER PATCHING  – For working Intel UHD 630 Graphics, working HDMI Port, working HDMI Audio on Aorus Z390 Pro
       


       
       
       
       
       
       
      FINAL CUT PRO  – Configuration for AMD RX5xx 
       
       
       
       
      AORUS PRO Z390 WIFI version with Intel CNVi  – Disable Bluetooth on HS14
       
      Resolve bluetooth issue  reported by @eSaF 
       
       
       
       
       
       
      CLOVER  – Updating / Upgrade Clover boot loader 
       
       
       
       
       
       
      SLEEP  – Sleep and Automatic Sleep

       
       
       
       
       
       
       
       
      SLEEP  – Resolving Instant Wake ( Corsair H100i v2 AIO )
       
       
       
       
       
       
       
       
      WIFI  – Clover Hotpatch PXSX to ARPT
       
       
       
       
       
       
       
       
       
       
      RECOMMENDED READING  – Excellent Hackintosh Vanilla guide created by CorpNewt with in depth tutorial on Clover.  
       
      https://hackintosh.gitbook.io/-r-hackintosh-vanilla-desktop-guide/config.plist-per-hardware/coffee-lake
       
       
       
       
       
       
       
       
       
      AORUS Z390 MOTHERBOARD X  – EFI WITH NO USB SSDT, WITH PORTS LIMIT PATCH, WITH SSDT-GPRW SLEEP / WAKE FIX
       
      Q - I notice you have the Aorus Pro Z390 version, will this guide work with other Gigabyte Aorus Z390  motherboards ?
      A - Possibly, but it is not guaranteed that these EFI folders below may work. 
       
       
      PRE-INSTALL Aorus X Z390 EFI - RX580.zip
      POST-INSTALL Aorus X Z390 EFI - RX580.zip
       
      PRE-INSTALL Aorus X Z390 EFI - Intel UHD630.zip
      POST-INSTALL Aorus X Z390 EFI - Intel UHD630.zip
       
       
       
       
       
       
       
       
       
       
       
       

       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
       
      SSDT-UIAC.aml.zip
      SSDT-UIAC.dsl.zip
       
      CodecCommander.kext.zip
      SSDT-ALC1220.aml.zip
       
      POST-INSTALL Aorus Pro Z390 EFI - RX580 2.zip
    • By t0mmenhansen
      I havent used my hackintosh in a while. I wanted to boot to my mac drive. This error comes up when i try to boot. Ive tryed using explorer++ and update the lilu kext and whatevergreen kext, no luck yet. Any ideas?
       
      9700k
      16GB corsair
      1080 nvidia card
      z370-f mobo
      mac drive is an SSD from kingston
      Display port outpoot
       
    • By fusion71au
      Clover r4961 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4961 for VMware.zip". Mount Clover-v2.4k-4961-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By Technology & more
      Can Someone make a guide to install macOS Mojave on the Surface Pro 1?
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&amp;t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×