Jump to content
tluck

[GUIDE] Lenovo T460 macOS with Clover

813 posts in this topic

Recommended Posts

updated the zip - audio kext mods

- added ambient noise for external mic input - i still get quite a bit of hiss.

- added extra Output -  LineOut for dock audio

- included syscl's updated nvram save scripts for /etc/rc.shutdown.d etc

 

@mangyver 

- i added the HS09 port - it's the finger print reader for me. 

Can we somehow modded the fingerprint to work like touchid lol ?

Share this post


Link to post
Share on other sites
Advertisement

Can we somehow modded the fingerprint to work like touchid lol ?

 

Lol, even under Windows it doesn't work very well...

 

But for the card reader do you think there is a solution?

Share this post


Link to post
Share on other sites

Thanks again everyone - this just gets better all the time!

 

Any advice on audio troubleshooting? I've followed all the instructions (twice) and still not working. Where should I check first?

 

Thanks

TDB

Share this post


Link to post
Share on other sites

@tluck: So on the t460 the 3 finger swipe left/right works good?

 

Hm.... i figured out, that the 3 finger swipe left/right works with rehabmans voodoops2 kext with the t560. The changes, you have did, make the trackpoint buttons work better (left click the left button/middle button for scrolling/right click is right button)... BUT the 3 finger swipe (left/right) doesn't work any longer.

Do you have an idea why the 3 finger swipe left and right doesn't work any longer on the t560 trackpad? 3 finger swipe up/down work perfect.

 

 

________________

the new audio kext is not working with the t560. The old one is working fine.

 

@thedeliveryboy: the AppleHDA_alc293 is in your /S/L/E or /L/E?

Share this post


Link to post
Share on other sites

so this AppleHDA_ALC293.kext isnt working for either of you?

this custom kext should be in /L/E

it links to the real AppleHDA.kext in /S/L/E

 

3 finger swipe - when you said it works? in what app does it work. i remap from the default mapping to command [ and command ] - which are back/forward in safari.

Share this post


Link to post
Share on other sites

@tluck: i go to the settings - keyboard - shortcut.

 

There i try to define a shortcut to any command... just for testing purposes. When i try to define a command with 3 finger swipe left/right it doesn't do anything there. Just the swipe up/down works.

When i use rehabs kext, it works. 

 

I also tried to delete your remapping, cause i thought it could be the problem, but it isn't.... as you said: Your command just redefines the 3 finger swipe left/right.

 

Is it possible to reach you in irc or anywhere???

 

And the new Applehda isn't working for me, too. Correct. The old version works..

Share this post


Link to post
Share on other sites

hmm.  i dont understand how swipe can be that different. 'my' voodooPS2 kext is essentially the same as rehabman's kext. i added LENOVO override definitions for Keyboard and Trackpad. but those can be removed for testing.

 

audio - wonder what is going on here.

- there is non-dock version of the files - in the Resources directory in the kext.

- copy the *nodock* files  to layout28.xml.zlib and Platforms.xml.zlib and rebuild the kextcache

Share this post


Link to post
Share on other sites

Can we somehow modded the fingerprint to work like touchid lol ?

The FP reader works in macos at all? The t460s touch sensor is pretty awesome. The t460 swipe sensor does indeed suck. The t470 has upgraded it to the same one as the t460s in addition to an IR cam for Windows Hello.

Share this post


Link to post
Share on other sites

@mangyver

- have you tested the new Audio kext i posted today? i want to see if there is a wide-spread issue?

- there used to be sw - i never used it - to use the finger print - it was for mac OS that worked on the T420 (Upek device finger print reader) - TrueSuite by Authentec. 

Share this post


Link to post
Share on other sites

Wow. I had check marked most of the prefs....  after unchecking the swipe left/right worked!!!!!!!

Thank you very much for investigating.

 

Regarding the audio: Didnt use the audio settings (i mean: hdmi audio) yet. If you want to i can test tomorrow if i can modify the audio kext.

Share this post


Link to post
Share on other sites

@barrrrt- cool - glad it is working now! 

 

- on audio just wanted to make sure the basic audio speakers/mic are still working for everyone.  I added 2 audio out options -(1) HDMI and  (2) LineOut for ThinkPad Dock

as well as tweaked the Boost levels for the Mics.

 

Since the T440 use ALC292 - which almost identical to the T460 ALC293 - was able to leverage shmilee's excellent work for the 460/560.  

Share this post


Link to post
Share on other sites

And on your side the audiokext is working without problems? Hm.... Wondering why it didn't find any device when i used the new kext.... But u had an idea... ill test tomorrow.

Share this post


Link to post
Share on other sites

@mangyver

- have you tested the new Audio kext i posted today? i want to see if there is a wide-spread issue?

- there used to be sw - i never used it - to use the finger print - it was for mac OS that worked on the T420 (Upek device finger print reader) - TrueSuite by Authentec.

Not yet. I'll give it a whirl soon. I've not had issues with the older kext though.

 

The new touch fingerprint sensor is from Synaptics. Probably no drivers for it.

Share this post


Link to post
Share on other sites

Not yet. I'll give it a whirl soon. I've not had issues with the older kext though.

 

The new touch fingerprint sensor is from Synaptics. Probably no drivers for it.

 

The updated XHC SSDT and the audio kext are working for me.

Share this post


Link to post
Share on other sites

Ah.. ok... its possible that it didn't work for me, cause I just changed the kext and didn't change the ssdt.

I created a new HDEF ssdt and checked the config.plist for the audio entry (port 28). After a restart, the new audio kext is working too.

Share this post


Link to post
Share on other sites

WWAN working

Hi guys.

 

I bought a Huawei ME906S wwan card for my t560. It took me really long, but finally i got it working. 

Short side note: the me906s seems to be the European version. The ME906E is on the markt too, and should work with the attached kext, too.

 

You need at least 2 kexts in the SLE or LE folder. After that, you are done.

 

The HuaweiDataCardDriver_10_9.kext is extracted from the newest "mobile connect" software from Huawei. Thats just a suite with the driver and a software that can connect to your network... but... the suite is not needed.

 

Card is not shown in system profile - network - wwan. I don't know why, but it doesn't matter... right? :D

 

 

post-201975-0-56305900-1483874243_thumb.png

post-201975-0-83232600-1483874259_thumb.png

post-201975-0-40729200-1483874273_thumb.png

me906HUAWEI.zip

Share this post


Link to post
Share on other sites

@barrrrt - thank you for this! Once I have copied the kexts and restarted, how to I add the WWAN card in System Preferences > Network?

 

On another note, I wanted to show you guys my "ThinkBook Air" driving an 85" display at my office via HDMI out. It really confuses people when they see macOS running on my Lenovo!

 

post-1869822-0-31125200-1483898637_thumb.jpg

Share this post


Link to post
Share on other sites

@thedeliveryboy - just click on the plus in the preferences >network. You will find a HuaweiMobile there.

 

Did it work on your side?

Share this post


Link to post
Share on other sites

What a great news!!!

 

WWAN working

Hi guys.

 

I bought a Huawei ME906S wwan card for my t560. It took me really long, but finally i got it working. 

Short side note: the me906s seems to be the European version. The ME906E is on the markt too, and should work with the attached kext, too.

 

You need at least 2 kexts in the SLE or LE folder. After that, you are done.

 

The HuaweiDataCardDriver_10_9.kext is extracted from the newest "mobile connect" software from Huawei. Thats just a suite with the driver and a software that can connect to your network... but... the suite is not needed.

 

Card is not shown in system profile - network - wwan. I don't know why, but it doesn't matter... right? :D

Share this post


Link to post
Share on other sites

@tluck, I am trying to adapt your guide to install on x250. Not sure if it is doable. But I will give it a try. One thing I notice is that in your guide, there is no guide on the handling of battery. Is there nothing needs to be done? Also x250 use different sound codec, yours use alc923 and x250 uses alc 2323, I suppose. So how to adapt your Kext to alc2323?

Share this post


Link to post
Share on other sites

@superwkn - it may be easier to adapt a T450 set of files to the x250. see https://github.com/shmilee/T450-Hackintosh

I adapted a lot of the stuff from the 450 to my box

 

the audio on x250 is probably ALC292 vs ALC293.

the battery stuff gets patched by patchmatic -  it creates a combined battery called BATC which is fake thing to aggregate BAT1 and BAT2

 

the process for DSDT/SSDT is fairly simple:

extract the original DSDT

use patchmatic to do some basic patching on the original. 

and then create a bunch of SSDT to (re) define all the devices

ARPT

HDEF

IGPU

LPC

PNLF

PS2K

SMBUS

XHC 

etc

 

it is a matched set - config.plist + DSDT/SSDT + custom kexts.

Share this post


Link to post
Share on other sites

Hi again.

 

Did anyone of you guys get a docking station to work?

I tried to use a hdmi cable with a docking station, and the computer restarted.

When I just put the hdmi cable into the notebook (without the dock) I have no problems.

 

Maybe some more fixes are needed?

Would like to discuss this a bit.... if there is no solution I will give the dock back :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By Leinad12
      Olá a todos.
      Estou com o macOS Mojave instalado num Lenovo 305 (com um i3 5005 e uma HD 5500) porém tou com um problema.
      Sempre que o computador entra em pausa (Sleep) não consigo voltar a "acordar" (Wake).
      Alguém pode me ajudar pf?
    • By ludufre
      Installing macOS Mojave on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      03/13/2019 13:15h GMT-0
      - Updated info about touchpad replacement and CPU and 4G LTE modem.
       
      02/05/2019 18:47h GMT-0
      - Updated info about CPU replacement and 4G LTE modem.
       
      02/04/2019 15:24h GMT-0
      - Sometimes the VoodooHDA.kext doesn't work.
      - Added AppleHDADisabler.kext to fix that (attached bellow).
       
      01/24/2019 14:42h GMT-0
      - Added more adjustments to use of VoodooHDA.
      - Updated VoodooHDA links to 2.9.1 official (without installer).
      - Changed PCM volume from 90 to 180 in Info.plist (attached modified VoodooHDA.kext bellow)
      - Updated SSDT-L440.aml (Removed HDEF and HDAU, not needed).
      - Updated config.plist (Changed to user Audio layout to 1).
       
      01/22/2019 20:47h GMT-0
      - I gave up on the AppleALC.
      - Headset does not work.
      - Now with VoodooHDA is perfect and the sound even louder.
       
      01/22/2019 14:37h GMT-0
      - Add info about update 10.14.3. 
       
      01/22/2019 13:46h GMT-0
      - Add link to BIOS reassing guide.
       
      01/20/2019 11:49h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      No mistery here. Just upgade.
       
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Upgrade CPU to i7-4712MQ (Ordered. It's on the way) Done, but received i7-4700MQ (47w TDP, with good paste I have no overheating)
      - Replace touchpad with T460 model (Ordered. It's on the way) Done. Sensitivity and perception of quality much better. I recommend 100%!
      - Sierra Gobi5000 4G LTE modem EM7355 (Ordered. It's on the way. I hope works. ) Done, but not work. Recognize but not connect. I already gave up...
      - Upgrade to 16GB RAM Done
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the RehabMan's CloverEFI fork (used 4701) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix64


       
       
      Make things works

      Will be created a partition named EFI and mounted in Desktop.
      - Replace the /Volumes/EFI/CLOVER/config.plist with mine attached below
                    If you have modded BIOS with Advanced Menu and enabled 128MB DRAM-prealloc use 128MB_DRAM-prealloc_config.plist.zip
                    If no, then use 32MB_DRAM-prealloc_config.plist.zip
      - Put SSDT-L440.aml attached below in /Volumes/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.3.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the FakeSMC.kext from here. I used the version 2018-0915.
      - Download the VoodooPS2Controller.kext from here. I used version 2018-1008.
      - Download the IntelMausiEthernet.kext from here. I used the version 2018-1031.
      - Download the Lilu.kext from here. I used the version 1.3.1.
      - Download the AppleALC.kext from here. I used the version 1.3.4.
      - Download the VoodooHDA from here. I used the version 2.9.1.
      - Download the WhateverGreen.kext from here. I used the version 1.2.6.
      - Download the AppleBacklightFixup.kext from here. I used the version 2018-1013.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the ACPIBatteryManager.kext from here. I used the version 2018-1005.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (In addition to removing the whitelist, add the advanced menu);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      Soon, I'll provide step by step in this process. Probably until end of this week.
      In the meantime, if you need to, send me your dump that I do steps 3 and 4 for you.
      I also add the Advanced Menu so you can increase to 128MB the DRAM-prealloc.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 1.1.9.
      - Download the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext from here. I used the version 2018-0505.
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.2.
       
       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

      The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.
       
      Last step
       
      Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/Other/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.3
       
      - Updated with success;
      - Everything works perfectly after reboot;
       

       
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @Shiki and all others members involved directly or indirectly.
       
       
       
       
       
       
      32MB_DRAM-prealloc_config.plist.zip
      128MB_DRAM-prealloc_config.plist.zip
      SSDT-L440.aml
      VoodooHDA.kext.zip
      AppleHDADisabler.kext.zip
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Replace Folder CLOVER Install.zip   -Install Sierra/High Sierra and boot into system!   -Install Clover and replace with my folder  CLOVER Post Install.zip   -Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edits for Skylake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app.zip   -DSDT bios F21 My DSDT with patches for skylake DSDT.GA Z170M-D3H F21.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -MIKEY -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI






       
      -FakeSMC http://www.hwsensors.com/releases -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
×