Jump to content
tluck

[GUIDE] Lenovo T460 macOS with Clover

810 posts in this topic

Recommended Posts

Well to start, my x1 carbon 4th gen runs with the same EFI folder from T460 but x1 carbon's performance lags especially when accessing Apps. I could clone my T460 SSD and run it on my x1 and apply the necessary patches there once I finish copying the partitions. 

Share this post


Link to post
Share on other sites
Advertisement
On 1/3/2019 at 7:52 PM, nijhawank said:

 

My backlight adjustment is working but not all brightness levels are present before the sleep (just between 70 - 100%). After the sleep cycle, all brightness levels are present.

 

From the WEG documentation...

  • igfxcflbklt=1 boot argument (and enable-cfl-backlight-fix property) to enable CFL backlight patch
  • applbkl=0 boot argument to disable AppleBacklight.kext patches for IGPU

Isn't the boot flag (igfxcflbklt and related property in config.plist) only for Coffylake? T460 is Skylake and I assume that applbkl=0 boot entry controls for everything other than coffylake and I assume that by default WEG applies the backlight patches and applblk=0 is only needed to disable backlight patches?

 

Is the understanding correct?

Hello,

I don't have any brightness controls under 10.13.6, do you know how to fix it ?

Share this post


Link to post
Share on other sites
1 hour ago, aleixsr said:

Hello,

I don't have any brightness controls under 10.13.6, do you know how to fix it ?

 

I never tried 10.13.6 (directly Mojave) but I guess that should not make any difference.

Assuming standard knowledge of doing things in hackintosh...

Use the latest Lilu, WhateverGreen (put in /Library/Extensions). Take SSDT-PNLF.aml (put in /EFI/CLOVER/ACPI/patched) from Rahabman's AppleBacklightFixup package.

Your DSDT must not have any brightness fix. 

If you have coffelake cpu, then use the config parameters in clover config.

 

Share this post


Link to post
Share on other sites

the more recent Whatevergreen replaces AppleBacklightInjector.

- you need to make sure the _UID in SSDT-PNLF.aml is set to 16 (0x10) vs 10 (0xA)

- remove AppleBacklightInjector.kext

- remove levels patch in config.plist  - so it wont change level range for 0-1000

Edited by tluck

Share this post


Link to post
Share on other sites

Well to start, my x1 carbon 4th gen runs with the same EFI folder from T460 but x1 carbon's performance lags especially when accessing Apps. I could clone my T460 SSD and run it on my x1 and apply the necessary patches there once I finish copying the partitions. -------------Edit.  

Forgot to add that my x1 carbon is running but with no audio. I used the same clover files from my T460. I recompiled the screen brightness kext and that's working fine. Where's the repo with the files you're talking about?

Share this post


Link to post
Share on other sites

@Blaggah this thread guide refers to this file repo: https://github.com/tluck/Lenovo-T460-Clover

 

- cloning your macOS HD is a great approach. i just did that very thing for my 2 systems to get them in sync.

each system has is own folder for their specific config files, ACPI, kexts - CLOVER/OEM/<board_id>/... 

 

- so everything works on the X1 but the audio? what is the audio codec? AppleALC supports so many codecs now but the config.plist file may be setting an invalid layout.

Share this post


Link to post
Share on other sites
23 hours ago, tluck said:

the more recent Whatevergreen replaces AppleBacklightInjector.   Ok, I updated Whatevergreen v1.2.6 and Lilu v1.3.1

- you need to make sure the _UID in SSDT-PNLF.aml is set to 16 (0x10) vs 10 (0xA) .  I used your zip file that is OK, nothing changed

- remove AppleBacklightInjector.kext . Done in /Library/Extensions and in /EFI/CLOVER/kexts/Other

- remove levels patch in config.plist  - so it wont change level range for 0-1000 I don't know how to do it

 

Hi, I marked in bold what I did to make brightness control work, thank you very much.

 

Now my issue is that when I try to sleep computer it reboots, do you know what can I check?

 

Thank you.

Edited by aleixsr

Share this post


Link to post
Share on other sites

sorry. i just updated the zip (now) to have the latest files. so maybe you should pull it down again. 

 

@blaggah - is your audio CX11852 - (lhttps://www.cnet.com/products/thinkpad-x1-carbon-4th-generation/)

not sure AppleALC support this codec, but you can use the general VoodooHDA to get audio.

 

Edited by tluck

Share this post


Link to post
Share on other sites
7 hours ago, tluck said:

@Blaggah this thread guide refers to this file repo: https://github.com/tluck/Lenovo-T460-Clover

 

- cloning your macOS HD is a great approach. i just did that very thing for my 2 systems to get them in sync.

each system has is own folder for their specific config files, ACPI, kexts - CLOVER/OEM/<board_id>/... 

 

- so everything works on the X1 but the audio? what is the audio codec? AppleALC supports so many codecs now but the config.plist file may be setting an invalid layout.

Thanks tluck, i took your advice and i managed to run patched the dsdt on my x1 and i deleted all the other ssdt in patched folder. I don't know what codec it is, but im assuming it's the same for the T470. Because it uses the same layout id as my x1 carbon 4th gen. Now the lappy doesn't seem to lag.. Now my audio is working but screen brightness doesn't seem to be working anymore. I only have DSDT.aml in patched folder now.. Do i need the PLNF ssdt in there as well?  Because it was working prior to removing the files and patched dsdt.

Share this post


Link to post
Share on other sites

@tluck I did just that and now i have screen brightness working again and my X1 Carbon doesn't feel sluggish at all.  I'm so glad i got this thing working.  Thank you for all the help m8.. One quick question though, the x1 has a password where it needs to be typed on cold boot, i tried disabling it but it doesn't work. 

----------Edited.. I downloaded the latest kext from Rehabman and it's working properly now.  I must say that my X1 Carbon is now a success.. Thanks guys..

Edited by Blaggah

Share this post


Link to post
Share on other sites
10 hours ago, aleixsr said:

Hello,

using High Sierra I got a reboot when I try to enter sleep mode, what can I check?

 

Thank you.

 

Huge thanks for the guide first of all. It allowed me to have a fully working install of Sierra on my T460s. 

I upgraded to High Sierra then Mojave which both mostly worked. Right now I'm dealing with the same issues as quoted - sleep and shutdown just reboot the machine. I also have an issue with the trackpad - if I track my finger slowly across the trackpad it works ok. But quicker movements aren't recognized. So, swiping quickly across the trackpad to get from one side of the screen to the other only move the cursor a small bit.

Also for some reason bluetooth isn't recognized. Wifi is.  

 

All the above issues weren't issues in Sierra. Just in High Sierra and Mojave

 

*EDIT*

Tried Clover 4844 and 4849, tried with release 01.17.2019 and 10.12.2018, tried 4 different USB drives, used ACPI files from my laptop/BIOS and the ones included in the releases

 

 

Edited by osmac

Share this post


Link to post
Share on other sites
1 hour ago, osmac said:

 

Huge thanks for the guide first of all. It allowed me to have a fully working install of Sierra on my T460s. 

I upgraded to High Sierra then Mojave which both mostly worked. Right now I'm dealing with the same issues as quoted - sleep and shutdown just reboot the machine. I also have an issue with the trackpad - if I track my finger slowly across the trackpad it works ok. But quicker movements aren't recognized. So, swiping quickly across the trackpad to get from one side of the screen to the other only move the cursor a small bit.

Also for some reason bluetooth isn't recognized. Wifi is.  

 

All the above issues weren't issues in Sierra. Just in High Sierra and Mojave

 

*EDIT*

Tried Clover 4844 and 4849, tried with release 01.17.2019 and 10.12.2018, tried 4 different USB drives, used ACPI files from my laptop/BIOS and the ones included in the releases

 

 

 

Hello, 

bluetooth is working ok for me (i'm using High Sierra), you can't see your bluetooth device?

Did you upgraded High Sierra to Mojave using App Store and using same EFI folder? 

On 1/18/2019 at 2:33 PM, Blaggah said:

@tluck I did just that and now i have screen brightness working again and my X1 Carbon doesn't feel sluggish at all.  I'm so glad i got this thing working.  Thank you for all the help m8.. One quick question though, the x1 has a password where it needs to be typed on cold boot, i tried disabling it but it doesn't work. 

----------Edited.. I downloaded the latest kext from Rehabman and it's working properly now.  I must say that my X1 Carbon is now a success.. Thanks guys..

 

@Blaggah can you please share your EFI folder? I've a friend with X1 Carbon also. Thank you.

Edited by aleixsr

Share this post


Link to post
Share on other sites
17 minutes ago, aleixsr said:

 

Hello, 

bluetooth is working ok for me (i'm using High Sierra), you can't see your bluetooth device?

Did you upgraded High Sierra to Mojave using App Store and using same EFI folder? 

 

 

Tried with same EFI folder that I used with Sierra, and using the folder from a fresh install. There's no bluetooth option in System Preferences or in Network. It's strange since it worked fine in Sierra. If I use Time Machine to go back to Sierra everything is perfect. Honestly I only upgraded so I could get the latest version of Xcode. I'm not a dev but I'd like to be one day

 

I could attach whatever files anyone would need that might help me narrow down the issues

Share this post


Link to post
Share on other sites

sorry i can't be of more help on T460 upgrades.

 

reboot on sleep could a problem with USB? but looking in the system log may help understand what is not right?

 

i cant recall if there is a need to patch to allow more than 15 usb ports or not. 

if so, they are not in the config for High Sierra or Mojave - same for any BRCM patches. 

 

Maybe if someone has a working T460 on HS or Mojave they can share their EFI and I will retrofit the patches to the repo.

 

@osmac - what is your BT device? meaning do you have a replacement Broadcom for example?

 

Share this post


Link to post
Share on other sites
On 1/23/2019 at 3:39 AM, aleixsr said:
 
@Blaggah can you please share your EFI folder? I've a friend with X1 Carbon also. Thank you.


I'll send you the EFI folder sometime this weekend. I'm out of town and don't have my X1 Carbon with me. It's 99% stable, just have issues with battery indication not syncing properly sometimes. Other than that, it's rock solid.
@aleixsr here's the clover from my x1 carbon.. I only have the DSDT and plnf.ssdt inside patched folder as they are the only ones i need for my machine. if you friend's x1 is the same as mine, he could use the same dsdt or else i'd recommend patching one himself for his machine..

 



Sent from my iPhone using Tapatalk

X1 Carbon 4thGen CLOVER.zip

Edited by Blaggah

Share this post


Link to post
Share on other sites
On 1/23/2019 at 8:26 PM, tluck said:

sorry i can't be of more help on T460 upgrades.

 

reboot on sleep could a problem with USB? but looking in the system log may help understand what is not right?

 

i cant recall if there is a need to patch to allow more than 15 usb ports or not. 

if so, they are not in the config for High Sierra or Mojave - same for any BRCM patches. 

 

Maybe if someone has a working T460 on HS or Mojave they can share their EFI and I will retrofit the patches to the repo.

 

@osmac - what is your BT device? meaning do you have a replacement Broadcom for example?

 

Hello here it is:

- EFI folder

- backtrace.log kernel panic when trying to sleep

 

Thank you!

EFI.zip

backtrace.log

Share this post


Link to post
Share on other sites

@aleixsr

 

darn. thought i did this already - but i just cleaned up the clean/wake scripts to remove the kextunload - this is not needed.

 

in fact you can decide if you need to totally remove the /etc/rc.sleep /etc/rc.wake scripts.

 

but for now just remove the kextunload/kextload lines in these files: /etc/rc.sleep /etc/rc.wake

Share this post


Link to post
Share on other sites

Hi all,

 

Been following this thread closely and managed to get my t470s system on 10.14.3 quite easily with the files from 1st post and a few edits for my system.

Items still having issue on

 

- battery percentage not reading correctly. Shows in menu bar ok but false read (0%)

- Screen brightness 

- backlight

 

Tried to do some patching myself but totally borked machine :) pays to do incremental back ups.

 

Attached problem reporting files - may I ask those in the know with more knowledge than myself to take a look an offer any advice / point in the right direction? t470s is a solid machine and believe only a bit of fine tuning is required.

 

debug_1146.zip

 

Many thanks

Edited by Dan_Marshall

Share this post


Link to post
Share on other sites
On 1/24/2019 at 10:41 PM, tluck said:

@aleixsr

 

darn. thought i did this already - but i just cleaned up the clean/wake scripts to remove the kextunload - this is not needed.

 

in fact you can decide if you need to totally remove the /etc/rc.sleep /etc/rc.wake scripts.

 

but for now just remove the kextunload/kextload lines in these files: /etc/rc.sleep /etc/rc.wake

 

Yeah, it is now working fine!

 

Thank you very much.

Share this post


Link to post
Share on other sites
On 1/18/2019 at 5:00 AM, Blaggah said:

Thanks tluck, i took your advice and i managed to run patched the dsdt on my x1 and i deleted all the other ssdt in patched folder. I don't know what codec it is, but im assuming it's the same for the T470. Because it uses the same layout id as my x1 carbon 4th gen. Now the lappy doesn't seem to lag.. Now my audio is working but screen brightness doesn't seem to be working anymore. I only have DSDT.aml in patched folder now.. Do i need the PLNF ssdt in there as well?  Because it was working prior to removing the files and patched dsdt.

Hi Blaggah, I have a question for you but first: hats off to you tluck, for setting all of this up and persisting to help all us mortals without even having the hardware available anymore!

 

So, the question, Blaggah: I also have a X1C4 and have everything working quite nicely but in terms of audio all I have is speakers and headphone working proper. Microphone does not work, neither internally nor externally. Can you please confirm that your statement 'audio is working' also covers the microphone? I have tried the EFI you posted and with that, on my machine, audio only works for output.

 

Apart from the audio, everything is very smooth. The X1 is a very nice machine; I triple boot it from the NVMe SSD (MacOS, Win10, Ubuntu). The looks on people's faces...

Share this post


Link to post
Share on other sites
7 hours ago, DrDude said:

Hi Blaggah, I have a question for you but first: hats off to you tluck, for setting all of this up and persisting to help all us mortals without even having the hardware available anymore!

 

So, the question, Blaggah: I also have a X1C4 and have everything working quite nicely but in terms of audio all I have is speakers and headphone working proper. Microphone does not work, neither internally nor externally. Can you please confirm that your statement 'audio is working' also covers the microphone? I have tried the EFI you posted and with that, on my machine, audio only works for output.

 

Apart from the audio, everything is very smooth. The X1 is a very nice machine; I triple boot it from the NVMe SSD (MacOS, Win10, Ubuntu). The looks on people's faces...

 

I can confirm that on my T470, audio in, from built in mic, and from a USB headset work fine. I have done a number of internation WebEX meetings with zero issues. 

 

I am injecting 11, 

 

    <key>Devices</key>
    <dict>
        <key>Audio</key>
        <dict>
            <key>Inject</key>
            <integer>11</integer>
        </dict>
 

Cheers,

Scott.

Share this post


Link to post
Share on other sites

Thanks kolodzieski! Unfortunately us X1C4 owners have a very exotic audio chip, a CX20753/4, not a ALC3268 like in a T470. Only layout id 3 and 21 is supported, with 21 for some exotic LG laptop.

 

That said, I have made the most peculiar progress. I picked up my rusty programming skills and compiled AppleALC myself. As a starting point I have simply copied the layout 3 configuration files to another layout id (I picked 77) and added that to AppleALC and my config. I figured I'd fiddle with the copy to try to get the mic working. Surprise, surprise: it works without any fiddling. I wish I understood, but I totally don't. I have some learning to do ;-) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Leinad12
      Olá a todos.
      Estou com o macOS Mojave instalado num Lenovo 305 (com um i3 5005 e uma HD 5500) porém tou com um problema.
      Sempre que o computador entra em pausa (Sleep) não consigo voltar a "acordar" (Wake).
      Alguém pode me ajudar pf?
    • By ludufre
      Installing macOS Mojave on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      03/13/2019 13:15h GMT-0
      - Updated info about touchpad replacement and CPU and 4G LTE modem.
       
      02/05/2019 18:47h GMT-0
      - Updated info about CPU replacement and 4G LTE modem.
       
      02/04/2019 15:24h GMT-0
      - Sometimes the VoodooHDA.kext doesn't work.
      - Added AppleHDADisabler.kext to fix that (attached bellow).
       
      01/24/2019 14:42h GMT-0
      - Added more adjustments to use of VoodooHDA.
      - Updated VoodooHDA links to 2.9.1 official (without installer).
      - Changed PCM volume from 90 to 180 in Info.plist (attached modified VoodooHDA.kext bellow)
      - Updated SSDT-L440.aml (Removed HDEF and HDAU, not needed).
      - Updated config.plist (Changed to user Audio layout to 1).
       
      01/22/2019 20:47h GMT-0
      - I gave up on the AppleALC.
      - Headset does not work.
      - Now with VoodooHDA is perfect and the sound even louder.
       
      01/22/2019 14:37h GMT-0
      - Add info about update 10.14.3. 
       
      01/22/2019 13:46h GMT-0
      - Add link to BIOS reassing guide.
       
      01/20/2019 11:49h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      No mistery here. Just upgade.
       
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Upgrade CPU to i7-4712MQ (Ordered. It's on the way) Done, but received i7-4700MQ (47w TDP, with good paste I have no overheating)
      - Replace touchpad with T460 model (Ordered. It's on the way) Done. Sensitivity and perception of quality much better. I recommend 100%!
      - Sierra Gobi5000 4G LTE modem EM7355 (Ordered. It's on the way. I hope works. ) Done, but not work. Recognize but not connect. I already gave up...
      - Upgrade to 16GB RAM Done
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ .app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the RehabMan's CloverEFI fork (used 4701) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix64


       
       
      Make things works

      Will be created a partition named EFI and mounted in Desktop.
      - Replace the /Volumes/EFI/CLOVER/config.plist with mine attached below
                    If you have modded BIOS with Advanced Menu and enabled 128MB DRAM-prealloc use 128MB_DRAM-prealloc_config.plist.zip
                    If no, then use 32MB_DRAM-prealloc_config.plist.zip
      - Put SSDT-L440.aml attached below in /Volumes/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.3.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the FakeSMC.kext from here. I used the version 2018-0915.
      - Download the VoodooPS2Controller.kext from here. I used version 2018-1008.
      - Download the IntelMausiEthernet.kext from here. I used the version 2018-1031.
      - Download the Lilu.kext from here. I used the version 1.3.1.
      - Download the AppleALC.kext from here. I used the version 1.3.4.
      - Download the VoodooHDA from here. I used the version 2.9.1.
      - Download the WhateverGreen.kext from here. I used the version 1.2.6.
      - Download the AppleBacklightFixup.kext from here. I used the version 2018-1013.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the ACPIBatteryManager.kext from here. I used the version 2018-1005.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (In addition to removing the whitelist, add the advanced menu);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      Soon, I'll provide step by step in this process. Probably until end of this week.
      In the meantime, if you need to, send me your dump that I do steps 3 and 4 for you.
      I also add the Advanced Menu so you can increase to 128MB the DRAM-prealloc.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 1.1.9.
      - Download the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext from here. I used the version 2018-0505.
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.2.
       
       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

      The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.
       
      Last step
       
      Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/Other/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.3
       
      - Updated with success;
      - Everything works perfectly after reboot;
       

       
       

       
      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @Shiki and all others members involved directly or indirectly.
       
       
       
       
       
       
      32MB_DRAM-prealloc_config.plist.zip
      128MB_DRAM-prealloc_config.plist.zip
      SSDT-L440.aml
      VoodooHDA.kext.zip
      AppleHDADisabler.kext.zip
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
          --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Replace Folder CLOVER Install.zip   -Install Sierra/High Sierra and boot into system!   -Install Clover and replace with my folder  CLOVER Post Install.zip   -Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edits for Skylake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app.zip   -DSDT bios F21 My DSDT with patches for skylake DSDT.GA Z170M-D3H F21.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -MIKEY -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI






       
      -FakeSMC http://www.hwsensors.com/releases -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   Installation   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER Post Install.zip   --Reboot   DSDT DSDT.MaLd0n.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC ----- -Disable GPU new patch and PNLF SSDT - Credits RehabMan


       
      SSDT    Generate your SSDT for PM, use ssdtPRGen by Piker-Alpha https://github.com/Piker-Alpha ssdtPRGen.command.zip   or just use "plugin-type"=0x01 in DSDT, SSDT or Clover config.plist   for check Power, Frequency, Temperature and Utilization, use it Install Intel Power Gadget.pkg.zip  
      -Audio
      https://github.com/vit9696/AppleALC
       
      -FakeSMC
      https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads/   -Atheros Ethernet https://github.com/Mieze/AtherosE2200Ethernet   -IntelGraphicsFixup https://sourceforge.net/projects/intelgraphicsfixup/   -IntelGraphicsDVMTFixup https://github.com/BarbaraPalvin/IntelGraphicsDVMTFixup   -USBInjectAll https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   Special Thanks to Pablo Galán   We're all here to have fun and learn from each other!   ENJOY!
×