Jump to content
tluck

[GUIDE] Lenovo T460 macOS with Clover

852 posts in this topic

Recommended Posts

i presume you installed VoodooHDA? if your AppleHDA.kext is in /Backup

 

for my AppleHDA_ALC293.kext to work.

1) make sure original AppleHDA.kext is in /S/L/E

2) remove VoodooHDA.kext (from either /L/E or /S/L/E)

3) remove AppleHDADisabler.kext (from either /L/E or /S/L/E)

 

run the _kext-install.command in the EFI/CLOVER/kext folder to install Apple_ALC293.kext in /L/E - which creates a symbolic link to original AppleHDA.kext binary in /S/L/E

make sure the config.plist stuff for HDEF/HDA patching is in your config.plist

the SSDT-HDEF file defines codec etc.

Share this post


Link to post
Share on other sites
Advertisement

@tluck it is now working fine thanks.

 

I'm having another strage issue, when I wakeup from sleep touchpad doesn't work, do you know how I can debug it? Do you have same issue?

 

Thanks.

Share this post


Link to post
Share on other sites

well yes and no.  sometimes the trackpad and trackPoint work before and after sleep for me. but sometimes not.

 

so look in the sleepwatcher -  rc.sleep and rc.wakeup files. which unloads the Trackpad kext before sleep and loads it in back after wake.

perhaps not the best way - but seeming effective workaround.

 

meant to document those files in the misc folder. if one googles  "sleepwatcher" you can download the installer package and then these are /etc/rc files that i use - which seem to help with both networking and Trackpad.

Share this post


Link to post
Share on other sites

Hello,

I just updated new OS X 10.11.6 Security update an now my laptop keyboard is not working, do you know anything about it?

 

I can see this error trying to refresh Kexts:

"Can't read info dictionary for VoodooPS2Keyboard.kext: IOCFUnserialize: syntax error near line 299"

Share this post


Link to post
Share on other sites

hmm. i installed the recent security patch without issue? i just test and rebuild caches ok.  what SIP (CsrActiveConfig). otherwise could be file corruption? how did you get that kext onto the system?

Share this post


Link to post
Share on other sites

I solved it removing /Library/Extensions/VoodooPS2Keyboard.kext and loading it again.

sudo touch /Library/Extensions/
sudo kextcache -i /
sudo kextload /Library/Extensions/VoodooPS2Controller.kext/
kextstat | grep -i voodoo

Share this post


Link to post
Share on other sites

FYI. i am on Sierra 10.12.1 now. I had to roll back the SKLFramebuffer kext to 10.11.6 version to avoid KP on startup. but i do not (or did not) have have full GFX anyway! will investigate more to understand why. but otherwise things are looking just fine.

 

Do you get all working like 10.11.6 ?

Share this post


Link to post
Share on other sites

Hi Tluck!

 

I think you should go on the other site, there is apparently the solution for HD520/530 for Sierra (and maybe El Capitan) ;)

 

This fix is not working for me on El Capitan, is it working for you ?

Share this post


Link to post
Share on other sites

This fix is not working for me on El Capitan, is it working for you ?

If you are looking for the glitch fix, create a SSDT with this snipet

DefinitionBlock ("ssdt.aml", "SSDT", 2, "APPLE ", "igpu", 0x00001000)
{
    External (_SB_.PCI0, DeviceObj)
    External (IGPU, DeviceObj)
 
    Scope (\_SB.PCI0)
    {
        Device (IGPU)
        {
            Name (_ADR, 0x00020000)  
 
            Method (_DSM, 4, NotSerialized)
            {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                        0x03
                    })
                }
 
                Return (Package (0x02)
                {
                    "AAPL,GfxYTile",
                    Buffer (0x4)
                    {
                        0x01, 0x00, 0x00, 0x00
                    }                    
                })
            }
        }
    }
}

Credits to PikeRAlpha

Share this post


Link to post
Share on other sites

thanks again for your efforts.

 

just to clarify something:

  • when i create a bootable installer via terminal, the T460s won't boot into clover - even after copying the files across as per the instructions.
  • when i create it via that other app thing which shall not be named, it boots into clover. however, i then boot in verbose mode it keeps crashing after the "Missing Bluetooth Controller Transport"and "USBMSC Identifier (non-unique)"

the question:

  • must i create the install USB via that other app thing which shall not be named or the terminal command? once i have that sorted, i'll keep going until i solve the next issue.

 

thanks

sparkypants

 

p.s. edit to remove the name of that other app thing which shall not be named. sorry about that.

 

 

My Hardware:

Mobo: Lenovo T460s (Clover)
CPU: Intel® Core i5-6300U CPU @ 2.40GHz/HM76
Graphics: Intel® HD Graphics 520 / 1920x1080

Share this post


Link to post
Share on other sites

no you can install OS X via Clover with USB.  how is the USB formatted?  you may have to check some bios settings to make sure UEFI USB is set right. 

my USB is formatted GPT and i don't use any tools from other websites - Clover + macOS

 

for Recovery and Installers, I inject IntelGFX and use device Id 0x12345678

Share this post


Link to post
Share on other sites

Awesome! Thanks - that worked and I can boot using the USB I created using terminal and adding the custom files.

 

Added the device id in Clover options, but still failing at "Missing Bluetooth..." error message. 

 

Will keep trying!

Share this post


Link to post
Share on other sites

I just updated the zip in post 1 with Clover 3909 and a few Sierra kexts patches and an updated VoodooPS2Controller that is Sierra compatible.

 

This exact EFI folder is what I have on my USB installer AND HD ESP. And Note - you many need to inject IntelGFX and set fake-id to 0x12345678 to avoid installer startup crashes.

Share this post


Link to post
Share on other sites

i just created the Sierra 10.12.1 the GPT USB today using this: 

 

sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app --nointeraction

 

and then i mounted ESP copied the EFI stuff (from the zip) to the USB. 

your picture showing the 0x1234568 is correct - how i did it.

Share this post


Link to post
Share on other sites

OK, still no luck. No doubt I'm doing something wrong. Please can I ask you to check the images attached and provide some of your expert guidance?

 

Thanks

Sparky

I'm trying USB boot and I'm getting same error, I'll test new tluck uploaded files asap.

 

Enviat des del meu HUAWEI GRA-L09 usant Tapatalk

Share this post


Link to post
Share on other sites

If you are looking for the glitch fix, create a SSDT with this snipet

DefinitionBlock ("ssdt.aml", "SSDT", 2, "APPLE ", "igpu", 0x00001000)
{
    External (_SB_.PCI0, DeviceObj)
    External (IGPU, DeviceObj)
 
    Scope (\_SB.PCI0)
    {
        Device (IGPU)
        {
            Name (_ADR, 0x00020000)  
 
            Method (_DSM, 4, NotSerialized)
            {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                        0x03
                    })
                }
 
                Return (Package (0x02)
                {
                    "AAPL,GfxYTile",
                    Buffer (0x4)
                    {
                        0x01, 0x00, 0x00, 0x00
                    }                    
                })
            }
        }
    }
}

Credits to PikeRAlpha

 

I tried it but it doesn't work, can anybody test or help me? Maybe I'm doing anything wrong.

Share this post


Link to post
Share on other sites

Hi

 

Having some trouble installing the kexts. These are the messages from the Terminal:

 

/EFI/CLOVER/kexts/_kext-install.command: line 88: cd: /Library/Extensions/AppleHDA_*.kext/Contents/MacOS: No such file or directory

 

and then

 

------------------------------------

Sleeping for 20 seconds before rebuild of kext cache - wait … 

IntelMausiEthernet.kext has incorrect permissions; omitting.

KernelCache ID: 0B39A1FE950B47855E851977C2A4F6B7

symlink("/System/Library/PrelinkedKernels/prelinkedkernel", "/System/Library/Caches/com.apple.kext.caches/Startup/kernelcache") failed 17 (File exists) <createPrelinkedKernel 2795>

… done!

 

also get a pop-up window that the AppleHDA and IntelMausi kexts cannot be used.

 

Any ideas/suggestions please?

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rtke333
      Hi!
       
      I have everything working on my Acer notebook, except FN + Brightness keys using VoodoPS2Controller.kext
       
      Now the brightness keys are "Pause+Break = Brightness Up" and "Fn+F12 = Brightness Down" working right now but they are not the actual keys. 
      The actual brightness keys are "Fn+RightArrow = Brightness Up" and "Fn+LeftArrow = Brightness Down" but they are not working.
      The problem is I don't know the codes.
      Installed ioio and enabled debugging to console:
      Pause/Break is generating: "ApplePS2Keyboard: sending key e045=71" which upper the brightness
      Fn+F12 is generating: "ApplePS2Keyboard: sending key 46=6b" which lower the brightness
      Fn+RightArrow/LeftArrow generates nothing.
      Keyboard attached to PS2K
      Then I used rehabman's guide to enable ACPIDebugging, Installed kext to L/E, Debug methods (Instrument EC Queries, Add DSDT Debug Methods) to DSDT, but there are no codes generated to the log.
       
      Attaching debug folder.
      Also I don't know if it will help, but on Linux I got a code from decreasing/rising brightness with Fn+Left/RightArrow keys:
      Fn+RightArrow: "0xe0 0x54 0xe0 0xd4"
      Fn+Left: "0xe0 0x4c 0xe0 0xcc"
       
      Also I love using EMlyDinEsH's SmartTouchpad Driver, with that all of my Fn keys are working except Brigtness keys ofc. If there are any fix I would like to use that with the smarttouchpad driver. 
      EMlyDinEsH's SmartTouchpad Driver: https://osxlatitude.com/forums/topic/1948-elan-focaltech-and-synaptics-smart-touchpad-driver-mac-os-x/
       
      Specs in my signature. 
      Please help me fix this very last issue on my acer.
       
      debug_4751.zip
    • By Angelo_
      Hi, I followed the rehabman guide (linked in the vanilla guide on the side of r/Hackintosh, not sure if I can link it) for laptops for my yoga 730ILW13 with an 8265u, Conexant 11870, 8gb of ram, 13.3" fhd and I found that upon booting the installer usb I get this weird issue where the screen displays what it should but the screen is incredibly dim (though it was off before using a flashlight on it) and it flashes every few seconds for a few milliseconds to the correct brightness, I used the plist for hd615-650 (including my 620), not quite sure what could be the culprit, first time hackintoshing a laptop so it might be a stupid brightness kext I forgot but didn't find any in that post or in this forum :c 
      Attached the clover zip so that anyone with more experience than me might give an idea in what could be a way to fix this.
      Thank you in advance 
       
       
       
      CLOVER.zip
    • By ludufre
      Installing macOS Mojave on Lenovo ThinkPad L440

       
      There are two version of this laptop:
      - 20AS = Chipset QM87, without Express Card (mine).
      - 20AT = Chipset HM86, with Express Card.
      I strong believe is the same thing...
       

      Changelog:
       
      03/28/2019 15:01h GMT-0
      - Added info about update 10.14.4. 
       
      03/13/2019 13:15h GMT-0
      - Updated info about touchpad replacement and CPU and 4G LTE modem.
       
      02/05/2019 18:47h GMT-0
      - Updated info about CPU replacement and 4G LTE modem.
       
      02/04/2019 15:24h GMT-0
      - Sometimes the VoodooHDA.kext doesn't work.
      - Added AppleHDADisabler.kext to fix that (attached bellow).
       
      01/24/2019 14:42h GMT-0
      - Added more adjustments to use of VoodooHDA.
      - Updated VoodooHDA links to 2.9.1 official (without installer).
      - Changed PCM volume from 90 to 180 in Info.plist (attached modified VoodooHDA.kext bellow)
      - Updated SSDT-L440.aml (Removed HDEF and HDAU, not needed).
      - Updated config.plist (Changed to user Audio layout to 1).
       
      01/22/2019 20:47h GMT-0
      - I gave up on the AppleALC.
      - Headset does not work.
      - Now with VoodooHDA is perfect and the sound even louder.
       
      01/22/2019 14:37h GMT-0
      - Added info about update 10.14.3. 
       
      01/22/2019 13:46h GMT-0
      - Added link to BIOS reassing guide.
       
      01/20/2019 11:49h GMT-0
      - First version.
       
      What works and what does not
       
      - Processor: Intel Core i5-4300M ->  Work. All SpeedStep stages.
      - Video Card: Intel HD4600 ->  Work. QE/CI and Metal.
      - Chipset: Intel QM87 ->  Work.
      - Mini DisplayPort ->  Work. But no audio, yet.
      - VGA ->  Not work. Normal.
      - Audio: ALC292 ->  Work.
      - WiFi/Bluetooth: Intel AC 7260 ->  Not work. Replaced with DW1560 (need whitelist removal).
      - Ethernet: Intel I217-LM ->  Work.
      - Card Reader: Realtek RTS5227 ->  Not work.
      - Keyboard and Touchpad ->  Work.
      - Webcam ->  Work.
      - Fingerprint Reader ->  Not work. Normal.
      - USB3.0 ->  Work.
      - Sleep ->  Work.
      - Airdrop, Handoff, Instant Hotspot and Continuity ->  Work after replaced wireless.
       
       
      Extras
       
      - FullHD 1920x1080 display upgrade: 
      Replaced with AU Optronics B140HAN01.1 30pin eDP (B140HAN01.2 and B140HAN01.3 also compatible).
      Apparently same screen as Dell Latitude E6440, E7440, Lenovo Ideapad U430 and E129.
       
      - CPU upgrade:
      Replaced the stock Intel Core i5 4300M 2.6Ghz (3.3Ghz turbo) 6M cache with Intel Core i7 4700MQ 2.4Ghz (3.4Ghz turbo) 6MB.
      I initially had problems with overheating. The processor ran at full load above 90 degrees.
      After using a quality thermal paste I can work between 70 and 80 degrees.
      Acceptable taking into consideration that the new processor has 47TDP versus 37TDP which is recommended.
      I also had no problem consuming the battery while charging. The original 65W source seems to have figured out.
       
      - Touchpad upgrade:
      Replaced the stock with T460 touchpad.
      This is serious: you have to do it! It should be stock. Touchpad with precision and absurd quality!
      Just do it!
       
      - RAM upgrade:
      No mistery here. Just upgade.
       
       
      Todo
       
      - Make DP audio work.
      - Make Card Reader work.
      - Upgrade CPU to i7-4712MQ (Ordered. It's on the way) Done, but received i7-4700MQ (47w TDP, with good paste I have no overheating)
      - Replace touchpad with T460 model (Ordered. It's on the way) Done. Sensitivity and perception of quality much better. I recommend 100%!
      - Sierra Gobi5000 4G LTE modem EM7355 (Ordered. It's on the way. I hope works. ) Done, but not work. Recognize but not connect. I already gave up...
      - Upgrade to 16GB RAM Done
      - Make touchpad appear in System Preferences
       
       
      What you need to install

      - Running install of macOS
      - One USB flash drive of 8GB or bigger
      - macOS Mojave install app
      - Clover EFI
      - Clover Configurator
      - Some KEXTs and SSDT patches


      How create create the install flash drive
       
      Prepare install flash drive

      Format the flash drive with GUID partition mapping and name it "Install".

      - Open Disk Utility.
      - Click in View, then "Show All Devices".
      - Select the destination flash drive, then Erase.
      - Name: Install, Format: Mac OS Extended (Journaled) and Scheme: GUID Partition Map
       
      Create install flash drive

      Open terminal and run this command:
      sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/Install --nointeraction This will take about 30 minutes.
       


      Install bootloader

      Download the RehabMan's CloverEFI fork (used 4910) and install with this options on "Install macOS Mojave":
       
      - Install for UEFI booting only
      - Install Clover in the ESP
      - UEFI Drivers - ApfsDriverLoader-64
      - UEFI Drivers - AptioMemoryFix-64


       
       
      Make things works

      Will be created a partition named EFI and mounted in Desktop.
      - Replace the /Volumes/EFI/CLOVER/config.plist with mine attached below
                    If you have modded BIOS with Advanced Menu and enabled 128MB DRAM-prealloc use 128MB_DRAM-prealloc_config.plist.zip
                    If no, then use 32MB_DRAM-prealloc_config.plist.zip
      - Put SSDT-L440.aml attached below in /Volumes/EFI/CLOVER/ACPI/patched/
       
      Generate your Serial, MLB and SmUUID
       
      - Open the replaced config.plist with Clover Configurator (used 5.3.2.0)
      - Go to SMBIOS, click few times in "Generate New" in Serial Number and SmUUID.
       
      Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the VirtualSMC.kext from here. I used version 1.0.2.
      - Download the VoodooPS2Controller.kext from here. I used version 2018-1008.
      - Download the IntelMausiEthernet.kext from here. I used the version 2018-1031.
      - Download the Lilu.kext from here. I used the version 1.3.5.
      - Download the VoodooHDA from here. I used the version 2.9.1 and patched the sound volume (attached below).
      - Download the WhateverGreen.kext from here. I used the version 1.2.7.
      - Download the AppleBacklightFixup.kext from here. I used the version 2018-1013.
      - Download the USBInjectAll.kext from here. I used the version 2018-1108.
      - Download the ACPIBatteryManager.kext from here. I used the version 2018-1005.
       
      - Download the FakeSMC.kext from here. I used the version 2018-0915. Replaced with VirtualSMC.kext due 10.14.4 issues on update.
      - Download the AppleALC.kext from here. I used the version 1.3.4. Replaced with VoodooHDA.kext due mic not working.
       
       
      Wifi and Bluetooth (DW1560 / BCM94352Z)
       
      Unfortunately, some notebook manufacturers are currently blocking the replacement of wireless cards. They want you to only use the models sold by them. And of course, none of them from Lenovo for this notebook model is compatible with MacOS.
       
      If you try to start with an unauthorized wifi card for them, you will receive a screen error:
      1802: Unauthorized network card is plugged in - Power off and remove the network card. Since this check is done directly in the BIOS, the only solution is to modify it.
      But since nothing is easy in this life, there is one small big problem:
      - The BIOS update procedure does not allow you to use modded files as it used to be.
      - You will need to physically reach your BIOS on the motherboard and make use of a USB BIOS reader/writer.
       
      So what you need to do:
      1. Disassembly your laptop;
      2. Dump your BIOS with an USB BIOS reader with SOIC8 clip (to not desolder from the motherboard);
      3. Patch it (In addition to removing the whitelist, add the advanced menu);
      4. Fix RSA signature;
      5. Reflash BIOS;
      6. Replace wireless card;
      7. Remount your laptop;
      8. Done.
       
      Soon, I'll provide step by step in this process. Probably until end of this week.
      In the meantime, if you need to, send me your dump that I do steps 3 and 4 for you.
      I also add the Advanced Menu so you can increase to 128MB the DRAM-prealloc.
       
      To fix a Modded BIOS to remove the 5 beeps on boot, you need this guide: https://www.insanelymac.com/forum/topic/337333-guide-fix-insyde-h2o-bios-signature-5-beeps-on-lenovo (traduzido: pt-BR)
       
       
      After replaced the wireless card. Download those Kexts and put in /EFI/CLOVER/kexts/Other/
       
      - Download the AirportBrcmFixup.kext from here. I used the version 1.1.9.
      - Download the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext from here. I used the version 2018-0505.
      - Download the BT4LEContinuityFixup.kext from here. I used the version 1.1.2.
       
       
      Now you can start the instalation without problem (I guess).
       
       
      How install
       
      UEFI Setup Configuration and Installation

      UEFI configuration
       
      My BIOS is the latest: 1.93 (J4ET93WW) 

      - Shutdown and insert the flash drive.
      - Power on with F1 pressed to enter BIOS setup.
      - Change value: Config - Intel(R) AMT - Intel(R) AMT Control to DISABLED
      - Change value: Security - Security Chip to DISABLED
      - Change value: Security - Anti-Theft - Intel(R) AT Module Activation to DISABLED
      - Change value: Security - Anti-Theft - Computrace to DISABLED
      - Change value: Security - Secure Boot to DISABLED
      - Change value: Startup - UEFI/Legacy Boot to BOTH, Legacy First and CSM Support = Yes
      - Save & Exit Setup (F10)
       
      - Now, hold the F12
      - In the list, select your flash drive.
       
      The installer will start. 
      
      Format destination disk

      Format the disk with GUID partition mapping and name it "Macintosh".

      - Select Disk Utility in the list, then press Continue.
      - Click in View, then "Show All Devices".
      - Select the destination Disk, then Erase.
      - Name: HD, Format: APFS and Scheme: GUID Partition Map

      Close Disk Utility.
      
      Select "Install macOS", then Continue.
      Follow instructions in screen.

      After install

      After first part install the system will reboot. Maybe you have to press F12 again and select the flash drive.
      
      The second part of the installation will begin. This will take 16 minutes.
       

      Post installation

      Install bootloader
       
      When the second part of install finish, the system will reboot again.

      After performing the user initial setup and go to the desktop, you need to install Clover on internal disk.

      Open the Clover installer inside flash drive that you copied before.

      Use same options above but choose the system partition this time.

      Now you need to replace the config.plist inside your destination disk EFI parittion with config.plist inside flash card EFI partition.

      The flash drive EFI partition is unmounted. Mount with terminal "sudo diskutil mount /dev/rdiskXs1". To know what X is, use "diskutil list", most likely is 1.
       
      Last step
       
      Copy all Kexts from flash drive to /Library/Extensions, with those commands in Terminal:
      sudo cp -R /Volumes/EFI/EFI/CLOVER/kexts/Other/* /Library/Extensions/ sudo chmod -R 755 /Library/Extensions sudo chown -R root:wheel /Library/Extensions sudo kextcache -i / Restart the system.
       
       
      It's done!
       
       
      Updates
       
      System update 10.14.3
       
      - Updated with success;
      - Everything works perfectly after reboot;
       

       
       
      System update 10.14.4
       
      - Updated Clover to 4910.
      - Updated Lilu.kext to 1.3.5 and WhateverGreen to 1.2.7.
      - After first reboot the update progress stoped with:
      GTrace synchronization point 4 Unsupported CPU Unsupported PCH hmm.. mismatch sizes: 3100 vs 20 It was still possible to start the previous installation, selecting "Macintosh" as opposed to "macOS Install" in Clover.
      So I created a flash drive with Clover 4910 and put only my config.xml, SSDT-L440.aml, the updated Lilu.kext and WhateverGreen.kext. And I decided to test VirtualSMC instead of FakeSMC.kext.
      With this I was able to install update 10.14.4. After installation I can boot normally, even with FakeSMC.kext that already in /Library/Extensions.
      I do not know what exactly happened, but now works everything like was previously.
       


       
       

      And last but not least
       
      I would like to thank the following community members, by making these dream possible:
      @crushers, @snatch, @apianti, @blackosx, @blusseau, @dmazar, @slice2009, @autumnrain, @phpdev32, @EMlyDinEsH, @RehabMan, @Scellow, @mitch_de, @Shailua, @Andy Vandijck, @maxfierke, @ArturXXX, @LexHimself, @brumas, @Shiki and all others members involved directly or indirectly.
       
       
       
       
       
       
      32MB_DRAM-prealloc_config.plist.zip
      128MB_DRAM-prealloc_config.plist.zip
      SSDT-L440.aml
      VoodooHDA.kext.zip
      AppleHDADisabler.kext.zip
    • By SepehrM
      I'm trying to install High Sierra 10.13.3 on an ASUS N552VW laptop, and I get stuck after this message:
      "could not recover SATA HDD after 5 attempts, terminating" 
      And some other warnings afterwards.
      Specs:
      CPU: Intel Skylake 6700HQ 2.6GHz
      RAM: 16GB DDR4
      2TB HDD + 128GB SSD
      GPU: Intel HD Graphics 530 + Nvidia GTX960m
      I'm installing using a 16GB USB3 flash drive on one of HDD volumes (UEFI Mode)
       
      I uploaded the verbose log and clover config.plist
      config-new.plist

    • By Leinad12
      Olá a todos.
      Estou com o macOS Mojave instalado num Lenovo 305 (com um i3 5005 e uma HD 5500) porém tou com um problema.
      Sempre que o computador entra em pausa (Sleep) não consigo voltar a "acordar" (Wake).
      Alguém pode me ajudar pf?
×