Jump to content
tluck

[GUIDE] Lenovo T460 macOS with Clover

666 posts in this topic

Recommended Posts

well maybe try removing SSDT-6x.aml and rerun.

 

Thanks, works :) I also had to remove SSDT-5x and 12.aml. BT now find devices!!!! :)

 
To understand it, the error obtained "AE_ALREADY_EXISTS" means that it is not necessary that SSDT??
 
 

Others problems here:

  1. When I use mini-displayport and wake from sleep display the display have refresh problems and I have reboot laptop to solve it. (test with 2 different monitors) 
  2. Also from sleep display, in some cases keyboard seems disabled and not responding... but if I press 2 or more times 'Fn' key then keyboard going on.

Thanks a lot

Share this post


Link to post
Share on other sites
Advertisement

Hello guys! 

I'd like to report something odd happening: after updating two days ago, this morning my thinkpad turned off out of the blue with battery at around 60%; turning back on, the indicator was red and showing 100%.
After rebooting It seems ok, now I’m doing a recalibration cycle.
Any idea of what may be causing this? Since It was at 55-60% could it be about the double battery?

Share this post


Link to post
Share on other sites

@buoncri95

- do you have the latest/update ACPIBatteryManager kext v1.81.3 ?

- this sounds like one of problems recently fixed.

Share this post


Link to post
Share on other sites

Thank for your job to help me to resolve the problem in My Thinkpad T460.

My PC is SSD 256GB with i7-6600U,so that I have to include a SD Card to extend my disk spaces.
I am very lucky to found the driver of Realtek 522A PCIE SDReader of my T460 with a SDXC Speed in BBS.
I think you can include it into your jobs to help others.
The topic link is here:
 
@tluck
 
Extract and Drop the Sinetek-rtsx.kext into /EFI/CLOVER/kexts/Other/ of EFI partition.and reboot, the PCIE SDReader will worked
 

Sinetek-rtsx.kext.zip

Share this post


Link to post
Share on other sites

Well done it works!

 

 

Thank for your job to help me to resolve the problem in My Thinkpad T460.

My PC is SSD 256GB with i7-6600U,so that I have to include a SD Card to extend my disk spaces.
I am very lucky to found the driver of Realtek 522A PCIE SDReader of my T460 with a SDXC Speed in BBS.
I think you can include it into your jobs to help others.
The topic link is here:
 
@tluck
 
Extract and Drop the Sinetek-rtsx.kext into /EFI/CLOVER/kexts/Other/ of EFI partition.and reboot, the PCIE SDReader will worked

 

Share this post


Link to post
Share on other sites

I just upgrade my system to High Sierra replacing the kexts, everything is okay, thank you @tluck.


It works in my T460s

Thanks a lot

 

 

Thank for your job to help me to resolve the problem in My Thinkpad T460.

My PC is SSD 256GB with i7-6600U,so that I have to include a SD Card to extend my disk spaces.
I am very lucky to found the driver of Realtek 522A PCIE SDReader of my T460 with a SDXC Speed in BBS.
I think you can include it into your jobs to help others.
The topic link is here:
 
@tluck
 
Extract and Drop the Sinetek-rtsx.kext into /EFI/CLOVER/kexts/Other/ of EFI partition.and reboot, the PCIE SDReader will worked

 

Share this post


Link to post
Share on other sites

Hi Tluck,

I just got T450S with HD5500 Graphics.

will those files posted here work with it? Or the differences between T450S and T460 are too great?

Share this post


Link to post
Share on other sites

Strange problem on my side.

 

Sometimes, using it on battery, suddenly I get the screen with full brightness, and I see on the menu bar that it's like that I had plugged the pc to power. Few seconds later, it comes back like before.

 

Very strange no?

Share this post


Link to post
Share on other sites

but ppl said one slot is soldered with 4gb in some model, so it can only be upgraded to 20gb at most 

 

In my T460 is not soldered...

s6eLucB.jpg

the soldered one I referred to is T460s, not t460 sorry for the confusion 

Share this post


Link to post
Share on other sites

Hi Tluck,

I just got T450S with HD5500 Graphics.

will those files posted here work with it? Or the differences between T450S and T460 are too great?

well if you mean the kexts, yes some should work 

 

i wish i still had my T460... but here is where i got a lot of good ideas etc:

 

https://github.com/shmilee/T450-Hackintosh.git

Share this post


Link to post
Share on other sites

Does anyone have DisplayPort working on the Lenovo T460? (I don't have it working, and the version of HDMI on T460 doesn't support 4K). 

Share this post


Link to post
Share on other sites

@Kworke - well it worked for me when I had a T460.  i used a mini-display port adapter to connect to HDMI etc. 

Share this post


Link to post
Share on other sites

It was tough to get High Sierra on the T560 working again, but finally the upgrade succeeded.

 

I guess I didn't took care, that the files in the /L/E Folder were still the old files. I had to update them too...  at least im for 90% sure :P

Share this post


Link to post
Share on other sites

I got the same problem when I upgraded to HS.

Now I had removed all kexts in /L/E floder and it work fine

 

It was tough to get High Sierra on the T560 working again, but finally the upgrade succeeded.

 

I guess I didn't took care, that the files in the /L/E Folder were still the old files. I had to update them too...  at least im for 90% sure :P

Share this post


Link to post
Share on other sites

sorry guys. I guess I thought it would be understood that to get to High Sierra easily, one must update ESP and kexts in /L/E before doing the upgrade. The kexts posted will run on 10.12 or 10.13

 

The basic procedure that seems to work:

 

1) update ESP and kexts with latest zip from GitHub (posted a new bundle yesterday) while still on 10.12.6

2) reboot and verify functions (audio etc)

3) directly download High Sierra from App Store to HD

4) install from HD

Share this post


Link to post
Share on other sites

Apparently there is a variant of the T460 with Nvidia Geforce GT 940MX sitting at RP09.PEGP . Tluck can you add another SSDT that disable the device ?

Share this post


Link to post
Share on other sites

By any chance does anyone know how to fix the Displayport? Currently only able to use HDMI but would be useful to be able to use both, if possible. 

 

Also, after upgrading to High Sierra, my battery % wasn't displaying correctly on the menu bar. I had to remove it by holding cmd key and then dragging the icon out....just in case someone comes upon the same issue!

Share this post


Link to post
Share on other sites

@vusun123 - sure if provided the SSDT, I will include in the next release. I don't have T460 but I have been updating the zip on Github with newer Clover and kexts. So obviously I can't test or validate anything.

 

@xcaret - are you on the latest ACPIBatteryManager kext? there were some recent updates. 

Share this post


Link to post
Share on other sites

@tluck With the new EFI folder i don't have Brightness  (T460s) with the older no problem 

 

 

Edit 

 

 AppleBacklightInjector     I have the new version exchanged for my old and the problem is no longer available

Share this post


Link to post
Share on other sites

@ka209 - what is difference between old and new?

did you run the custom create_backlight kext script to remake the from the new one?

Share this post


Link to post
Share on other sites

@xcaret - are you on the latest ACPIBatteryManager kext? there were some recent updates. 

 

 

Yes, I am on the latest ACPIBatteryManager from your new kext pack. The battery percentage is working now after dragging the battery icon out of the menu bar and re-adding it on the System Preferences.....just wanted to throw this glitch with my system in case anyone else faces the same problem. 

 

Is displayport supposed to be working? So far, I've only gotten the HDMI to work. 

 

Never mind, I got it to work now! I just went ahead and followed the DSDT/SSDT steps again and now it is working. 

 

thank you for all your help!!!!

Share this post


Link to post
Share on other sites

@ka209 - what is difference between old and new?

did you run the custom create_backlight kext script to remake the from the new one?

 

okay I have forgot it :-(  

 

after I create a new backlight kext it`s work´s fine thank you 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   -Replace Folder CLOVER Install.zip   -Install Sierra/High Sierra and boot into system!   -Install Clover and replace with my folder  CLOVER Post Install.zip   -Reboot and activate video!   Bingo!   Now you need a fine tune! I prefer DSDT way, apply all patches in one file, many people prefer many SSDTs or Clover patches!   If you need DSDT edits for Skylake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer IORegistryExplorer.app.zip -Run it, post files generate in your desktop RunMe.app.zip   -DSDT bios F21 My DSDT with patches for skylake DSDT.GA Z170M-D3H F21.zip   -Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -MIKEY -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI






       
      -FakeSMC http://www.hwsensors.com/releases -Audio https://github.com/vit9696/AppleALC -USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads -LAN https://github.com/Mieze/IntelMausiEthernet   Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   Installation   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER Install.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER Post Install.zip   --Reboot   DSDT DSDT.MaLd0n.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BLC0 -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC ----- -Disable GPU new patch and PNLF SSDT - Credits RehabMan


       
      SSDT    Generate your SSDT for PM, use ssdtPRGen by Piker-Alpha https://github.com/Piker-Alpha ssdtPRGen.command.zip   or just use "plugin-type"=0x01 in DSDT, SSDT or Clover config.plist   for check Power, Frequency, Temperature and Utilization, use it Install Intel Power Gadget.pkg.zip  
      -Audio
      https://github.com/vit9696/AppleALC
       
      -FakeSMC
      https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads/   -Atheros Ethernet https://github.com/Mieze/AtherosE2200Ethernet   -IntelGraphicsFixup https://sourceforge.net/projects/intelgraphicsfixup/   -IntelGraphicsDVMTFixup https://github.com/BarbaraPalvin/IntelGraphicsDVMTFixup   -USBInjectAll https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   Special Thanks to Pablo Galán   We're all here to have fun and learn from each other!   ENJOY!
    • By nysander
      I start this topic to make my Lenovo Thinkpad W540 usable with High Sierra
       
      I followed many guides but this one started by @tluck made me most progress: 
      My setup as in signature
       
      I will update first post with statuses of working features:
       
      Graphics:
      Nvidia Quadro - disabled
      Intel HD 4600 - working @ 1920x1080 and 1,5GB RAM (had to set ig-plaform-id as Haswell desktop, mobile do not work)
      using intelGraphicsFixUp.kext
       
      Sound:
      internal speakers and mic works with AppleACL.kext and profile 28

      USB:
      i boot MacOS from USB drive and it works, mouse and pendrive also works
      USB power not work yet, so USB WiFi dongle and iPhone connection not work (no power @ USB)
      IOReq finds only USB 3.0 controller not USB 2.0 even though I have 2 ports USB 3.0 and 2 ports USB 2.0
       
       
      Integrated Camera:
      recognised in IOReq but not working now (probably due to USB)
       
      Bluetooth:
      as USB but works without problem

      Ethernet:
      works with intelMausiEthernet.kext

      Keyboard:
      internal is PS2 so VoodooPS2Controller.kext is needed - some mappings I would like to have different but works

      Touchpad:
      works with VoodooPS2Controller.kext from @tluck topic
       
      Trackpoint:
      One time works mostly not - debugging in progress
       
      Batery Status:
      not working
       
      Integrated WiFi:
      intel -  not working
       
      Sleep / Hibernate:
      not working
       
      Backlight:
      not working
       
      Other found issues:
      besides that graphics works @ 1920x1080 and have a lots of ram window shadows (especially dock shadow) looks bad
       
      External VGA:
      not tested yet
       
      External Mini Display Port / Thunderbolt:
      not tested yet
       
      I will post my clover / debug config later
       
       
    • By frenzycoder
      Hi, 
       
      I try to get a notebook working vanilla. 
       
      I used clover and patched DSDT.aml to get it booting. Now I have power-management issues and sound left. 
      Sound is more important for me at the moment.
       
      My notebook has following hardware: 
      Realtek ALC269 @ Intel Skylake PCH-H 
       
      lspci on ubuntu said: 
      00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
       
      id: multimedia description:  Audio device product:  Sunrise Point-LP HD Audio vendor:  Intel Corporation physical id:  1f.3 bus info:  pci@0000:00:1f.3 version:  21 width:  64 bits clock:  33MHz capabilities:  pm msi bus_master cap_list configuration: driver = snd_hda_intel latency = 32 resources: irq : 128 memory : df120000-df123fff memory : df100000-df10ffff  
      What would be the best way to install it? 
      Is it possible to do it only with EFI/Clover or do I have to touch /L/E? 
       
       
×