Jump to content
bilbo

[Guide] Z820 - El Capitan The great guide (Sucess)

199 posts in this topic

Recommended Posts

Hi,

 

Anybody are getting on the Z820 the Sleep and wake from Sleep? Mine are entering on sleep, but don't wake up correctly. No display, a don't spin up HDDs. Only the fans start up.

Share this post


Link to post
Share on other sites
Advertisement

Yes bios also.. pretty much the bios settings I had in place already. I'll check the drop table stuff as I am dropping cpupm and dmac.. sure I had it dropping nothing at one point also but never hurts to revisit.

 

 

Edit - I'll send the ssdt syntax when I get back to pc,. On phone typing this is just now.. for version currently it's 21.x but have used many from V12 to 14 to 15.x.

 

I think syntax will be -target 0 -cpu2 -l 32 -c 0 -x 0

 

But I have tried vanilla and many more with changing cputype panicking on boot.

 

 

Cheers

 

Hi cass67

 

./ssdtPRGen.sh -p 'E5-2670' -b Mac-F60DEB81FF30ACF6 -w 3 -x 1 -l 32

 

This has worked for me with the latest version of the script.

 

 

Give it a shot with:

 

./ssdtPRGen.sh -p 'E5-2690' -b Mac-F60DEB81FF30ACF6 -w 3 -x 1 -l 32

 

 

My efi folder and used kexts in s/l/e

https://drive.google.com/open?id=1uyrw0FaqrIoBa8HZlBdxRQdjpHXyj8n8

https://drive.google.com/open?id=1B1d2EfQJ213d6cQizfa8195f8RsoIHrS

 

I patched aicpupm but used the cloverpatch 

post-885315-0-36028900-1519330312_thumb.png

Share this post


Link to post
Share on other sites

Hi cass67

 

./ssdtPRGen.sh -p 'E5-2670' -b Mac-F60DEB81FF30ACF6 -w 3 -x 1 -l 32

 

This has worked for me with the latest version of the script.

 

 

Give it a shot with:

 

./ssdtPRGen.sh -p 'E5-2690' -b Mac-F60DEB81FF30ACF6 -w 3 -x 1 -l 32

 

 

My efi folder and used kexts in s/l/e

https://drive.google.com/open?id=1uyrw0FaqrIoBa8HZlBdxRQdjpHXyj8n8

https://drive.google.com/open?id=1B1d2EfQJ213d6cQizfa8195f8RsoIHrS

 

I patched aicpupm but used the cloverpatch 

 

 

Nice one thanks, ill check It out ...

 

EDIT - Awesome thanks, I have that coil whine noise now on the PSU, thats indicating some PM is in play, I'm stuck in turbo mode now so thats a difference and the cpu temps have gone down 20deg C .. now for a new ssdt to be generated :)

 

EDIT 2 - You are indeed the man .. THANKS SO MUCH !!! 

 

on version 21.5 of ssdtprgen what works for me is - 

 

ssdtPRGen.sh -cpus 2 -p E5-2690 -target 0 -l 32 -x 1 -c 3

 

​I appear to have the whole range of Pstates now - 

 

CPU Ratio Info:

------------------------------------

CPU Low Frequency Mode.............: 1200 MHz

CPU Maximum non-Turbo Frequency....: 2900 MHz

CPU Maximum Turbo Frequency........: 3800 MHz

CPU P-States [ (12) 25 36 ]

CPU C3-Cores [ 3 6 7 ]

CPU C6-Cores [ 3 6 ]

CPU P-States [ (12) 25 26 36 ]

CPU C3-Cores [ 3 6 7 9 13 ]

CPU C6-Cores [ 3 6 12 15 16 ]

CPU P-States [ (12) 17 25 26 36 ]

CPU C3-Cores [ 0 1 3 6 7 9 12 13 ]

CPU C6-Cores [ 3 6 8 12 15 16 ]

CPU P-States [ (12) 16 17 25 26 36 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 ]

CPU C6-Cores [ 3 6 8 12 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 ]

CPU C6-Cores [ 3 6 8 12 13 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 ]

CPU C6-Cores [ 0 3 6 8 9 10 12 13 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 ]

CPU C6-Cores [ 0 3 6 8 9 10 12 13 15 16 ]

CPU C6-Cores [ 0 1 3 6 8 9 10 12 13 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 16 ]

CPU C6-Cores [ 0 1 2 3 6 8 9 10 12 13 15 16 ]

CPU P-States [ (12) 16 17 19 25 26 36 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 16 ]

 
 
( I removed the AppleIntelCPUPowerManagementInfo.kext in favour of the new one  AppleIntelInfo.kext
 
Now for some benchmark testing ;)
 
Geekbench 3 - 
 
Single core - 3027 

Multi core - 38190

 
Geekbench 4 - 
 

Single core - 3272 

Multi core - 30477

 

Cinebench R15 -

 

2158

 

That will do nicely !! 

 

Cheers

Share this post


Link to post
Share on other sites

 

Nice one thanks, ill check It out ...

 

EDIT - Awesome thanks, I have that coil whine noise now on the PSU, thats indicating some PM is in play, I'm stuck in turbo mode now so thats a difference and the cpu temps have gone down 20deg C .. now for a new ssdt to be generated :)

 

EDIT 2 - You are indeed the man .. THANKS SO MUCH !!! 

 

on version 21.5 of ssdtprgen what works for me is - 

 

ssdtPRGen.sh -cpus 2 -p E5-2690 -target 0 -l 32 -x 1 -c 3

 

​I appear to have the whole range of Pstates now - 

 

CPU Ratio Info:

------------------------------------

CPU Low Frequency Mode.............: 1200 MHz

CPU Maximum non-Turbo Frequency....: 2900 MHz

CPU Maximum Turbo Frequency........: 3800 MHz

CPU P-States [ (12) 25 36 ]

CPU C3-Cores [ 3 6 7 ]

CPU C6-Cores [ 3 6 ]

CPU P-States [ (12) 25 26 36 ]

CPU C3-Cores [ 3 6 7 9 13 ]

CPU C6-Cores [ 3 6 12 15 16 ]

CPU P-States [ (12) 17 25 26 36 ]

CPU C3-Cores [ 0 1 3 6 7 9 12 13 ]

CPU C6-Cores [ 3 6 8 12 15 16 ]

CPU P-States [ (12) 16 17 25 26 36 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 ]

CPU C6-Cores [ 3 6 8 12 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 ]

CPU C6-Cores [ 3 6 8 12 13 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 ]

CPU C6-Cores [ 0 3 6 8 9 10 12 13 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 ]

CPU C6-Cores [ 0 3 6 8 9 10 12 13 15 16 ]

CPU C6-Cores [ 0 1 3 6 8 9 10 12 13 15 16 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 16 ]

CPU C6-Cores [ 0 1 2 3 6 8 9 10 12 13 15 16 ]

CPU P-States [ (12) 16 17 19 25 26 36 ]

CPU C3-Cores [ 0 1 3 6 7 9 10 12 13 14 16 ]

 
 
( I removed the AppleIntelCPUPowerManagementInfo.kext in favour of the new one  AppleIntelInfo.kext
 
Now for some benchmark testing ;)

Awesome !

Looks good :)

Share this post


Link to post
Share on other sites

Cool, It seems that you got it .

 

Btw, yes, AppleIntelCPUPowerManagementInfo.kext is obsolete in Sierra. :rolleyes:

 

yes looking good :) 

 

Just a bit of tuning on the clover config I think but as it seems a bit heavy, but lets see... As you mentioned in the PM the Nvidia checkboxes are ticked and no probs with the black screens now, even in verbose boot mode which was an issue I had also ... 

 

Thanks to you all on this thread .. I sucked info from everywhere :)

 

Cheers

Share this post


Link to post
Share on other sites

Hi,

 

Anybody are getting on the Z820 the Sleep and wake from Sleep? Mine are entering on sleep, but don't wake up correctly. No display, a don't spin up HDDs. Only the fans start up.

 

Wake from sleep doesn't work that good ... On my system i have it turned off in System Preferneces (ticked first box - Prevent computer from going to sleep ....) because even though network usb and gpu (nvidia gtx740) wake up just fine, the HDD's don't come back and Finder Hangs on any attempt to access 'em.

 

Anyone else who succeeded ?

Share this post


Link to post
Share on other sites

Wake from sleep doesn't work that good ... On my system i have it turned off in System Preferneces (ticked first box - Prevent computer from going to sleep ....) because even though network usb and gpu (nvidia gtx740) wake up just fine, the HDD's don't come back and Finder Hangs on any attempt to access 'em.

 

Anyone else who succeeded ?

 

Are you booting from the LSI controller, or from motherboard SATA controller?

 

If booting from the LSI (using Astek drivers) this is a known issue, which despeinao is currently trying to fix.   It won't work unless/until he can find a solution, which is not simple.

 

If booting from SATA controller then ignore this post!

Share this post


Link to post
Share on other sites

Are you booting from the LSI controller, or from motherboard SATA controller?

 

If booting from the LSI (using Astek drivers) this is a known issue, which despeinao is currently trying to fix.   It won't work unless/until he can find a solution, which is not simple.

 

If booting from SATA controller then ignore this post!

 

Hi

 

I'm booting from the Grey AHCI ports with all other drives connected at the bottom (LSI on board controller) sata/sas connectors.

I'm using Despeinao's patched Astek drivers.

Share this post


Link to post
Share on other sites

Hi

 

I'm booting from the Grey AHCI ports with all other drives connected at the bottom (LSI on board controller) sata/sas connectors.

I'm using Despeinao's patched Astek drivers.

 

OK. I don't have a Z820 so I can't be 100% sure, but the symptom you describe is exactly identical to the issue that despeinao and I get when booting from the LSI.

 

I don't get it when I boot from SATA with other drives on the LSI, however my other drives are currently NTFS formatted and have no macOS programs/data on them. Basically, I'm not even using them at the moment, they're visible in Finder but that's it.

 

So it's entirely possible that the same wake problem could exist if you have open files on an LSI drive, even if it's not being booted from that controller.

 

You can test this by booting with all drives connected to AHCI SATA ports and then trying sleep/wake.

Share this post


Link to post
Share on other sites

I don't have sleep, either, . My SO HD is connected to AHCI SATA, and when I'm testing I have all HD plugged in SAS LSI , disconnected (I have a  front case for SSDs in front panel).  So, I think your guess is wrong.

 

As a side note, I don't have "computer sleep" setting in preference panel.

Share this post


Link to post
Share on other sites

Has anybody here tried booting from a Z turbo drive (old) or G2?

The Z-drive G2 doesn't work on Zx20 workstation for the lack of a NVMe OpROM. I didn't try the G1 (AHCI mode).

 

I'm using a Samsung 950pro which has the missing OpROM and can get Mac OS X Sierra to boot from it.

 

For now I'm waiting for a compiled / updated guide to finish the Sierra setup.

Share this post


Link to post
Share on other sites

I don't have sleep, either, . My SO HD is connected to AHCI SATA, and when I'm testing I have all HD plugged in SAS LSI , disconnected (I have a  front case for SSDs in front panel).  So, I think your guess is wrong.

 

As a side note, I don't have "computer sleep" setting in preference panel.

 

Hi Bilbo !

 

It's not a "computer sleep" setting per se - It's under energy saver, the box right under the slider that says 'prevent computer from sleeping automatically when the display is off'

Share this post


Link to post
Share on other sites

I don't have sleep, either, . My SO HD is connected to AHCI SATA, and when I'm testing I have all HD plugged in SAS LSI , disconnected (I have a  front case for SSDs in front panel).  So, I think your guess is wrong.

 

 

 

OK yeah I guess that's something different then and specific to Z820. 

Share this post


Link to post
Share on other sites

When I wrote the guide, I forgot mention that , from every and now, I have to boot rebulding caches (using clover options). Have you tried to do it?

 

 

 

 

I have no idea about that . ...  :unsure:

 

And , I still got several kernel panic recently  :(

 

      Kernel Extensions in backtrace:
         net.osx86.kexts.GenericUSBXHCI(1.2.11)[00000000-0000-0000-0000-000000000000]@0xffffff7fa054c000->0xffffff7fa0563fff
 
Mac OS version:
16F73
 

 

 

 

I have native usb 2.0x2 , pci-e NEC usb 3.0 x4 ports

meanwhile , the driver status :

 

$ kextstat |grep USB

 

   14    0 0xffffff7f80a8a000 0x4000     0x4000     com.rehabman.driver.USBInjectAll (0.5.17) 99003E98-4591-37FA-9885-3B51950B765C <12 11 4 3>

   21   10 0xffffff7f80c2f000 0x69000    0x69000    com.apple.iokit.IOUSBHostFamily (1.1) B9C17AFF-13E0-3070-9024-C74ABABBFBE9 <20 7 6 5 4 3 1>

   46    1 0xffffff7f818cf000 0x3d000    0x3d000    com.apple.driver.usb.AppleUSBEHCI (1.1) 3EDD9377-6B29-3013-BEFF-CDD967AB4B80 <21 11 7 6 5 4 3 1>

   47    0 0xffffff7f819ae000 0xe000     0xe000     com.apple.driver.usb.AppleUSBEHCIPCI (1.1) 75E7962D-E6C2-35EB-A831-2090FB8958FE <46 21 12 11 7 6 5 4 3 1>

   50    9 0xffffff7f80ca0000 0x9a000    0x9a000    com.apple.iokit.IOUSBFamily (900.4.1) D403C49A-FBF5-35DE-9A92-F282BCF5E0E9 <21 12 7 5 4 3 1>

   51    0 0xffffff7f80d4c000 0x18000    0x18000    net.osx86.kexts.GenericUSBXHCI (1.2.11) no UUID <50 12 7 5 4 3>

   56    0 0xffffff7f81999000 0x5000     0x5000     com.apple.driver.usb.AppleUSBHostPacketFilter (1.0) 77B2A55E-67C6-3DC1-A803-A85BB3F2CDE7 <21 7 6 5 4 3 1>

   59    0 0xffffff7f819e9000 0x19000    0x19000    com.apple.driver.AppleUSBLegacyHub (900.4.1) 5BF2E274-DF70-343E-9C2F-BC65A09319A3 <50 5 4 3 1>

   61    2 0xffffff7f8199e000 0x4000     0x4000     com.apple.driver.AppleUSBHostMergeProperties (1.1) 54BF5D73-5065-37BF-B22A-6867E44AD241 <4 3 1>

   62    0 0xffffff7f819e6000 0x3000     0x3000     com.apple.driver.AppleUSBMergeNub (900.4.1) 33D9C82A-9F2C-3018-BB91-789615F1C024 <61 50 4 3 1>

   67    0 0xffffff7f81963000 0x2e000    0x2e000    com.apple.driver.usb.AppleUSBHub (1.1) 94ABC212-358F-3C61-A4CC-E04C319085D7 <21 11 5 4 3 1>

   68    0 0xffffff7f819d6000 0xa000     0xa000     com.apple.driver.AppleUSBComposite (900.4.1) AB6261EE-61E1-3007-87A4-AB90E9959814 <50 4 3 1>

   71    0 0xffffff7f81ae3000 0x4f000    0x4f000    com.apple.driver.AppleLegacyUSBAudio (2.9.5f19) DFE1F27F-B75B-320E-AAA5-EB995C08375E <70 50 12 5 4 3>

   72    0 0xffffff7f819a2000 0x8000     0x8000     com.apple.driver.usb.AppleUSBHostCompositeDevice (1.1) B675F448-83A9-3596-98F3-160EFD0719CD <21 5 4 3 1>

   75    0 0xffffff7f81845000 0xb000     0xb000     com.apple.driver.usb.IOUSBHostHIDDevice (1.1) 6C775083-AB4B-31F5-9B0D-3FD524F92E91 <40 21 5 4 3 1>

   88    0 0xffffff7f819cc000 0xa000     0xa000     com.apple.iokit.IOUSBHIDDriver (900.4.1) F5AC617E-119C-37FA-9C71-8D76648EDDE1 <50 40 5 4 3 1>

  122    1 0xffffff7f819bf000 0x3000     0x3000     com.apple.iokit.IOUSBUserClient (900.4.1) 4B883193-8AF7-39C6-9F84-9FB10D56167F <61 50 7 5 4 3 1>

  123    0 0xffffff7f82a95000 0x8000     0x8000     org.virtualbox.kext.VBoxUSB (5.1.22) D956DCFA-4E4F-320A-BEBC-E4823501B1FF <122 120 50 7 5 4 3 1>

Share this post


Link to post
Share on other sites

So I screwed up my Sierra install trying to use Rampage's Dual CPU DMG and I couldn't get anything booting again, even starting from scratch. Is Sierra that tricky or I am confusing steps somewhere ?

 

@bilbo : did you take a look at this DMG ? There's a specific folder for the Z820 / Z840 there.

Share this post


Link to post
Share on other sites

From rampage's dmg , I take only fakesmc andVoodooTSCync.kext . Yes, I saw the z820 folder. They are: one ssdt of unknown origin and purpose. And one EFI folder, of unknown origin too. It has nullpowermanagement and voodooHDA , so, I don't recommend use it at all.

Share this post


Link to post
Share on other sites

Thank you for this tutorial..I will be buying this workstation very soon, refurbished, for my Pro Tools DAW setup....

Share this post


Link to post
Share on other sites
On 12/26/2017 at 11:06 PM, despeinao said:

Binary patch for Clover (use the original driver):

Hi.

This patch work with Mojave but Catalina...

Can you, please, make a patch for Catalina?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By amadeusex
      Hi there y' all.
       
      I'm selling my hp z820 with the specs listed below since i accidentally bought me another one (that's what i told to my wife anyway).
       
      The machine runs flawlessly High High Sierra 10.13.6 and also has Win7 pro and Win10 pro licences tied to the machine.
       
      The machine is in Athens Greece
       
      I'm asking for 850 euros shipped within the European Union.
       
            Features     • Make: HP • Modell: Workstation Z820   • Processor: 2x Intel XEON Quad-Core E5-2670 • Chipset: Intel C602    • Memory: 64 GB ECC RAM • Sound: Realtek ALC262   • Graphics Card: nVidia Quadro K600   • SAS - Controller: LSI SAS2308 with RAID (0, 1, 5, 10) • SSD - 256 GB • DVD RW   • 2x Ethernet-LAN (RJ-45): 2 (Dual Gigabit - 1000Mbit/s)   • FireWire: 2x (1x Front + 1x Back) • USB 2.0: 5x (1x Front + 4x Back) • USB 3.0: 4x (2x Front + 2x Back)   • PS/2 • serial RS232 • Line-In • Line-Out • Microphone • FireWire (6polig)    • PSU: 1125 Watt    • (WxHxD): 203mm x 444mm x 525mm • Weight: 21,1kg   The machine is configured to also run MacOS 10.13.6 High Sierra without any hiccups and complete working power management.   Geekbench 4 64-bit  MacOs Results
      https://browser.geekbench.com/v4/cpu/12062123
      Geekbench 4 64-bit  Win10 Results
      https://browser.geekbench.com/v4/cpu/11972736
      The pictured drive trays are not included - the original placeholders will be mounted!


    • By Angelo_
      Just recently installed Mojave on my yoga 730(i5-8250u, 8gb of ram and 1080p 13.3" touchscreen) and got many features working, now the only issues are that my igpu is shown as only 7mb(and not metal capable, not sure whether it is or not) even tho I should've changed it from 5917 to 5916 (added both EFI folder and send me), the screen is shown as a 30.5" in system information and the cpu even tho I extracted the ssdt for it with ssdtPRGen.sh and appleintelinfo.kext to get low frequency info (ssdt was done with info 15,400,1600,3400 so it should go between 16-3400mhz and down to 400 in idle), idk what is wrong with my installation, can you guys help me or linke me something to fix those issues?
       
      Ps thunderbolt shows as no device found, is it regular for hackintoshes to be that way or do I need something for that too? Laptop has 2 tb3 ports as x4 pcie 3
      EFI.zip
      Send me Angeloss-MacBook-Pro.zip
    • By bilbo
      THE GREAT GUIDE
      HIGH SIERRA + Z820

       
      ********
      10/07/2018
       
       
      *********************************************************************************
      ————————————————————————————————————————
      ————————————————————————————————————————
       
      (from El Capitan's guide)
      (from Sierra's guide)
       
      Introduction:
       
      Hi everybody. 
      Again, a new guide version, updated to High Sierra. I hope it will be useful for you all. This time, the update is easy. Basically, the 100% of Sierra’s guide is still valid for High Sierra. The guide has been updated to update links, kexts versions … etc, and some parts try to be more clear. Just there are some important topic to keep in mind:
       
      1. What's new?.
      There is a new and absolute important setting to install High Sierra. We have to activate “legacy ACPI cpu tables” in Advanced Section, in BIOS. Without this option enabled, we will get a KP. 
      This option changes completely the structure of the SSDT needed for PM. We have to get rid old SSDT versions, if you extracted them with this option disabled. And all SSDT generated by ssdtPRGen, too. And, if your DSDT has the “SSDT-1-CpuDef” code injected, (following my previous guides, to skip "No ACPI Processor declarations found in the DSDT!" error, (see PM section) ) you will have to delete that part, because the DSDT will cause a KP. A better method is described in this guide. No need of add strange code into DSDT.

       
      2.Can I use my old files from Sierra´s EFI folder?
      The most important, yes. You can keep your config.plist and your DSDT(see point N.1) … saving tons of time. You have to use the new drivers64Uefi files installed by new clover version, and update the kexts versions of main kexts. The specific kexts for our dear machine, USB3, Astek driver, remains in same version.Of course, I provide of all links and files (into my stuff folder) in this guide.
       
      3. So, do I Need repeat again every step of this guide?.
      If you comes from Sierra´s guide, no. After 1stboot and graphics divers install, you can use your previous files (see point 1.) reboot and jump directly to PM section. 
      For new users, Yes, sure.

      4. Consider any part of this guide open to discuss.
      If you see something wrong, or which could be improved, please, just say it, and I’ll fix it. English is not my native language. If you can’t understand some step, or something could be best written, please, just say it and I’ll fix it too
       

      FOR 26x7 and 26x3 USERS!!!. Finally, there a Fix to this models. It´s under test, but I think it should work. Check out FIRST the last section of this guide.
       
      5. And please, (this is for "anonymous" users) don't PM me with personalquestions. No need for that.Any question can be answered openly.
       
       
      Ok, let’s go.
       
       
       
      PART I
       
      1-BIOS SETUP
       
       
      This guide is for UEFI systems. This is not important to follow this guide except in Clover installation section. Keep in mind it to adapt some settings if you need use legacy-bios mode. 
       
      If you don’t need any special option, and you have been playing with options, reset the bios to default settings.Later, you will be able to change and test, if you need some specific option. The next section describe the essential options. 
       
      6. The main BIOS options are:
       
      In storage: 
      set ACHI mode (IMPORTANT).
       

       
       
      Set boot order. UEFI first, (for me), USB first and HD second. 
       


       
      Security : 
      Device Security: I like disable unused devices (scu controller and serial port). Optional.



       
      Disable Vt-d: Disabled. IMPORTANT. 
       

       

       
      Secure boot. Disabled (...to boot with non signed OS). 
      I use UEFI boot, but I keep legacy support active. This is optional.
       

       
       
      In Power :
      Set Runtimepower management to Enabled. This option will allow Power Management later. About the rest of options, I’m not sure of the impact in performance. Set them by default by the moment. Not important for the guide. Only remeber for further tests that with Pcie Performance Mode enabled, power boost is disabled. Idle Power Savings manage sleep policies.


       
       
      In Advanced:
       
      Set PXE, Storage and Video to EFI. (for me) , or legacy, as your want. If you have a graphic card non EFI-compliant, you can set video in Legacy, keeping an UEFI boot.
      Don’t forget set thunderbolt policy in Legacy mode.
       

       

       
      And Now, the essential setting for High Sierra: 
       
      -Enable “Legacy ACPI CPU Tables”
       


       

       

      _________________________________________________________________________________________________________________________________
       
       
       
      PART II:
       
      INSTALLATION
       
      7- MEDIA CREATION
       
      (This guide assume you have a MacOs running. I have no idea how do it on PC)
       
      -Important: Download HighSierra dmg only from Apple.Don´t use suspicious dmgs or Isos. It’s not longer available to search in Apple Store, since Mojave release. Go to this link, and click in “Get macOS high Sierra” (at mid of the page). It will open the apple store download link. The dmg is downloaded in /Applications folder. Let the file in Applications folder. (and keep one compressed copy for future attempts)

       
      -Format one USB stick with common settings:
       


       
      Go to erase tab, select GUID partition table in options, and Mac Os Extended (Journaled) as Filesystem. Name the partition as “USB”. Ok to Apply.   
      On a terminal window, type (copy and paste) :  
      sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction  
      Enter and type your admin password. It will take 10-15 minutes. (When it finish, you’ll see the prompt again)  
      8. INSTALLING CLOVER.
       
      -Download Clover from here. Version used to make this guide: Clover_v2.4k_r4658.
      -Download Clover Configurator from here. It makes easier edit config.plist file and we can use a lot of clover features easily. Now there is a “global edition”
      -Download plisteditor pro demo for edit info.plist files.
      -Download my High Sierra stuff folder. (at the end of the guide)
      -Additional tools: One tool for install kexts, fix permission and rebuild cache. I use Kext helper from rampage’s dmg, although I need always force quit. I don´t like the rest of utilities. This is a personal option. Also you can download  EFI mounter (from download sections of this site). CloverConfigurator mounts EFI too, but maybe with this utility is easier.
       
      -Install Clover in the USB. On first screen, don’t forget change the install location in order to do not install on your Internal HD. Select your USB stick.
      Click on Customize. Choose “Install for UEFI booting only” and “Install Clover in the ESP” as main options (if your system is UEFI-based) This is optional: choose your favorite Theme. In Drivers64UEFI select: Now is longer section. It´s only because is more exact showing the drivers installed. We have to keep selected the default options and add the same additional drivers. Keep in mind two important things:                   -There is a new driver, APFS driver, for the “new” filesystem. This driver is now essential, in order to allow clover “see” HDs formatted with this FS. It´s activated by default. 
                       -The OSxAptiopnFix2Drv has a new version, v3.
                ... The conclusion of this long explanation, is that we have to add to the default selection of drivers: 
       
                                - EmuVariableUefi-64
                               - OsxAptionFix3Drv
       

      Let the rest of option unselected and Click on Install.
       
       
      9- CONFIGURE CLOVER

      When clover finishes, it will mount EFI partition. Time to modify it. You’ll find all necessary files in my folder. There are three things to modify: config.plist, drivers, and kexts
       
      9.1 Config.plist
       
      The default config.plist is not useful for us. Replace it by mine (folder n.2)
      But take a look to options (with clover configurator) to understand my options in order to be able to adapt them for your specs or your preferences. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options. 
       
           Acpi section.
          All fixes in ACPI section has been removed except some minor fixes in 2 subsection, smart ups option, etc. SmartUps it’s not important now, but it will be later. So I prefer activate this option. 
          The most important, The rename usb devices patches are included. 
       
          

          Boot section
          Bootflags needed are only -v and npci=0x2000. Of course -v is optional only to see the boot process. You can deactivate it when you finish.
       
          
       
          Any option activated in Boot Graphics/ Cpu/Device/Disable driver
       
          Gui options. These are only personal preferences.
       
          
       
          Graphics. AnyGraphic injection annd any option activated. At least, no needed for my 1080ti card. Check it out for your card video.
       
          
       
          An essential section. Kernels Patches needed.
       
          
       
          RT Variables. BooterConfig, and Csr to deactivate security policy in Sierra. The info values are taken from smbios.
       
          
       
          SMBIOS.  Set it to Mac Pro 6,1. 
       
          
       
                    IMPORTANT—>press “generate new” repeatedly to get one random fresh serial number
       
          System parameter: 
       
          
       
       
      9.2 -Drivers64UEFI folder.
       
      As usual, delete VBoxHfs-64driver and replace it by HFSPlus.efi. (from my folder).

           
       
       
      9.3 Kexts folder:
       
      Add my Kexts from my stuff to /EFI/CLOVER/Kexts/10.13
       
      They are:

           
       
      These are the versions Updated since Sierra´s guide.
       
      FakeSMC.kext. If you remember, I have some unexpected KP due to fake smc sensors. Well, I have searched a bit about this, and testing. The main topic is keep the fake smc version and sensors kext of same version or branch. There are several branchs developing              different versions (slice, rehabman, kozleck, etc), after test, and test, I think the most stables and those which gives me best sensor readings is kozeck version. I attach the v1440 from kozleck. In this step I only use FakeSMC kext, withput sensors kexts. Anyway, if you have a better version, use it. Just, don´t forget no use the sensors Kexts.   
      VoodooTSCync.kext, to avoid boot with -x (from rampagdev, dual cpu dmg). You’ll find several versions into my folder.I haven’t noticed any change using the generic or the specific version. I think that is not important for our platform.                  The customize method is:

       

       
               Anyway, I provided the generic version and customized versions for every cpu.

       
      IntelMausiEthernet.kext . Kext for the ethernet card from rehabman. (2018-0424version). It will allow have internet connection on first boot.  AppleIntelE1000e.kext. Kext for ethernet card from here (2017-10-18 version). (Change of  server if you have problems downloading) <<<< update. Use this better than IntelMausiEthernet.kext
       
      UsbInjectall, for USB2 from rehabman( 2018-0822version)  
      And add to /EFI/CLOVER/Kexts/others
       
       

       
       
      Lilu kext (from here, 1.2.7version)  
      WhateverGreen.kext (from here, 1.2.2 version) old NvidiaGraphicsFixup proyect has been integrated into this proyect. It's useful for nvidia and amd graphics cards  
      This couple of kexts avoid black screen booting with 6,1 smbios. Is quite important keep in mind the versions of these kexts keeping the right versions among this kexts. Prior to update some of them, you have to check in original websites if it's is compatible with the rest. These versions are ready to work with 10.13.6. 
       
      Thats all. We have our usb installer ready. Copy in a folder all stuff necessary to repeat the process and copy it to the USB stick. You will have it available after first boot.
       
      Reboot from the USB stick and install High Sierra. 

       
      10- INSTALLATION

       
      Some advices:
           -Use only USB2 ports, preferably the front USB2 port.
           -Don’t use USB hubs, or cable extenders… (personal issues)
           -Unplug any other usb device
           -Be sure that you have plugged your internal sata drive to one of the two internal achi sata controller.
       

       
           -The boot process may be slow, (and with terrible and apocalyptic errors). Be patient
           -Maybe, the boot stucks with the error “consideredRebuildKernel …. blabla”. Just reboot again.
           -If you have two monitors, shutdown one can help with graphical errors.
           -Plug your graphic card in PCI Slot 2.
           -For inexperienced users: On first screen, go to disk utility and erase the Volume. (APFS and GPT). Quit the utility and return to first screen. Choose Install.
           -The process is splitted in two steps. The first step promises take only 4 or 5minutes … and now, it’s true!!!. It will take4 or 5 minutes(with a SSD).
           -After this first reboot, in clover boot screen, you will see more partitions than expected. APFS file system manage more partitions in a more complex way (physical layer, logical layer… bla, bla). Select  the new internal HighSierra boot installer partition, not the usb installer. It will finish the  process. This step, takes 10-15min aprox (using a SSD).
       
      Note.I had some unexpected reboot in this step. Only re-trying if you have it also.
       
      -To boot again after installation, keep booting from USB , ant then choose internal HD as clover boot screen.
       
       
      ---------------------------------------------------------------------------------------------------------------------------------
       
       
       
      PART III:
       
      FIRST BOOT
       
      11. Optional updates.
      Finally, we are on High Sierra's Dektop. The Mac os Version is 17G65. In the date of this guide (oct/2018) is the last version. (there is an optional update only for real macbook laptops). For future security updates, this is the moment to update. Set up the internet options and update the system, but remember check if the Lilu and whatevergreen kexts are compatible or if you need use a new version, or you will geta KP or a black screen on boot. Update using the update app, reboot, and wait for the update installation.
       
      12- Install Clover.
      On first reboot, install clover again on HDD, repeating same process and same options than with the USB installer, but keep in mind you have to add some options on clover’s screen install:
       


       

           -Install RC scripts on target volume
           -Optional RC scripts
           -Install Clover Preference Panel.

      …and install clovermanager.app. This is optional but it’s the best way to manage the themes and find a good theme. I provide of one nice High Sierra Theme and the Bootcamp theme. Of course, left this for later. 
       
      Install clover and add same files used on the USB: config.plist , hfsplus driver and kexts. Reboot. You can now extract the USB installer and reboot from the internal HDD.
      After boot, go to clover preference panel and set it to auto mount EFI partition. It will be useful along this process. Disable this when you finish and you get stable your system.
       
       
    • By Haive_Music
      Hey guys,
       
      I'm really hoping someone has the experience and ability to help me iron out the last remaining issue on my build.  
       
      The motherboard is: Gigabyte Z370 Aorus Gaming 7 and I'm running a Alpine Ridge thunderbolt card (Revision 2).   I've gotten everything working for the most part with the exception of Thunderbolt hotplug.  This is the last piece of the puzzle.  I've tried so many different DSDT/SSDT's, cable plugged in, and unplugged, without any luck at all. 
      I've managed to get my Focusrite Clarett 8Pre Thunderbolt working and it's showing up under the PCI section.  It works great, until I shut the device off and turn it back on.  I'd really like to try to get this hotplug issue sorted out, but I've had absolutely no luck so far.
       
      I've managed to get the Alpine Ridge NHI and USB controllers showing up in the PCI section too, but for some reason, the USB lists a bunch of ',,,,,,,,' after the name. 
       
       
      I'll be the first to admit - I don't really know a whole lot about what I'm doing with this stuff, but I've attached relevant files in hopes someone more experienced and knowledable can help me get this working.  
       
      Thanks guys!
      config.plist
      DSDT.aml
      John’s iMac.iojones

      SSDT-TB3.aml
    • By ivoryblade
      Hello! My internal SSD lifetime is running out so I'm thinking how to upgrade it. I don't want to replace it with slow Sata SSD so I want to buy OWCMercury Helios and install new nvme fast ssd, but I won't be able to boot from it using standard boot loader.... Is it possible to boot nvme ssd using Clover on real iMac?
×