Jump to content
bilbo

[Guide] Z820 - El Capitan The great guide (Sucess)

200 posts in this topic

Recommended Posts

Yes, There is something wrong with the update. Did you update the nvidia drivers also ? 

 

I'm in 11.6 without problems but I never update the minor versions of the SO. I install it directly in last version. If you download El capitan now from appstore, the SO is updated to 10.11.6 . That is another reason because I always wait to last version x.x.6 or so, to update to the last mountain of Apple ;)

Share this post


Link to post
Share on other sites
Advertisement

No, I actually uninstalled the nvidia web drivers on the 11.6 installation before copying the 11.0 kexts across and I haven't re-installed them since.  I will test that when I get a chance though.

Share this post


Link to post
Share on other sites

Hi, could anybody post a working link to the original AstekFusion2Family and AstekFusion2Adapter kexts, please? The astekcorp.com and astektechservices.com ones don't work anymore. Thank you!

Share this post


Link to post
Share on other sites

Merry Christmas to everyone !

 

I had some drawbacks with my MacOs installation after changing my monitor.

 

My old one albeit working just fine and with 23" big enough only came with a single vga input. After replacing it with an HP 2465 (and accidentally invoking auto update) i had major graphic glitches. Studio one (DAW-sequencer software) and logic Pro (ditto) would play back just fine but their interface would not refresh graphics unless You clicked anywhere on the app and only for some seconds.

 

Same day later and i couldn't boot from the HDD (it would stop after login - no KP just no desktop) and i had to use the installer usb to get to the OS (which as You all know sucks bc You don't have the refined system with PM yada yada yada)

 

Long story short - Together with the necessity to transfer the os to an SSD I did the installation from scratch ... again.

 

This time (and because of the fact that up to here i had my old monitor connected to the HDMI output with an active HDMI to DVI-I converter) i decided to use

lilu.kext and NvidiaGraphicsFixup which just works fine.

 

I also cleaned my DSDT from scratch and somehow didn't get the annoying error i had the first time (where i just deleted that method after trying for some hours to find a solution) and created the SSDT for power management again.

 

I tried to use the EFI folder from the HDD installation but power management wasn't working good enough (don't know why - it does now so i can't complain).

 

Also i didn't have to install any application again because migration assistant (applications/utilities) works just fine - otherwise i had to spend some days to install all that cr@p again !

 

Geek bench 3 scores are now even better - 34-35k

post-885315-0-31937300-1514222943_thumb.jpg

http://browser.geekbench.com/geekbench3/8514928

 

Cinebench 15 score is 1956 (CPU) and 54 Fps (GPU - ASUS Nvidia GTX 740)

 

post-885315-0-12332500-1514222969_thumb.jpg

 

 

My z820 has the 3.91 bios and is loaded with 64Gb ram and 2 E5 2670 v1 cpus.

 

My kexts used in S/L/E

https://drive.google.com/open?id=1B1d2EfQJ213d6cQizfa8195f8RsoIHrS

 

My EFI folder

https://drive.google.com/open?id=1x5HiyMuR9nPZIrFLW5eLkPg6IKMMr-5f

 

Happy holidays and a happy new year from Greece !

 

Share this post


Link to post
Share on other sites

Merry Christmas to everyone !

 

.....

 

 

I'm very very glad to read people hacking z820 succesfully !!! :lol:

 

 

 

 

Hi, could anybody post a working link to the original AstekFusion2Family and AstekFusion2Adapter kexts, please? The astekcorp.com and astektechservices.com ones don't work anymore. Thank you!

 

 

Here is the original installer. If you do some improve to patch them to work in SIerra, please, let us know ;)

Astek_Fusion2_HBA_Driver-2.62_032813a.zip

Share this post


Link to post
Share on other sites

Here is the original installer. If you do some improve to patch them to work in SIerra, please, let us know ;)

 

Thank you!

 

I've managed to make a working version for High Sierra (I don't see any reason why it shouldn't work with Sierra or earlier)

 

Binary patch for Clover (use the original driver):

<dict>
	<key>Comment</key>
	<string>Astek Fusion 2 Unrestricted</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>
	xoGSAwAAAQ+3uYABAADoaQoAAA==
	</data>
	<key>Name</key>
	<string>AstekFusion2Family</string>
	<key>Replace</key>
	<data>
	xoGSAwAAAA+3uYABAADpBgAAAA==
	</data>
</dict>

Diff to the disassembled code (AstekFusion2Family, disassembled using otool -jtV):

--- AstekFusion2Family OR.asm	2017-12-26 21:57:32.000000000 +0100
+++ AstekFusion2Family.asm	2017-12-26 21:57:38.000000000 +0100
@@ -1,4 +1,4 @@
-AstekFusion2Family OR:
+AstekFusion2Family:
 (__TEXT,__text) section
 _string_to_config:
 0000000000000540	55 	pushq	%rbp
@@ -19458,9 +19458,9 @@ __ZN37com_astekcorp_driver_AstekFusion2S
 00000000000146df	c6 81 8f 03 00 00 00 	movb	$0x0, 0x38f(%rcx)
 00000000000146e6	c6 81 90 03 00 00 00 	movb	$0x0, 0x390(%rcx)
 00000000000146ed	c6 81 91 03 00 00 00 	movb	$0x0, 0x391(%rcx)
-00000000000146f4	c6 81 92 03 00 00 01 	movb	$0x1, 0x392(%rcx)
+00000000000146f4	c6 81 92 03 00 00 00 	movb	$0x0, 0x392(%rcx)
 00000000000146fb	0f b7 b9 80 01 00 00 	movzwl	0x180(%rcx), %edi
-0000000000014702	e8 69 0a 00 00 	callq	__ZL18is_astek_vendor_idj ## is_astek_vendor_id(unsigned int)
+0000000000014702	e9 06 00 00 00 	jmp	0x1470d
 0000000000014707	48 83 f8 00 	cmpq	$0x0, %rax
 000000000001470b	74 7c 	je	0x14789
 000000000001470d	bf 05 00 00 00 	movl	$0x5, %edi

And I've also attached the patched drivers if you don't want Clover to patch them for you.

Unrestricted_Astek_Fusion2_HBA_Driver.zip

Share this post


Link to post
Share on other sites

Ooow despeinao, installed and tested. And it's works !!! Thanks a lot!!! We owe you a few beers ... A big release. :thumbsup_anim: :thumbsup_anim: :thumbsup_anim:

 

 

P:D muchas gracias :D

Share this post


Link to post
Share on other sites

I´m triying to install sierra 12.6 to my Z820 and i always got stuck at the same point. No matter if i boot from USB or if I try to boot via another HD (i copied my EFI to it before), the result is always the same. I got stuck at the stop sign.

 

Does anyone have a solution for this problem?

EFI Z820.zip

post-703997-0-40028100-1514488069_thumb.jpeg

post-703997-0-07473700-1514488086_thumb.jpeg

Share this post


Link to post
Share on other sites

It´s the usb issue.

 

It's easy to see that your clover folder is absoltly wrong and messy.

 

First. You deleted the 10.x.x kext folders from KEXT folder, and all kexts are in "other"  ... Why?

 

You have also more kexts ... "WhateverGreen" ?¿?¿?¿? and I miss some folder more. Really weird.

 

Second. Open the config.plist with cloverconfigurator. Everything is wrong :surprised: :surprised: ;)

 

So, delete clover folder from your usb  and reinstall clover again following my guide. (download the last version for Sierra) .

 

Go to step 2, read this

2.1 Config.plist

 

Clover makes a config.plist with some options pre-selected. Change the original config.plist by mine. But take a look to options (with clover configurator) to understand it in order to be able to adapt them for your specs. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options.

... and follow the guide . to get a right usb installer Use clover configurator to have a more clear overview.


And remember that it'a a guide for El Capitán. To install completely Sierra has several concerns. I'm working on a new guide for sierra in my spare time. I don't know how long will take it. But keep in mind that some parts of the guide need an update.

Share this post


Link to post
Share on other sites

I changed things from your guide because i wanted to install sierra and the el capitan files didn´t work for me.

 

"other" folder: I usually put kext into this folder. Clover loads kext´s from that folder no matter which osx version you use. I´ve never experienced any issue with it.

Whatevergreen & Lilu Kext is they way to get AMD RX Cards to work properly. There´s just one other way but you need to edit the dsdt for it and i usually do that as a part of the post installation process.

 

I though it was the USB problem myself but i copied my folder to an HD and the problem persisted. 

 

Anyways, thanks a lot for your thoughts and I´ll start over again ;)...

Share this post


Link to post
Share on other sites

 

"other" folder: I usually put kext into this folder. Clover loads kext´s from that folder no matter which osx version you use. I´ve never experienced any issue with it.

 

 

I know. But I think there is no need to do that. It´s  the recomended folder to use lilu and agp ifx but for the rest of kexts .... anyway It's up to you.

 

I didn't know Whatevergreen.kext . Keep in mind that you don't need graphic working 100% . You can patch it later. But if it is neccesary, ok.

 

So focus in your config.plist. Open it with clover configurator and compare it with my config.plist for install of my stuff. Check the patches of ACPI section. You are mixing several patches  ( Rename devices to usb ) , provided by default by clover ,and my patches. Delete the rest of them and keep only my patches (see screensots of my guide). This , with USBInjectAll.kext will do the magic to boot.

 

But , you have a lot of extra patches, related with PM, and other things selected. And you have deselected a lot of essentials patchs of kernel and "kexts patches section". Your config.plist never will work.

 

In short...I I highly recommend you use my basic config plist and add only options for your graphic issue. You will be able to refine it later.

 

Luck

 

PS- Sorry If I sounded a bit rude ;)

Share this post


Link to post
Share on other sites

You are totally right. I left the Clover DSDT Patches in the ACPI section patches from a config i found for a high sierra installation of a Z420.

They have no meaning in both contexts, because there are HDAS, EHC1 & 2 devices in the DSDT. Important are just the renames to EH01 & 02 for USBinjectall and those are the same you have in your config.

 

I´m editing the DSDT at the moment and will try again tomorrow morning with your basic config.

Share this post


Link to post
Share on other sites

Hi mates.

 

I'm finishing a new guide to update our machines to Sierra . I'm close to finish it. I'm in a temp install. I have to wait for some new toy, and repeat and check all again.

 

All is still working like under El Capitan... pros (audio, graphics, drivers controllers, PM ) and cons (USB3).  some steps has been improved. But I could say we are ready to jump to next mountain in a stable way.

 

A good idea could be make a dsdt cleaned and patched for us, but it depends of the bios version. Now I'am in 3.85. (I have to use some certified bios versions).  there are a lot of versions. 3.87 , 3.88, 3.90 , 3.91 ... but I'm interested specially in 3.90 and 3.91 version,  (last versions , and less work) 

 

So please, for those with this versions, upload your whole dsdt tables for your bios version. To extract them,---use only this method---, press f4 on boot clover screen, and then, after boot,  compress and upload the folder /efi/clover/acpi/origin .

Share this post


Link to post
Share on other sites

Hi

 

Unfortunately HP sells two different versions of the z820 workstations. v1 and v2. v1 supports Sandy bridge CPUs and v2 adds support for ivy bridge processors.

 

The only difference is the boot block (2011 vs 2013) which cannot be upgraded via bios flash. It can be done but only with a risky procedure involving external hadware to manually flash the bios chip and resolder again onto the main board.

 

 https://h30434.www3.hp.com/t5/Business-PCs-Workstations-and-Point-of-Sale-Systems/z820-e5-2600-v2-ivy-bridge-upgrade/td-p/5086052/page/7

 

 

How's that 1080 ti working ?

Share this post


Link to post
Share on other sites

mmm. I though that z820 v1 / v2 version was only different in bios version. So I'm gonna need bios in both versions :(

 

 

1080 is not working well. It works, but with some issue with hardware accelaration and working with two monitors. It doesn't have a big perfomance , either. The worst is even  the soft which I work  doesn't recognize the card. The lesson I learned these days is in despite of all the info about Pascal Support by nvidia drivers in sierra , 10xx series are not supported yet <_< .

 

The only consolation is that in linux and windows works pretty well.

 

I'll try in high sierra, but I don't have time. Testing Sierra, working, etc

Share this post


Link to post
Share on other sites

"1080 is not working well"

 

Did You try the Lilu / NvidiaGraphixFixup kexts ?

 

Gpus other than the natively supported ones tend to be difficult to configure with the MacPro6,1 definition ... 

Share this post


Link to post
Share on other sites

Yes I did. They're necessary to fix black screen on boot in "on-the-fly" way. I don't think that NvidiaGraphixFixup have any impact on perfomance. 

 

My last hope is try on High Sierra. But I must finish my test on Sierra.

Share this post


Link to post
Share on other sites

Hi, what kind of problem do you have with 1080 ti? it worked all the time as gui in slot 2 without any problem or performance issues with 2 monitors on the output. now i have have two 1080 ti installed in slots 4 (gui) and 6 with perfect results in cuda applications.

 

i have problem that only front usb 2 connector is working with macpro 6.1 definition. with macpro 5.1 definition are working rear usb ports too. exist any solution for this?

 

thanks.

Share this post


Link to post
Share on other sites

I have some specifical problems.

 

- dual monitor DVI + Display port doesn't work on boot. I have to turn off the display port monitor on boot.

 

- some minor blocks in some UI effects (minimizing windows .. etc)

 

-Not so great perfomance as I expected. Geekbench, cinebench, unigine heaven, etc)

 

-Soft which I work doesn't recognize the card , what cold be a symptom of it's not working 100%. In linux works 100%

 

 

Please post your specs. so and driver versions, z820 specs, clover confs, kexts etcto compare.

Share this post


Link to post
Share on other sites

Hi, if you want the drives attached to the LSI Fusion adapter to show up as internal, just add this patch to the KextsToPatch section in Clover:

<dict>
	<key>Comment</key>
	<string>Astek Fusion 2 Fix External</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>
		PHN0cmluZz5FeHRlcm5hbDwvc3RyaW5nPg==
	</data>
	<key>InfoPlistPatch</key>
	<true/>
	<key>Name</key>
	<string>AstekFusion2Adapter</string>
	<key>Replace</key>
	<data>
		PHN0cmluZz5JbnRlcm5hbDwvc3RyaW5nPg==
	</data>
</dict>

Share this post


Link to post
Share on other sites

For anyone trying to get the native USB 3.0 ports to work, I would recommend buying this PCI-E card: Ableconn PUSB31P2A USB 3.1 Gen 2 (10 Gbps) 2-Port Type-A PCI Express (PCIe) x4 Host Adapter Card - Support Mac OS X 10.12 Sierra and Windows 10/8

Works like a charm OOB on the latest Sierra release. It costs around US $30.00, but you get the latest gen2 10gbps USB 3.1 connectivity. You can pick either Type-A, Type-C or Type-A and Type-C mixed depending on your needs.

 

Anyone else not able to shutdown or restart properly with this card installed? I boot verbose all the time just to make sure everything looks ok, usually when I shutdown I'll get a little more verbose script about shutting down. With this PCI card installed the screen goes black, the computer stays on, then reboots with a 929-fatal mca error. 

 

I'm running 10.12.6 on a HP z620 with dual 2960s 

 

If I remove the card, the computer shuts down or reboots normally. I have tried multiple PCI slots, all with the same results. 

 
any ideas? 

Share this post


Link to post
Share on other sites

Thank you!

 

I've managed to make a working version for High Sierra (I don't see any reason why it shouldn't work with Sierra or earlier)

 

Binary patch for Clover (use the original driver):

<dict>
	<key>Comment</key>
	<string>Astek Fusion 2 Unrestricted</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>
	xoGSAwAAAQ+3uYABAADoaQoAAA==
	</data>
	<key>Name</key>
	<string>AstekFusion2Family</string>
	<key>Replace</key>
	<data>
	xoGSAwAAAA+3uYABAADpBgAAAA==
	</data>
</dict>

Diff to the disassembled code (AstekFusion2Family, disassembled using otool -jtV):

--- AstekFusion2Family OR.asm	2017-12-26 21:57:32.000000000 +0100
+++ AstekFusion2Family.asm	2017-12-26 21:57:38.000000000 +0100
@@ -1,4 +1,4 @@
-AstekFusion2Family OR:
+AstekFusion2Family:
 (__TEXT,__text) section
 _string_to_config:
 0000000000000540	55 	pushq	%rbp
@@ -19458,9 +19458,9 @@ __ZN37com_astekcorp_driver_AstekFusion2S
 00000000000146df	c6 81 8f 03 00 00 00 	movb	$0x0, 0x38f(%rcx)
 00000000000146e6	c6 81 90 03 00 00 00 	movb	$0x0, 0x390(%rcx)
 00000000000146ed	c6 81 91 03 00 00 00 	movb	$0x0, 0x391(%rcx)
-00000000000146f4	c6 81 92 03 00 00 01 	movb	$0x1, 0x392(%rcx)
+00000000000146f4	c6 81 92 03 00 00 00 	movb	$0x0, 0x392(%rcx)
 00000000000146fb	0f b7 b9 80 01 00 00 	movzwl	0x180(%rcx), %edi
-0000000000014702	e8 69 0a 00 00 	callq	__ZL18is_astek_vendor_idj ## is_astek_vendor_id(unsigned int)
+0000000000014702	e9 06 00 00 00 	jmp	0x1470d
 0000000000014707	48 83 f8 00 	cmpq	$0x0, %rax
 000000000001470b	74 7c 	je	0x14789
 000000000001470d	bf 05 00 00 00 	movl	$0x5, %edi

And I've also attached the patched drivers if you don't want Clover to patch them for you.

 

Thank you so much for posting this! You really made my day. I'm using a:

02:00.0 Serial Attached SCSI controller [0107]: LSI Logic / Symbios Logic SAS2008 PCI-Express Fusion-MPT SAS-2 [Falcon] [1000:0072] (rev 03) (subsys 1028:1f1c)

and was about to give up. Big thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By bilbo
      THE GREAT GUIDE
      HIGH SIERRA + Z820

       
      ********
      10/07/2018
       
       
      *********************************************************************************
      ————————————————————————————————————————
      ————————————————————————————————————————
       
      (from El Capitan's guide)
      (from Sierra's guide)
       
      Introduction:
       
      Hi everybody. 
      Again, a new guide version, updated to High Sierra. I hope it will be useful for you all. This time, the update is easy. Basically, the 100% of Sierra’s guide is still valid for High Sierra. The guide has been updated to update links, kexts versions … etc, and some parts try to be more clear. Just there are some important topic to keep in mind:
       
      1. What's new?.
      There is a new and absolute important setting to install High Sierra. We have to activate “legacy ACPI cpu tables” in Advanced Section, in BIOS. Without this option enabled, we will get a KP. 
      This option changes completely the structure of the SSDT needed for PM. We have to get rid old SSDT versions, if you extracted them with this option disabled. And all SSDT generated by ssdtPRGen, too. And, if your DSDT has the “SSDT-1-CpuDef” code injected, (following my previous guides, to skip "No ACPI Processor declarations found in the DSDT!" error, (see PM section) ) you will have to delete that part, because the DSDT will cause a KP. A better method is described in this guide. No need of add strange code into DSDT.

       
      2.Can I use my old files from Sierra´s EFI folder?
      The most important, yes. You can keep your config.plist and your DSDT(see point N.1) … saving tons of time. You have to use the new drivers64Uefi files installed by new clover version, and update the kexts versions of main kexts. The specific kexts for our dear machine, USB3, Astek driver, remains in same version.Of course, I provide of all links and files (into my stuff folder) in this guide.
       
      3. So, do I Need repeat again every step of this guide?.
      If you comes from Sierra´s guide, no. After 1stboot and graphics divers install, you can use your previous files (see point 1.) reboot and jump directly to PM section. 
      For new users, Yes, sure.

      4. Consider any part of this guide open to discuss.
      If you see something wrong, or which could be improved, please, just say it, and I’ll fix it. English is not my native language. If you can’t understand some step, or something could be best written, please, just say it and I’ll fix it too
       

      FOR 26x7 and 26x3 USERS!!!. Finally, there a Fix to this models. It´s under test, but I think it should work. Check out FIRST the last section of this guide.
       
      5. And please, (this is for "anonymous" users) don't PM me with personalquestions. No need for that.Any question can be answered openly.
       
       
      Ok, let’s go.
       
       
       
      PART I
       
      1-BIOS SETUP
       
       
      This guide is for UEFI systems. This is not important to follow this guide except in Clover installation section. Keep in mind it to adapt some settings if you need use legacy-bios mode. 
       
      If you don’t need any special option, and you have been playing with options, reset the bios to default settings.Later, you will be able to change and test, if you need some specific option. The next section describe the essential options. 
       
      6. The main BIOS options are:
       
      In storage: 
      set ACHI mode (IMPORTANT).
       

       
       
      Set boot order. UEFI first, (for me), USB first and HD second. 
       


       
      Security : 
      Device Security: I like disable unused devices (scu controller and serial port). Optional.



       
      Disable Vt-d: Disabled. IMPORTANT. 
       

       

       
      Secure boot. Disabled (...to boot with non signed OS). 
      I use UEFI boot, but I keep legacy support active. This is optional.
       

       
       
      In Power :
      Set Runtimepower management to Enabled. This option will allow Power Management later. About the rest of options, I’m not sure of the impact in performance. Set them by default by the moment. Not important for the guide. Only remeber for further tests that with Pcie Performance Mode enabled, power boost is disabled. Idle Power Savings manage sleep policies.


       
       
      In Advanced:
       
      Set PXE, Storage and Video to EFI. (for me) , or legacy, as your want. If you have a graphic card non EFI-compliant, you can set video in Legacy, keeping an UEFI boot.
      Don’t forget set thunderbolt policy in Legacy mode.
       

       

       
      And Now, the essential setting for High Sierra: 
       
      -Enable “Legacy ACPI CPU Tables”
       


       

       

      _________________________________________________________________________________________________________________________________
       
       
       
      PART II:
       
      INSTALLATION
       
      7- MEDIA CREATION
       
      (This guide assume you have a MacOs running. I have no idea how do it on PC)
       
      -Important: Download HighSierra dmg only from Apple.Don´t use suspicious dmgs or Isos. It’s not longer available to search in Apple Store, since Mojave release. Go to this link, and click in “Get macOS high Sierra” (at mid of the page). It will open the apple store download link. The dmg is downloaded in /Applications folder. Let the file in Applications folder. (and keep one compressed copy for future attempts)

       
      -Format one USB stick with common settings:
       


       
      Go to erase tab, select GUID partition table in options, and Mac Os Extended (Journaled) as Filesystem. Name the partition as “USB”. Ok to Apply.   
      On a terminal window, type (copy and paste) :  
      sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction  
      Enter and type your admin password. It will take 10-15 minutes. (When it finish, you’ll see the prompt again)  
      8. INSTALLING CLOVER.
       
      -Download Clover from here. Version used to make this guide: Clover_v2.4k_r4658.
      -Download Clover Configurator from here. It makes easier edit config.plist file and we can use a lot of clover features easily. Now there is a “global edition”
      -Download plisteditor pro demo for edit info.plist files.
      -Download my High Sierra stuff folder. (at the end of the guide)
      -Additional tools: One tool for install kexts, fix permission and rebuild cache. I use Kext helper from rampage’s dmg, although I need always force quit. I don´t like the rest of utilities. This is a personal option. Also you can download  EFI mounter (from download sections of this site). CloverConfigurator mounts EFI too, but maybe with this utility is easier.
       
      -Install Clover in the USB. On first screen, don’t forget change the install location in order to do not install on your Internal HD. Select your USB stick.
      Click on Customize. Choose “Install for UEFI booting only” and “Install Clover in the ESP” as main options (if your system is UEFI-based) This is optional: choose your favorite Theme. In Drivers64UEFI select: Now is longer section. It´s only because is more exact showing the drivers installed. We have to keep selected the default options and add the same additional drivers. Keep in mind two important things:                   -There is a new driver, APFS driver, for the “new” filesystem. This driver is now essential, in order to allow clover “see” HDs formatted with this FS. It´s activated by default. 
                       -The OSxAptiopnFix2Drv has a new version, v3.
                ... The conclusion of this long explanation, is that we have to add to the default selection of drivers: 
       
                                - EmuVariableUefi-64
                               - OsxAptionFix3Drv
       

      Let the rest of option unselected and Click on Install.
       
       
      9- CONFIGURE CLOVER

      When clover finishes, it will mount EFI partition. Time to modify it. You’ll find all necessary files in my folder. There are three things to modify: config.plist, drivers, and kexts
       
      9.1 Config.plist
       
      The default config.plist is not useful for us. Replace it by mine (folder n.2)
      But take a look to options (with clover configurator) to understand my options in order to be able to adapt them for your specs or your preferences. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options. 
       
           Acpi section.
          All fixes in ACPI section has been removed except some minor fixes in 2 subsection, smart ups option, etc. SmartUps it’s not important now, but it will be later. So I prefer activate this option. 
          The most important, The rename usb devices patches are included. 
       
          

          Boot section
          Bootflags needed are only -v and npci=0x2000. Of course -v is optional only to see the boot process. You can deactivate it when you finish.
       
          
       
          Any option activated in Boot Graphics/ Cpu/Device/Disable driver
       
          Gui options. These are only personal preferences.
       
          
       
          Graphics. AnyGraphic injection annd any option activated. At least, no needed for my 1080ti card. Check it out for your card video.
       
          
       
          An essential section. Kernels Patches needed.
       
          
       
          RT Variables. BooterConfig, and Csr to deactivate security policy in Sierra. The info values are taken from smbios.
       
          
       
          SMBIOS.  Set it to Mac Pro 6,1. 
       
          
       
                    IMPORTANT—>press “generate new” repeatedly to get one random fresh serial number
       
          System parameter: 
       
          
       
       
      9.2 -Drivers64UEFI folder.
       
      As usual, delete VBoxHfs-64driver and replace it by HFSPlus.efi. (from my folder).

           
       
       
      9.3 Kexts folder:
       
      Add my Kexts from my stuff to /EFI/CLOVER/Kexts/10.13
       
      They are:

           
       
      These are the versions Updated since Sierra´s guide.
       
      FakeSMC.kext. If you remember, I have some unexpected KP due to fake smc sensors. Well, I have searched a bit about this, and testing. The main topic is keep the fake smc version and sensors kext of same version or branch. There are several branchs developing              different versions (slice, rehabman, kozleck, etc), after test, and test, I think the most stables and those which gives me best sensor readings is kozeck version. I attach the v1440 from kozleck. In this step I only use FakeSMC kext, withput sensors kexts. Anyway, if you have a better version, use it. Just, don´t forget no use the sensors Kexts.   
      VoodooTSCync.kext, to avoid boot with -x (from rampagdev, dual cpu dmg). You’ll find several versions into my folder.I haven’t noticed any change using the generic or the specific version. I think that is not important for our platform.                  The customize method is:

       

       
               Anyway, I provided the generic version and customized versions for every cpu.

       
      IntelMausiEthernet.kext . Kext for the ethernet card from rehabman. (2018-0424version). It will allow have internet connection on first boot.  AppleIntelE1000e.kext. Kext for ethernet card from here (2017-10-18 version). (Change of  server if you have problems downloading) <<<< update. Use this better than IntelMausiEthernet.kext
       
      UsbInjectall, for USB2 from rehabman( 2018-0822version)  
      And add to /EFI/CLOVER/Kexts/others
       
       

       
       
      Lilu kext (from here, 1.2.7version) NOTE: The kext for download is available in " LILU-X.X.X-RELEASE.zip" link  
      WhateverGreen.kext (from here, 1.2.2 version) old NvidiaGraphicsFixup proyect has been integrated into this proyect. It's useful for nvidia and amd graphics cards.  NOTE: The kext for download is available in " WhateverGreen-X.X.X-RELEASE.zip" link  
      This couple of kexts avoid black screen booting with 6,1 smbios. Is quite important keep in mind the versions of these kexts keeping the right versions among this kexts. Prior to update some of them, you have to check in original websites if it's is compatible with the rest. These versions are ready to work with 10.13.6. 
       
      Thats all. We have our usb installer ready. Copy in a folder all stuff necessary to repeat the process and copy it to the USB stick. You will have it available after first boot.
       
      Reboot from the USB stick and install High Sierra. 

       
      10- INSTALLATION

       
      Some advices:
           -Use only USB2 ports, preferably the front USB2 port.
           -Don’t use USB hubs, or cable extenders… (personal issues)
           -Unplug any other usb device
           -Be sure that you have plugged your internal sata drive to one of the two internal achi sata controller.
       

       
           -The boot process may be slow, (and with terrible and apocalyptic errors). Be patient
           -Maybe, the boot stucks with the error “consideredRebuildKernel …. blabla”. Just reboot again.
           -If you have two monitors, shutdown one can help with graphical errors.
           -Plug your graphic card in PCI Slot 2.
           -For inexperienced users: On first screen, go to disk utility and erase the Volume. (APFS and GPT). Quit the utility and return to first screen. Choose Install.
           -The process is splitted in two steps. The first step promises take only 4 or 5minutes … and now, it’s true!!!. It will take4 or 5 minutes(with a SSD).
           -After this first reboot, in clover boot screen, you will see more partitions than expected. APFS file system manage more partitions in a more complex way (physical layer, logical layer… bla, bla). Select  the new internal HighSierra boot installer partition, not the usb installer. It will finish the  process. This step, takes 10-15min aprox (using a SSD).
       
      Note.I had some unexpected reboot in this step. Only re-trying if you have it also.
       
      -To boot again after installation, keep booting from USB , ant then choose internal HD as clover boot screen.
       
       
      ---------------------------------------------------------------------------------------------------------------------------------
       
       
       
      PART III:
       
      FIRST BOOT
       
      11. Optional updates.
      Finally, we are on High Sierra's Dektop. The Mac os Version is 17G65. In the date of this guide (oct/2018) is the last version. (there is an optional update only for real macbook laptops). For future security updates, this is the moment to update. Set up the internet options and update the system, but remember check if the Lilu and whatevergreen kexts are compatible or if you need use a new version, or you will geta KP or a black screen on boot. Update using the update app, reboot, and wait for the update installation.
       
      12- Install Clover.
      On first reboot, install clover again on HDD, repeating same process and same options than with the USB installer, but keep in mind you have to add some options on clover’s screen install:
       


       

           -Install RC scripts on target volume
           -Optional RC scripts
           -Install Clover Preference Panel.

      …and install clovermanager.app. This is optional but it’s the best way to manage the themes and find a good theme. I provide of one nice High Sierra Theme and the Bootcamp theme. Of course, left this for later. 
       
      Install clover and add same files used on the USB: config.plist , hfsplus driver and kexts. Reboot. You can now extract the USB installer and reboot from the internal HDD.
      After boot, go to clover preference panel and set it to auto mount EFI partition. It will be useful along this process. Disable this when you finish and you get stable your system.
       
       
    • By amadeusex
      Hi there y' all.
       
      I'm selling my hp z820 with the specs listed below since i accidentally bought me another one (that's what i told to my wife anyway).
       
      The machine runs flawlessly High High Sierra 10.13.6 and also has Win7 pro and Win10 pro licences tied to the machine.
       
      The machine is in Athens Greece
       
      I'm asking for 850 euros shipped within the European Union.
       
            Features     • Make: HP • Modell: Workstation Z820   • Processor: 2x Intel XEON Quad-Core E5-2670 • Chipset: Intel C602    • Memory: 64 GB ECC RAM • Sound: Realtek ALC262   • Graphics Card: nVidia Quadro K600   • SAS - Controller: LSI SAS2308 with RAID (0, 1, 5, 10) • SSD - 256 GB • DVD RW   • 2x Ethernet-LAN (RJ-45): 2 (Dual Gigabit - 1000Mbit/s)   • FireWire: 2x (1x Front + 1x Back) • USB 2.0: 5x (1x Front + 4x Back) • USB 3.0: 4x (2x Front + 2x Back)   • PS/2 • serial RS232 • Line-In • Line-Out • Microphone • FireWire (6polig)    • PSU: 1125 Watt    • (WxHxD): 203mm x 444mm x 525mm • Weight: 21,1kg   The machine is configured to also run MacOS 10.13.6 High Sierra without any hiccups and complete working power management.   Geekbench 4 64-bit  MacOs Results
      https://browser.geekbench.com/v4/cpu/12062123
      Geekbench 4 64-bit  Win10 Results
      https://browser.geekbench.com/v4/cpu/11972736
      The pictured drive trays are not included - the original placeholders will be mounted!


    • By Angelo_
      Just recently installed Mojave on my yoga 730(i5-8250u, 8gb of ram and 1080p 13.3" touchscreen) and got many features working, now the only issues are that my igpu is shown as only 7mb(and not metal capable, not sure whether it is or not) even tho I should've changed it from 5917 to 5916 (added both EFI folder and send me), the screen is shown as a 30.5" in system information and the cpu even tho I extracted the ssdt for it with ssdtPRGen.sh and appleintelinfo.kext to get low frequency info (ssdt was done with info 15,400,1600,3400 so it should go between 16-3400mhz and down to 400 in idle), idk what is wrong with my installation, can you guys help me or linke me something to fix those issues?
       
      Ps thunderbolt shows as no device found, is it regular for hackintoshes to be that way or do I need something for that too? Laptop has 2 tb3 ports as x4 pcie 3
      EFI.zip
      Send me Angeloss-MacBook-Pro.zip
    • By Haive_Music
      Hey guys,
       
      I'm really hoping someone has the experience and ability to help me iron out the last remaining issue on my build.  
       
      The motherboard is: Gigabyte Z370 Aorus Gaming 7 and I'm running a Alpine Ridge thunderbolt card (Revision 2).   I've gotten everything working for the most part with the exception of Thunderbolt hotplug.  This is the last piece of the puzzle.  I've tried so many different DSDT/SSDT's, cable plugged in, and unplugged, without any luck at all. 
      I've managed to get my Focusrite Clarett 8Pre Thunderbolt working and it's showing up under the PCI section.  It works great, until I shut the device off and turn it back on.  I'd really like to try to get this hotplug issue sorted out, but I've had absolutely no luck so far.
       
      I've managed to get the Alpine Ridge NHI and USB controllers showing up in the PCI section too, but for some reason, the USB lists a bunch of ',,,,,,,,' after the name. 
       
       
      I'll be the first to admit - I don't really know a whole lot about what I'm doing with this stuff, but I've attached relevant files in hopes someone more experienced and knowledable can help me get this working.  
       
      Thanks guys!
      config.plist
      DSDT.aml
      John’s iMac.iojones

      SSDT-TB3.aml
    • By ivoryblade
      Hello! My internal SSD lifetime is running out so I'm thinking how to upgrade it. I don't want to replace it with slow Sata SSD so I want to buy OWCMercury Helios and install new nvme fast ssd, but I won't be able to boot from it using standard boot loader.... Is it possible to boot nvme ssd using Clover on real iMac?
×