Jump to content
bilbo

[Guide] Z820 - El Capitan The great guide (Sucess)

198 posts in this topic

Recommended Posts

Haha,

 

here were 400 reboots in one month period (12h/day), I have tried all distros from MLion further. Then stopped fooling around and went back feeding kids. The best I have achieved (for stable) was a working Yosemite (w/o patching dsdt/ssdt) with only one cpu and gtx950. I didn't manage to install El Capitan because at the time I didn't understand the prohibit logo at setup. Now I know that usb had stopped functioning. I am very satisfied with this Sierra built on Z620. Dual Xeon on mac and 96Gb RAM are great :)

 

There are some geekbench3 results on Z620 if anybody is intrested in...  all are w/o patching dsdt/ssdt
 

post-1633996-0-44155600-1498035284_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

Haha,

 

 

There are some geekbench3 results on Z620 if anybody is intrested in...  all are w/o patching dsdt/ssdt

 

 

Could you provide cinebench R15 scores for reference?

 

 

 

Thanks.

Share this post


Link to post
Share on other sites

Your scores are OK I think..

Thank you !

 

For performance issue, In my opinion, if you can show "CPU works 3GHZ during Cinebench testing". There are no performance issue.  I found the answer was in your picture but it trimmed at right hand side. (#46)

 

Cheers.

Share this post


Link to post
Share on other sites

I already succeed to install mac 10.11 on my Z820, thanks for Bilbo for sharing this post.

 

But I wanna know anyone succeed to update or install mac 10.12 on Z820?  

 

Cause I want to use xcode 9 and it required mac 10.12.

Share this post


Link to post
Share on other sites

Thanks Bilbo for the Guide, i manage to install and complete all the fixes, firewire, PM, usb, but can't get audio to work, can u guys help me out? thank u

Share this post


Link to post
Share on other sites

My GeekBench 4 scores. Everything works including audio - except for USB3.

Will attempt to fix USB3 next.

 

Thanks a lot for the excellent guide.

post-1697671-0-14453500-1501609846_thumb.jpeg

post-1697671-0-12831800-1501610189_thumb.jpeg

post-1697671-0-42435900-1501610612_thumb.jpg

Share this post


Link to post
Share on other sites

I have read some people about problems with audio. I've just check the section on my guide and  I think all info is explained. I know it's hard, but be patience and follow the guide step by step.

 

But maybe there is something wrong or bad explained because of my bad English. Please, tell me when you stuck, and I'll try to fix the guide.

Share this post


Link to post
Share on other sites

Dear bro,

I got kernel panic after update 10.12.5---->10.12.6

please help.

Kernel Panic in Backtrace with AppleIntelCPUPowerManagement.kext according to your picture you have posted.

See the first page, in the tutorials is written:

 „Now we are going to install the tool to check our C and P - states. The usual tools are the AppleIntelCPUPowerManagementInfo.kext or the most recent the AppleIntelInfo.kext , they both from piker. But none of them work. They cause a kernel Panic in our PC. Fortunately, one user from this forum patched a right version a time ago. I don’t know the kind of patch , and if it depends of the architecture , bios (msr-locked) or whatever. It’s and old version, but it works.“

 

Delete or remove the Apple standard AppleIntelCPUPowerManagementInfo.kext from S/L/Extensions and replace it with this one here:

http://www.insanelymac.com/forum/topic/295200-testers-needed-cpu-power-management-for-sb-and-ib-xeons-or-i7-39xx-on-x79-or-c60x-chipset/page-3?do=findComment&comment=1986508

then repair the permissions and refresh the kernel cache.

 

Edit:

and check your bootargs

Share this post


Link to post
Share on other sites

@kumaroli thank you anyway, am still on el capitan and i want to upgrade, i guess i will have to buy a pci to sata card, is everything else working?

Share this post


Link to post
Share on other sites

Thanks Bilbo, great post.

I followed your post, and I get Sierra 10.12.16 works on my Z820 now. 

My Z820 HW Spec: 2X E5-2660 V2, 20 CPU Cores. 1X EVGA GTX 1060 Graphics,  card 8X16G DDR3 memory, 1X512G SSD, 1 LSI 9260-8I Raid card (I abandoned the LSI 2308 for it can not work on Sierra).

 

  • The system works stable, but I have the following problems.
  • Firewire can not work : if we using FixHPET option in Clover ACPI options, firewire can not be found. But if you don't us this fix option, although we can see firewire, system will reboot in about 30 seconds.
  • USB 3.0 can not work.
  • Sound card can not work with AppleHDA, my workaround is using voodooHDA 2.8.6, but poor quality of sound. I have to use USB earphone.

 

I have DSDT, SSDT. Some versions of hack drivers have bugs and will make system crack, so I have tried many versions.

See the picture of my system I attached.

 

Now I can use Sierra to run latest Xcode version on my Z820, I don't have to always transfer to my Macbook pro. That's great.

 

 

If someone can help me to solve this problem, I will be very happy:)


snapshot of my Sierra on Z820.

post-1425262-0-09564100-1503447834_thumb.pngpost-1425262-0-84013300-1503447837_thumb.pngpost-1425262-0-33738800-1503447841_thumb.pngpost-1425262-0-52622100-1503447844_thumb.pngpost-1425262-0-40105600-1503447847_thumb.pngpost-1425262-0-64686200-1503447851_thumb.pngpost-1425262-0-41258800-1503447857_thumb.pngpost-1425262-0-81373200-1503447862_thumb.pngpost-1425262-0-85328200-1503447873_thumb.pngpost-1425262-0-98739900-1503447867_thumb.png


post-1425262-0-80505000-1503447996_thumb.pngpost-1425262-0-48968300-1503448002_thumb.pngpost-1425262-0-65022000-1503448004_thumb.png

Share this post


Link to post
Share on other sites

using this:

SASMegaRAID.kext


Open the DSDT. Locate Devices IPCI, TIMR and RTC (use search function).

IPCI should be IPIC 


Now firewire works. The reason is that I could not find IPCI, after change it to IPIC, I rm the IRQ in DSDT and then it works.

post-1425262-0-64989800-1503457866_thumb.png


Dear bro,

I got kernel panic after update 10.12.5---->10.12.6

please help.

Drop your SSDT.aml and boot to your system and then try to regenerate your SSDT.aml using ssdtPRGen.sh. The latest version of ssdtPRGen may not work, try using another version from author's website.

Share this post


Link to post
Share on other sites

Open the DSDT. Locate Devices IPCI, TIMR and RTC (use search function).

IPCI should be IPIC 

 

Thanks, guide fixed ;)

  • USB 3.0 can not work.
  • Sound card can not work with AppleHDA, my workaround is using voodooHDA 2.8.6, but poor quality of sound. I have to use USB earphone.

 

... Some versions of hack drivers have bugs and will make system crack,

 

USB3

Anyone has native usb3 working. The simplest way is add one usb3  pci card. But I´d like fix this also.

 

AUDIO

I quote myself:

 

I have read some people about problems with audio. I've just check the section on my guide and  I think all info is explained. I know it's hard, but be patience and follow the guide step by step.

 

But maybe there is something wrong or bad explained because of my bad English. Please, tell me when you stuck, and I'll try to fix the guide.

 

...But maybe with Sierra the proccess had to be updated

 

 

Drivers:

 

It´s a known problem. The lsi 2308 hacked drivers don't work on SIerra

Share this post


Link to post
Share on other sites

Just joining the party - I just got a used Z620 (dual 2660v2) with a Quadro M4000 that I'm trying to get Sierra on. This isn't my first Hackintosh, but this machine makes it much more complicated than the forgiving GA-H77-DS3H board... So far no success (USB installer KPs at AppleIntelCPUPowerManagement.kext), but I'll get there, eventually...

Share this post


Link to post
Share on other sites

Just joining the party - I just got a used Z620 (dual 2660v2) with a Quadro M4000 that I'm trying to get Sierra on. This isn't my first Hackintosh, but this machine makes it much more complicated than the forgiving GA-H77-DS3H board... So far no success (USB installer KPs at AppleIntelCPUPowerManagement.kext), but I'll get there, eventually...

Greetings aphid,

 

Just follow the Z820 instructions to the letter and you should be able to get it working on your machine.  You'll definitely get there eventually!!  Enjoy your Sierra on your "MacPro"!

 

I'm a total newbie for this but great at following instructions. I'm waiting (patiently) for a set of instructions for Sierra and hopefully High Sierra for the Dell Precision T7910 for my next Hackintosh!

Good luck!

Share this post


Link to post
Share on other sites

For anyone trying to get the native USB 3.0 ports to work, I would recommend buying this PCI-E card: Ableconn PUSB31P2A USB 3.1 Gen 2 (10 Gbps) 2-Port Type-A PCI Express (PCIe) x4 Host Adapter Card - Support Mac OS X 10.12 Sierra and Windows 10/8

Works like a charm OOB on the latest Sierra release. It costs around US $30.00, but you get the latest gen2 10gbps USB 3.1 connectivity. You can pick either Type-A, Type-C or Type-A and Type-C mixed depending on your needs.

Share this post


Link to post
Share on other sites
It happened twice.

 

 

*** Panic Report ***

panic(cpu 8 caller 0xffffff801f9ff2dd): Kernel trap at 0xffffff7fa035c592, type 0=divide error, registers:

CR0: 0x000000008001003b, CR2: 0x00007ff1b0c0e7c0, CR3: 0x0000000034604000, CR4: 0x00000000000626e0

RAX: 0x000000000000005d, RBX: 0xffffff813b6ea800, RCX: 0x0000000000000000, RDX: 0x0000000000000000

RSP: 0xffffff8e30963da0, RBP: 0xffffff8e30963e40, RSI: 0xffffff814e1bae00, RDI: 0xffffff814e1baf00

R8:  0x00000000045d2001, R9:  0x0000000000000000, R10: 0x000000000ec00000, R11: 0xffffff8e30716058

R12: 0x0000000000000000, R13: 0xffffff81238bc000, R14: 0x0000000000000000, R15: 0x000000000000005e

RFL: 0x0000000000010246, RIP: 0xffffff7fa035c592, CS:  0x0000000000000008, SS:  0x0000000000000010

Fault CR2: 0x00007ff1b0c0e7c0, Error code: 0x0000000000000000, Fault CPU: 0x8, PL: 1, VF: 0

 

Backtrace (CPU 8), Frame : Return Address

0xffffff8e30963a30 : 0xffffff801f8ea53c 

0xffffff8e30963ab0 : 0xffffff801f9ff2dd 

0xffffff8e30963c90 : 0xffffff801f89b593 

0xffffff8e30963cb0 : 0xffffff7fa035c592 

0xffffff8e30963e40 : 0xffffff7fa0354616 

0xffffff8e30963ee0 : 0xffffff801febc69f 

0xffffff8e30963f30 : 0xffffff801febaf01 

0xffffff8e30963f80 : 0xffffff801feba4e6 

0xffffff8e30963fb0 : 0xffffff801f8988f7 

      Kernel Extensions in backtrace:

         net.osx86.kexts.GenericUSBXHCI(1.2.11)[00000000-0000-0000-0000-000000000000]@0xffffff7fa034c000->0xffffff7fa0363fff

            dependency: com.apple.iokit.IOUSBFamily(900.4.1)[D403C49A-FBF5-35DE-9A92-F282BCF5E0E9]@0xffffff7fa02a0000

            dependency: com.apple.iokit.IOPCIFamily(2.9)[bD9FCDEF-30CB-3911-B247-EE51DD069C76]@0xffffff7fa004f000

 

BSD process name corresponding to current thread: kernel_task

Boot args: npci=0x2000 nvda_drv=1 kext-dev-mode=1 cpus=32 

 

Mac OS version:

16F73

 

Kernel version:

Darwin Kernel Version 16.6.0: Fri Apr 14 16:21:16 PDT 2017; root:xnu-3789.60.24~6/RELEASE_X86_64

Kernel UUID: FB2170A8-257D-3C64-B14D-BC06CC94E34C

Kernel slide:     0x000000001f600000

Kernel text base: 0xffffff801f800000

__HIB  text base: 0xffffff801f700000

System model name: MacPro6,1 (Mac-F60DEB81FF30ACF6)

 

System uptime in nanoseconds: 73204999775828

last loaded kext at 69053606066525: com.intel.kext.intelhaxm 6.2.1 (addr 0xffffff7fa2105000, size 172032)

last unloaded kext at 69273233630975: com.apple.driver.AppleXsanScheme 3 (addr 0xffffff7fa20fd000, size 32768)

loaded kexts:

com.intel.kext.intelhaxm 6.2.1

org.virtualbox.kext.VBoxNetAdp 5.1.22

org.virtualbox.kext.VBoxNetFlt 5.1.22

org.virtualbox.kext.VBoxUSB 5.1.22

org.virtualbox.kext.VBoxDrv 5.1.22

com.insanelymac.driver.AppleIntelE1000e 2.4.14

org.hwsensors.driver.GPUSensors 1394

net.osx86.kexts.GenericUSBXHCI 1.2.11

as.lvs1974.NvidiaGraphicsFixup 1.1.2

as.vit9696.Lilu 1.1.4

org.netkas.driver.FakeSMC 1758

com.rehabman.driver.USBInjectAll 0.5.17

com.apple.filesystems.afpfs 11.0.5

com.apple.nke.asp-tcp 8.0.1

com.apple.filesystems.autofs 3.0

com.apple.driver.AGPM 110.23.17

com.apple.driver.ApplePlatformEnabler 2.7.0d0

com.apple.driver.X86PlatformShim 1.0.0

com.apple.driver.pmtelemetry 1

com.apple.iokit.IOUserEthernet 1.0.1

com.apple.driver.AppleUpstreamUserClient 3.6.4

com.apple.driver.AppleMCCSControl 1.3.1

com.apple.iokit.IOBluetoothSerialManager 5.0.4f18

com.apple.GeForce 10.1.7

com.apple.Dont_Steal_Mac_OS_X 7.0.0

com.apple.driver.AppleOSXWatchdog 1

com.apple.driver.AppleHV 1

com.apple.driver.AppleLPC 3.1

com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0

com.apple.driver.AppleIntelMCEReporter 107

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0

com.apple.BootCache 40

com.apple.driver.AppleUSBLegacyHub 900.4.1

com.apple.filesystems.hfs.kext 366.50.19

com.apple.iokit.IOAHCIBlockStorage 295.20.1

com.apple.driver.AppleAHCIPort 326.60.1

com.apple.driver.AppleACPIButtons 5.0

com.apple.driver.AppleHPET 1.8

com.apple.driver.AppleRTC 2.0

com.apple.driver.AppleSMBIOS 2.1

com.apple.driver.AppleAPIC 1.7

com.apple.driver.AppleIntelCPUPowerManagementClient 219.0.0

com.apple.nke.applicationfirewall 172

com.apple.security.quarantine 3

com.apple.security.TMSafetyNet 8

com.apple.driver.AppleIntelCPUPowerManagement 219.0.0

com.apple.driver.AppleIntelCPUPowerManagementInfo 1

com.apple.security.SecureRemotePassword 1.0

com.apple.iokit.IOUSBUserClient 900.4.1

com.apple.kext.triggers 1.0

com.apple.iokit.IOSurface 159.7

com.apple.driver.AppleSMBusController 1.0.18d1

com.apple.iokit.IOSMBusFamily 1.1

com.apple.iokit.IOBluetoothFamily 5.0.4f18

com.apple.iokit.IOAcceleratorFamily2 311.13

com.apple.nvidia.driver.NVDAGK100Hal 10.1.7

com.apple.nvidia.driver.NVDAResman 10.1.7

com.apple.AppleGraphicsDeviceControl 3.14.47

com.apple.driver.AppleSSE 1.0

com.apple.iokit.IONDRVSupport 516.1

com.apple.iokit.IOUSBHIDDriver 900.4.1

com.apple.iokit.IOGraphicsFamily 515.3

com.apple.driver.Apple16X50Serial 3.2

com.apple.iokit.IOSerialFamily 11

com.apple.iokit.IOSlowAdaptiveClockingFamily 1.0.0

com.apple.driver.X86PlatformPlugin 9.9.9

com.apple.driver.AppleSMC 3.1.9

com.apple.driver.IOPlatformPluginFamily 6.0.0d8

com.apple.iokit.IOSCSIArchitectureModelFamily 394.50.1

com.apple.driver.usb.IOUSBHostHIDDevice 1.1

com.apple.driver.usb.networking 5.0.0

com.apple.driver.usb.AppleUSBHostCompositeDevice 1.1

com.apple.driver.AppleLegacyUSBAudio 2.9.5f19

com.apple.iokit.IOAudioFamily 205.15

com.apple.vecLib.kext 1.2.0

com.apple.driver.AppleUSBComposite 900.4.1

com.apple.driver.usb.AppleUSBHub 1.1

com.apple.driver.AppleUSBMergeNub 900.4.1

com.apple.driver.AppleUSBHostMergeProperties 1.1

com.apple.filesystems.hfs.encodings.kext 1

com.apple.driver.usb.AppleUSBHostPacketFilter 1.0

com.apple.iokit.IONetworkingFamily 3.2

com.apple.iokit.IOUSBFamily 900.4.1

com.apple.driver.usb.AppleUSBEHCIPCI 1.1

com.apple.driver.usb.AppleUSBEHCI 1.1

com.apple.iokit.IOAHCIFamily 288

com.apple.driver.AppleEFINVRAM 2.1

com.apple.driver.AppleEFIRuntime 2.1

com.apple.iokit.IOHIDFamily 2.0.0

com.apple.security.sandbox 300.0

com.apple.kext.AppleMatch 1.0.0d1

com.apple.driver.AppleKeyStore 2

com.apple.driver.AppleMobileFileIntegrity 1.0.5

com.apple.driver.AppleCredentialManager 1.0

com.apple.driver.KernelRelayHost 1

com.apple.iokit.IOUSBHostFamily 1.1

com.apple.driver.AppleBusPowerController 1.0

com.apple.driver.DiskImages 444.50.16

com.apple.iokit.IOStorageFamily 2.1

com.apple.iokit.IOReportFamily 31

com.apple.driver.AppleFDEKeyStore 28.30

com.apple.driver.AppleACPIPlatform 5.0

com.apple.iokit.IOPCIFamily 2.9

com.apple.iokit.IOACPIFamily 1.4

com.apple.kec.Libm 1

com.apple.kec.pthread 1

com.apple.kec.corecrypto 1.0

 

Network Service: Ethernet, Ethernet, en0

 

USB Device: USB 2.0 Bus

USB Device: Hub

USB Device: Basic Optical Mouse

USB Device: HP Basic USB Keyboard

Thunderbolt Bus: 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By amadeusex
      Hi there y' all.
       
      I'm selling my hp z820 with the specs listed below since i accidentally bought me another one (that's what i told to my wife anyway).
       
      The machine runs flawlessly High High Sierra 10.13.6 and also has Win7 pro and Win10 pro licences tied to the machine.
       
      The machine is in Athens Greece
       
      I'm asking for 1000 euros shipped within the European Union.
       
            Features     • Make: HP • Modell: Workstation Z820   • Processor: 2x Intel XEON Quad-Core E5-2670 • Chipset: Intel C602    • Memory: 64 GB ECC RAM • Sound: Realtek ALC262   • Graphics Card: nVidia Quadro K600   • SAS - Controller: LSI SAS2308 with RAID (0, 1, 5, 10) • SSD - 256 GB • DVD RW   • 2x Ethernet-LAN (RJ-45): 2 (Dual Gigabit - 1000Mbit/s)   • FireWire: 2x (1x Front + 1x Back) • USB 2.0: 5x (1x Front + 4x Back) • USB 3.0: 4x (2x Front + 2x Back)   • PS/2 • serial RS232 • Line-In • Line-Out • Microphone • FireWire (6polig)    • PSU: 1125 Watt    • (WxHxD): 203mm x 444mm x 525mm • Weight: 21,1kg   The machine is configured to also run MacOS 10.12.6 High Sierra without any hiccups and complete working power management.   Geekbench 4 64-bit  MacOs Results
      https://browser.geekbench.com/v4/cpu/12062123
      Geekbench 4 64-bit  Win10 Results
      https://browser.geekbench.com/v4/cpu/11972736
      The pictured drive trays are not included - the original placeholders will be mounted!


    • By Angelo_
      Just recently installed Mojave on my yoga 730(i5-8250u, 8gb of ram and 1080p 13.3" touchscreen) and got many features working, now the only issues are that my igpu is shown as only 7mb(and not metal capable, not sure whether it is or not) even tho I should've changed it from 5917 to 5916 (added both EFI folder and send me), the screen is shown as a 30.5" in system information and the cpu even tho I extracted the ssdt for it with ssdtPRGen.sh and appleintelinfo.kext to get low frequency info (ssdt was done with info 15,400,1600,3400 so it should go between 16-3400mhz and down to 400 in idle), idk what is wrong with my installation, can you guys help me or linke me something to fix those issues?
       
      Ps thunderbolt shows as no device found, is it regular for hackintoshes to be that way or do I need something for that too? Laptop has 2 tb3 ports as x4 pcie 3
      EFI.zip
      Send me Angeloss-MacBook-Pro.zip
    • By bilbo
      THE GREAT GUIDE
      HIGH SIERRA + Z820

       
      ********
      10/07/2018
       
       
      *********************************************************************************
      ————————————————————————————————————————
      ————————————————————————————————————————
       
      (from El Capitan's guide)
      (from Sierra's guide)
       
      Introduction:
       
      Hi everybody. 
      Again, a new guide version, updated to High Sierra. I hope it will be useful for you all. This time, the update is easy. Basically, the 100% of Sierra’s guide is still valid for High Sierra. The guide has been updated to update links, kexts versions … etc, and some parts try to be more clear. Just there are some important topic to keep in mind:
       
      1. What's new?.
      There is a new and absolute important setting to install High Sierra. We have to activate “legacy ACPI cpu tables” in Advanced Section, in BIOS. Without this option enabled, we will get a KP. 
      This option changes completely the structure of the SSDT needed for PM. We have to get rid old SSDT versions, if you extracted them with this option disabled. And all SSDT generated by ssdtPRGen, too. And, if your DSDT has the “SSDT-1-CpuDef” code injected, (following my previous guides, to skip "No ACPI Processor declarations found in the DSDT!" error, (see PM section) ) you will have to delete that part, because the DSDT will cause a KP. A better method is described in this guide. No need of add strange code into DSDT.

       
      2.Can I use my old files from Sierra´s EFI folder?
      The most important, yes. You can keep your config.plist and your DSDT(see point N.1) … saving tons of time. You have to use the new drivers64Uefi files installed by new clover version, and update the kexts versions of main kexts. The specific kexts for our dear machine, USB3, Astek driver, remains in same version.Of course, I provide of all links and files (into my stuff folder) in this guide.
       
      3. So, do I Need repeat again every step of this guide?.
      If you comes from Sierra´s guide, no. After 1stboot and graphics divers install, you can use your previous files (see point 1.) reboot and jump directly to PM section. 
      For new users, Yes, sure.

      4. Consider any part of this guide open to discuss.
      If you see something wrong, or which could be improved, please, just say it, and I’ll fix it. English is not my native language. If you can’t understand some step, or something could be best written, please, just say it and I’ll fix it too
       

      FOR 26x7 and 26x3 USERS!!!. Finally, there a Fix to this models. It´s under test, but I think it should work. Check out FIRST the last section of this guide.
       
      5. And please, (this is for "anonymous" users) don't PM me with personalquestions. No need for that.Any question can be answered openly.
       
       
      Ok, let’s go.
       
       
       
      PART I
       
      1-BIOS SETUP
       
       
      This guide is for UEFI systems. This is not important to follow this guide except in Clover installation section. Keep in mind it to adapt some settings if you need use legacy-bios mode. 
       
      If you don’t need any special option, and you have been playing with options, reset the bios to default settings.Later, you will be able to change and test, if you need some specific option. The next section describe the essential options. 
       
      6. The main BIOS options are:
       
      In storage: 
      set ACHI mode (IMPORTANT).
       

       
       
      Set boot order. UEFI first, (for me), USB first and HD second. 
       


       
      Security : 
      Device Security: I like disable unused devices (scu controller and serial port). Optional.



       
      Disable Vt-d: Disabled. IMPORTANT. 
       

       

       
      Secure boot. Disabled (...to boot with non signed OS). 
      I use UEFI boot, but I keep legacy support active. This is optional.
       

       
       
      In Power :
      Set Runtimepower management to Enabled. This option will allow Power Management later. About the rest of options, I’m not sure of the impact in performance. Set them by default by the moment. Not important for the guide. Only remeber for further tests that with Pcie Performance Mode enabled, power boost is disabled. Idle Power Savings manage sleep policies.


       
       
      In Advanced:
       
      Set PXE, Storage and Video to EFI. (for me) , or legacy, as your want. If you have a graphic card non EFI-compliant, you can set video in Legacy, keeping an UEFI boot.
      Don’t forget set thunderbolt policy in Legacy mode.
       

       

       
      And Now, the essential setting for High Sierra: 
       
      -Enable “Legacy ACPI CPU Tables”
       


       

       

      _________________________________________________________________________________________________________________________________
       
       
       
      PART II:
       
      INSTALLATION
       
      7- MEDIA CREATION
       
      (This guide assume you have a MacOs running. I have no idea how do it on PC)
       
      -Important: Download HighSierra dmg only from Apple.Don´t use suspicious dmgs or Isos. It’s not longer available to search in Apple Store, since Mojave release. Go to this link, and click in “Get macOS high Sierra” (at mid of the page). It will open the apple store download link. The dmg is downloaded in /Applications folder. Let the file in Applications folder. (and keep one compressed copy for future attempts)

       
      -Format one USB stick with common settings:
       


       
      Go to erase tab, select GUID partition table in options, and Mac Os Extended (Journaled) as Filesystem. Name the partition as “USB”. Ok to Apply.   
      On a terminal window, type (copy and paste) :  
      sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction  
      Enter and type your admin password. It will take 10-15 minutes. (When it finish, you’ll see the prompt again)  
      8. INSTALLING CLOVER.
       
      -Download Clover from here. Version used to make this guide: Clover_v2.4k_r4658.
      -Download Clover Configurator from here. It makes easier edit config.plist file and we can use a lot of clover features easily. Now there is a “global edition”
      -Download plisteditor pro demo for edit info.plist files.
      -Download my High Sierra stuff folder. (at the end of the guide)
      -Additional tools: One tool for install kexts, fix permission and rebuild cache. I use Kext helper from rampage’s dmg, although I need always force quit. I don´t like the rest of utilities. This is a personal option. Also you can download  EFI mounter (from download sections of this site). CloverConfigurator mounts EFI too, but maybe with this utility is easier.
       
      -Install Clover in the USB. On first screen, don’t forget change the install location in order to do not install on your Internal HD. Select your USB stick.
      Click on Customize. Choose “Install for UEFI booting only” and “Install Clover in the ESP” as main options (if your system is UEFI-based) This is optional: choose your favorite Theme. In Drivers64UEFI select: Now is longer section. It´s only because is more exact showing the drivers installed. We have to keep selected the default options and add the same additional drivers. Keep in mind two important things:                   -There is a new driver, APFS driver, for the “new” filesystem. This driver is now essential, in order to allow clover “see” HDs formatted with this FS. It´s activated by default. 
                       -The OSxAptiopnFix2Drv has a new version, v3.
                ... The conclusion of this long explanation, is that we have to add to the default selection of drivers: 
       
                                - EmuVariableUefi-64
                               - OsxAptionFix3Drv
       

      Let the rest of option unselected and Click on Install.
       
       
      9- CONFIGURE CLOVER

      When clover finishes, it will mount EFI partition. Time to modify it. You’ll find all necessary files in my folder. There are three things to modify: config.plist, drivers, and kexts
       
      9.1 Config.plist
       
      The default config.plist is not useful for us. Replace it by mine (folder n.2)
      But take a look to options (with clover configurator) to understand my options in order to be able to adapt them for your specs or your preferences. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options. 
       
           Acpi section.
          All fixes in ACPI section has been removed except some minor fixes in 2 subsection, smart ups option, etc. SmartUps it’s not important now, but it will be later. So I prefer activate this option. 
          The most important, The rename usb devices patches are included. 
       
          

          Boot section
          Bootflags needed are only -v and npci=0x2000. Of course -v is optional only to see the boot process. You can deactivate it when you finish.
       
          
       
          Any option activated in Boot Graphics/ Cpu/Device/Disable driver
       
          Gui options. These are only personal preferences.
       
          
       
          Graphics. AnyGraphic injection annd any option activated. At least, no needed for my 1080ti card. Check it out for your card video.
       
          
       
          An essential section. Kernels Patches needed.
       
          
       
          RT Variables. BooterConfig, and Csr to deactivate security policy in Sierra. The info values are taken from smbios.
       
          
       
          SMBIOS.  Set it to Mac Pro 6,1. 
       
          
       
                    IMPORTANT—>press “generate new” repeatedly to get one random fresh serial number
       
          System parameter: 
       
          
       
       
      9.2 -Drivers64UEFI folder.
       
      As usual, delete VBoxHfs-64driver and replace it by HFSPlus.efi. (from my folder).

           
       
       
      9.3 Kexts folder:
       
      Add my Kexts from my stuff to /EFI/CLOVER/Kexts/10.13
       
      They are:

           
       
      These are the versions Updated since Sierra´s guide.
       
      FakeSMC.kext. If you remember, I have some unexpected KP due to fake smc sensors. Well, I have searched a bit about this, and testing. The main topic is keep the fake smc version and sensors kext of same version or branch. There are several branchs developing              different versions (slice, rehabman, kozleck, etc), after test, and test, I think the most stables and those which gives me best sensor readings is kozeck version. I attach the v1440 from kozleck. In this step I only use FakeSMC kext, withput sensors kexts. Anyway, if you have a better version, use it. Just, don´t forget no use the sensors Kexts.   
      VoodooTSCync.kext, to avoid boot with -x (from rampagdev, dual cpu dmg). You’ll find several versions into my folder.I haven’t noticed any change using the generic or the specific version. I think that is not important for our platform.                  The customize method is:

       

       
               Anyway, I provided the generic version and customized versions for every cpu.

       
      IntelMausiEthernet.kext . Kext for the ethernet card from rehabman. (2018-0424version). It will allow have internet connection on first boot.  AppleIntelE1000e.kext. Kext for ethernet card from here (2017-10-18 version). (Change of  server if you have problems downloading) <<<< update. Use this better than IntelMausiEthernet.kext
       
      UsbInjectall, for USB2 from rehabman( 2018-0822version)  
      And add to /EFI/CLOVER/Kexts/others
       
       

       
       
      Lilu kext (from here, 1.2.7version)  
      WhateverGreen.kext (from here, 1.2.2 version) old NvidiaGraphicsFixup proyect has been integrated into this proyect. It's useful for nvidia and amd graphics cards  
      This couple of kexts avoid black screen booting with 6,1 smbios. Is quite important keep in mind the versions of these kexts keeping the right versions among this kexts. Prior to update some of them, you have to check in original websites if it's is compatible with the rest. These versions are ready to work with 10.13.6. 
       
      Thats all. We have our usb installer ready. Copy in a folder all stuff necessary to repeat the process and copy it to the USB stick. You will have it available after first boot.
       
      Reboot from the USB stick and install High Sierra. 

       
      10- INSTALLATION

       
      Some advices:
           -Use only USB2 ports, preferably the front USB2 port.
           -Don’t use USB hubs, or cable extenders… (personal issues)
           -Unplug any other usb device
           -Be sure that you have plugged your internal sata drive to one of the two internal achi sata controller.
       

       
           -The boot process may be slow, (and with terrible and apocalyptic errors). Be patient
           -Maybe, the boot stucks with the error “consideredRebuildKernel …. blabla”. Just reboot again.
           -If you have two monitors, shutdown one can help with graphical errors.
           -Plug your graphic card in PCI Slot 2.
           -For inexperienced users: On first screen, go to disk utility and erase the Volume. (APFS and GPT). Quit the utility and return to first screen. Choose Install.
           -The process is splitted in two steps. The first step promises take only 4 or 5minutes … and now, it’s true!!!. It will take4 or 5 minutes(with a SSD).
           -After this first reboot, in clover boot screen, you will see more partitions than expected. APFS file system manage more partitions in a more complex way (physical layer, logical layer… bla, bla). Select  the new internal HighSierra boot installer partition, not the usb installer. It will finish the  process. This step, takes 10-15min aprox (using a SSD).
       
      Note.I had some unexpected reboot in this step. Only re-trying if you have it also.
       
      -To boot again after installation, keep booting from USB , ant then choose internal HD as clover boot screen.
       
       
      ---------------------------------------------------------------------------------------------------------------------------------
       
       
       
      PART III:
       
      FIRST BOOT
       
      11. Optional updates.
      Finally, we are on High Sierra's Dektop. The Mac os Version is 17G65. In the date of this guide (oct/2018) is the last version. (there is an optional update only for real macbook laptops). For future security updates, this is the moment to update. Set up the internet options and update the system, but remember check if the Lilu and whatevergreen kexts are compatible or if you need use a new version, or you will geta KP or a black screen on boot. Update using the update app, reboot, and wait for the update installation.
       
      12- Install Clover.
      On first reboot, install clover again on HDD, repeating same process and same options than with the USB installer, but keep in mind you have to add some options on clover’s screen install:
       


       

           -Install RC scripts on target volume
           -Optional RC scripts
           -Install Clover Preference Panel.

      …and install clovermanager.app. This is optional but it’s the best way to manage the themes and find a good theme. I provide of one nice High Sierra Theme and the Bootcamp theme. Of course, left this for later. 
       
      Install clover and add same files used on the USB: config.plist , hfsplus driver and kexts. Reboot. You can now extract the USB installer and reboot from the internal HDD.
      After boot, go to clover preference panel and set it to auto mount EFI partition. It will be useful along this process. Disable this when you finish and you get stable your system.
       
       
    • By Haive_Music
      Hey guys,
       
      I'm really hoping someone has the experience and ability to help me iron out the last remaining issue on my build.  
       
      The motherboard is: Gigabyte Z370 Aorus Gaming 7 and I'm running a Alpine Ridge thunderbolt card (Revision 2).   I've gotten everything working for the most part with the exception of Thunderbolt hotplug.  This is the last piece of the puzzle.  I've tried so many different DSDT/SSDT's, cable plugged in, and unplugged, without any luck at all. 
      I've managed to get my Focusrite Clarett 8Pre Thunderbolt working and it's showing up under the PCI section.  It works great, until I shut the device off and turn it back on.  I'd really like to try to get this hotplug issue sorted out, but I've had absolutely no luck so far.
       
      I've managed to get the Alpine Ridge NHI and USB controllers showing up in the PCI section too, but for some reason, the USB lists a bunch of ',,,,,,,,' after the name. 
       
       
      I'll be the first to admit - I don't really know a whole lot about what I'm doing with this stuff, but I've attached relevant files in hopes someone more experienced and knowledable can help me get this working.  
       
      Thanks guys!
      config.plist
      DSDT.aml
      John’s iMac.iojones

      SSDT-TB3.aml
    • By ivoryblade
      Hello! My internal SSD lifetime is running out so I'm thinking how to upgrade it. I don't want to replace it with slow Sata SSD so I want to buy OWCMercury Helios and install new nvme fast ssd, but I won't be able to boot from it using standard boot loader.... Is it possible to boot nvme ssd using Clover on real iMac?
×