Jump to content
bilbo

[Guide] Z820 - El Capitan The great guide (Sucess)

198 posts in this topic

Recommended Posts

Hi, I've installed OSX 10.11.6 El capitan in my HP Z400, and I have two problems: Audio and Firewire.

 

The most important problem for me it's the firewire connection, because in my work I used a firewire sound card.

My computer can't detect firewire device, by it gives energy to the device.

 

Do you think I could use the same firewire fix that you used in this guide to fix my firewire?

 

This is my system specifications:

 

HP Z400 hexacore x5650

12 GB RAM

BIOS version 3,57

OS X El Capitan 10.11.6 (15G31)

Nvidia Quadro NVS 300

Firewire built-in connection and PCI card.

SSD Samsung 850 Evo 500gb

Share this post


Link to post
Share on other sites
Advertisement

Firewire problem can be fixed editing DSDT, it is a HPET conflict.

For audio you can use Voodo

 

Yes, I tried to fix my DSDT with this, but it didn't work:

Device (HUB)
            {
                Name (_ADR, 0x001E0000)  // _ADR: Address
                Name (_PRW, Package (0x02)  // _PRW: Power Resources for Wake
                {
                    0x0B, 
                    0x04
                })
                Method (_S4D, 0, NotSerialized)  // _S4D: S4 Device State
                {
                    Return (0x03)
                }

                Method (_S5D, 0, NotSerialized)
                {
                    Return (0x03)
                }

                Device (FRWR)
                {
                    Name (_ADR, 0x00090000)  // _ADR: Address
                    Name (_GPE, 0x1A)  // _GPE: General Purpose Events
                    Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                    {
                        Store (Package (0x02)
                            {
                                "fwhub", 
                                Buffer (0x04)
                                {
                                     0x11, 0x58, 0xc1, 0x11                         
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }

                    Name (_SUN, 0x00000003)  // _SUN: Slot User Number
                }

            }
Edited by Allan
Code tag - Added

Share this post


Link to post
Share on other sites

Hi, thank you!

 

I was trying to work and to patch other DSDT (it seems more similar to my specifications), but firewire stills failing.

 

I saw this code in the DSDT, and I want to know my firewire address to change it. Do you know how can I do it?

// shdw - BEG : FRWR Device injection (was not there in original DSDT), as per info @ https://www.root86.com/topic/3193-firewire-asus-m3a79-t/
                Device (FRWR)  // shdw - lspci output : 37:05.0 FireWire (IEEE 1394) [0c00]: Agere Systems FW322/323 [11c1:5811] (rev 70)
                {
                    Name (_ADR, 0x37050000)  // My firewire address reported by 'lspci -n'
                    Name (_GPE, 0x1A)

                    Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
                    {
                        Store (Package (0x06)
                        {
                            "built-in",
                            Buffer (One)
                            {
                                 0x01
                            },

                            "fwhub",
                            Buffer (0x04)
                            {
                                0x00, 0x00, 0x00, 0x00
                            },

                            "device-id",
                            Buffer (0x04)
                            {
                                0x11, 0x58, 0x00, 0x00  // Board device ID is [5811]
                            }
                        }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                     }

Share this post


Link to post
Share on other sites
Orignal Code Extracted with ACPI Scope under windows 7   


Device(HUB)
            {
                Name(_ADR, 0x001E0000)
                Name(_PRW, Package(0x02){0x0B, 0x04})
                Method(_S4D, 0x00, NotSerialized)
                {
                    Return(0x03)
                }
                Method(_S5D, 0x00, NotSerialized)
                {
                    Return(0x03)
                }
                Method(_PRT, 0x00, NotSerialized)
                {
                    If (LEqual(\PICM, Zero))
                    {
                        Return(Package(0x05)
                        {
                            Package(0x04){0x0004FFFF, 0x00, \_SB.PCI0.LNKE, 0x00},
                            Package(0x04){0x0004FFFF, 0x01, \_SB.PCI0.LNKF, 0x00},
                            Package(0x04){0x0004FFFF, 0x02, \_SB.PCI0.LNKG, 0x00},
                            Package(0x04){0x0004FFFF, 0x03, \_SB.PCI0.LNKH, 0x00},
                            Package(0x04){0x0009FFFF, 0x00, \_SB.PCI0.LNKH, 0x00}
                        })
                    }
                    Else
                    {
                        Return(Package(0x05)
                        {
                            Package(0x04){0x0004FFFF, 0x00, 0x00, 0x14},
                            Package(0x04){0x0004FFFF, 0x01, 0x00, 0x15},
                            Package(0x04){0x0004FFFF, 0x02, 0x00, 0x16},
                            Package(0x04){0x0004FFFF, 0x03, 0x00, 0x17},
                            Package(0x04){0x0009FFFF, 0x00, 0x00, 0x17}
                        })
                    }
                }
                Device(SLT6)
                {
                    Name(_ADR, 0x00040000)
                    Name(_SUN, 0x06)
                }
                Device(FIRE)
                {
                    Name(_ADR, 0x00090000)
                }
                Method(_S3D, 0x00, NotSerialized)
                {
                    Return(0x03)
                }
            }

post-555472-0-39556700-1491859727_thumb.jpg

post-555472-0-54319600-1491859860_thumb.gif

Edited by Allan
Code tag - Added

Share this post


Link to post
Share on other sites

Hey all.  Having issues as well installing 10.12.4 on Z820.  Stuck at steps VII.E/F.  Audio is not being recognized.  USB is funky (USB3 ports detected as USB2 and USB2 ports are no worky).  I'm ok if USB2 ports don't work (I have a spare USB3 hub) but not having full speed USB3 kinda sucks.  LSI-2038 causes immediate reboot on kext help b7 install.  Won't boot on it's own afterwards with several different errors (sometimes a crash in the Astek drivers, othertimes elsewhere).  Booting into Recovery Mode, I can delete AstekFusion*.kext from /S/L/E and then rebuild kextcache.  And that gets me booting again.  Is there something I'm doing obviously wrong in DSDT or config.plist?

 

Also, wouldn't boot with nvda_drv=1 though I have latest nVidia Web Driver & CUDA Driver installed.  IPIC, TIMR, RTC had different IRQ numbers (2, 0, 8, respectively) but deleted them anyways.  Fix HPET also causes random boot issues and compilation issues.

 

Clover 4049

Clover Configurator 4.41.1

 

HP Z820

BIOS v3.91 (upgraded from 3.63)

BIOS Boot Block Date 12/28/2011

2x E5-2660 v1

128GB RAM

nVidia Quadro K2000

Macintosh HD is a SanDisk 120GB SSD (SDSSDA120G)

LSI-2038 is connected to 3x 5TB Seagate HDD configured as a single ~15TB RAID 0 device

DSDT copy.aml.zip

DSDT.aml.zip

config.plist.zip

post-324279-0-34983800-1491978737_thumb.png

post-324279-0-99112100-1491978745_thumb.png

post-324279-0-51202000-1491978755_thumb.png

Share this post


Link to post
Share on other sites

Would you mind sharing the items below?  Thanks.

 

BIOS Version

Clover version

DSDT

SSDT

config.plist

 

 

Thanks again!

 

Thanks for this fantastic guide. I was able to successfully install, (and update), Sierra 10.12.4 on my dual e5-2690 z620.
 
Keep up the good work!

about_this_mac.png

Share this post


Link to post
Share on other sites

Sorry, I missed this reply and I've already dumped the OS and cloned back to nix, (was only on OSX to export some old final cut projects). The BIOS ver is j61 v03.91, the boot block date is 12/28/2011 and the FW version is 7.1.21.1134.  I don't have the DSDT SSDT or config.plist files, but I can tell you that I ran it with the latest clover and clover configurator as of Friday, 21 April 2017. I didn't even bother with the AppleHDA and just used VoodooHDA as I knew I was going back to linux today, (need the machine for work tomorrow).
 
The thing ran amazingly well and I was able to export my projects and media from an old sata disk in no time.
 
Here it is doing work:

z620_macos_cpu_davinci_001.png

z620_macos_cpu_davinci_002.png

Share this post


Link to post
Share on other sites

Oh My GOOOOD :) That's great man : i think you have worked on it during months !!

Installed Sierra under my Z620 : got to the Part 4.....rebooted the beast...and getting the login on my screen, but no USB :'(

 

Should be a little thing....but what ?

Any help please ???

 

........


hum after trying all of the USB....just one is working....

and seems that my EFI partition has vanished !!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites

Good to hear that. We need gather as info as possible about Sierra and update the guide. It seems it needs some effort again. I don´t plain update to sierra until last and stable version.

 

Jimmy, do you use anye raid card?

Share this post


Link to post
Share on other sites

Tieubaubau , unfortunately, those kexts come from old drivers from an outdated raid card with the same chipset than LSI2308. No longer version.

 

Sierra changes some game rules and it seems is the cause of the panic. We would need some developer expert to take a look and see if there is some hope :(

Share this post


Link to post
Share on other sites

Did you deviate from the guide at all? Are you using the built in raid?

Also, do mind sharing your?

 

BIOS Version

Clover version

DSDT

SSDT

config.plist

 

 

Thanks

Share this post


Link to post
Share on other sites

In general, I followed the guide, especially instructions about DSDT/SSDT. I hope it is obvious from the picture that I did it on Sierra, not El Capitan. I don't use raid, only a single Samsung SSD for target install and HDD instead of USB stick.   


BIOS version = 2.15.1229
Clover version = 2.4k rev 4077

DSDT/SSDT/config.plist in the attached file


The system is very stable, everything works great (all software I use, for example: LightWave 3D, Cinema 4D, RealFlow, FinalCut Pro, LogicPro X ...). As far as I can see the only glitch is when the system resumes from sleep animations in GUI are a bit laggy - probably this goes to NVidia driver. It would be nice if someone tests my configurations (in the attached file) since I think there might be a room for improvements. What I miss the most, are working USB3 ports. As I can see, only two USB2 ports are working.  


Regarding ssdt.aml, first I created SSDT for my CPU E5-2670v1. Power management seemed to work and power consumption of the system was 140W (Wattmeter is always pluged-in), but Geekbench (Multicore Score around 22k) and my renders were too slow compared to Win7. HWMonitor was showing the lowest frequency of CPU was 2.2 GHz. I was playing with the ssdtPRGen.sh script further and eventually it worked out (not sure though) with E5-2670v2 setting. 


ssdtPRGen.sh script parameters that I succeeded:

sh ssdtPRGen.sh -cpus 2 -target 0 -l 32 -c 3


After that, the lowest frequency was correct (1.2 GHz) and full performance was regained (renders as expected, i.e. 3-5% faster than Win7, Geekbench showed almost 39k). That's it. 


Tests and reports by other users are more than welcome. 


Big thanks to author's tutorial, I wouldn't manage without it. 


I made at least 400 reboots with previous OS X versions in the past but power management never worked that well.  




 

clover.zip

Share this post


Link to post
Share on other sites

Happy for read all that good news.

 

 

 

 

 

 

I made at least 400 reboots with previous OS X versions in the past but power management never worked that well.  




 

 

200 reboots was my average by month :D . Even I was afraid of break the PC.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By amadeusex
      Hi there y' all.
       
      I'm selling my hp z820 with the specs listed below since i accidentally bought me another one (that's what i told to my wife anyway).
       
      The machine runs flawlessly High High Sierra 10.13.6 and also has Win7 pro and Win10 pro licences tied to the machine.
       
      The machine is in Athens Greece
       
      I'm asking for 850 euros shipped within the European Union.
       
            Features     • Make: HP • Modell: Workstation Z820   • Processor: 2x Intel XEON Quad-Core E5-2670 • Chipset: Intel C602    • Memory: 64 GB ECC RAM • Sound: Realtek ALC262   • Graphics Card: nVidia Quadro K600   • SAS - Controller: LSI SAS2308 with RAID (0, 1, 5, 10) • SSD - 256 GB • DVD RW   • 2x Ethernet-LAN (RJ-45): 2 (Dual Gigabit - 1000Mbit/s)   • FireWire: 2x (1x Front + 1x Back) • USB 2.0: 5x (1x Front + 4x Back) • USB 3.0: 4x (2x Front + 2x Back)   • PS/2 • serial RS232 • Line-In • Line-Out • Microphone • FireWire (6polig)    • PSU: 1125 Watt    • (WxHxD): 203mm x 444mm x 525mm • Weight: 21,1kg   The machine is configured to also run MacOS 10.12.6 High Sierra without any hiccups and complete working power management.   Geekbench 4 64-bit  MacOs Results
      https://browser.geekbench.com/v4/cpu/12062123
      Geekbench 4 64-bit  Win10 Results
      https://browser.geekbench.com/v4/cpu/11972736
      The pictured drive trays are not included - the original placeholders will be mounted!


    • By Angelo_
      Just recently installed Mojave on my yoga 730(i5-8250u, 8gb of ram and 1080p 13.3" touchscreen) and got many features working, now the only issues are that my igpu is shown as only 7mb(and not metal capable, not sure whether it is or not) even tho I should've changed it from 5917 to 5916 (added both EFI folder and send me), the screen is shown as a 30.5" in system information and the cpu even tho I extracted the ssdt for it with ssdtPRGen.sh and appleintelinfo.kext to get low frequency info (ssdt was done with info 15,400,1600,3400 so it should go between 16-3400mhz and down to 400 in idle), idk what is wrong with my installation, can you guys help me or linke me something to fix those issues?
       
      Ps thunderbolt shows as no device found, is it regular for hackintoshes to be that way or do I need something for that too? Laptop has 2 tb3 ports as x4 pcie 3
      EFI.zip
      Send me Angeloss-MacBook-Pro.zip
    • By bilbo
      THE GREAT GUIDE
      HIGH SIERRA + Z820

       
      ********
      10/07/2018
       
       
      *********************************************************************************
      ————————————————————————————————————————
      ————————————————————————————————————————
       
      (from El Capitan's guide)
      (from Sierra's guide)
       
      Introduction:
       
      Hi everybody. 
      Again, a new guide version, updated to High Sierra. I hope it will be useful for you all. This time, the update is easy. Basically, the 100% of Sierra’s guide is still valid for High Sierra. The guide has been updated to update links, kexts versions … etc, and some parts try to be more clear. Just there are some important topic to keep in mind:
       
      1. What's new?.
      There is a new and absolute important setting to install High Sierra. We have to activate “legacy ACPI cpu tables” in Advanced Section, in BIOS. Without this option enabled, we will get a KP. 
      This option changes completely the structure of the SSDT needed for PM. We have to get rid old SSDT versions, if you extracted them with this option disabled. And all SSDT generated by ssdtPRGen, too. And, if your DSDT has the “SSDT-1-CpuDef” code injected, (following my previous guides, to skip "No ACPI Processor declarations found in the DSDT!" error, (see PM section) ) you will have to delete that part, because the DSDT will cause a KP. A better method is described in this guide. No need of add strange code into DSDT.

       
      2.Can I use my old files from Sierra´s EFI folder?
      The most important, yes. You can keep your config.plist and your DSDT(see point N.1) … saving tons of time. You have to use the new drivers64Uefi files installed by new clover version, and update the kexts versions of main kexts. The specific kexts for our dear machine, USB3, Astek driver, remains in same version.Of course, I provide of all links and files (into my stuff folder) in this guide.
       
      3. So, do I Need repeat again every step of this guide?.
      If you comes from Sierra´s guide, no. After 1stboot and graphics divers install, you can use your previous files (see point 1.) reboot and jump directly to PM section. 
      For new users, Yes, sure.

      4. Consider any part of this guide open to discuss.
      If you see something wrong, or which could be improved, please, just say it, and I’ll fix it. English is not my native language. If you can’t understand some step, or something could be best written, please, just say it and I’ll fix it too
       

      FOR 26x7 and 26x3 USERS!!!. Finally, there a Fix to this models. It´s under test, but I think it should work. Check out FIRST the last section of this guide.
       
      5. And please, (this is for "anonymous" users) don't PM me with personalquestions. No need for that.Any question can be answered openly.
       
       
      Ok, let’s go.
       
       
       
      PART I
       
      1-BIOS SETUP
       
       
      This guide is for UEFI systems. This is not important to follow this guide except in Clover installation section. Keep in mind it to adapt some settings if you need use legacy-bios mode. 
       
      If you don’t need any special option, and you have been playing with options, reset the bios to default settings.Later, you will be able to change and test, if you need some specific option. The next section describe the essential options. 
       
      6. The main BIOS options are:
       
      In storage: 
      set ACHI mode (IMPORTANT).
       

       
       
      Set boot order. UEFI first, (for me), USB first and HD second. 
       


       
      Security : 
      Device Security: I like disable unused devices (scu controller and serial port). Optional.



       
      Disable Vt-d: Disabled. IMPORTANT. 
       

       

       
      Secure boot. Disabled (...to boot with non signed OS). 
      I use UEFI boot, but I keep legacy support active. This is optional.
       

       
       
      In Power :
      Set Runtimepower management to Enabled. This option will allow Power Management later. About the rest of options, I’m not sure of the impact in performance. Set them by default by the moment. Not important for the guide. Only remeber for further tests that with Pcie Performance Mode enabled, power boost is disabled. Idle Power Savings manage sleep policies.


       
       
      In Advanced:
       
      Set PXE, Storage and Video to EFI. (for me) , or legacy, as your want. If you have a graphic card non EFI-compliant, you can set video in Legacy, keeping an UEFI boot.
      Don’t forget set thunderbolt policy in Legacy mode.
       

       

       
      And Now, the essential setting for High Sierra: 
       
      -Enable “Legacy ACPI CPU Tables”
       


       

       

      _________________________________________________________________________________________________________________________________
       
       
       
      PART II:
       
      INSTALLATION
       
      7- MEDIA CREATION
       
      (This guide assume you have a MacOs running. I have no idea how do it on PC)
       
      -Important: Download HighSierra dmg only from Apple.Don´t use suspicious dmgs or Isos. It’s not longer available to search in Apple Store, since Mojave release. Go to this link, and click in “Get macOS high Sierra” (at mid of the page). It will open the apple store download link. The dmg is downloaded in /Applications folder. Let the file in Applications folder. (and keep one compressed copy for future attempts)

       
      -Format one USB stick with common settings:
       


       
      Go to erase tab, select GUID partition table in options, and Mac Os Extended (Journaled) as Filesystem. Name the partition as “USB”. Ok to Apply.   
      On a terminal window, type (copy and paste) :  
      sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction  
      Enter and type your admin password. It will take 10-15 minutes. (When it finish, you’ll see the prompt again)  
      8. INSTALLING CLOVER.
       
      -Download Clover from here. Version used to make this guide: Clover_v2.4k_r4658.
      -Download Clover Configurator from here. It makes easier edit config.plist file and we can use a lot of clover features easily. Now there is a “global edition”
      -Download plisteditor pro demo for edit info.plist files.
      -Download my High Sierra stuff folder. (at the end of the guide)
      -Additional tools: One tool for install kexts, fix permission and rebuild cache. I use Kext helper from rampage’s dmg, although I need always force quit. I don´t like the rest of utilities. This is a personal option. Also you can download  EFI mounter (from download sections of this site). CloverConfigurator mounts EFI too, but maybe with this utility is easier.
       
      -Install Clover in the USB. On first screen, don’t forget change the install location in order to do not install on your Internal HD. Select your USB stick.
      Click on Customize. Choose “Install for UEFI booting only” and “Install Clover in the ESP” as main options (if your system is UEFI-based) This is optional: choose your favorite Theme. In Drivers64UEFI select: Now is longer section. It´s only because is more exact showing the drivers installed. We have to keep selected the default options and add the same additional drivers. Keep in mind two important things:                   -There is a new driver, APFS driver, for the “new” filesystem. This driver is now essential, in order to allow clover “see” HDs formatted with this FS. It´s activated by default. 
                       -The OSxAptiopnFix2Drv has a new version, v3.
                ... The conclusion of this long explanation, is that we have to add to the default selection of drivers: 
       
                                - EmuVariableUefi-64
                               - OsxAptionFix3Drv
       

      Let the rest of option unselected and Click on Install.
       
       
      9- CONFIGURE CLOVER

      When clover finishes, it will mount EFI partition. Time to modify it. You’ll find all necessary files in my folder. There are three things to modify: config.plist, drivers, and kexts
       
      9.1 Config.plist
       
      The default config.plist is not useful for us. Replace it by mine (folder n.2)
      But take a look to options (with clover configurator) to understand my options in order to be able to adapt them for your specs or your preferences. It’s a basic config.plist. I could add more options or fixes. but is a good idea install with minimum options. 
       
           Acpi section.
          All fixes in ACPI section has been removed except some minor fixes in 2 subsection, smart ups option, etc. SmartUps it’s not important now, but it will be later. So I prefer activate this option. 
          The most important, The rename usb devices patches are included. 
       
          

          Boot section
          Bootflags needed are only -v and npci=0x2000. Of course -v is optional only to see the boot process. You can deactivate it when you finish.
       
          
       
          Any option activated in Boot Graphics/ Cpu/Device/Disable driver
       
          Gui options. These are only personal preferences.
       
          
       
          Graphics. AnyGraphic injection annd any option activated. At least, no needed for my 1080ti card. Check it out for your card video.
       
          
       
          An essential section. Kernels Patches needed.
       
          
       
          RT Variables. BooterConfig, and Csr to deactivate security policy in Sierra. The info values are taken from smbios.
       
          
       
          SMBIOS.  Set it to Mac Pro 6,1. 
       
          
       
                    IMPORTANT—>press “generate new” repeatedly to get one random fresh serial number
       
          System parameter: 
       
          
       
       
      9.2 -Drivers64UEFI folder.
       
      As usual, delete VBoxHfs-64driver and replace it by HFSPlus.efi. (from my folder).

           
       
       
      9.3 Kexts folder:
       
      Add my Kexts from my stuff to /EFI/CLOVER/Kexts/10.13
       
      They are:

           
       
      These are the versions Updated since Sierra´s guide.
       
      FakeSMC.kext. If you remember, I have some unexpected KP due to fake smc sensors. Well, I have searched a bit about this, and testing. The main topic is keep the fake smc version and sensors kext of same version or branch. There are several branchs developing              different versions (slice, rehabman, kozleck, etc), after test, and test, I think the most stables and those which gives me best sensor readings is kozeck version. I attach the v1440 from kozleck. In this step I only use FakeSMC kext, withput sensors kexts. Anyway, if you have a better version, use it. Just, don´t forget no use the sensors Kexts.   
      VoodooTSCync.kext, to avoid boot with -x (from rampagdev, dual cpu dmg). You’ll find several versions into my folder.I haven’t noticed any change using the generic or the specific version. I think that is not important for our platform.                  The customize method is:

       

       
               Anyway, I provided the generic version and customized versions for every cpu.

       
      IntelMausiEthernet.kext . Kext for the ethernet card from rehabman. (2018-0424version). It will allow have internet connection on first boot.  AppleIntelE1000e.kext. Kext for ethernet card from here (2017-10-18 version). (Change of  server if you have problems downloading) <<<< update. Use this better than IntelMausiEthernet.kext
       
      UsbInjectall, for USB2 from rehabman( 2018-0822version)  
      And add to /EFI/CLOVER/Kexts/others
       
       

       
       
      Lilu kext (from here, 1.2.7version)  
      WhateverGreen.kext (from here, 1.2.2 version) old NvidiaGraphicsFixup proyect has been integrated into this proyect. It's useful for nvidia and amd graphics cards  
      This couple of kexts avoid black screen booting with 6,1 smbios. Is quite important keep in mind the versions of these kexts keeping the right versions among this kexts. Prior to update some of them, you have to check in original websites if it's is compatible with the rest. These versions are ready to work with 10.13.6. 
       
      Thats all. We have our usb installer ready. Copy in a folder all stuff necessary to repeat the process and copy it to the USB stick. You will have it available after first boot.
       
      Reboot from the USB stick and install High Sierra. 

       
      10- INSTALLATION

       
      Some advices:
           -Use only USB2 ports, preferably the front USB2 port.
           -Don’t use USB hubs, or cable extenders… (personal issues)
           -Unplug any other usb device
           -Be sure that you have plugged your internal sata drive to one of the two internal achi sata controller.
       

       
           -The boot process may be slow, (and with terrible and apocalyptic errors). Be patient
           -Maybe, the boot stucks with the error “consideredRebuildKernel …. blabla”. Just reboot again.
           -If you have two monitors, shutdown one can help with graphical errors.
           -Plug your graphic card in PCI Slot 2.
           -For inexperienced users: On first screen, go to disk utility and erase the Volume. (APFS and GPT). Quit the utility and return to first screen. Choose Install.
           -The process is splitted in two steps. The first step promises take only 4 or 5minutes … and now, it’s true!!!. It will take4 or 5 minutes(with a SSD).
           -After this first reboot, in clover boot screen, you will see more partitions than expected. APFS file system manage more partitions in a more complex way (physical layer, logical layer… bla, bla). Select  the new internal HighSierra boot installer partition, not the usb installer. It will finish the  process. This step, takes 10-15min aprox (using a SSD).
       
      Note.I had some unexpected reboot in this step. Only re-trying if you have it also.
       
      -To boot again after installation, keep booting from USB , ant then choose internal HD as clover boot screen.
       
       
      ---------------------------------------------------------------------------------------------------------------------------------
       
       
       
      PART III:
       
      FIRST BOOT
       
      11. Optional updates.
      Finally, we are on High Sierra's Dektop. The Mac os Version is 17G65. In the date of this guide (oct/2018) is the last version. (there is an optional update only for real macbook laptops). For future security updates, this is the moment to update. Set up the internet options and update the system, but remember check if the Lilu and whatevergreen kexts are compatible or if you need use a new version, or you will geta KP or a black screen on boot. Update using the update app, reboot, and wait for the update installation.
       
      12- Install Clover.
      On first reboot, install clover again on HDD, repeating same process and same options than with the USB installer, but keep in mind you have to add some options on clover’s screen install:
       


       

           -Install RC scripts on target volume
           -Optional RC scripts
           -Install Clover Preference Panel.

      …and install clovermanager.app. This is optional but it’s the best way to manage the themes and find a good theme. I provide of one nice High Sierra Theme and the Bootcamp theme. Of course, left this for later. 
       
      Install clover and add same files used on the USB: config.plist , hfsplus driver and kexts. Reboot. You can now extract the USB installer and reboot from the internal HDD.
      After boot, go to clover preference panel and set it to auto mount EFI partition. It will be useful along this process. Disable this when you finish and you get stable your system.
       
       
    • By Haive_Music
      Hey guys,
       
      I'm really hoping someone has the experience and ability to help me iron out the last remaining issue on my build.  
       
      The motherboard is: Gigabyte Z370 Aorus Gaming 7 and I'm running a Alpine Ridge thunderbolt card (Revision 2).   I've gotten everything working for the most part with the exception of Thunderbolt hotplug.  This is the last piece of the puzzle.  I've tried so many different DSDT/SSDT's, cable plugged in, and unplugged, without any luck at all. 
      I've managed to get my Focusrite Clarett 8Pre Thunderbolt working and it's showing up under the PCI section.  It works great, until I shut the device off and turn it back on.  I'd really like to try to get this hotplug issue sorted out, but I've had absolutely no luck so far.
       
      I've managed to get the Alpine Ridge NHI and USB controllers showing up in the PCI section too, but for some reason, the USB lists a bunch of ',,,,,,,,' after the name. 
       
       
      I'll be the first to admit - I don't really know a whole lot about what I'm doing with this stuff, but I've attached relevant files in hopes someone more experienced and knowledable can help me get this working.  
       
      Thanks guys!
      config.plist
      DSDT.aml
      John’s iMac.iojones

      SSDT-TB3.aml
    • By ivoryblade
      Hello! My internal SSD lifetime is running out so I'm thinking how to upgrade it. I don't want to replace it with slow Sata SSD so I want to buy OWCMercury Helios and install new nvme fast ssd, but I won't be able to boot from it using standard boot loader.... Is it possible to boot nvme ssd using Clover on real iMac?
×