Jump to content
565 posts in this topic

Recommended Posts

Has the issue with the hissing, sound crackling been fixed with VIA1708? While using 2.8.8 along with Skype and YouTube, I was getting hearing popping noise from time to time which got louder when using Microphone. I hope that this removes it, since I would like to go back to OS X but the sound issues are killing me.

VIA codec will work too if someone provide full dump and then test the kext with corrected info.plist tuned for the codec.

Hi @Slice, I tried VoodooHDA 2.8.8 and 2.8.9 in Dell Precision M3800(ALC668). It works great expect that the white noise come out when I plug in headphone. 

 

I have tried to use CodecCommander.kext to solve the headphone noise issue, but no success.

 

Also I tuned Info.plist with ALC668, no luck.

 

So could you please kindly give me some hints to solve this issue. I am pretty eager to use your VoodooHDA, since there's an annoying bug located in AppleHDA that will cause plug-in headphone lose sound during cold boot, and have to sleep to fix. VoodooHDA has no such issue with headphone!!

 

Here's my audio dump, if you please to see, I will be much appreciate!

ALC668_codec_dump.zip

 

Have a good day,

Yating

Hi @Slice,

 

This is node patch used in 2.8.8 to make multiple speakers work in my system  -  IDT92HD81B1X5 , but not able to apply the same correctly to the 2.8.9 Info.plist . Can you help shed some light on it.

 

                   <key>NodesToPatch</key>
			<array>
			<dict>
	 		<key>Codec</key>
	 		<integer>0</integer>
	 		<key>Config</key>
	 		<string>0x92170150</string>
	 		<key>Node</key>
	 		<integer>16</integer>
			<key>Node</key>
	 		<integer>13</integer>
			</dict>
			</array>

@mnfesq , It would be great if you can you post your Info.plist  for Beats. I'm using your 2.8.8 plist in which you had patched Node16 and Node13 get multiple speakers on my system.

 

Here's my patched VoodooHDA.  I have 3 nodes patched for each of the 3 audio devices that make up the Beats audio on my HP laptop.

 

VoodooHDA.kext.zip

 

If you have just upgraded from El Capitan to Sierra, be sure to put your modified/customized/third-party kexts in the kexts/10.12 folder in Clover.

 

Hi @Slice,

 

This is node patch used in 2.8.8 to make multiple speakers work in my system  -  IDT92HD81B1X5 , but not able to apply the same correctly to the 2.8.9 Info.plist . Can you help shed some light on it.

 

 

                   <key>NodesToPatch</key>
			<array>
			<dict>
	 		<key>Codec</key>
	 		<integer>0</integer>
	 		<key>Config</key>
	 		<string>0x92170150</string>
	 		<key>Node</key>
	 		<integer>16</integer>
			<key>Node</key>
	 		<integer>13</integer>
			</dict>
			</array>

 

You are missing 2 of the 3 patches needed to make all of your speakers work.  The patch should look like this:

			<key>NodesToPatch</key>
			<array>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180150</string>
					<key>Node</key>
					<integer>16</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180160</string>
					<key>Node</key>
					<integer>14</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180540</string>
					<key>Node</key>
					<integer>5</integer>
				</dict>
			</array>
  • Like 2

Hi @Slice, I tried VoodooHDA 2.8.8 and 2.8.9 in Dell Precision M3800(ALC668). It works great expect that the white noise come out when I plug in headphone. 

 

I have tried to use CodecCommander.kext to solve the headphone noise issue, but no success.

 

Also I tuned Info.plist with ALC668, no luck.

 

So could you please kindly give me some hints to solve this issue. I am pretty eager to use your VoodooHDA, since there's an annoying bug located in AppleHDA that will cause plug-in headphone lose sound during cold boot, and have to sleep to fix. VoodooHDA has no such issue with headphone!!

 

Here's my audio dump, if you please to see, I will be much appreciate!

attachicon.gifALC668_codec_dump.zip

 

Have a good day,

Yating

CodecCommander is not needed for VoodooHDA. VH knows what to do.

 

Your codec dump is from linux so I don't know what is happen in macOS. It will be better to see output from getdump utility in macOS.

Anyway. If you want you can do the same sound as in Linux just making the same pinconfigs for all nodes as in Linux

Node 0x12 0x90a60130

Node 0x14 0x90170110

Node 0x15 0x0321101f

Node 0x16 0x40000000 - disabled

Node 0x18 0x411111f0 - disabled

Node 0x19 0x411111f0 - disabled

Node 0x1a 0x411111f0 - disabled

Node 0x1b  0x411111f0 - disabled

Node 0x1d 0x40d6832d - wrong config

Node 0x1e 0x411111f0 - disabled

Node 0x1f 0x411111f0 - disabled

  • Like 1

Here's the codec dump for VIA 1708S. I hope that it can help :)

 

 

 

Your codec dump is from linux so I don't know what is happen in macOS. It will be better to see output from getdump utility in macOS.

 

  • Like 1

You are missing 2 of the 3 patches needed to make all of your speakers work.  The patch should look like this:

			<key>NodesToPatch</key>
			<array>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180150</string>
					<key>Node</key>
					<integer>16</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180160</string>
					<key>Node</key>
					<integer>14</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180540</string>
					<key>Node</key>
					<integer>5</integer>
				</dict>
			</array>

 

 

Thanks for the reply @mnfesq , but unfortunately there seems to be some anomaly. There is no audio via Speaker(Multi) & Speaker(Analog) [Woofer] works . I guess our audio system could be different,mine is HP DV6 6154TX . I was using your 2.8.8 patch in which you had just 2 nodes - 13,16 which resulted in two Speakers(Analog) . I used them together through MIDI setup. 

 

Can you help shed some light on that ?

 

UPDATE

 

I altered your patch with these & got Speaker (Analog) & Speaker (Multi) working .

                                <dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92170150</string>
					<key>Node</key>
					<integer>16</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180540</string>
					<key>Node</key>
					<integer>13</integer>
				</dict> 

System Preferences Sound  :

 

esqg46.png

 

 

Interestingly, VoodooHDA Settings shows another Speaker(Analog) ! Of course it doesn't work.

 

rrjzol.png

 

 

Still confused about my audio setup  :whistle: 

 

 

 

 

 

Thanks for the reply @mnfesq , but unfortunately there seems to be some anomaly. There is no audio via Speaker(Multi) & Speaker(Analog) [Woofer] works . I guess our audio system could be different,mine is HP DV6 6154TX . I was using your 2.8.8 patch in which you had just 2 nodes - 13,16 which resulted in two Speakers(Analog) . I used them together through MIDI setup. 

 

Can you help shed some light on that ?

 

UPDATE

 

I altered your patch with these & got Speaker (Analog) & Speaker (Multi) working .

                                <dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92170150</string>
					<key>Node</key>
					<integer>16</integer>
				</dict>
				<dict>
					<key>Codec</key>
					<integer>0</integer>
					<key>Config</key>
					<string>0x92180540</string>
					<key>Node</key>
					<integer>13</integer>
				</dict> 

System Preferences Sound  :

 

esqg46.png

 

 

Interestingly, VoodooHDA Settings shows another Speaker(Analog) ! Of course it doesn't work.

 

rrjzol.png

 

 

Still confused about my audio setup  :whistle: 

 

 

 

 

 

So our pin configurations are not identical.  The kext I posted above works for me but it is not entirely accurate.  I do not need to patch the node for my front speakers.  They work OOB with VoodooHDA.  It's the two other sets of speakers, both called multi, that require patching.  Here's an updated kext which removes all of the unnecessary patches:

 

VoodooHDA.kext.zip

 

Of course, this will not work OOB for you because of your different pin configurations.  By changing the 8 to a 7, you switched it from multichannel analog to analog.  I think that is your non-functioning second analog device.  (I have never been able to get 2 devices to work that are both 7s.  That's why bottom and top speakers are both 8s.)  It is doubtful to me that you have your top speakers working (both bottom and top speakers should show up as a single device called multi.). The only way to confirm whether you have all 3 sets of speakers working is to use getdump which I have attached.

 

getdump.zip

 

When you run this, it will open in Terminal and will give you lots of info.  What you want to look for is the section called Patched pins configuration:  Here's what mine looks like:

 

post-270804-0-58585400-1474307296_thumb.png

 

If you see 3 speaker entries, 2 of which are entitled multi, you will have all 6 speakers working.  Just post your patched pin configuration in your next post.

CodecCommander is not needed for VoodooHDA. VH knows what to do.

 

Your codec dump is from linux so I don't know what is happen in macOS. It will be better to see output from getdump utility in macOS.

Anyway. If you want you can do the same sound as in Linux just making the same pinconfigs for all nodes as in Linux

Node 0x12 0x90a60130

Node 0x14 0x90170110

Node 0x15 0x0321101f

Node 0x16 0x40000000 - disabled

Node 0x18 0x411111f0 - disabled

Node 0x19 0x411111f0 - disabled

Node 0x1a 0x411111f0 - disabled

Node 0x1b  0x411111f0 - disabled

Node 0x1d 0x40d6832d - wrong config

Node 0x1e 0x411111f0 - disabled

Node 0x1f 0x411111f0 - disabled

 

Hi Slice, I've changed the value in VH as you suggested, seems the noise has reduced a little bit, but still persist.

 

Input device disappeared after using the value.

 

Here's two getdump(one is with native VH, another is with touched VH). Thanks for your reply! 

getdump_and_info.zip

 

I've searched on google that ALC668 with VH has headphone white noise. There is some information can be found from what linux kernel devs did to suppress the static. In particular two commits:

The basic idea seems to be that when the headphones are plugged in, the speaker configuration produces static. The darkvoid and vbo used to define the lineout clearly to solve the issue with noise on the combo jack in AppleHDA. But, as I mentioned above, AppleHDA also has an annoying bug to cause the ALC668's headphone lose sound during cold boot. If this issue can be fixed, I am pretty sure that all ALC668 with combo jack users will switch from AppleHDA to VoodooHDA(pretty cool)! 

 

Again, thanks for the VH project, invaluable driver to power audio up!

syscl

Edited by syscl

You made a mistake

Node 0x12 - hex value, while you should use decimal value in info.pilst patching

0x12 = 18

0x13 = 19

0x14 = 20

Try again

@Slice, thanks for your patience and tips, white noise still persists as pervious, but this time Input device come back.

 

Here's the info and new getdump and info for VH

getdump_v2_and_info.zip

 

syscl

@Slice, thanks for your patience and tips, white noise still persists as pervious, but this time Input device come back.

 

Here's the info and new getdump and info for VH

attachicon.gifgetdump_v2_and_info.zip

 

syscl

All is good in your dump. Now you can tune the sound with prefpane

Screen Shot 2016-09-20 at 21.04.11.png

And may be check some setting in the info.plist.

For example "InhibitCache=true"

All is good in your dump. Now you can tune the sound with prefpane

attachicon.gifScreen Shot 2016-09-20 at 21.04.11.png

And may be check some setting in the info.plist.

For example "InhibitCache=true"

I've tried the following combinations..., with no luck:

  • InhibitCache=true
  • Pref/VoodooHDA/Speaker(only speaker, no headphone option available): IMix: 0-Max
  • PCM: 0-Max
  • Noise reduction: 0-Max
  • Enhanced stereo: Min-0-Max

Through setting IMix to Max will reduce the hp noise a little bit. 

 

@Slice, the way that CodecCommander.kext used to fix the hp noise is the following config codec:

                                <key>Realtek ALC668</key>
				<dict>
					<key>Custom Commands</key>
					<array>
						<dict>
							<key>Command</key>
							<data>
							AVcIgw==
							</data>
							<key>Comment</key>
							<string>0x15 SET_UNSOLICITED_ENABLE 0x83</string>
							<key>On Init</key>
							<true/>
							<key>On Sleep</key>
							<false/>
							<key>On Wake</key>
							<true/>
						</dict>
						<dict>
							<key>Command</key>
							<data>
							AbcHIA==
							</data>
							<key>Comment</key>
							<string>Node 0x1b - Pin Control (In Enable)</string>
							<key>On Init</key>
							<false/>
							<key>On Sleep</key>
							<false/>
							<key>On Wake</key>
							<true/>
						</dict>
					</array>

So, can I configure the value through VH to see if this commands can fix the hp noise? Don't know how to convert the above code into VH's info.plist.

 

Thanks,

syscl

@syscl

By this patches I see

Node 0x15 = 21 SET_UNSOLICITED_ENABLE - this is possibility to switch between Speaker and Headphones. Already present.

If you want to make them independent devices then you can assing to Headphone new config

nid 21 0x03211020

 

Node 0x1b = 27. This node is unused. I don't think it should be enabled.

  • 2 weeks later...

Hello Users,

 

I am using macOs Sierra on Haswell MacBook Pro 11,1. I have installed VoodooHDA 2.8.9 kext using Kext Vizard, when I play a music it sound fine but when I record audio its record like a robot voice. I tried to sort it out but unable to fix it and also VoodooHDA.prefPane is unable to open. Any solution will be highly appreciated thanks.

 

 

post-1815823-0-32743900-1475873139_thumb.png

  • Slice changed the title to VoodooHDA 2.9.7
  • Allan pinned this topic
  • Allan unpinned this topic
  • Allan featured this topic
×
×
  • Create New...