Jump to content

441 posts in this topic

Recommended Posts

Good afternoon.

 

I copied VoodooHDA 2.8.9 within the kext 10.12 and other folder and not injected. Installed in S / L / E produces panic in Sierra PB7 and earlier. Also cause panic in El Capitan and Yosemite.

 

Deputy Error Report. Regards

 


Share this post


Link to post
Share on other sites
Advertisement

You have to install also AppleHDADisabler.kext else panic because of Voodoo<->AppleHDA conflict.

 I have installed AppleHDADisabler.kext because I was using 2.8.4 VoodooHDA working perfectly. I have ALC284.

 

 

Captura_de_pantalla_2016_09_01_a_las_22_subir foto

Share this post


Link to post
Share on other sites

Panic in my Yosemite 10.10.5:

 

Captura_de_pantalla_2016_09_02_a_las_19_sube fotos

 

 

All this leads me to think that the sound hardware of my computer is not compatible with VoodooHDA 2.8.9, regardless of the version of Mac OS you use.
Greetings.

Share this post


Link to post
Share on other sites

Panic in my Yosemite 10.10.5:

 

Captura_de_pantalla_2016_09_02_a_las_19_sube fotos

 

 

All this leads me to think that the sound hardware of my computer is not compatible with VoodooHDA 2.8.9, regardless of the version of Mac OS you use.

Greetings.

You Can Try this

Thats working for me on Mavericks / El Capitan / Sierra

 

http://www.insanelymac.com/forum/files/file/517-voodoohda-289pkg/

 

Edit...

If you try option VoodooHDA 2.8.9 Clover UEFI & ESP

Sierra 10.12 you need on S/L/E Original AppleHDA =  No panic!

Share this post


Link to post
Share on other sites

Some users claim that using VoodooHDA they hear loud bump at system start and sound in system comes with noise.

Although this can be repaired with existing drivers I propose a version that do this automatically.

It started silently and have very clear output. The file is compiled as 32/64 and works from 10.6 up to 10.12.

attachicon.gifVoodooHDA.kext-289.zip

The sources is in my signature.

 

There is a VoodooHDA,prefPane compatible with Sierra

attachicon.gifVoodooHDA.prefPane-289.zip

attachicon.gifСнимок экрана 2016-08-26 в 6.50.10.png

 

Thanks for the VoodooHDA.kext-289.zip it cleared my audio issue with 288 (whitenoise sound low volume), for some reason i can't use the preference pane?

 

Edit: Hiss is back after restart? Not sure what's happening now, is there a way to uninstall 288 and only use the VoodooHDA.kext-289.zip ???

 

Edit 2: got it working from http://www.insanelymac.com/forum/files/file/517-voodoohda-289pkg/

 

Thanks to Slice and chris1111 amazing work guys!!!!

post-91745-0-13155600-1472913835_thumb.png

Share this post


Link to post
Share on other sites

Thanks for the VoodooHDA.kext-289.zip it cleared my audio issue with 288 (whitenoise sound low volume), for some reason i can't use the preference pane?

 

Edit: Hiss is back after restart? Not sure what's happening now, is there a way to uninstall 288 and only use the VoodooHDA.kext-289.zip ???

I never thinked about.

You should find a way to erase old preferences to install new prefpanel.

Share this post


Link to post
Share on other sites

I found some issues with the preference pane after restart the settings aren't "holding", i had to readjust options and volumes, for example Input Gain was boosted (which is why I was getting the hiss). Also the volume "knob" control could maybe be improved by having 1-10 printed around it, I wasn't sure where max volume was to go.

 

Anyway minor issues on amazing work, thank you very much and thanks for answering questions slice, much appreciated!

Share this post


Link to post
Share on other sites

On Sierra Prefpane need to be instal on Library /PreferencePanes

and clic to VoodooHDA.prefPane to Install

 

hi Chris, the preference pane doesn't keep my preferences after reset, i have to click PCI device again and select headphone port, for example.

 

After that Input gain is turned up so i have to turn it down, otherwise i get a hiss..Not a massive problem, just a minor hinderance

Share this post


Link to post
Share on other sites

Hello

 

All is perfect with Sierra GM and ALC 892 except the microphone. Siri doesn't recognize correctly  my voice.

Share this post


Link to post
Share on other sites

Hello

 

All is perfect with Sierra GM and ALC 892 except the microphone. Siri doesn't recognize correctly  my voice.

VoodooHDA does not corrupt sound quality. Mic is working or no.

You can move volume or noise controllers to improve reliability.

Share this post


Link to post
Share on other sites

VoodooHDA does not corrupt sound quality. Mic is working or no.

You can move volume or noise controllers to improve reliability.

Thanks a lot.

 

Voodoo is great. Since, I activated "Say Siri" with advanced control on Sierra GM 16A319, Siri recognize correctly my voice : USB Headphone set and Logitech C525 webcam.

Share this post


Link to post
Share on other sites

there are fixes and preferences you can enable or edit within voodoohda's info.plist to conform to your needs in case it does not work out of the box, so to say.

Thanks

Share this post


Link to post
Share on other sites

Has the issue with the hissing, sound crackling been fixed with VIA1708? While using 2.8.8 along with Skype and YouTube, I was getting hearing popping noise from time to time which got louder when using Microphone. I hope that this removes it, since I would like to go back to OS X but the sound issues are killing me.

Share this post


Link to post
Share on other sites

@Slice -- I see you patched 2 nodes in the config.plist.  Could you explain them?  I have 3 nodes patched in order to get my Beats Audio to function (midrange and subwoofer speakers).  I see your codecs are different than mine.  Does that mean that 2.8.9 will work the same for me as 2.8.8?  Your kext works fine for me but I think I have more treble than I used to.  I'm still playing with it to see if I get any sound improvement.  Thanks for your reply.

 

@mnfesq , It would be great if you can you post your Info.plist  for Beats. I'm using your 2.8.8 plist in which you had patched Node16 and Node13 get multiple speakers on my system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ITzTravelInTime
      KX AUDIO DRIVER MOD
       
      Hi guys i am a small developer, i really like to use my sound blaster cards on my machines and i love also coding, so when i find the source code for the kx audio driver on git hub and then Eugene, the creator of kx audio driver decided to no longer maintain the project, i decided to start working on a mod of this driver and maintain it. 
       
      With my mod, created starting from the sources of the last official version of kx audio driver and all the small commiunity updates, i am working to keep the driver compatible with the latest mac os versions and to improove the driver over time.
       
      Supported cards are:
       
       - most of the Sound Blaster live!, live! 5.1 and live! 5.1 digital series (except for the cards not using the 10k1 architecture)
       - sound blaster pci 512 and pci 256
       - Sound Blaster Audigy, Audigy 2 and Audigy 2 zs series
       - E-MU cards based on the 10k2 sound chip (like the EMU8852 aka 0404m, including the pcie version)
       - Sound Blaster Audigy 4 (SB0610 only) and the Audigy 4 pro
       - Sound Blaster Audigy RX (SB0155)
       - other creative and e-mu cards based on the (10k1,10k2, 10k2.5 and CA10300 based cards)
       
      The NOT supported cards includes (but are not limited to):
       
       - ES1370/ES1371/ES1372/ES1373 based sound cards
       - Any CA0106 based card and cards with similar architectures (like sound blaster live! 24 bit, sound blaster audigy SE SB0570, audigy LS and similars, but audigy SA is supported)
       - Any sound blaster x-fi (some of them works on macOS using a modified version of voodoo hda)
       - Any sound blaster recon3D
       - Sound blaster Audigy FX
       - Any sound blaster Z/ZS/ZX and similar series
       - Any sound blaster AE5/AE7/AE9 series
       - Any sound card without an emu sound chip
      - Any ISA Sound card
       
      In the time being the things i have modded or added with this mod are:
       
      - cracking and stability fixes
       
      - added a more proper support for the pci express Sound Blaster audigy rx SB0155 (which basically is an audigy 4 with a pcie bridge chip) 
       
      - more user-frienly names for the cards in the settings and other system menus (so the name will be, for example, SB live! 5.1 SB0060 instead of kx SB0060 [e880] witch was shown in the original driver)
       
      - added support to sample rate changing and bit resolution change (the absolte worst supported quality is 7 khz at 8 bit dept while the absolute best is 192 khz at 32 bit depth)
       
      - inputs support
       
      - added boot args to manage the driver (more info on those soon)
       
      What i'd like to implement but i don't know how to do:
       
       - fix the support when using more than one card, to get all the cards shown in the settings and other menus,
       
       - have the gameport/midi port of older cards to be used in mac os as a midi in/out
       
      If other developers would like to join and help they are free to do so, this is a free open source project afterall, and also an hand from other people with testing and feedback will be nice.
       
      LINKS and downloads:
               -  github repo:                                               https://github.com/ITzTravelInTime/kx-audio-driver   (kext download coming soon, since an update is coming)  
       





    • By AbhilashSathe
      I'm currently using AppleALC inside /EFI/Clover/Kexts.
      Sound works fine through Laptop speakers. However, as soon as I connect my earphones, i start getting a continuous buzzing sound. Can anyone help me with this?

      config.plist
      SSDTS_DSDT.zip

       
      rough 
    • By LSP414
      Cannot figure out where to put custom ringtones on Catalina so I can select them in contacts. They are in the iTunes folder but are not recognized
    • By Diptamondal
      dell inspiron 5378 hackintosh wifi don't work 
    • By noisegate
      Hi,
       
      I use AppleALC v1.3.5, I can see the device in system info but no sound. Any idea?
       
      Thanks!
       
×