Jump to content
  1. Badruzeus

    Badruzeus

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By chummdoggin
      A setup with an IVY bridge e5430 dell worked fine. but now seems the XHC device
      is a hardware issue. There is no bios setting to enable disable. Only enable/disable boot/external.USB in general.
      All set to enable. Also just mention of USB in power settings wake on USB.
       
      Did show up when I set up the ports w/USBINJECTALL, then was working on imessage isssue when the DSDT
      stopped loading after updating clover. I had two versions of MAcIasl. One with iasl 6. and one had 6.2a. Kept
      the 6.2a, was RM's most recent. One problem Im confused by is it compiles fine but after saved if its opened,
      the error that was repaired comes back.
       
      This part:
       
                      If (LEqual (PM6H, One))
                      {
                          CreateBitField (BUF0, \_SB.PCI0._Y0C._RW, ECRW)  // _RW_: Read-Write Status
                          Store (Zero, ECRW (If (PM0H)
                                  {
                                      CreateDWordField (BUF0, \_SB.PCI0._Y0D._LEN, F0LN)  // _LEN: Length
                                      Store (Zero, F0LN)
                                  }))
                      }
       
      Loads with the error but not sure what happened on the original that worked.
       
      Any Idea?
       
      Going over the boot log, The XHC device is there under the PCI readings dont think hardware issue... 1e31 Just seems the saved DSDT should not
      have errors after saved, but using the other version of Maciasl, the DSDT would save without errors and open without but it would not load.
      acted like there was no FakeSMC... 
       
      Edit: Seems all the saved DSDT have that error when re-opened using that version  RM's Maciasl w/iasl v.6.2a but seems to load fine.

       
      debug_8785.zip
    • By susteve
      Hello, I am new here, so I apologize if I've chosen the wrong subforum for this question. 
       
      I am scratching my head a bit on an issue with a clients MacBook pro.  He was having USB connection issues and claimed the laptop wasn't detecting any USB connected to it. 
       
      Figuring it was a failed USB port, I took it in but ended up just feeling more confused after doing some diagnostics. 
       
      It came in loaded with Catalina, a recent upgrade spurned the beginning of the issues the client told me. 
       
      I decided to revert it back to the default OS in the base recovery image, which is Yosemite. 
       
      Upon finishing the install, I found that the USB port was in fact working again. Figuring I had resolved the issue, I updated it back to Catalina just to be met with the same issue upon reinstalling. 
       
      SMH 
       
      Tried nvram, pram, and smc reset each to no avail.  
       
      One thing to note is that during boot, the USB is getting power as it lights up when connected during boot up. 
       
      But the ports are dead as soon as it boots into the operating system. 
       
      I have a strong feeling that this is a driver issue. I tried unloading and reloading the USB IO kext, with no noticable change. 
       
      Is anyone here familiar with this issue? Would there be any other kext related troubleshooting i can perform ? Is it possible to revert to the kext used in Yosemite on catalina ?
       
      One last thing to note, on Yosemite the USB was functioning 100%. But I did get a strange notification that the USB ports were using power even when there wasn't any connected to it. Either way, I find it very very odd that it works perfectly in Yosemite. 
       
      Thanks in advance
       
      Steve 
    • By jdorz
      Hello all,

      I have successfully gotten my Hackintosh working 99 percent. The remaining issue that I am running into is that my system will randomly kernel panic upon a user issued shutdown or reboot WHEN I have either a usb sound card or usb headset plugged into any of my USB ports (both 2.0 and 3.0). If I remove the headset, it will power down with no issues. Does anyone have any suggestions?

      My system is as follows:
      MacOS 10.14 Mojave
      Gigabyte H370 HD3
      8400 i5 Coffee Lake
      Radeon RX 580 sound card

      Fixed
       
      Solution
       
      Use this folder for serie 100/200/300
      https://olarila.com/forum/viewtopic.php?f=28&t=8222
       
      reboot and extract one send_me for full dsdt patch by MaLd0n
      --Run_Me
      RunMe.app
       
       
       
    • By guira
      Hey all, im new in Hackintosh world, I managed to install macOS Mojave in ASUS laptop x555LA, WIFI,HDMI,INTEL graphics, touchpad, laptop keyboard, ethernet, sound( barely, have to change it every time i run the laptop) is WORKING (after to much hours :D), also clover starts well without USB connected.
      Now my problem is that in clover, USB mouse and USB keyboard works perfectly but when MacOS load, don't know why, they stop working(just touchpad and lap keyboard working), I tried all to repair this but I can't, anyone can help me? also brightness not working but not a problem, just want USB keyboard and USB mouse working.
      AH and sorry for my English, im trying my best :D.
      btw, USB mouse and keyboard worked  when installing Mojave, but never worked in desktop or in login.
      Thanks so much , if u need more info I will be here!
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/forum/viewtopic.php?f=28&t=8222   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×