Jump to content
everart

Dependências Entre Kexts!

15 posts in this topic

Recommended Posts

Salve galera!!!

 

Primeiramente queria dizer que meu Hackingtosh é um note Acer Aspire 4739, Yosemite 10.10.3. Queria se possível uma dica sobre um problema bem chato aqui com meu audio. Meu codec é o alc271x! Eu já tentei tudo que foi possível pra fazer o Applehda funcionar mas não deu, estou usando voodoo e pra mim funciona maravilhosamente bem, com um único problema! o voodoo tem algumas dependências com o IOAudioFamily, e eu tenho uma Interface de audio USB que não é reconhecida se minha IOAudioFamily não for original.

 

Resumindo:

 

Com uma versão da IOAudioFamily eu tenho voodoohda funcionando mas minha interface USB não é reconhecida.

 

Com outra versão da IOAudioFamily minha interface USB funciona perfeitamente mas o voodoohda não funciona.

 

obs: Uma coisa interessante do Voodoohda quando uso a outra kext é que ele até funciona por alguns segundos e depois entra tipo em MUTE!

então eu abro o Audio e MIDI e qualquer mudança que eu fizer lá o audio volta e para, volta e para, volta e para.

 

Alguma dica.

voodoo funciona IOAudioFamily.kext.zip

USB FUNCIONA IOAudioFamily.kext.zip

Share this post


Link to post
Share on other sites
Advertisement

Voodoo 2.8.7!! foi a única que funcionou aqui.


O console mostra: 

 

05/08/16 15:30:10,698 com.apple.kextcache[438]: AppleUSBAudio.kext - no compatible dependency found for com.apple.iokit.IOAudioFamily.

05/08/16 15:30:17,975 com.apple.kextcache[438]: AppleUSBAudio.kext - no compatible dependency found for com.apple.iokit.IOAudioFamily.

Artur_pt. você poderia me mandar a sua versão do AppleUSBAudio? queria testar aqui pra ver se vai funcionar.

Share this post


Link to post
Share on other sites

olá

 

já reparaste as permissões e atualizaste o kextcache ?

 

pode ser 1 problema de cache ..

sudo kextcache -prelinked-kernel

isso é uma kext de sistema .. própria da versão de osx .. nunca de deve mexer com kext de sistema

 

bom hack

Share this post


Link to post
Share on other sites

kext file:///System/Library/Extensions/DirectHW.kext/ is in hash exception list, allowing to load


AppleUSBAudio.kext - no compatible dependency found for com.apple.iokit.IOAudioFamily.


AppleUSBAudio.kext is missing dependencies (including anyway; dependencies may be available from elsewhere)


kext-dev-mode allowing invalid signature -67030 0xFFFFFFFFFFFEFA2A for kext AppleIntelHDGraphicsFB.kext


kext-dev-mode allowing invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext AppleIntelCPUPowerManagement.kext


kext file:///System/Library/Extensions/AppleHDADisabler.kext/ is in hash exception list, allowing to load


kext file:///System/Library/Extensions/ALXEthernet.kext/ is in hash exception list, allowing to load


kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext ACPIBacklight.kext


Invalid signature -67030 for kext <OSKext 0x7fadd43400c0 [0x7fff79416ed0]> { URL = "VoodooHDA.kext/ -- file:///System/Library/Extensions/", ID = "org.voodoo.driver.VoodooHDA" }


AppleUSBAudio.kext - no compatible dependency found for com.apple.iokit.IOAudioFamily.


AppleUSBAudio.kext - no compatible dependency found for com.apple.iokit.IOAudioFamily.


Prelink failed for com.apple.driver.AppleUSBAudio; omitting from prelinked kernel.


Share this post


Link to post
Share on other sites

olá

 

tens a certeza que essa kext é a correspondente à versão do sistema ?

 

tem qualquer coisa esquisita ai na tua instalação ...

 

tenta subir de versão .. talvez fazer update ao sistema .. para 10.10.4

 

bom hack

Share this post


Link to post
Share on other sites

Essa AppleUSBAudio.kext é vanilla!!! retirei agora da media de instalação, mas a IOAudioFamily.kext, essa não é original!!! mas o meu voodoo só funciona com ela.

se eu por a original minha AppleUSB carrega normal mas!! meu Voodoo não funciona.  :wallbash:  :wallbash:  :wallbash: 

Share this post


Link to post
Share on other sites

Bom!!! Dei uma boa lida no tópico lá e consegui fazer funcionar os 2 juntos porem o Voodoohda só funcional por alguns segundos, ele continua lá mas sem audio!

Por essa razão acho que é um problema de "Pin Default" do meu codec. O audio não tá sendo direcionado pra saída certa mas está

funcionando.

 

Você poderia me ajudar com o meu codec dump Artur? acho que só falta isso.

 

 

post-1757707-0-63529300-1470476593_thumb.png

Share this post


Link to post
Share on other sites

Fix meu upgrade pra El captain e o audio continua a mesma coisa, funciona alguns segundos e para  :(  :(  :(  Isso já tá consumindo minha alma. É tão frustrante não ter conhecimento.  :wallbash:  :wallbash:  :wallbash: Alguém poderia me dar um help aqui?? 

Share this post


Link to post
Share on other sites

Fix meu upgrade pra El captain e o audio continua a mesma coisa, funciona alguns segundos e para  :(  :(  :(  Isso já tá consumindo minha alma. É tão frustrante não ter conhecimento.  :wallbash:  :wallbash:  :wallbash: Alguém poderia me dar um help aqui??

 

Então edita a sua appleHda: http://www.insanelymac.com/forum/topic/295316-guia-de-como-corrigir-a-applehda-para-o-seu-codec/

Share this post


Link to post
Share on other sites

Já tentei!!! Mas da kernel panic. Codec alc271x fix o patche da dsdt, tudo como manda o figurino. Não consigo encontrar o erro.

Share this post


Link to post
Share on other sites

Descobri o problema!!! Na realidade o problema não está no Voodoohda o problema está na kext IOAudioFamily!!! O voodoohda só funciona aqui com uma IOAudioFamily Patcheada que eu achei na net, essa kext resolve um problema e cria outro!!! O áudio onboard funciona mas o audio via usb não. :cry:  :cry:  :cry:  :cry:  Eu já procurei como fazer o patch da IOAudioFamily na net mas não achei nada. acho que essa é a única solução. Corrigir o patch da IOAudioFamily pra ela reconhecer o audio via usb. :(  :(  :(  :(

Share this post


Link to post
Share on other sites

Descobri o problema!!! Na realidade o problema não está no Voodoohda o problema está na kext IOAudioFamily!!! O voodoohda só funciona aqui com uma IOAudioFamily Patcheada que eu achei na net, essa kext resolve um problema e cria outro!!! O áudio onboard funciona mas o audio via usb não. :cry:  :cry:  :cry:  :cry:  Eu já procurei como fazer o patch da IOAudioFamily na net mas não achei nada. acho que essa é a única solução. Corrigir o patch da IOAudioFamily pra ela reconhecer o audio via usb. :(  :(  :(  :(

tenta esta kext: AppleHDA-274.7-ALC271x.zip

instale ela + o DSDT que a acompanha, repare as permissões e reconstrua os caches

para isso use a ferramenta de @Micky1979: http://www.insanelymac.com/forum/files/file/432-insanelyrepairpermission/ 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By esata
      I have just installed High Sierra 10.13.6 - Build: 17G65
      When trying to install the drivers with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]-High-Sierra-Edition-10.4.0 a message appeared stating that the installation failed (attached).
      Any suggestions on how to proceed?

      [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] log:
      05/20/19 08:24:59 - Starting [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 10.1.1-20171113
      05/20/19 08:44:04 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 08:44:07 - Installing 'BootVolume'
      05/20/19 08:44:07 - Copying 'apfs.efi'
      05/20/19 08:44:07 - Copy of 'apfs.efi' failed.
      'Failed copying apfs.efi'. Exiting.
      05/20/19 08:45:06 - Starting [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 10.3.0-20180516
      05/20/19 08:47:56 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 08:48:00 - Installing 'BootVolume'
      05/20/19 08:48:01 - Copying 'apfs.efi'
      05/20/19 08:48:01 - Copy of 'apfs.efi' failed.
      'Failed copying apfs.efi'. Exiting.
      05/20/19 22:07:02 - Starting [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 10.4.0-20180812
      05/20/19 22:09:43 - Failed to find node with path 'Drivers > Audio > Realtek ALCxxx > H310 / B360 / H370 / Q370 Audio Device ID Patch'
      05/20/19 22:09:43 - Failed to find node with path 'Drivers > Audio > Realtek ALCxxx > 200 / Z370 Series / X299 Audio Device ID Patch'
      05/20/19 22:15:06 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 22:15:11 - Installing 'BootVolume'
      05/20/19 22:15:11 - Mounting EFI at destination 'HighSierra'
      05/20/19 22:15:12 - EFI partition for volume does not contain a CLover config.plist. Exiting.
      05/20/19 22:15:59 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 22:16:04 - Installing 'BootVolume'
      05/20/19 22:16:04 - Mounting EFI at destination 'HighSierra'
      05/20/19 22:16:04 - EFI partition for volume does not contain a CLover config.plist. Exiting.
      05/20/19 22:16:56 - Installing 'Bootloaders > Clover UEFI Boot Mode'
      05/20/19 22:17:00 - Installing 'BootVolume'
      05/20/19 22:17:00 - Mounting EFI at destination 'HighSierra'
      05/20/19 22:17:01 - EFI partition for volume does not contain a CLover config.plist. Exiting.
      05/20/19 22:20:23 - Starting [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] 10.4.0-20180812
       

      DESKTOP:
      ASUS G20CB-B21 Gaming Desktop
      Mobo:  ASUS H170-P/G20CB/DP_MB.
      Processador: Intel Core i7-6700 3.4GHz
      Cooler/WC: G20AJ CPU FAN ASSY / G20BM O MOD ASSY
      VGA: NVIDIA GTX 1070 8GB
      Propriedades WLAN: Realtek 8821AE LAN 802.11ac PCI-E NIC sem fio
      Propriedades do adaptador de rede: Adaptador de rede Realtek 8821AE Wireless LAN 802.11ac PCI-E NIC
      Áudio: nVIDIA GP104 HDMI/DP @ nVIDIA GP104 - Controlador de áudio de alta definição PCI - Realtek ALC887 @ Intel Sunrise Point PCH - Controlador de áudio de alta definição [D1] PCI
      Memória: (2x8GB) 16GB DDR4 SDRAM
      SSDs: 120GB Kingston - Hyperx Fury SHFS37A / 120G / 7309541 / 9904447-724.F00G
      HDD: 1TB TOSHIBA DT01ACA100
      Fonte:  ADAPTADOR 180W 19.5V 3P(5.5PIH) / ADAPTADOR 230W 19.5V 3P(7.4PHI)
      Traduzido com www.DeepL.com/Translator


      install log.txt
      Multbeast log.txt
    • By End3rPower50
      Hi, I bought a Dell DW1820A based on BCM94350ZAE
      I can't install kext for this chipset on my hackintosh
      Can anyone help me?
      Thanks in advace 
      P.S Sorry for my bad English
       
      CLOVER.zip
    • By antonioruri
      Buongiorno, ho da poco messo a posto quasi tutto sulla mia prima configurazione hackintosh che va benissimo. In questi giorni è apparso l'aggiornamento di sicurezza di High Sierra come da titolo e me lo ha scaricato ma prima di partire con l'installazione vorrei avere delle delucidazioni riguardo agli aggiornamenti in generale soprattutto ai minor, per ora non ho bisogno di aggiornare a Mojave.
      Si corrono dei rischi ad eseguire aggiornamenti di questo tipo (sicurezza come in questo caso) o ad esempio a versioni piu nuove dello stesso sistema MacOS? Se sì quali sono e come si prevengono? 
      Non vorrei ritrovarmi a dover re installare tutto formattando il disco partendo da zero. Qualche tempo fa ad mio amico succedeva che il disco veniva crittografato con "Filevault" e diventava inaccessibile, questo dopo un minor update, al che ha dovuto ricominciare da 0. Cos'è il Filevault? Potrebbe capitare questo anche a me? Vorrei sapere tutto prima di andare a fare delle minchiate.
      Grazie in anticipo a chi vorrà e avrà la pazienza aiutarmi. 
    • By End3rPower50
      Hi, i want to buy "Broadcom bcm94350zae" for my laptop
      is this compatible with macOS Mojave?
    • By End3rPower50
      Hi, is Qualcomm Atheros AR956x compatible with MacOS Mojave 10.14.3?
×