Jump to content
Gogeta5026

Graphics problems with macOS Sierra

10 posts in this topic

Recommended Posts

I was able to get 10.12 16A238m to boot with Clover r3631 however... I can only start it up when I use the tags of GraphicsEnabler=No nvda_drv=0 nv_disable=1. Only problem is the graphics are all choppy and everything takes forever.

Is there something specific I need to change in order for it to boot normally (I usually used npci=0x2000 and nvda_drv=1) and got everything to boot fine.  I tried looking through the thread and just got a little lost after reading 10-15 pages.

If anybody knows the solution... THAT WOULD BE GREAT!

Edited by Allan
There is not problem with Clover, but with macOS Sierra

Share this post


Link to post
Share on other sites
Advertisement

beta 3 of 10.12 no issue clover works injection works and audio works all is well

I need some help here. What exactly do I have to do in order to get 10.12 to boot? Is there something specific I have to do?

I can only seem to boot using GraphicsEnabler=No nvda_drv=0 nv_disable=1. I currently have ncpi=0x2000 nvda_drv=1 in order to get 10.11.6 to boot 

Share this post


Link to post
Share on other sites

I need some help here. What exactly do I have to do in order to get 10.12 to boot? Is there something specific I have to do?

I can only seem to boot using GraphicsEnabler=No nvda_drv=0 nv_disable=1. I currently have ncpi=0x2000 nvda_drv=1 in order to get 10.11.6 to boot 

GraphicsEnabler=No sure does nothing with Clover (is for Enoch/Chameleon). Maybe take a look at Graphics-->Inject-->NVidia  (YES or NO)

:)

Share this post


Link to post
Share on other sites

GraphicsEnabler=No sure does nothing with Clover (is for Enoch/Chameleon). Maybe take a look at Graphics-->Inject-->NVidia  (YES or NO)

:)

Still no luck trying that. NVIDIA drivers were updated. Only way I've been able to boot is with nvda_drv=0 nv_disable=1. I attached pictures of were the -v command stops at right before it restarts when using nvda_drv=1.

 

post-1411155-0-26772600-1468900948_thumb.jpg

post-1411155-0-05123500-1468900952_thumb.jpg

Share this post


Link to post
Share on other sites

Did you try to disable your internal CPU-Graphics?
Did you set your SMBIOS to Mac 14,1? In my case (970 GTX), this missing setting prevented my graphic card to startup completely.

Share this post


Link to post
Share on other sites

Did you try to disable your internal CPU-Graphics?

Did you set your SMBIOS to Mac 14,1? In my case (970 GTX), this missing setting prevented my graphic card to startup completely.

Yes, I do have my SMBIOS set 14,1. For disabling internal CPU-Graphics... do I do that in BIOS?

Share this post


Link to post
Share on other sites

Yes, there should be an option in your BIOS Settings.
In addition, try to set your Graphics Output from "Automatic" to "PCI-E 1 Slot" (Maybe it will be named differently in your Bios settings).

What happens if you don't use -v ? Does your Display turn black, but the system is not rebooting? 

Share this post


Link to post
Share on other sites

Yes, there should be an option in your BIOS Settings.

In addition, try to set your Graphics Output from "Automatic" to "PCI-E 1 Slot" (Maybe it will be named differently in your Bios settings).

 

What happens if you don't use -v ? Does your Display turn black, but the system is not rebooting? 

I'll try when I get home from work. No -v, it just reboots.

Share this post


Link to post
Share on other sites

I'll try when I get home from work. No -v, it just reboots.

 

Hi,

 Have you fixed this issue ?. This is the same problem happening for me so please help me if you have found the solution.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×