Jump to content
nmano

[Guide] Mac OSX 10.12 and 10.13 with X99 Broadwell-E family and Haswell-E family

2,141 posts in this topic

Recommended Posts

Finally i was able to boot with Sierra last build thanks to nmano guide and help! I used nmano files, the updated one. Config.plist (i removed nvme last booted drive) and kexts. I've an X99 Deluxe USB3.1 board with unlocked msr 3301 bios.

Everything seems to run smootly, graphic card and xcpm but i noticed that not all usb3 ports are working. 

PS Thanks to my friend fabiosun too for helping me to setup files and for his big patience with me.

May I ask which drivers do you have in EFI/Clover/Drivers64 folder? If I warm boot, I get stuck on memory allocation, but a cold boot takes me through. I have the OsxAptioFixDrv-2000.efi

Share this post


Link to post
Share on other sites
Advertisement

May I ask which drivers do you have in EFI/Clover/Drivers64 folder? If I warm boot, I get stuck on memory allocation, but a cold boot takes me through. I have the OsxAptioFixDrv-2000.efi

To solve memory allocation probs i use OsxAptioFix2Drv-free2000.efi instead of OsxAptiodrv provided by clover. I got the same issue without the free2000 version.

Share this post


Link to post
Share on other sites

To solve memory allocation probs i use OsxAptioFix2Drv-free2000.efi instead of OsxAptiodrv provided by clover. I got the same issue without the free2000 version.

yeah that's the one I am using but warm boot always gets stuck. Are you facing this problem too? Also, what other drivers are you using (some might cause problems?)

Share this post


Link to post
Share on other sites

yeah that's the one I am using but warm boot always gets stuck. Are you facing this problem too? Also, what other drivers are you using (some might cause problems?)

I've DataHubDxe-64 - EmuVariableUefi-64 (mandatory for my board) - FSInject-64 - HFSPlus - OsxAptioFix2Drv-free2000 and OsxFatBinaryDrv-64

Share this post


Link to post
Share on other sites

Finally i was able to boot with Sierra last build thanks to nmano guide and help! I used nmano files, the updated one. Config.plist (i removed nvme last booted drive) and kexts. I've an X99 Deluxe USB3.1 board with unlocked msr 3301 bios.

Everything seems to run smootly, graphic card and xcpm but i noticed that not all usb3 ports are working. 

PS Thanks to my friend fabiosun too for helping me to setup files and for his big patience with me.

I have the same Mainboard. You have modded bios ore unlock msr with KernelPatch? If You have modded bios can you share the file? 

Share this post


Link to post
Share on other sites

I have the same Mainboard. You have modded bios ore unlock msr with KernelPatch? If You have modded bios can you share the file? 

I deleted the modded file but here there are guides how to patch bios with uefipatch...it's very simple. Here is the post:

http://www.insanelymac.com/forum/topic/285444-uefipatch-uefi-patching-utility/page-96?hl=%2Buefipatch&do=findComment&comment=2277274

Share this post


Link to post
Share on other sites

Fixed unsupported GPU Error After Effects with CUDA

1-Install Cuda

2-Edit  to raytracer_supported_cards.txt

Just add your device on top

GeForce GTX 970

GeForce GTX 285

GeForce GTX 675MX

GeForce GTX 680

GeForce GTX 680MX

GeForce GT 650M

Quadro CX

Quadro FX 4800

Quadro 4000

Quadro K5000

 

/Applications/Adobe After Effects CC 2015/Adobe After Effects CC 2015.app/Contents/Resources/raytracer_supported_cards.txt

 

 

Fast Draft: Available

 Texture Memory: 1638.00 MB

Ray-tracing: GPU

 

OpenGL

Vendor: NVIDIA Corporation

Device: NVIDIA GeForce GTX 970 OpenGL Engine

Version: 2.1 NVIDIA-10.13.65 367.15.10.05f01

Total Memory: 4.00 GB

Shader Model: -

CUDA

Driver Version: 8.0

Devices: 1 (GeForce GTX 970)

Current Usable Memory: 2.66 GB (at application launch)

Maximum Usable Memory: 4.00 GB

post-413859-0-91924000-1475327955_thumb.png

raytracer_supported_cards.txt

post-413859-0-15474000-1475328019_thumb.png

Share this post


Link to post
Share on other sites

Fabiosun,

 

I won't have time to check FW 3402 for a month since I will be out for business trip.

Will check it out once I get back.

 

hi nmano

could you check this?

Could you help to create a valid DSDT for my system?

I would like to know if using a correct DSDT produces different results on my rig

Thank you

Share this post


Link to post
Share on other sites

Hi Fliagd.

 

I was wondering if you can take a look at mine too, for dual CPU?

 

I keep getting kernel panic with 121 CPUS but when i shut off hyper treading I got 120 and can pass on to installation screen. I've tried playing with the DSDT and found SCK0-04 and not sure if thats responsible for passing wrong information to the kernel.

 

Thanks a lot,

 

Here is the original ACPI dump from clover.

origin.zip 

Share this post


Link to post
Share on other sites

Hi Fliagd.

 

I was wondering if you can take a look at mine too, for dual CPU?

 

 

Have you put VoodoTSCsync?

Share this post


Link to post
Share on other sites

that's the only

 

Have you put VoodoTSCsync?

 

Thats the only thing I haven't done. What would be the value for 2x 22 core cpus?

Share this post


Link to post
Share on other sites

that's the only

 

 

Thats the only thing I haven't done. What would be the value for 2x 22 core cpus?

try with tscsync to 21,

If that does not work,

try with 43 in tscsync

Share this post


Link to post
Share on other sites

Gimme a few min I'll test it out
Same thing.

Panic with hyper on:
7e3b506290e550e8d4d061e5233ab213.jpg

And without:
46a5838a47682a1f5dcb6c5b19fbbd37.jpg


What really confuses me is that between those two the first one have the double amount of processor ids, but what's funny is that I think os thinks we are in 2040 with 120 core cpus.

Can this be the dsdt issue?

 

 

on the side note, after I've managed to install, i get this, Terminal failes to open and GeekBench doesn't know what architecture it is running on.

 

Oh and on this board I have to specify the amount of memory I've got in the SMBIOS section otherwise it only detects 32gb out of 128.

post-6786-0-95951600-1475366320_thumb.jpg

Share this post


Link to post
Share on other sites

when you boot without hyper threading

What is displayed in "About This Mac"?

 

 

It show 2x the cpu but unknown, I'm working on installing it again, will have the screen shot the moment I'm on the system, but the problem is even with the hyper threading off, the system is unworkable, can't access terminal, and gets some random kernel crashes time to time. I've tried tweaking DSDT with the X99 patches and removing extra CPU stuff from it, but no luck.

Share this post


Link to post
Share on other sites

Have you put a Fake CPUID?

Yup: 0x040674

 

That's the only one that worked for me.

 

The weird thing is that fabiosun have the same CPU just a single one and different motherboard and it installs without a problem, I've even tried his config file just in case. Same results.

 

I guess there is something ether in dual cpus or in the motherboard.

Share this post


Link to post
Share on other sites

I think this is due to the number of cores 44x2
88 cores must exceed OSX capacity management
The motherboard is not in question


osX management capacity would 2F (47) so 48 cores (CP2F)

This is probably why you can not activate the hyper thearding

post-1181448-0-57359200-1475368350.png

Edited by Fljagd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×