Jump to content
nmano

[Guide] Mac OSX 10.12 and 10.13 with X99 Broadwell-E family and Haswell-E family

2,136 posts in this topic

Recommended Posts

I have pretty close mainboard to you

USB's all working?

Once I got USB 3 working (Wont work on el capitan though works for others with X99-A/Delux/etc my USB 2.0 now show as USB 3.0 and then 3.1 controller lol?

 

 

No audio

I also have no PCI table

by chance if you can post patch for DSDT so I can edit mine also :D

We need to get some patches going for Maciasl

cmanns, I'm not sure if your board is so similar to mine, but in my (recently updated with the latest BIOS from Asus), I use the following uefi bios settings to have usb working.

 

Intel xHCI Mode - Smart Auto

EHCI Legacy Support - Enable

xHCI Hand Off - Enable

EHCI Hand Off - Enable

 

Sound is working​ with voodoohda

 

All kext and drivers i use for my system, are above in the attached zip.

 

About dsdt and pci devices i don´t understand nothing, and that´s why asked for help…

Share this post


Link to post
Share on other sites
Advertisement

 

Thanks nmano, you are amazing!

Finally I can see the PCI devices, but one of them says it has no controller installed ... is something I can do, or is it normal?

Nmano, in my X-99 since El Cap until now I have always used for the sound onboard voodooHDA. I will have to continue use it or wiht the DSDT is no longer need?

And one more question, based on your knowledge, suggests that I make some changes in my clover folder, config.plist, drivers or kexts?

Thanks for everything.

Now i´m going update to PB7

 

And now, with the IMEI Controller in PCI Devices  :thumbsup_anim:

post-1313347-0-72068900-1472946800_thumb.png

Share this post


Link to post
Share on other sites

Hi José Luis

Asus X99 deluxe

Sound Card

Realtek® ALC1150 8 channels

Wifi

Broadcom Corp BCM20702A0

Network

Intel® I218V, 1 x Controladora de red Gigabit
Intel® I211-AT, 1 x Gigabit LAN

Video Card

NVIDIA GeForce

Archive.zip

Share this post


Link to post
Share on other sites

Kernel patched for just reboot fix 10.12 DP5 0x228f50© Pike R. Alpha

XCPM clover config patched.

If you disable clover patched AppleIntelCPUPowerManagement loaded.

This way worked xcpm and Apple intel.

 

excuse me nmano, what would i put in Clover Kernel to Patch for reboot fix.

 

Broadwell-E CPU and Sierra PB7

 

Sorry but totes noob over here

Share this post


Link to post
Share on other sites

10.12 (16A320) XCPM

I used same patched i edit Kernel

_xcpm_bootstrap Sierra © Pike R. Alpha

Find 83C3C483FB22

Replace 83C3C183FB22

 

_xcpm_pkg_scope_msr  © Pike R. Alpha

Find BE0700000031D2E894FCFFFF

Replace BE0700000031D29090909090

 

_xcpm_core_scope_msrs  © Pike R. Alpha

Find BE0200000031D2E86CFCFFFF

Replace BE0200000031D29090909090

 

xcpm performance fix 1 (wrsmr fix to get CPU max) © okrasit

Find 89D8C1E008B99901

Replace B800FF0000B99901  

 

XCPM_idle Replace All fix by Pike R. Alpha

Find 20B9E20000000F30

Replace 20B9E20000009090

Share this post


Link to post
Share on other sites

10.12 (16A320) XCPM

I used same patched i edit Kernel

_xcpm_bootstrap Sierra © Pike R. Alpha

Find 83C3C483FB22

Replace 83C3C183FB22

 

_xcpm_pkg_scope_msr  © Pike R. Alpha

Find BE0700000031D2E894FCFFFF

Replace BE0700000031D29090909090

 

_xcpm_core_scope_msrs  © Pike R. Alpha

Find BE0200000031D2E86CFCFFFF

Replace BE0200000031D29090909090

 

xcpm performance fix 1 (wrsmr fix to get CPU max) © okrasit

Find 89D8C1E008B99901

Replace B800FF0000B99901  

 

XCPM_idle Replace All fix by Pike R. Alpha

Find 20B9E20000000F30

Replace 20B9E20000009090

 

Thanks Nmano, unfortunately they don't seem to work for me, i still have to use FakeCPUID of 0x040674 to even boot.

 

Is there a Reboot fix kernel patch for Broadwell E/EP cpu and Sierra (GM?)

 

I've written to PikerAlpha on his Github and this is what i got back from him:

 

 

1.) Your BIOS does not set the lock bit for MSR(0xE2) and thus you don't need the _xcpm_idle patch.

2.) I would recommend to use FakeCPUID 0x040674 whenever possible. and not use the XCPM patches. Except for the reboot patch. Without a FakeCPUID you would of course need the XCPM patches.

3.) Then run FreqEditVectors.sh to inject the missing data. I used one of the plists of the iMac171,1

4.) The reboot patch can be replaced by other patches to stop the kernel (XCPM routines) from programming the following MSR's: 0x01A0, 0x01AA, 0x0620, 0x063A, 0x0642.

5.) I do not recommend to use the max turbo patches from okrasit as this basically reduces the meaning of XCPM to zero. You either want XCPM to function or keep using IOPPF: AppleIntelCPUPowerManagement mode.

This procedure works for other people. Me included. So why wouldn't it work for you? Perhaps you need to restore the factory vanilla kernel and possibly IOPlatformPluginFamily.kext as well. And start all over again. I simply fail to understand the problem. I would love to hear from people that solved it, but in my book this is due to user error. No pun intended.

Share this post


Link to post
Share on other sites

10.12 (16A320) XCPM

I used same patched i edit Kernel

_xcpm_bootstrap Sierra © Pike R. Alpha

Find 83C3C483FB22

Replace 83C3C183FB22

 

_xcpm_pkg_scope_msr  © Pike R. Alpha

Find BE0700000031D2E894FCFFFF

Replace BE0700000031D29090909090

 

_xcpm_core_scope_msrs  © Pike R. Alpha

Find BE0200000031D2E86CFCFFFF

Replace BE0200000031D29090909090

 

xcpm performance fix 1 (wrsmr fix to get CPU max) © okrasit

Find 89D8C1E008B99901

Replace B800FF0000B99901  

 

XCPM_idle Replace All fix by Pike R. Alpha

Find 20B9E20000000F30

Replace 20B9E20000009090

 

I have a doubt! The patch for XCPM is to be applied through the Clover Configurator right? If not, what is the correct way to apply it?

Share this post


Link to post
Share on other sites

I have a doubt! The patch for XCPM is to be applied through the Clover Configurator right? If not, what is the correct way to apply it?

I edit Kernel via Hex Fiend.app

 

The only thing I need and can not run is the onboard Creative plate SoundRecon3Di I think brings the CA-0132 chip

 

 

Hi fibrolco

I used this for 10.11 and 10.12

Creative-CA0132 Layout ID -9

AppleALC.kext.zip

Share this post


Link to post
Share on other sites

I edit Kernel via Hex Fiend.app

 

 

 

Hi fibrolco

I used this for 10.11 and 10.12

Creative-CA0132 Layout ID -9

Thanks nmano, i will try with Hex Fiend.

Share this post


Link to post
Share on other sites

10.12 (16A320) XCPM

I used same patched i edit Kernel

_xcpm_bootstrap Sierra © Pike R. Alpha

Find 83C3C483FB22

Replace 83C3C183FB22

 

_xcpm_pkg_scope_msr  © Pike R. Alpha

Find BE0700000031D2E894FCFFFF

Replace BE0700000031D29090909090

 

_xcpm_core_scope_msrs  © Pike R. Alpha

Find BE0200000031D2E86CFCFFFF

Replace BE0200000031D29090909090

 

xcpm performance fix 1 (wrsmr fix to get CPU max) © okrasit

Find 89D8C1E008B99901

Replace B800FF0000B99901  

 

XCPM_idle Replace All fix by Pike R. Alpha

Find 20B9E20000000F30

Replace 20B9E20000009090

 

Thanks nmano, it works for me. Now already with speedstep without Nullcpupowerm, FakeCpuID and VoodooTscsynk. Sorry nmano, I tried with Hex Fiend, but I and Hex Fiend not speak the same language and had to do it in Clover :P
In your opinion, should I keep active KernelPM on Clover or not?
Thank you

post-1313347-0-16374700-1473865505_thumb.png

post-1313347-0-92666200-1473865517_thumb.png

post-1313347-0-93204200-1473865526_thumb.png

Share this post


Link to post
Share on other sites

I did the update to 10.12 (16A322) and once again, everything went well. One more time just had to edit AppleGraphicsControl.kext and wi-fi  ;)

By the way, the XCPM patch continues to work well in this version and Sleep/Wake up too   :thumbsup_anim:

I am beginning to get bored of always running fine  :D

post-1313347-0-83349700-1473881073_thumb.png

post-1313347-0-48507000-1473881085_thumb.png

post-1313347-0-17847700-1473881092_thumb.png

post-1313347-0-87803700-1473881100_thumb.png

post-1313347-0-70133700-1473881400_thumb.png

post-1313347-0-65014400-1473881409_thumb.png

Share this post


Link to post
Share on other sites

Hi,

Are you sure that xcpm patch are working well?

 

System start but we all have a common problem if I see all IPG graphics

System does not reach low steps in idle if EIST is disabled.

This seems a common problem in all thread I can see and it is a "problem" for different kind of cpu (Haskell E EP or Broadwell E/EP)

 

But I am also happy of these results! :-)

 

 

I did the update to 10.12 (16A322) and once again, everything went well. One more time just had to edit AppleGraphicsControl.kext and wi-fi  ;)

By the way, the XCPM patch continues to work well in this version  :thumbsup_anim:

I am beginning to get bored of always running fine  :D

Share this post


Link to post
Share on other sites

Hi Fabio,

Yes I had noticed this fact. It works, but rarely goes down to minimum speed and because of this I also noticed that the temperature of the CPU increased a few degrees. And I also noticed that with the EIST OFF, consumption graph in the IPG crashes. After I published the prints, I have created a SSDT with imac14.2 vectors as advise doing, but with or without SSDT, the result seems to be always the same. With EIST ON and Nullcpu in Clover the graph comes more times the minimum speed (1.20), but does not work in turbo speed.
With EIST OFF and without Nullcpu in Clover, the XCPM work and reaches the turbo speed, but as I said, rarely drops to a minimum.
But there is no better, it is preferable works as having nothing.


Hi,

Are you sure that xcpm patch are working well?

 

System start but we all have a common problem if I see all IPG graphics

System does not reach low steps in idle if EIST is disabled.

This seems a common problem in all thread I can see and it is a "problem" for different kind of cpu (Haskell E EP or Broadwell E/EP)

 

But I am also happy of these results! :-)

 

Share this post


Link to post
Share on other sites

hello, all i just wanted to chime in and say i downloaded latest clover and ran the install over the top of my Sierra on my SSD (PB7) and now i have XCPM working properly with just the Rebootfix, thanks to Piker Alpha.

AppleIntelInfo.kext v1.8 Copyright © 2012-2016 Pike R. Alpha. All rights reserved

Settings:
------------------------------------------
logMSRs..................................: 1
logIGPU..................................: 0
logCStates...............................: 1
logIPGStyle..............................: 1
InitialTSC...............................: 0x285838719d8 (81 MHz)
MWAIT C-States...........................: 8480

Processor Brandstring....................: Intel(R) Core(TM) i7-6800K CPU @ 3.40GHz

Processor Signature..................... : 0x406F1
------------------------------------------
 - Family............................... : 6
 - Stepping............................. : 1
 - Model................................ : 0x4F (79)

Model Specific Registers (MSRs)
------------------------------------------

MSR_CORE_THREAD_COUNT............(0x35)  : 0x6000C
------------------------------------------
 - Core Count........................... : 6
 - Thread Count......................... : 12

MSR_PLATFORM_INFO................(0xCE)  : 0x20080C3BF3812200
------------------------------------------
 - Maximum Non-Turbo Ratio.............. : 0x22 (3400 MHz)
 - Ratio Limit for Turbo Mode........... : 1 (programmable)
 - TDP Limit for Turbo Mode............. : 1 (programmable)
 - Low Power Mode Support............... : 1 (LPM supported)
 - Number of ConfigTDP Levels........... : 1 (additional TDP level(s) available)
 - Maximum Efficiency Ratio............. : 12
 - Minimum Operating Ratio.............. : 8

MSR_PMG_CST_CONFIG_CONTROL.......(0xE2)  : 0x403
------------------------------------------
 - I/O MWAIT Redirection Enable......... : 1 (enabled, IO read of MSR(0xE4) mapped to MWAIT)
 - CFG Lock............................. : 0 (MSR not locked)
 - C3 State Auto Demotion............... : 0 (disabled/unsupported)
 - C1 State Auto Demotion............... : 0 (disabled/unsupported)
 - C3 State Undemotion.................. : 0 (disabled/unsupported)
 - C1 State Undemotion.................. : 0 (disabled/unsupported)
 - Package C-State Auto Demotion........ : 0 (disabled/unsupported)
 - Package C-State Undemotion........... : 0 (disabled/unsupported)

MSR_PMG_IO_CAPTURE_BASE..........(0xE4)  : 0x10414
------------------------------------------
 - LVL_2 Base Address................... : 0x414
 - C-state Range........................ : 1 (C6 is the max C-State to include)

IA32_MPERF.......................(0xE7)  : 0x11F721F962
IA32_APERF.......................(0xE8)  : 0x1094F7A244
MSR_0x150........................(0x150) : 0x52424

MSR_FLEX_RATIO...................(0x194) : 0xE0000
------------------------------------------

MSR_IA32_PERF_STATUS.............(0x198) : 0x226900002300
------------------------------------------
 - Current Performance State Value...... : 0x2300 (3500 MHz)

MSR_IA32_PERF_CONTROL............(0x199) : 0x2600
------------------------------------------
 - Target performance State Value....... : 0x2600 (3800 MHz)
 - Intel Dynamic Acceleration........... : 0 (IDA engaged)

IA32_CLOCK_MODULATION............(0x19A) : 0x0
IA32_THERM_STATUS................(0x19C) : 0x884E0000

IA32_MISC_ENABLES................(0x1A0) : 0x850089
------------------------------------------
 - Fast-Strings......................... : 1 (enabled)
 - Automatic Thermal Control Circuit.... : 1 (enabled)
 - Performance Monitoring............... : 1 (available)
 - Enhanced Intel SpeedStep Technology.. : 1 (enabled)

MSR_TEMPERATURE_TARGET...........(0x1A2) : 0x640A00
------------------------------------------
 - Turbo Attenuation Units.............. : 0 
 - Temperature Target................... : 100
 - TCC Activation Offset................ : 0

MSR_MISC_PWR_MGMT................(0x1AA) : 0x402000
------------------------------------------
 - EIST Hardware Coordination........... : 0 (enabled)

MSR_TURBO_RATIO_LIMIT............(0x1AD) : 0x2323232323232626
------------------------------------------
 - Maximum Ratio Limit for C01.......... : 26 (3800 MHz) 
 - Maximum Ratio Limit for C02.......... : 26 (3800 MHz) 
 - Maximum Ratio Limit for C03.......... : 23 (3500 MHz) 
 - Maximum Ratio Limit for C04.......... : 23 (3500 MHz) 
 - Maximum Ratio Limit for C05.......... : 23 (3500 MHz) 
 - Maximum Ratio Limit for C06.......... : 23 (3500 MHz) 

IA32_ENERGY_PERF_BIAS............(0x1B0) : 0x0

MSR_POWER_CTL....................(0x1FC) : 0x2104005B
------------------------------------------
 - C1E Enable............................: 1

MSR_RAPL_POWER_UNIT..............(0x606) : 0xA0E03
------------------------------------------
 - Power Units.......................... : 3 (1/8 Watt)
 - Energy Status Units.................. : 14 (61 micro-Joules)
 - Time Units .......................... : 10 (976.6 micro-Seconds)

MSR_PKG_POWER_LIMIT..............(0x610) : 0x7FFD00014EA82
------------------------------------------
 - Package Power Limit #1............... : 3408 Watt
 - Enable Power Limit #1................ : 1 (enabled)
 - Package Clamping Limitation #1....... : 0 (disabled)
 - Time Window for Power Limit #1....... : 10 (2560 milli-Seconds)
 - Package Power Limit #2............... : 4090 Watt
 - Enable Power Limit #2................ : 1 (enabled)
 - Package Clamping Limitation #2....... : 1 (allow going below OS-requested P/T state setting Time Window for Power Limit #2)
 - Time Window for Power Limit #2....... : 3 (20 milli-Seconds)
 - Lock................................. : 0 (MSR not locked)

MSR_PKG_ENERGY_STATUS............(0x611) : 0x3AC7B4E
------------------------------------------
 - Total Energy Consumed................ : 3761 Joules (Watt = Joules / seconds)

MSR_PKG_POWER_INFO...............(0x614) : 0x1700460
------------------------------------------
 - Thermal Spec Power................... : 140 Watt
 - Minimum Power........................ : 0
 - Maximum Power........................ : 0
 - Maximum Time Window.................. : 0

MSR_PP0_POWER_LIMIT..............(0x638) : 0x14FFD0
------------------------------------------
 - Power Limit.......................... : 4090 Watt
 - Enable Power Limit................... : 1 (enabled)
 - Clamping Limitation.................. : 0 (disabled)
 - Time Window for Power Limit.......... : 10 (10240 milli-Seconds)
 - Lock................................. : 0 (MSR not locked)

MSR_PP0_ENERGY_STATUS............(0x639) : 0x0

MSR_TURBO_ACTIVATION_RATIO.......(0x64C) : 0x0

MSR_PKGC3_IRTL...................(0x60a) : 0x0
MSR_PKGC6_IRTL...................(0x60b) : 0x0
MSR_PKG_C2_RESIDENCY.............(0x60d) : 0x60FA75686
MSR_PKG_C3_RESIDENCY.............(0x3f8) : 0x0
MSR_PKG_C2_RESIDENCY.............(0x60d) : 0x60FA75686
MSR_PKG_C6_RESIDENCY.............(0x3f9) : 0x1580ECC93C

IA32_TSC_DEADLINE................(0x6E0) : 0x28587BD735C

CPU Ratio Info:
------------------------------------------
Base Clock Frequency (BLCK)............. : 100 MHz
Maximum Efficiency Ratio/Frequency.......: 12 (1200 MHz)
Maximum non-Turbo Ratio/Frequency........: 34 (3400 MHz)
Maximum Turbo Ratio/Frequency............: 38 (3800 MHz)
P-State ratio * 100 = Frequency in MHz
------------------------------------------
CPU P-States [ (12) 30 35 ]
CPU C6-Cores [ 1 3 5 7 9 11 ]
CPU P-States [ 12 30 32 (34) 35 ]
CPU C6-Cores [ 0 1 2 3 4 5 7 8 9 11 ]
CPU P-States [ 12 22 30 32 (34) 35 ]
CPU P-States [ 12 22 30 31 32 34 (35) ]
CPU P-States [ (12) 22 28 30 31 32 34 35 ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 11 ]
CPU P-States [ (12) 22 27 28 30 31 32 34 35 ]
CPU P-States [ 12 22 23 27 28 30 31 32 34 35 (36) ]
CPU C6-Cores [ 0 1 2 3 4 5 6 7 8 9 10 11 ]
CPU P-States [ (12) 20 22 23 27 28 30 31 32 34 35 36 ]
CPU P-States [ (12) 20 22 23 24 27 28 30 31 32 34 35 36 ]
CPU P-States [ 12 20 22 23 24 26 27 28 30 31 32 (34) 35 36 ]
CPU P-States [ (12) 20 22 23 24 26 27 28 29 30 31 32 34 35 36 ]
CPU P-States [ 12 20 22 23 24 25 26 27 28 29 30 31 32 (34) 35 36 ]
CPU P-States [ 12 20 22 23 24 25 26 27 28 29 30 31 32 33 (34) 35 36 ]
CPU P-States [ (12) 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 ]

Share this post


Link to post
Share on other sites

No fakecpuid?

 

yes i have fakeCPUID but this is not a problem, i haven't tested without, will try maybe tonight.

 

But pikeralpha, told me to leave it in before, so i am not that worried.

 

I was going to reply to your thread Giacomoleopardo, but i thought maybe you dont have the computers anymore (gone to the film editing guys), I will link you to my EFI when i get a chance over the next couple of days, pm or email me your email and i will dropbox (same username here) @gmail.com

Share this post


Link to post
Share on other sites

Thanks! I no longer have the triplet, in fact, but still I'm on the topic with a lot of interest! Would you share here your EFI folder rather than private mail? I guess I'm not the only one interested in that. Oh, and any chance you tried your new config with 10.11.6 (of course with proper kernel patches)?

Share this post


Link to post
Share on other sites

No i haven't tried with new clover and patches, i think when Sierra gets released tomorrow i will download patch and just use that install from now on (i have less kexts and patches and it feels more vanilla)

 

Here's my link to EFI for anyone interested:

 

https://mega.nz/#!zREnSTgA!ool3mGJlFIqX9BXtSfRjvml-39bMc3jRO2dS4ZKcyNk

Share this post


Link to post
Share on other sites

can some of the successful people post a step by step guide? I either get to PCI configuration begin and it reboots, or doesn't go beyond the memory allocation (I have tried with Test2.efi + OsxAptioFixDrv2-64.efi/OsxAptioFixDrv-64.efi). Please help!

Share this post


Link to post
Share on other sites

can some of the successful people post a step by step guide? I either get to PCI configuration begin and it reboots, or doesn't go beyond the memory allocation (I have tried with Test2.efi + OsxAptioFixDrv2-64.efi/OsxAptioFixDrv-64.efi). Please help!

About memory allocation probs try OsxAptioFix2Drv-free2000.efi from here https://nickwoodhams.com/x99-hackintosh-osxaptiofixdrv-allocaterelocblock-error-update/ but put only this without other optio versions.

About KP you should check your system and change something in config.plist according to your system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×