Jump to content
kylon

Cloud Clover Editor (CCE) [Clover, Ozmosis, Chameleon, OpenCore]

121 posts in this topic

Recommended Posts

i would ask TheKing or bsod they are the devs for ozmosis the ozmosis thread

Share this post


Link to post
Share on other sites
Advertisement

the code seems fine

i downloaded the config from here and i manually added the section from here

no data was lost.

 

do you still have the affected plist?

also, can you try to fully clear your browser cache, please? a lof of files were changed in the cce bank commit.

 

PS: meanwhile, i added the new sip flag.

 

thanks

Share this post


Link to post
Share on other sites

i do not still have the affected defaults.plist but i asked bs0d to post a master Defaults.plist in oz thread it may help solve some issues. thx for updating.

Share this post


Link to post
Share on other sites

I hope CCE Bank does match your idea

 

Nice idea, thanks! Maybe you want to update your system requirement readme with +SQL?

Its hard to maintaining both 1st page & repos readme. I hope single link refer to official repos readme should be enough?

 

also, can you try to fully clear your browser cache, please?

 

Could you tell me what exact browser cache problem here, when & where? By adding some unique hash to url stlll cannot fix this problem?

Share this post


Link to post
Share on other sites

Nice idea, thanks! Maybe you want to update your system requirement readme with +SQL?

Its hard to maintaining both 1st page & repos readme. I hope single link refer to official repos readme should be enough?

 

Could you tell me what exact browser cache problem here, when & where? By adding some unique hash to url stlll cannot fix this problem?

 

You are right :P

updated.

 

I prefer to keep the readme as small as possible so it s easier to read, i added a link to this thread.

 

 

The browser usually saves css, html, js etc.. locally, and sometimes the cache is not updated, or at least it may requires some time (according to your browser, browser settings, usage).

 

Cce heavily rely on js, so, if your browser mix new stuff and old stuff, cce may not work as expected (especially if there are a lot of changes).

 

thanks

Share this post


Link to post
Share on other sites
<link rel="stylesheet" href="../style/css/cce.css?id=hash">
<script data-rocketsrc="../style/js/index.js?id=hash" type="text/rocketscript"></script>

What Im trying to purpose is: By appending "?id=hash" into your url assets. "Hash" can be your commit id, current date or anything as long its unique & auto generate after each updates.

Share this post


Link to post
Share on other sites

you might not be able to do this but if users are using MacPro smbios they need to omit any extra firmware related stuff to skip the board/ecc ram checks, here is an example of how to do it so it skips checks.

Defaults.plist.zip

Share this post


Link to post
Share on other sites

you might not be able to do this but if users are using MacPro smbios they need to omit any extra firmware related stuff to skip the board/ecc ram checks, here is an example of how to do it so it skips checks.

 

so, no fw features, features mask and fw revision?

 

cce does not know if you will use that config in 10.12 or 10.13 so i cannot delete your settings if you are using a macpro.

 

i could add a new setting that will delete and disable any fw field, if you think this is a good solution.

 

OT:

the ProcessorSerial key is new to me.

is it a plain copy of SystemSerial?

 

thanks

 

 

latest SMBIOS datas by Sherlocks are online.

Share this post


Link to post
Share on other sites

so, no fw features, features mask and fw revision?

 

cce does not know if you will use that config in 10.12 or 10.13 so i cannot delete your settings if you are using a macpro.

 

i could add a new setting that will delete and disable any fw field, if you think this is a good solution.

 

OT:

the ProcessorSerial key is new to me.

is it a plain copy of SystemSerial?

 

thanks

 

 

latest SMBIOS datas by Sherlocks are online.

 

above file, oz file? i think oz also has fw features, features mask in source. 

clover now use fw features, features mask regardless of model when booting. macpro6,1 too.  not sure whether macpro6,1 acutally need these keys or not

 

i think your cce is no problem in clover.

 

add. thank you for smbios update

Share this post


Link to post
Share on other sites

If i understood correctly the macpro cannot boot 10.13 if you set the fw stuff (ozmosis only), so the clover side should be fine.

Share this post


Link to post
Share on other sites
Hello, if you open through CCE config.plist then the structure breaks down:

before:


<key>Arbitrary</key>

<array>

<dict>

<key>Comment</key>

<string>Inject Intel HD properties</string>

<key>CustomProperties</key>

<array>

<dict>

<key>Key</key>

<string>AAPL,ig-platform-id</string>

<key>Value</key>

<data>

AAASWQ==

</data>

</dict>

</array>

<key>PciAddr</key>

<string>00:02.00</string>

</dict>

</array>


 

after:


<key>Arbitrary</key>

<array>

<dict>

<key>Comment</key>

<string>Inject Intel HD properties</string>

<key>CustomProperties</key>

<array>

<dict>

<key>Key</key>

<string>AAPL,ig-platform-id</string>

<key>Value</key>

<integer>1259</integer>

</dict>

</array>

<key>PciAddr</key>

<string>00:02.00</string>

</dict>

</array>

The video card stops working, correct this bug.

Share this post


Link to post
Share on other sites

taking a little break...

 

@ctich

fixed

 

@Sherlocks

what is the type of ChassisType? int or hex?

 

thanks

Share this post


Link to post
Share on other sites

A major update to cce bank is coming the next month.

 

Unfortunately, public configs from bank 1.0 are not compatible.

Please save your configs locally or pm me to update your old config.

 

A tool to update your private configs will be available soon.

 

No more breaking changes should happen in future updates.

 

Thanks

Share this post


Link to post
Share on other sites

Probably yes

 

Where can i find an up to date documentation, repo or branch and config? (If any)

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

Darwin_0002 is oldWay

 

OldWay is not supported anymore, but it should work.

 

No need to keep them both.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
    • By STLVNUB
      Script file to clone and help build Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
       
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
      Currently NDK Repo has problems so "all" and "n" DON'T WORK
       
      Easier typing bob than.....usual stuff
      Enjoy
       
    • By Kaisar870
      How to Add APPLE RTC PATCH 
      Could you please explain how to add Apple RTC patch in open core Plist? TIA
×