Jump to content
kylon

Cloud Clover Editor (CCE) [Clover, Ozmosis, Chameleon, OpenCore]

121 posts in this topic

Recommended Posts

i would ask TheKing or bsod they are the devs for ozmosis the ozmosis thread

Share this post


Link to post
Share on other sites
Advertisement

the code seems fine

i downloaded the config from here and i manually added the section from here

no data was lost.

 

do you still have the affected plist?

also, can you try to fully clear your browser cache, please? a lof of files were changed in the cce bank commit.

 

PS: meanwhile, i added the new sip flag.

 

thanks

Share this post


Link to post
Share on other sites

i do not still have the affected defaults.plist but i asked bs0d to post a master Defaults.plist in oz thread it may help solve some issues. thx for updating.

Share this post


Link to post
Share on other sites

I hope CCE Bank does match your idea

 

Nice idea, thanks! Maybe you want to update your system requirement readme with +SQL?

Its hard to maintaining both 1st page & repos readme. I hope single link refer to official repos readme should be enough?

 

also, can you try to fully clear your browser cache, please?

 

Could you tell me what exact browser cache problem here, when & where? By adding some unique hash to url stlll cannot fix this problem?

Share this post


Link to post
Share on other sites

Nice idea, thanks! Maybe you want to update your system requirement readme with +SQL?

Its hard to maintaining both 1st page & repos readme. I hope single link refer to official repos readme should be enough?

 

Could you tell me what exact browser cache problem here, when & where? By adding some unique hash to url stlll cannot fix this problem?

 

You are right :P

updated.

 

I prefer to keep the readme as small as possible so it s easier to read, i added a link to this thread.

 

 

The browser usually saves css, html, js etc.. locally, and sometimes the cache is not updated, or at least it may requires some time (according to your browser, browser settings, usage).

 

Cce heavily rely on js, so, if your browser mix new stuff and old stuff, cce may not work as expected (especially if there are a lot of changes).

 

thanks

Share this post


Link to post
Share on other sites
<link rel="stylesheet" href="../style/css/cce.css?id=hash">
<script data-rocketsrc="../style/js/index.js?id=hash" type="text/rocketscript"></script>

What Im trying to purpose is: By appending "?id=hash" into your url assets. "Hash" can be your commit id, current date or anything as long its unique & auto generate after each updates.

Share this post


Link to post
Share on other sites

you might not be able to do this but if users are using MacPro smbios they need to omit any extra firmware related stuff to skip the board/ecc ram checks, here is an example of how to do it so it skips checks.

Defaults.plist.zip

Share this post


Link to post
Share on other sites

you might not be able to do this but if users are using MacPro smbios they need to omit any extra firmware related stuff to skip the board/ecc ram checks, here is an example of how to do it so it skips checks.

 

so, no fw features, features mask and fw revision?

 

cce does not know if you will use that config in 10.12 or 10.13 so i cannot delete your settings if you are using a macpro.

 

i could add a new setting that will delete and disable any fw field, if you think this is a good solution.

 

OT:

the ProcessorSerial key is new to me.

is it a plain copy of SystemSerial?

 

thanks

 

 

latest SMBIOS datas by Sherlocks are online.

Share this post


Link to post
Share on other sites

so, no fw features, features mask and fw revision?

 

cce does not know if you will use that config in 10.12 or 10.13 so i cannot delete your settings if you are using a macpro.

 

i could add a new setting that will delete and disable any fw field, if you think this is a good solution.

 

OT:

the ProcessorSerial key is new to me.

is it a plain copy of SystemSerial?

 

thanks

 

 

latest SMBIOS datas by Sherlocks are online.

 

above file, oz file? i think oz also has fw features, features mask in source. 

clover now use fw features, features mask regardless of model when booting. macpro6,1 too.  not sure whether macpro6,1 acutally need these keys or not

 

i think your cce is no problem in clover.

 

add. thank you for smbios update

Share this post


Link to post
Share on other sites

If i understood correctly the macpro cannot boot 10.13 if you set the fw stuff (ozmosis only), so the clover side should be fine.

Share this post


Link to post
Share on other sites
Hello, if you open through CCE config.plist then the structure breaks down:

before:


<key>Arbitrary</key>

<array>

<dict>

<key>Comment</key>

<string>Inject Intel HD properties</string>

<key>CustomProperties</key>

<array>

<dict>

<key>Key</key>

<string>AAPL,ig-platform-id</string>

<key>Value</key>

<data>

AAASWQ==

</data>

</dict>

</array>

<key>PciAddr</key>

<string>00:02.00</string>

</dict>

</array>


 

after:


<key>Arbitrary</key>

<array>

<dict>

<key>Comment</key>

<string>Inject Intel HD properties</string>

<key>CustomProperties</key>

<array>

<dict>

<key>Key</key>

<string>AAPL,ig-platform-id</string>

<key>Value</key>

<integer>1259</integer>

</dict>

</array>

<key>PciAddr</key>

<string>00:02.00</string>

</dict>

</array>

The video card stops working, correct this bug.

Share this post


Link to post
Share on other sites

taking a little break...

 

@ctich

fixed

 

@Sherlocks

what is the type of ChassisType? int or hex?

 

thanks

Share this post


Link to post
Share on other sites

A major update to cce bank is coming the next month.

 

Unfortunately, public configs from bank 1.0 are not compatible.

Please save your configs locally or pm me to update your old config.

 

A tool to update your private configs will be available soon.

 

No more breaking changes should happen in future updates.

 

Thanks

Share this post


Link to post
Share on other sites

Probably yes

 

Where can i find an up to date documentation, repo or branch and config? (If any)

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

Darwin_0002 is oldWay

 

OldWay is not supported anymore, but it should work.

 

No need to keep them both.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By STLVNUB
      Script file to clone and help build Clover, Opencore (official and unofficial) repos
      Script will create link to itself in /usr/local/bin/bob
      Wouldn't hurt to check there are no "Bob"'s there, i "Hope" there isn't.
      Then you only need to type bob. and a parameter
      "n" for NDK repo, unofficial
      "a" for ACID repo, official
      "c" for CLOVER
      It also takes "all" for ALL, if your game
       
      Easier typing bob than.....usual stuff
      Enjoy
       
    • By MaLd0n
      -Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -Donations with Bitcoin
      33HeGCuCSh4tUBqdYkQqKpSDa1E7WeAJQ3
       
      -Donations with PicPay 
      @danielnmaldonado
       
      ---TUTORIAL---
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Original Post--
      https://www.olarila.com/topic/6531-olarila-hackbeast-z390-designare-thunderbolt-full-dsdt-patches-clover-opencore/
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://www.olarila.com/topic/6364-mojave-catalina-on-mobos-series-100200300-with-opencore-bootloader/
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By heiza
      Ryzen 7 2700X
      ASUS Prime X470 Pro
      32GB G.Skill Ripjaws V DDR4-3200
      ASRock Phantom Gaming Vega 56
       
      My motherboard doesn’t have an option for 4G encoding. And boot modes are listed as ”Windows UEFI Mode” and “Other OS”.
       
×