Jump to content
kylon

Cloud Clover Editor (CCE) [Clover, Ozmosis, Chameleon, OpenCore]

121 posts in this topic

Recommended Posts

Advertisement

Now i found another bug when i generate a SMBIOS.

 

Family is "Macbook Pro" not "MacbookPro" with no space between this 2 words.

Share this post


Link to post
Share on other sites

ok i checked clover wiki.

 

<key>Family</key>
<string>MacBookAir</string>

 

it seens Clover Configurator Error.

 

Thanks for your work.

:D  :D  :D

Share this post


Link to post
Share on other sites

Hi kylon.

 

I found the Family in SMBIOS should have a space between Macbook and Pro/Air.

 

Look Here

https://sourceforge.net/p/cloverefiboot/code/3948/tree//rEFIt_UEFI/Platform/platformdata.c#l369

 

Clover sourcecode showed family data.

 

thanx for your hard work.

Share this post


Link to post
Share on other sites

Hi kylon.

 

I have found another smbios update.

 

Macbook Pro 8,1 BootROM is MBP81.88Z.0047.B2C.1510261540 rather than MBP81.88Z.0047.B2A.1506082203.

 

Hope you may fix it.

 

Thanks.

Share this post


Link to post
Share on other sites

Hi kylon.

 

I have found another smbios update.

 

Macbook Pro 8,1 BootROM is MBP81.88Z.0047.B2C.1510261540 rather than MBP81.88Z.0047.B2A.1506082203.

 

Hope you may fix it.

 

Thanks.

Seemed that this caused nothing on our hackintosh build cuz we are not real Macs and thus we don't need it. And using a legacy version can make everything work well too.

Note that this will not cause annoying SMC update. A SMC update is only related to a wrong SMC version.

Share this post


Link to post
Share on other sites

Seemed that this caused nothing on our hackintosh build cuz we are not real Macs and thus we don't need it. And using a legacy version can make everything work well too.

Note that this will not cause annoying SMC update. A SMC update is only related to a wrong SMC version.

 

You are wrong.

 

If BootROM is lower it will always download Firmware on our EFI/Apple and can't reduce it.

 

So,It's better to update it.

 

I know it maybe have no need on hackitonsh but way not make our laptop more perfect?

Share this post


Link to post
Share on other sites

You are wrong.

 

If BootROM is lower it will always download Firmware on our EFI/Apple and can't reduce it.

 

So,It's better to update it.

 

I know it maybe have no need on hackitonsh but way not make our laptop more perfect?

Nope. SMC Firmware update is just related to SMC version settings that is controlled by FakeSMC.

Since you are using a hackintiosh build and then you don't use real Mac's BIOS. So this can do nothing. It may just change some entries in System Report. Nothing more.

Share this post


Link to post
Share on other sites

Nope. SMC Firmware update is just related to SMC version settings that is controlled by FakeSMC.

Since you are using a hackintiosh build and then you don't use real Mac's BIOS. So this can do nothing. It may just change some entries in System Report. Nothing more.

 

First,i know you mean.

 

I want to say SMC Rev is nothing with our hackintosh but it can make our hackintosh looks more comfortable,aren't they?just like you dress beautiful clothes.

 

But the BootROM is related to our hackintosh because if BootROM is not updated,the macOS will download the firmware automaticly to "EFI/Apple/Firmware" and will also download if you delete it.so the BootROM is needed for our hackintosh and the smc rev can make our hackintosh more like a native macOS and more comfortable,so i suggest to update it.

 

So,please stop it.

 

Thanks.

Share this post


Link to post
Share on other sites

First,i know you mean.

 

I want to say SMC Rev is nothing with our hackintosh but it can make our hackintosh looks more comfortable,aren't they?just like you dress beautiful clothes.

 

But the BootROM is related to our hackintosh because if BootROM is not updated,the macOS will download the firmware automaticly to "EFI/Apple/Firmware" and will also download if you delete it.so the BootROM is needed for our hackintosh and the smc rev can make our hackintosh more like a native macOS and more comfortable,so i suggest to update it.

 

So,please stop it.

 

Thanks.

I think you got misplaced.

SMC Rev is an SMC Key, if this is not latest then will get an update about SMC firmware update. You can fix this by editing FakeSMC/C*/Info.plist. And kozlek's fork of FakeSMC can get a proper key via Clover.

BootROM is just a useless but necessary part located in SMBios part. If this is wrong then will cause nothing.

Share this post


Link to post
Share on other sites

hello kylon.

 

I have found you commit some data about smbios.

post-1140626-0-70328100-1480857925_thumb.png

 

MacBookPro8,1 smc rev is 1.69f4 not 1.68f99.

 

https://sourceforge.net/p/cloverefiboot/code/3945/tree//rEFIt_UEFI/Platform/platformdata.c#l803

you can change smbios data according this page.

post-1140626-0-29042600-1480857967_thumb.png

 

https://support.apple.com/zh-cn/HT201518this page some data are not updated.

Share this post


Link to post
Share on other sites

It is changed in commit 3953

You're right.

 

I checked macbookpro8,1 8,2 8,3 from official smc files.

 

Clover platformdata has correct data.

 

나의 LG-F410S 의 Tapatalk에서 보냄

hello kylon.

 

I have found you commit some data about smbios.

attachicon.gifQQ20161204-0@2x.png

 

MacBookPro8,1 smc rev is 1.69f4 not 1.68f99.

 

https://sourceforge.net/p/cloverefiboot/code/3945/tree//rEFIt_UEFI/Platform/platformdata.c#l803

you can change smbios data according this page.

attachicon.gif3.png

 

https://support.apple.com/zh-cn/HT201518this page some data are not updated.

You have to use 8,2 smbios if you want 69f04

 

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

You're right.

 

I checked macbookpro8,1 8,2 8,3 from official smc files.

 

Clover platformdata has correct data.

 

나의 LG-F410S 의 Tapatalk에서 보냄

You have to use 8,2 smbios if you want 69f04

 

나의 LG-F410S 의 Tapatalk에서 보냄

Thanks very much for your hard work.

 

 

从我的 iPhone 发送,使用 Tapatalk

Share this post


Link to post
Share on other sites

Thank you for update smbios all mac models. We can see model information easily now :)

 

Have a nice day.

 

Add. I see MacBookPro13,3 has not graphic information in Your update. Only have HD530

 

Have to include Radeon Pro 450, 455, 460 info.

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

@Sherlocks

thanks - added.

 

There s a new link in op (altervista)

It is faster and it should be more stable than sf.

Thanks.

 

I updated firmware information in latest clover commit.

 

I want to take a point. That is bios date.

Some apple products use other format.

Month/day/year.

 

Year format important.

You can see what i said in latest commit.

 

Sorry my english.

 

Have a nice day

 

나의 LG-F410S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites

hello @kylon

 

i want to help smbios info

 

first.

Location In Chassis

 

all models has "Part Component"

 

imac13,3 detail specs

here

http://www.everymac.com/systems/apple/imac/specs/imac-core-i3-3.3-21-inch-aluminum-early-2013-education-specs.html

 

everymac inform 13,1 product name, but it's wrong. anyway you need to write spec from link above

 

macbookpro13,3 has AMD Radeon Pro 450 / AMD Radeon Pro 455 / AMD Radeon Pro 460. right. also HD 530 

http://www.apple.com/uk/macbook-pro/specs/

 

Merry Christmas :)

 

add. Macbook 1,2 -> MacBook Pro 1,2

post-980913-0-71627100-1482681992_thumb.png

Share this post


Link to post
Share on other sites

Merry Christmas

 

@Sherlocks

Your help is much appreciated :)

Can you explain "part component"?

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By datta0
      Hi, I have a small problem with my Open core Hackintosh build.
      I actually got EFI from someone on the internet and tweaked it a bit so I could get up and running.
      Here is my EFI.
      My laptop boots fine but while booting, it shows the apple logo for the first 5 seconds, then goes blank for 2-3minutes and then I see apple login screen.
      This happens every time. I tried a few config edits but didn't work.
      Can someone look into my EFI and suggest any necessary changes that can improve boot times?

      Thanks in advance 
    • By Raffay1234
      I'm transitioning from Clover to Opencore. I thought the process will be simpler but it turns out it isn't. I have created a bootable Catalina USB with Opencore but stuck at this error. I have attached my EFI and the verbose output. Anyone please provide some guidance please?
       
      The laptop is HP Pavilion 15 Gaming:
      Intel Core i7-9750H
      16GB RAM
      256GB SSD + 1TB SSD
      PS2 Keyboard + I2C Trackpad
       

      EFI.zip
    • By rawmassen
      Hi there,
       
      If anyone could help I'd be very grateful, I'm trying to move from Clover to OC but have hit a brick wall for the last 2 days.
       
      It's an ACPI table error: SB_.PCIO.XHC_RHUB.HS11, Namespace lookup failure.
       


      Skylake Build:
      OpenCore 0.5.9
      Mojave 10.14.6, iMac17,1
      Asus Maximus Hero VIII
      6700K
       
      I've attached the config.plist and ACPI folder.
       
      EFI Drivers: OpenRuntime.efi and HfsPlus.efi
      Kexts: IntelMausi, Lilu, VirtualSMC, Whatevergreen
       
      Things I've tried...
       
      1) Clearing NVRAM (as it was previously booted by Clover)
       
      2) Hackintool USB Mapping: both the SSDT files and the USBPorts.kext
       
      3) USBInjectAll.kext (with and without SSDT files)
       
      4) SSDT-RHUB.aml. This seems to be directly involved, spent a long time with this but with no luck.
       
      I followed this guide:
       
      https://dortania.github.io/Getting-Started-With-ACPI/Universal/rhub-methods/manual.html
       
      Everything is XHC in my DSDT, except these definitions at the top (line 72 and 73):
       
          External (_SB_.PCI0.XHC_.DUAM, MethodObj)    // Warning: Unknown method, guessing 0 arguments     External (_SB_.PCI0.XHC_.RHUB.INIR, MethodObj)    // Warning: Unknown method, guessing 0 arguments  
      So I edited the SSDT-RHUB.dsl to this:
       
      /* * Goal of this SSDT is to shut off the RHUB to force macOS into * manually building ports when the ACPI is screwed up */ DefinitionBlock ("", "SSDT", 2, "DRTNIA", "RhubOff", 0x00001000) { External (_SB_.PCI0.XHC.RHUB, DeviceObj) // Full pathing to RHUB, change to yours Scope (_SB.PCI0.XHC.RHUB) // Full pathing to RHUB, change to yours { Method (_STA, 0, NotSerialized) { If (_OSI ("Darwin")) { Return (Zero) // This disables the device only in macOS } Else { } } } } Which results in this AML version:
      DefinitionBlock ("", "SSDT", 2, "DRTNIA", "RhubOff", 0x00001000) { External (_SB_.PCI0.XHC_.RHUB, DeviceObj) Scope (_SB.PCI0.XHC.RHUB) { Method (_STA, 0, NotSerialized) // _STA: Status { If (_OSI ("Darwin")) { Return (Zero) } Else { } } } } But I get the same error. 
       
      I'm at a complete loss, can anyone help?
       
       
      config.plist
      ACPI.zip
    • By nyichiban1
      So I got some new hardware:
      Asus Z490I Gaming ITX
      NZXT H1 Case
      Intel i9-10900
      samsung 970 EVO plus NVME
      SK Hynix 1TB SSD
      32GB G.Skill 3200 C14 Ram
      MSI 5700 XT Evoke
       
      So I got windows installed and wanted to install macOS using opencore. I had no luck getting past the [EB|#LOG:EXITBS:START] error and decided to use someone else's EFI who had the same motherboard minus the CPU and GPU (i7-10700k and Radeon VII). I went ahead with that EFI and voila got it to install and got past the error I had. The issue was after the install there is a reboot and that's where it hangs and give me an error log that I attached. Tried a few more things to see what I could do but was stuck on that error log every single time. Decided to try again today and now I can't get past the original error log. I've looked at the dortania guide for that error and tried everything it suggested but still won't get past the error. Not sure what else to do but to try Clover maybe. Anyone have any suggestions? I've attached my EFI as well. Thanks in advance.
      Installer_Log_8-Jul-2020.txt
      EFI.zip
    • By CaccapoKissima
      Hi, I wanted to transpose my CLOVER installation to OpenCore for future updates.
       
      I followed this guide and after some googling
      https://github.com/dortania/vanilla-laptop-guide
      I've fixed the LOG: EXITBS error (RANDOM SEED like error).
      Now I still receiving the IOPCI error (kernel_task kernel panic). 
       
      My CLOVER is fully working.
      - Backlight and Monitor
      - Trackpad
      - i7-7700HQ
      - Battery Patch
      - Camera and Audio (B&O)
      - Keyboard
      - dGPU GTX 1050 is turned off
       
      On OpenCore I translated everything except the battery (I just need to apply the If statement in ACPI), but I want first to boot on Mac OS using the OpenCore.
       
      HP Pavilion Power 15 
       
       
      config.plist

×