Jump to content
Sign in to follow this  
Followers 0
imjohnjo

Problema con Audio en El Capitan 10.11.5 Gigabyte Z97X Gaming 3

33 posts in this topic

Recommended Posts

Buenas a todos/as! Soy nuevo en el foro, este es mi primer tema.

 

Hace una semana pude hacer upgrade de hardware y eso me dio pie para armarme mi primera Hackintosh!

Paso antes que nada a describirles mi Hard:

 

CPU: i5 4690k

MB: Gigabyte Z97X Gaming 3 (BIOS F7)

RAM: Kingston 10GB DDR3 1333

HD: Western Digital  320gb

VGA: Nvidia GTX 970 OC 4GB

 

PSU: Coolermaster GX 750

 

 

Como se imaginaran al ser mi primera vez, no tengo idea de comandos, ni kexts, etc etc... Sin embargo logre llegar a instalar OSX El Capitan 10.11.5 casi completamente.

Me guie por varios tutoriales. La configuración de hard, la elegí en base a las guías de Tony, y el tutoríal de instalación del canal Cat&Andrew, ese video puntualmente. Solo que yo NO use la opción Inject Nvidia, ni tampoco instale el SMBios, después les explico donde lo instale.

 

Después de instalar el OSX, vi por foros que para instalar el driver de mi gtx970, debía descargar el web driver para 10.11.5, apagar la pc, sacar la placa de video, instalar al driver sin la placa y cuando lo instale, recién apague la pc, conectar la placa de video y recién ahí arrancar el sistema. Hice "EXACTAMENTE ESO". Al momento de iniciar, terminaba de cargar el logo de apple y se reiniciaba la pc, y así indefinidamente, le puse el bootflag nv_disable=1 y ahí entro y la reconocia a la placa todo bien, entonces ahí instalo el SMBios "iMac (15,1) - i7-4790k (27 inch Retina)"  este ultimo lo hizo ya con clover desde el archivo "config.plist" que esta dentro de la partición EFI al montarla con clover, guardo los cambios, reinicio y ahí ya entraba con la gtx970 a full jajaja, después de eso vi que decían que era mas compatible el SMBios "iMac (14,2) - i5-4670/i7-4771 (Hashwell)" así que instale ese, reinicie y entro sin problemas así que lo deje ahí nomas ya.

 

 

En fin, después de instalar todo esto me doy cuenta que no tengo audio, pero yo SI había instalado con El .######., mi driver de audio que es el "ALC1150", sin embargo no tenia audio ni me aparecía en Preferencias de Sistema para cambiar el dispositivo de salida. Desde ahí comenze a buscar como instalar el driver de audio, y encontré estos archivos: corri "audio_codecdetect_v1.6-3.command" y me decía que no detectaba dispositivos de sonido, que revise si estaba instalado y habilitado en la Bios, y eso esta todo OK, después intente instalar por Clover (montando la partición EFI"audio_cloverALC-110_v1.0r10.command" pero me da error y comienza a decirme "entry does not exist" infinitamente sin hacer nada mas. Y por ultimo instale "audio_realtekALC-110_v1.0o1.command" sin abrir Clover, ni montar la partición EFI, y después copie dentro de la carpeta EFI/CLOVER/KEXTS/10.11, los archivos que se descomprimen al instalar el "audio_realtekALC-110_v1.0o1.command" que se llaman: "AppleHDA-orig.kext" y "AppleHDA.kext" Sin resultado positivo todavía..

 

Y ya hoy a la mañana encontré la Guía del amigo Trapezita (nose como etiquetarlo jajaja)... Pero tampoco pude solucionarlo

 

Ya para terminar, como no podia solucionar el tema del audio, me pase a ver como podía cambiar la resolución de mi monitor (TV LCD 32" Full HD) que lo tengo conectado por cable VGA y me daba como máximo una resolución de 1600x1200 y no podía ponerlo a 1920x1080. Sin instalar nada le conecte un cable HDMI y ahí si podía cambiar la resolución a 1080p, pero se veía muy feo, estaba a 1080p con un refresco de 60 hercios pero se veía como si tuviera una refresco de 25 hercios, todo saturado y como con dientes de sierra en todas las lineas. Este problema ya lo tenia en Windows, probé con otros cables HDMI, cambiando drivers y nada...  al final lo solucione usando el cable VGA, por eso hizo lo mismo en OSX... Entonces buscando encontre la app SwitchResX4, que es de pago, pero baje la versión de prueba y con eso pude cambiar a 1080p por cable VGA, pero después de eso tengo el problema que cada vez que enciendo la pc o reinicio para hacer efectivo el cambio de la instalación de alguna app del AppStore por ejemplo, la pc cuando termina la carga del logo se reinicia, y así 2, 3 o hasta 4 veces máximo. y ahí entra al sistema pero mostrándome un aviso de que el sistema se apago por un problema . Suponiendo que SwitchResX4 era el problema lo borre de la carpeta de descargas y del escritorio, porque no se instalo, sino que se ejecuto y abrio una carpeta en el escritorio con una app que decía SwitchResX4 Panel... Eso es lo que borre, pero después de borrarlo, sigo con el mismo problema al iniciar la pc, pero la pc quedo en 1920x1080 a pesar de que en preferencias del sistema, en el apartado de pantalla, no me aparece la resolución para 1080p, y como titulo de la ventana dice así:

 

IMAGEN

 

Bueno eso seria todo jajaja... Perdón por ser muy extenso pero, no entiendo mucho del tema y para ser lo mas claro posible lo hago así. Espero puedan ayudarme desde ya muchas gracias!

Share this post


Link to post
Share on other sites
Advertisement

Hola, podrías crear un reporte completo de DarwinDumper para poder estudiar mejor tu hardware y configuración del sistema? Has eliminado todo rastro de parches de audio antes de usar la guía de Trapezita? El reporte de DD debería mostrar si queda algún remanente.

Share this post


Link to post
Share on other sites

Hola, podrías crear un reporte completo de DarwinDumper para poder estudiar mejor tu hardware y configuración del sistema? Has eliminado todo rastro de parches de audio antes de usar la guía de Trapezita? El reporte de DD debería mostrar si queda algún remanente.

Hola Maniac10! No se como se elimina todo rastro de instalación de patches... Voy a intentar hacer el reporte que me decis y lo subo aquí. Cual descargo de los archivos, el repository o el darwindumper solo?

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Hola imjohnjo

 

Recuerdo que cuando escribiste en mi tutorial, te pedí que agregues tu hardware para una respuesta concreta y que a su vez menciones la guía que seguiste.

 

Lo bueno de todo eso, si recién estás entrando al mundo del hackintosh, es que tienes una configuración Haswell (por tu procesador).

Para nuestra enorme suerte, Rampagedev, que es Local Moderator de acá, se tomó el trabajo de hacer SSDT de muchas mainboard.

Usa su método, instala de vuelta todo y olvídate de Tony que es la guía que seguiste (la del video).

 

Guía
http://www.rampagedev.com/?page_id=144

 

SSDT

http://www.rampagedev.com/?page_id=50

 

Las probabilidades de que funcione perfecto tu hack siguiendo sus pasos son del 100% en Yosemite.

Para El Capitan un 98%.

El 1% en contra, si en caso tu USB installer se cuelga al instalar El Capitan, es porque debes cambiar un driver del USB de la carpeta "Drivers64UEFI". Este driver es el OsxAptioFix2Drv-64.efi, este debe ir en lugar del OsxAptioFixDrv-64.efi (No ambos juntos). Cuando instalas con Clover lo eliges.

Y el otro 1% es que los USB 3.0 te reconocen como 2.0.

Con El Capitan, los puertos USB 3.0 presenta "probemillas", entonces hay varias maneras de corregirlo. El propio Rampagedev te incluye un SSDT-1 beta para solucionar esto. Pero esos detalles lo resolvemos acá en caso de que no te funcionen.

 

Usando su SSDT, que está hecho para tu mainboard en específico, podrás morir en paz.

Yo he usado su SSDT para mi modelo de mainboard por 2 años y aún sigo secándome las lágrimas de lo bien que funciona. 

 

Seguro has leído y visto que muchos hacen, pretenden, sueñan o quieren hacer un DSDT para que su sistema les funcione como de fábrica, tu no lo necesitas si usas su SSDT, éste ya contiene todo lo que necesita tu hardware.

Esta foto es una captura de su DMG, así que corriste con suerte.

 

081.png  E9F.png

 

Olvidé mencionar.

 

Como te dije, si sigues su guía, todo funciona perfecto, pero si quieres instalar el audio siguiendo el tutorial de Audio Nativo en Clover, has todo lo que diga su guía excepto la parte del audio, ahí usas la mía.

Rampagedev usa el script de Toleda.

 

Cosas a saber:

Usando la guía de Rampagedev, todos los kexts se instalarán en /Sistema /Librería/ Extensions.

Si eres nuevo, sigue al pie de la letra, ya cuando funcione, te aventuras a volver a instalar y poner los kexts en la partición EFI. 

Se pueden instalar los kexts tanto en /Sistema /Librería/ Extensions como en la partición EFI, /Clover /kexts /10.xx o /Clover /kexts /Others.

Cualquiera de las dos son correctas.

Share this post


Link to post
Share on other sites

Hola imjohnjo

 

Recuerdo que cuando escribiste en mi tutorial, te pedí que agregues tu hardware para una respuesta concreta y, a su vez, nos menciones la guía que seguiste.

 

Lo bueno de todo eso, si recién le estás armando, es que tienes una configuración Haswell (por tu procesador).

Para nuestra enorme suerte, Rampagedev, que es Local Moderator de acá, se tomó el trabajo de hacer SSDT de muchas mainboard.

Usa su método, instala de vuelta todo y olvídate de Tony que es la guía que seguiste (la del video).

 

Guía

http://www.rampagedev.com/?page_id=144

 

SSDT

http://www.rampagedev.com/?page_id=50

 

Las probabilidades de que te funcione perfecto tu hack siguiendo sus pasos son del 100% en Yosemite.

Para El Capitan un 98%.

1%, si en caso tu USB installer se cuelgue al instalar El Capitan, debes cambiar un driver del USB, de la carpeta "Drivers64UEFI". Este driver es el OsxAptioFix2Drv-64.efi, que debe ir en lugar del OsxAptioFixDrv-64.efi.

El otro 1% son que los USB 3.0 que te reconozcan como 2.0.

Con El Capitan los puertos USB 3.0 hay "probemillas", entonces hay varias maneras de corregirlo. El propio Rampagedev te incluye un SSDT-1 beta para solucionar esto. Pero esos detalles lo resolvemos acá en caso de que no te funcionen.

 

Usando su SSDT que está hecho para tu mainboard en específico, podrás morir en paz.

Yo he usado su SSDT para mi modelo de mainboard por 2 años y aún sigo secándome las lágrimas de lo bien que funciona. 

 

Seguro has leído y visto que muchos hacen un DSDT para que su sistema les funcione como de fábrica, tu no lo necesitas si usas su SSDT, éste ya contiene todo lo que tu hardware necesita.

Esa una foto captura de su DMG, así que corriste con suerte.

 

081.png  E9F.png

 

Olvidé mencionar.

 

Como te dije, si sigues su guía, todo funciona perfecto, pero si quieres instalar el audio siguiendo el tutorial de Audio Nativo en Clover, has todo lo de la guía de Rampagedev excepto la parte del audio.

El igual usa el script de Toleda.

Gracias Amigo! No entiendo que es lo de SSDT ni DSDT jajaja... Entonces borro y formateo todo me decis vos y comienzo de 0?

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Para no entrar en explicaciones, Maniac10 seguro lo hará de manera técnica, un DSDT o SSDT vienen a ser como el Arca de la Alianza o el Santo Grial, lo que Indiana Jones, los nazis y todos los que hacen hackintosh buscan para tener la gracia de Dios y vida eterna en sus configuraciones.

Eso en resumen.

 

Pero acá está la parte teórica para que leas.

http://www.insanelymac.com/forum/topic/298027-guide-aio-guides-for-hackintosh/

 

B98.png

 

 

Ah, en tema de hacer una nueva instalación. 

Es mejor, sí.

Share this post


Link to post
Share on other sites

Hola Maniac10! No se como se elimina todo rastro de instalación de patches... Voy a intentar hacer el reporte que me decis y lo subo aquí. Cual descargo de los archivos, el repository o el darwindumper solo?

 

La aplicación sola, no hace falta el repositorio a menos que quieras compilarla tu mismo :P. Si vas a comenzar una instalación nueva no te preocupes por el reporte, primero reinstala y luego si tienes problemas lo haces y subes el zip resultante (debes seleccionar "Archive as zip" en el programa).

 

Que tengas suerte!

 

 

EDITO: En la wiki de Clover, mas allá de hablar sobre el bootloader en sí, también explica superficialmente otros temas relacionados al hackintosh.

Edited by Maniac10

Share this post


Link to post
Share on other sites

Hola Trapecista! Sabes que siguiendo la guía que me pasaste tengo una duda. Cuando abro el comando Clover.command, se me abre le terminal, pongo la contraseña y se sale el terminal, después quiero volver a abrirlo y se abre y cierra la aplicacion.... y la otra pregunta es en que momento se copian todos los archivos del Capitan que bajo del Appstore?

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Hola imjohnjo

Te refieres al momento de hacer la USB booteable?

Share this post


Link to post
Share on other sites

Exacto! Formato el pendrive instalo el clover y al momento de ejecutar el Clover.command es lo que te comento. y bueno lo otro es cuando se pasan los archivos de instalación del El Capitan al USB

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Para hacer la USB, siguiendo la guía de Rampagedev, necesitas para eso tener ya descargada la .App de El Capitan, la misma que debe estar en Aplicaciones.

Eso como primero. 

 

Si ese comando no te resulta, prueba este.

Abre la terminal y escribe:

 

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Clover --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app

 

Lo que está resaltado en negro "Clover", es el nombre de la USB.

Imagino que si seguiste el manual, así debiste llamarlo.

Fíjate en las mayúsculas y minúsculas.

Share this post


Link to post
Share on other sites

si nombre el USB como Clover... Entonces si tengo como nombre Clover del USB, copio tal y como esta con los espacios y las barras invertidas ese comando que me pasaste o tengo que modificar algo?

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Tienes que abril la terminal, es el paso 1.

 

Escribes ahí:

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/Clover --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app

 

Te pedirá la contraseña, la pones, y automáticamente empezará el proceso de creación de la imagen de El Capitan en la USB.

Prueba eso, si no te sale, te doy otra alternativa más fácil.

Share this post


Link to post
Share on other sites

Ya lo solucione, había bajado el Clover.command para el OSX 10,9 jajajaja, no habia leído bien que estaban bien especificados por versiones jajaja... perdón! ahora se esta copiando tal y cual como la guía, por las dudas había vuelto a forrajear el USB y vuelto a instalar el clover...

 

Otra pregunta. Cuando hay que copiar los kexts en EFI/CLOVER/KEXTS/10.11, ahí van los que están para descargar supongo verdad? Que son AppleACPIPS2Nub, ApplePS2Controller, FakeSMC, Ispcidrv, NullCpuPowerManagement y por ultimo Patched_10.7_AppleRTC?

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Muchos usuarios fallan en esa guía por leer mal, cientos.

 

En kexts, no necesitas todos.

Solo necesitas uno para instalar (en tu caso): el FakeSMC

 

Podrías agregar otros, como los que son para tu Internet, pero aún no sabes cuál necesitas.

Debes saber que el único kext que jamás debe faltar es ese, el FakeSMC. Sin él, no podrás iniciar el sistema.

 

Mientras se termina la creación de la USB, deja veo en Gigabyte qué kext de red necesitas.

Me avisas cuando termine el proceso, hasta eso busco.

Share this post


Link to post
Share on other sites
Guest jonatrapezita

La página de Gigabyte me indica esto:

 

F71.png

 

Como ves, tu controlador de Internet es el Atheros E2201.

 

Descárgate ese kext de acá:

http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/

 

Cuando te bajes, encontrarás dos carpetas. Usa el kext de la carpeta: "Release".

 

Estoy seguro que solo con esos 2 kexts serán suficiente para te funcione tu hack sin problemas. No necesitas más.

Prueba con esos, pero en caso de que no tengas Internet te vuelves por acá.

 

Un detalle, como te había dicho, si al instalar El Capitan se te "cuelga"o tira un error, no es necesario hacer otra USB. Necesitas cambiar un driver de la carpeta Drivers64UEFI.

Este driver es el OsxAptioFix2Drv-64.efi, este debe ir en lugar del OsxAptioFixDrv-64.efi.

Recuerda, no ambos juntos.

 

Te agrego el driver, acá el link de descarga.

https://www.dropbox.com/s/v9jztclg2ykxkkj/OsxAptioFix2Drv-64.efi.zip?dl=0

Share this post


Link to post
Share on other sites

Muchas graciasTrapezita! Gracias por tu dedicación en ayudarme. Yo copie todos los kexts que te mencione ya, esta mal o solo copio esos dos que me dijiste? En cuanto a los drivers que mencionas, en la carpeta drivers64UEFI solo tengo el que vos mencionas, el OsxAptioFix2Drv-64.efi

Share this post


Link to post
Share on other sites
Guest jonatrapezita

En la USB solo copia solo esos 2, el FakeSMC y el Atheros.

Eso para la instalación.

 

Si te fijas en la guía de Rampagedev, en su DMG de Haswell, carpeta 2, el agrega 4 kexts.

 

255.png

 

Un kext es el FakeSMC y los otros 3 son de Internet.

Rampagedev pone 3 de Internet para abarcar varios modelos de mainboards, el no puede saber qué usuario tiene tal hardware, entonces te manda todos porque uno de ellos te ha de funcionar.

 

En post instalación, puedes instalar los kexts usando la herramienta que el agrega. Esos kext automáticamente irán a  /Sistema /Librería/ Extensions

O, en lugar de eso, puedes agregar los kexts a la partición EFI, /Clover /kexts /10.11

 

Cualquier de los dos métodos son correctos.

 

Con kexts me refiero a los dos (Fake y Atheros).

Si luego de post, no tienes Internet, prueba instalando o agregando los 3 de la carpeta de Haswell.


Una cosa, cuando instalas Clover en la USB, se te crean otros Drivers además del OsxAptioFix2Drv-64.efi

Los otros también deben estar, no solo el AptioFix2.

 

Por último, si luego de cambiar el AptioFix2 sigues sin poder instalar, como en su guía mismo lo menciona, usa este driver HFSPlus.efi en lugar de VBoxHfs-64.efi

Te lo adjunto.

https://www.dropbox.com/home?preview=HFSPlus.efi.zip

 

Un ejemplo, te muestro cómo tengo mi carpeta de drivers64UEFI de mi USB.

Tengo esos porque mi mainboard, como la tuya, es para UEFI. En realidad ambas son dual bios. Pero prefiere UEFI.

Estos mismos drivers de la USB, los agrego en mi partición EFI. Los mismos.

 

D91.png

Edited by Trapezita

Share this post


Link to post
Share on other sites

Recién inicio desde el pendrive, borro la partición donde tenía instalado el capitan (es un disco de 320gb con una partición de 100 para OSX y 200 y pico para datos, las dos particiones las cree con Disk Utility la primera vez que instale el capitan)... y después de borrarla, cuando voy a instalar me dice que el disco está con fallas de S.M.A.R.T y que haga un backup eso me dice y no puedo elegir la partición para instalar.... El disco tiene errores, ya lo sabía de hace mucho tiempo, pero la primera vez no me daba ese error y me dejó instalar lo más bien y al primer intento. Hay algo que pueda hacer?

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Si pudiste instalar antes El Capitan en ese mismo disco y no te salía ese mensaje de Smart, repara permisos en el discos y chécalo de nuevo.

Los mensajes de SMART también se pueden eliminar desactivando esa opción en la Bios, pero si te funcionó antes no es necesario hacer eso.

Share this post


Link to post
Share on other sites

Como se edita permisos en el disco? Y busco la opción en la BIOS para deshabilitar S.M.A.R.T pero no me aparece por ningún lado... como podría hacer?

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Utilidad de discos.

Selecciona cada partición y luego el disco completo.

En cada una, clic en Primera Ayuda.

 

3F4.png

 

Si aún tienes problemas y otro disco duro, respalda tus datos en otra parte y formatea todo ese disco.

Formatéalo de verdad, usa Gparted para eso. Es una distro GNU/Linux live cd. Si lo haces con Gparted, no olvides elegir GPT.

 

Si es tu primera hackintosh, trata de hacerlo lo "más" llevadero posible, lo más fácil.

He visto casos que en su primera hackintosh incluso quieren hacer triple booteo: Windows, Linux y OSX, sin contar con particiones extras para datos.

Es amargarse la vida en vano.

Share this post


Link to post
Share on other sites

Amigo! Ya estoy en el live cd de Linux, pero nose como formatear el disco como me dijiste... nose cual es el sksta de archivos de mac, y no me aparece por ningún lado la opción de GPT.

 

Podrías ayudarme por favor? Nose como subir una foto/imagen para mostrarte donde estoy, y justo estoy del celu porque borre la partición que tenía osx jajaja

Share this post


Link to post
Share on other sites
Guest jonatrapezita

Mira este video.

https://www.youtube.com/watch?v=31Ygnn4RpMU

Sáltate directo al minuto 2:25.

Has lo que él hace desde el 2:25 hasta el 2:48, solo eso.

 

No necesitas ver más. Me resultó tan irritante el tipo que estuve a punto de destruir mi monitor.

 

Advertencias:

- Cuando lo hagas, debes estar consciente qué disco borras, en caso de tener otros conectados.

- Eso mata todo el disco.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Slice
      Now I want to add vector graphics support in Clover. See rev 4560 and later.
      It is not working yet but designers may begin to create Vector Themes.
      It supposed to consist of SVG elements and has design size. It will be rendered to any screen size scaled from design size.
       
    • By ITzTravelInTime
      KX AUDIO DRIVER MOD
       
      Hi guys i am a small developer, i really like to use my sound blaster cards on my machines and i love also coding, so when i find the source code for the kx audio driver on git hub and then Eugene, the creator of kx audio driver decided to no longer maintain the project, i decided to start working on a mod of this driver. 
       
      With my mod, created starting from the sources of the last version of kx audio driver, and also by using apple developer documentation for pci and audio drivers as reference, i am working to achieve 2 things mainly: get all the cards supported by the driver to work with all the recent versions os macOS and add support for other cards that are not officially supported by the driver that works or could, but needs to be more properly supported.
       
      This driver is made to support cards based on the E-mu 10k1, 10k2 and similars (like what is used by audigy rx and audigy 4 cards).
       
      Supported cards are:
       
       - most of the sound blaster live!, live! 5.1 and live! 5.1 digital series
       - sound blaster 512
       - sound blaster 256
       - other creative and e-mu sound cards based on the 10k1 chip (cards with the ES1370/ES1371/ES1372/ES1373 chips are not supported)
       - sound blaster Audigy series (1 st gen)
       - sound blaster Audigy 2  and audigy 2 zs series
       - E-MU cards based on the 10k2 sound chip
       - Some Audigy 4 cards (SB0610 only) and the audigy 4 pro
       - Sound blaster Audigy RX (sb0155)
       - other creative and e-mu cards based on the (10k2, 10k2,5 and CA10300 based cards)
       
      NOT supported cards:
       
       - Any ISA Sound card
       - ES1370/ES1371/ES1372/ES1373 based sound cards
       - CMI8738/CMI8788 based cards
       - Any CA0106 based card and cards with similar architectures (like sound blaster live! 24 bit, sound blaster audigy SE SB0570, audigy LS and similars, but audigy SA is supported)
       - Any sound blaster x-fi (some of them works on macOS using a modified version of voodoo hda)
       - Any sound blaster recon3D
       - Any sound blaster Z/ZS/ZX and similar series
       - Any sound blaster AE5 series
       
      In the time being the things i have modded or added with this mod are:
       
      - increased the simple buffer frames number with different values for emu10k1 based cards and emu10k2 based cards (including recent audigy 4 and rx) to reduce and all the audio cracking issues and possibly fixing all of them on a lot of cards
       
      - added a more proper support for the pci express sound blaster audigy rx (which basically is an audigy 4 with a pcie bridge chip) 
       
      - added more fancy names for the cards in the settings and other menus (so the name will be, for example, SB live! 5.1 SB0060 instead of kx SB0060 [e880] witch was shown in the original driver)
       
      - added support to sample rate changing and added lots of sample rates (from 8 khz to 176,4 khz) to accomodate any possible usecase (note that 10k1 sound cards are limited up to 48khz sample rate, and 10k2 based cards are limited to 176,4 khz because of issues getting 192 khz to work, for now the driver goes up to 176,4 khz for such cards) 
       
      - added boot args to manage the driver:
       
      Boot args to use with the kx audio driver mod: -kx_disable or -kxdisable or -kxoff This will prevent the driver from doing any initialization work, so the driver is basically disabled, use it to boot your ssytem in case the driver is giving you issues and kernel panics while you are trying to boot/using your system, so you are able to remove this driver or replace it with another version of it or to do some truble shooting. -kx_debug or -kxdebug or -kxspec Will show more debug info about the card, mainly the i/o port address and the kind of bus that it uses -kx_exp_deb or -kx_beta or -kxbeta Will enable experimental and probably not working or unstable features like showing inputs for the card or 192 khz sampling rate, use it only for testing and debug purposes, this may likely cause instability and problems in the everyday usage! Use it at your own risk! -kx_original or -kxoriginal This will basically turn off almost all the mods of this mod, so the driver will come to work as it was before modding it, this can be usefoul as a "safe mode" like feture to have a working driver in case of problems with features of the mod, so using this means no crsking issues improvements, only 48 khz sample rate and only features of the non-modded kx audio driver for mac os x  
      - created a script file to use with the driver for installing the driver and also to load/unload, update, repolace it and it's libraries.
       
      What i'd like to implement but i don't know how to do:
       
       - I'd like mainly to add a more proper support to the pci bridge chip of the audigy rx,
       
       - have audio inputs working,
       
       - fix the support when using more than one card, to get all the cards shown in the settings and other menus,
       
       - have the gameport/midi port of older cards to be used in mac os as a midi in/out
       
      If other developers would like to join and help me, you can, and also an hand from other people with testing and feedback will be nice.
       
      link for the kext only (if you have clover put it in [your clover efi folder]/clover/kexts/[your macOS version]/ so it will not be deleted when updating macOS):
               - download from the downloads section:          kX Audio Driver Mod by ITzTravelInTime 1.01                                                                                    - external download:                                      https://dl.dropboxus...Driver.kext.zip   link for the installer pack (the best way to install it, but you have to reinstall it when you upgrade macOS, remeber to fix kext permitions and rebuild the kernelcache if you want to remove the kext from it's install directory without using the unistall feature of the provvided script):              - download:                                                   https://dl.dropboxus...aller pack.zip   Source code from Git Hub:          -  github repo:                                               https://github.com/ITzTravelInTime/kx-audio-driver   NOTE: Some system because of some problems with the HPET may need to use FixHPET in clover and to install the kext in /System/Library/Extensions or to do other kind of hpet mods to run the driver properly, but only on some systems, most systems should not require it  






    • By fusion71au
      Clover r4542 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 14 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4542 for VMware.zip". Mount Clover-v2.4k-4542-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By MaLd0n
      First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Run it, post files generated in your desktop RunMe.app  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with patches for Skylake DSDT.MaLd0n ASUS Z170M PLUS.zip   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DMAC -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -IMEI -PNLF -HDMI --FakeSMC
      http://www.hwsensors.com/releases   --Audio https://github.com/vit9696/AppleALC   --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   --LAN https://github.com/Mieze/IntelMausiEthernet   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!
×