Jump to content
Mork vom Ork

Patch for using NVMe under macOS Sierra is ready.

1,362 posts in this topic

Recommended Posts

Advertisement

I am attempting to use an OWC Aura Pro X SSD NVMe (Silicon Motion pci126f,2260) on a a PCIe adapter in a MacPro1,1 running MacOS 10.11.6 (15G22010). I built the kext in patch_nvme adding the devid to the script and using the spoof; installed it disabling SIP and modifying the attributes (correctly I think): sudo chmod -R 755 and sudo chown -R root:wheel.

Unfortunately System Information/Hardware/PCI shows that the NVM Express Controller device is present but that the driver is not installed.

Can someone walk me through the troubleshooting to determine why the kext will not load? Thanks.

Edited by vicsandr

Share this post


Link to post
Share on other sites

I am running Sierra on a Mac Pro 5,1 with an NVMe boot volume.  I have been using this patch for both the 2018-005 and 2018-006 security updates.  Based on the previous comment from InsanelyMac Legend I thought I'd just try running the 2019-001 security update.  As expected, my Mac Pro 5,1 crashed on startup.  I then booted from a different volume, and deleted the newly created "IONVMeFamily.kext".  I rebooted from my NVMe volume, and it worked OK.  So it seems that it is OK to just run the 2019-001 security update, and then boot from a different volume and delete the IONVMeFamily.kext file.  Sierra 10.12.6 with the 2019-001 security update seems to work OK with the HackrNVMeFamily-10_12_6_sec2018-006.kext file once the IONVMeFamily.kext is deleted.

Share this post


Link to post
Share on other sites

Hi,


I updated my original post about the Plextor/LiteOn/Hynix patch with a new Find/Replace pattern, as the underlying code seems to be changing in the upcoming 10.14.4 (judging by the betas).

The new pattern is backwards compatible with older OSX versions, so I recommend everyone using this patch to change it with the new variant, in order not to lose booting ability when the 10.14.4 update arrives.

Share this post


Link to post
Share on other sites

Good day.

 

Can anyone please tell how to use patch_nvme.sh + config_patches.plist with 10.14.3 and PLEXTOR M9Pe? 

What parameters should be used in order to launch patch_nvme.sh and patch IONVMeFamily.kext?

 

Thank you in advance
 

Share this post


Link to post
Share on other sites

How can i made Plextor M9PeY 256Gb work with 10.14.3 OS X in my Mac Pro5.1? Can some one help please

Share this post


Link to post
Share on other sites
Posted (edited)

Thank you very much :)

I used this patch for my XPS 15 9570 with Hynix PC401 1TB  NVMe SSD, which was not recognized by Mojave 10.4.4.

Applying the patch solved the issue.

 

BUT Very important note: the SATA mode in BIOS must be set to AHCI. Dell as a standard sets SATA to RAID, which causes the NVMe drives to be not recognized by MacOS. I did not have that info and I was wondering why my hdd is not recognized even with patching... But Then I tried the setting SATA  from RAID to AHCI and that, with above patching applied, solved the problem - Mojave recognizes my Hynix SSD :) I Now I just need to transfer the OS from my USB drive to internal SSD :)

 

I just added the code below  into the config.plist under the part "<key>Patches</key>"

That's all. But it is for HACkintosh users, I do not know how MAC users should do patching.

 

On 6/8/2018 at 12:58 AM, Pene said:

 


      <dict>
        <key>Comment</key>
        <string>IONVMeFamily: Ignore FLBAS bit:4 being set - for Plextor/LiteOn/Hynix</string>
        <key>Disabled</key>
        <false/>
        <key>Name</key>
        <string>IONVMeFamily</string>
        <key>Find</key>
        <data>SBr2wRAPhQ==</data>
        <key>Replace</key>
        <data>SBr2wQAPhQ==</data>
      </dict>

 

 
Edited by gombi

Share this post


Link to post
Share on other sites

Have a question I followed this...sort of to create a patch and help my OS (EL Capitan) see my NVM e drive, I got this message in Terminal ... 

Leons-MacBook-Pro:patch-nvme.git Drex-Guru$ ./patch_nvme.sh 

Determined patch automatically from vanilla IONVMeFamily: 10_11_6_15G22010

Creating patched HackrNVMeFamily-10_11_6_15G22010.kext from /System/Library/Extensions/IONVMeFamily.kext

Vanilla MD5 matches expected MD5 entry (9b1349964b4d0d757c35189ca9f6ea9a)

Patched MD5 matches expected MD5 entry (d2d5c10907bf0d159d58e496b48d245e)

Leons-MacBook-Pro:patch-nvme.git Drex-Guru$ 

so ....well, where is the created patch to pop into Kext Utility?  please excuse my ignorance I'm spinning here my drive died the other day and I have a major hand in next week that my lap top simply will not edit. I am by no means a programmer, and this might as well be in Martian.

Kind regards,

Leon.

Share this post


Link to post
Share on other sites

Hi everyone, I have a problem with installing macOs.
I have a Matebook X Pro, 7GB of RAM and 512 of SSD.
My problem occurs when I start the macOs installer and I never read the SSD.
My SSD is a LITEON CA3-8D512.
I tried to edit the kext files but nothing.
Can someone help me?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×