Jump to content
darkvoid

[FIX] macOS Sierra DP1 BCM94532Z WiFi

130 posts in this topic

Recommended Posts

post-1377288-0-42579500-1477669526_thumb.pngpost-1377288-0-06594900-1477669529_thumb.png

 

so this is my ID:

14E443B117AA062E

base64: MTRFNDQzQjExN0FBMDYyRQ==

 

but what I have to do, this is for replace string, but for what to put in find pattern?

Can't get it at all.

Share this post


Link to post
Share on other sites
Advertisement

Hi guys. I'm stuck without wifi after this latest patch as well and I'm not sure what is going on or how to fix it. Thanks for helping!

 

post-1848400-0-54725300-1476201448_thumb.png

post-1848400-0-74898700-1477677797_thumb.png

Share this post


Link to post
Share on other sites

I have to problem, i add keys in Clover Configuration , in 3 postion BCM , reload cache and prelikedkernel.. nothing change. What i do wrong? i have the same wifi card like on subject. And after update from 10.12 to 10.12.1 stopped working, before i use method from Lenovo y50-70 Guide (Rehhab...) And working great. but after update OS, stopped working i see this method here working on someone people but  how? i do the same. Put new HEX key (find / replace) but nothing happen . Help it's important for me. 

Share this post


Link to post
Share on other sites

Hi guys. I'm stuck without wifi after this latest patch as well and I'm not sure what is going on or how to fix it. Thanks for helping!

 

 

Have you tried using the kexts (IO89211Family.kext and IO80211FamilyV2.kext) from Sierra 10.12.0 beta 1? These worked for me

Share this post


Link to post
Share on other sites

where i can download ? send mi link pls. 

 

If you go to the App Store/purchases, you should be able to download the original Sierra beta installer from which you can extract the kexts. I shall be away from my keyboard for about an hour, but you should check earlier posts as details are given there.

Share this post


Link to post
Share on other sites

Finally found what I needed. But for all of you that have the same card as mine: Broadcom BCM4352, and after updating from 10.12 to 10.12.1 your WIFI stopped working just add these three patches to your config, and restart the computer:

			<dict>
				<key>Comment</key>
				<string>AirPortBrcm4360 - PCI Error 1</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				QTnEdRs=
				</data>
				<key>Name</key>
				<string>AirPortBrcm4360</string>
				<key>Replace</key>
				<data>
				QTnEZpA=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>AirPortBrcm4360 - PCI Error 2</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				QQ+3zTnBdQw=
				</data>
				<key>Name</key>
				<string>AirPortBrcm4360</string>
				<key>Replace</key>
				<data>
				QQ+3zTnBZpA=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>AirPortBrcm4360 - PCI Error 3</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g33EBHQG
				</data>
				<key>Name</key>
				<string>AirPortBrcm4360</string>
				<key>Replace</key>
				<data>
				g33EBGaQ
				</data>
			</dict>

Share this post


Link to post
Share on other sites

 

Finally found what I needed. But for all of you that have the same card as mine: Broadcom BCM4352, and after updating from 10.12 to 10.12.1 your WIFI stopped working just add these three patches to your config, and restart the computer:

			<dict>
				<key>Comment</key>
				<string>AirPortBrcm4360 - PCI Error 1</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				QTnEdRs=
				</data>
				<key>Name</key>
				<string>AirPortBrcm4360</string>
				<key>Replace</key>
				<data>
				QTnEZpA=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>AirPortBrcm4360 - PCI Error 2</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				QQ+3zTnBdQw=
				</data>
				<key>Name</key>
				<string>AirPortBrcm4360</string>
				<key>Replace</key>
				<data>
				QQ+3zTnBZpA=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>AirPortBrcm4360 - PCI Error 3</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g33EBHQG
				</data>
				<key>Name</key>
				<string>AirPortBrcm4360</string>
				<key>Replace</key>
				<data>
				g33EBGaQ
				</data>
			</dict>

This actually worked for me. Thanks beBoss!

Share this post


Link to post
Share on other sites

Finally found what I needed. But for all of you that have the same card as mine: Broadcom BCM4352, and after updating from 10.12 to 10.12.1 your WIFI stopped working

1. Not your work, credit: Neo.aka.Darkman/Post #15/http://www.insanelymac.com/forum/topic/316060-pre-release-macos-sierra-10121/?p=2281834

2. BCM4352: no PCI Error. Actual problem: Clover/config.plist/ACPI/DSDT/Fixes/FixAirport_4000/Yes stopped working.

3. Neo.aka.Darkman is using a fake AW-CE123H (4352) Device ID: 2154.

4. Remove Clover Airport injection.  Use kext (RehabMan) injection or ssdt/dsdt injection/add:

"compatible", 
Buffer (0x0D)
{
    "pci14e4,43a0"
}

5. The only 4352 patch required is 5 GHz patch, Post #1.

Share this post


Link to post
Share on other sites

1. Not your work, credit: Neo.aka.Darkman/Post #15/http://www.insanelymac.com/forum/topic/316060-pre-release-macos-sierra-10121/?p=2281834

2. BCM4352: no PCI Error. Actual problem: Clover/config.plist/ACPI/DSDT/Fixes/FixAirport_4000/Yes stopped working.

3. Neo.aka.Darkman is using a fake AW-CE123H (4352) Device ID: 2154.

4. Remove Clover Airport injection.  Use kext (RehabMan) injection or ssdt/dsdt injection/add:

"compatible", 
Buffer (0x0D)
{
    "pci14e4,43a0"
}

5. The only 4352 patch required is 5 GHz patch, Post #1.

 

Did I say that is my work? Facepalm  :D

Share this post


Link to post
Share on other sites

Guys I have BCM943225HMB after upgrading to 10.12.1 the whilst patch didn't work I even tried the patch mentioned by Denicio didn't work either .

What is the correct patch for me ?

Hello .... any solution for BCM943225HMB

Share this post


Link to post
Share on other sites

1. Not your work, credit: Neo.aka.Darkman/Post #15/http://www.insanelymac.com/forum/topic/316060-pre-release-macos-sierra-10121/?p=2281834

2. BCM4352: no PCI Error. Actual problem: Clover/config.plist/ACPI/DSDT/Fixes/FixAirport_4000/Yes stopped working.

3. Neo.aka.Darkman is using a fake AW-CE123H (4352) Device ID: 2154.

4. Remove Clover Airport injection.  Use kext (RehabMan) injection or ssdt/dsdt injection/add:

"compatible", 
Buffer (0x0D)
{
    "pci14e4,43a0"
}

5. The only 4352 patch required is 5 GHz patch, Post #1.

 

Before 10.12.1 I've used ReHabman kext inject and the 5GHz patch to get everything working but now it is not working. After looking at DPCIManager realise my device id is different.

 

Right now I have only FakePCIID_Broadcom_WiFi.kext only, I don't care about 5Ghz if the device is not even detected at all.

 

Vendor, Device, Sub Ven, Sub Dev, Vendor Name, Device Name

14E4, 43B1, 103C, 2154, Broadcom Corporation, BCM4352 802.11ac Wireless Network Adapter

 

EDIT:

 

Console is spaming this

 

com.apple.xpc.launchd[1] (com.apple.wifivelocityd): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

Edited by colordeficiency

Share this post


Link to post
Share on other sites

 

On macOS Sierra DP1, when using a BMC94532Z NGFF WiFi card, AirportBrcm4360.kext no longer successfully loads.

 

This problem is caused by the driver not being able to initialize the fvco (frequency voltage controlled oscillator).

 

Apply the following patch in Clover to enable WiFi using the BCM94352Z:

Kext:    AirPortBrcm4360
Find:    81F952AA00007529 
Replace: 81F952AA00006690

Through Clover config.plist:

<dict>
	<key>Comment</key>
	<string>AirPortBrcm4360 - fcvo</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>gflSqgAAdSk=</data>
	<key>Name</key>
	<string>AirPortBrcm4360</string>
	<key>Replace</key>
	<data>gflSqgAAZpA=</data>
</dict>

Thanks, this worked for my TP-Link Archer T6E AC1300 on macOS Sierra 10.12.3.

Share this post


Link to post
Share on other sites

Hallo

I am on a Sierra 10.12.3 installation, applied the above patch to plist, placed FakePCIID.kext and FakePCIID_Broadcom_WiFi.kext in S/L/E,

but WIFI is not showing or working.

 

What are the kext required?

 

thx

Share this post


Link to post
Share on other sites

Hi I have Sierra 10.12.4 and I can not start handoff to work, my system are recognize PIC card BCM94352Z on Lenovo Y5-70

and both work great, just I can not start handoff to work, and iMessage too.
can some one help ?

 

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Same card in Dell XPS 13 BCM94350ZAE/DW1820a [14e4:43a3].

Booting with verbose gives:

 

sudo dmesg | grep -i ARPT

 

ARPT: 2.706942: srom rev:11
ARPT: 2.739163: Over-riding wl_msg_level, found "wl_msg_level" arg, value[0x00000fff]
ARPT: 2.739170: Over-riding wl_msg_level2, found "wl_msg_level2" arg, value[0x00000fff]
ARPT: 2.743458: BRCM tunables:
ARPT: 2.743462:   pullmode[1] txringsize[  256] txsendqsize[1024] reapmin[   32] reapcount[  128]
ARPT: 2.745520: wl0: Broadcom BCM43ba, vendorID[0x14e4] BAR0[0xdc400004]
ARPT: 2.745687: wl0: powerStateWillChangeTo: PowerFlags 0xf000 new state 2 theDriver 0x56590bc9ff88b381
ARPT: 2.745732: D3 Exit Sanity : Verify PCIE
ARPT: 2.746089: D3 Exit Sanity : Verify Backplane errors
ARPT: 2.746151: D3 Exit Sanity : OL_CAP:1 M:0
ARPT: 2.746155: D3 Exit Sanity complete - Device is in good state
ARPT: 2.773715: Log system state... : reinit:6:-PCICfgRdFail-CfgReg:0x78
ARPT: 2.833306: 
ARPT: 2.833312: Fatal Error - Initiate powercycle 
ARPT: 2.838439: ai_core_reset: WARN1: resetstatus=0xffffffff
ARPT: 2.840716: ai_core_reset: WARN2: resetstatus=0xffffffff
ARPT: 2.841818: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.844111: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.846857: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.849419: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.852371: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.854616: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.856977: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.859958: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.862425: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.863567: ai_core_reset: Failed to take core 0x812 out of reset
ARPT: 2.863726: wlc_ltr_init: ltrspacing wr=0x1f4 rd=0xffffffff
ARPT: 2.863845: wlc_ltr_init: ltrhysteresiscnt wr=0xc0001 rd=0xffffffff
ARPT: 2.864007: wlc_ltr_init_reg: rd[0x844]=0xffffffff wr[0x844]=0x883c883c
ARPT: 2.864244: wlc_ltr_init_reg: rd[0x848]=0xffffffff wr[0x848]=0x88648864
ARPT: 2.864483: wlc_ltr_init_reg: rd[0x84c]=0xffffffff wr[0x84c]=0x90039003
ARPT: 2.864603: wl:wlc_ltr_hwset: orig ltr=3 new ltr=0 [0=>sleep, 2=>active]
ARPT: 2.864683: wl:wlc_ltr_hwset: Sending LTR message ltr=0 [0=>sleep, 2=>active]
ARPT: 2.865805: ai_core_reset: WARN1: resetstatus=0xffffffff
ARPT: 2.868098: ai_core_reset: WARN2: resetstatus=0xffffffff
ARPT: 2.869240: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.871494: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.873733: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.875945: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.878141: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.880353: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.882562: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.884870: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.887157: ai_core_reset: WARN3 resetstatus=0xffffffff
ARPT: 2.888370: ai_core_reset: Failed to take core 0x812 out of reset
ARPT: 2.888993: wlIoctl: wlc_ioctl called with cmd 118 returned error -26
ARPT: 2.889000: wl0: setAP: err setting ioctl WLC_SET_AP to 0, err -26 "Not Permitted"
ARPT: 2.889149: wl0: powerStateWillChangeTo: PowerFlags 0x0400 new state 1 theDriver 0x56590bc9ff88b381
ARPT: 2.889175: PowerState did not change to OFF : 2IOV_OL_TCPKEEPALIVE_CONN: no valid info
ARPT: 3.190307: wl0: wlc_iovar_op: wl_tcpkeepalive_conn BCME -23 (Unsupported)
ARPT: 3.190316: wlIovarOp: wlc_iovar_op called with cmd "wl_tcpkeepalive_conn" returned error -23
ARPT: 3.190338: AirPort_Brcm43xx::syncPowerState: WWEN[disabled]
ARPT: 3.190349: wlIoctl: wlc_ioctl called with cmd 118 returned error -26
ARPT: 3.190357: wl0: setAP: err setting ioctl WLC_SET_AP to 0, err -26 "Not Permitted"
ARPT: 3.190420: wl0: powerStateWillChangeTo: PowerFlags 0xf000 new state 2 theDriver 0x56590bc9ff88b381
ARPT: 3.190449: D3 Exit Sanity : Verify PCIE
ARPT: 3.190470: D3 Exit Sanity : Verify Backplane errors
ARPT: 3.190777: D3 Sanity : Backplane timeout detected 
ARPT: 3.190783: wl0: fatal error, reinitializing, total count of reinit's[1], @'wlc_verify_d3_exit':56127
ARPT: 3.190790: Perform hard reset, skip core init
ARPT: 3.190797: AirPort_Brcm43xx::syncPowerState: Device in bad state after wakeup - err:-1
ARPT: 3.190853: Power Cycle Completed
ARPT: 3.190919: Log system state... : DriverState
ARPT: 3.192499: Fatal Error - Initiate powercycle 
ARPT: 3.228157: 
ARPT: 3.228165: Log system state... : DriverState
ARPT: 3.265353: 
ARPT: 5.143371: WLAN adapter PCIE config space was not restored (stateNumber = 2)
ARPT: 5.153363: wl0: fatal error, reinitializing, total count of reinit's[2], @'wl_nocard_war':4312
ARPT: 5.174015: Perform hard reset, skip core init
 

Any ideas? Also tried with fake id via clover. nothing. Card show up but unable to power on.

Thank you

I'm still to figure this out.... If some experienced folk like @darkvoid @RehabMan @toleda can help, the problem of DW1820A may be solved.

I have all the hardware and skill to help debug.

Share this post


Link to post
Share on other sites

I am using the same patch for handoff/hotspot that I use with El Capitan and it is working fine for me.

 

attachicon.gifUntitled.png

would you please upload your config.plist file for your efi folder, because i want to copy the section you are using to activate your dw1550(i am using the same card), normally i have to edit kext file manually after every update and thanks

Share this post


Link to post
Share on other sites

So I am currently running 10.12.5, however I installed the lasted Fakepciid package and once I did my bluetooth stopped working.  I have Brcmpatchram2 and the repo kext installed but still does not work.  Once I remove the FakePCIID_XHCIMUX kext it will work again, but then I only get one USB working.    If I install and older XHCIMUX kext, my bluetooth will work, but only one USB.  Its like I am stuck with having one or the other.  The other issue is that when my bluetooth is working.  I can turn on the feature to have my Apple Watch unlock the Mac, but when it attempts to unlock it will just spin and ask for the password.  I made sure that the handoff support is working, but doesn't actually seem to work.  I have a BCM94350 card installed.  My WIFI however works perfectly.  its just my bluetooth.   I would appreciate any help that you all can give.  

Share this post


Link to post
Share on other sites

 

On macOS Sierra DP1, when using a BMC94532Z NGFF WiFi card, AirportBrcm4360.kext no longer successfully loads.

 

This problem is caused by the driver not being able to initialize the fvco (frequency voltage controlled oscillator).

 

Apply the following patch in Clover to enable WiFi using the BCM94352Z:

Kext:    AirPortBrcm4360
Find:    81F952AA00007529 
Replace: 81F952AA00006690

Through Clover config.plist:

<dict>
	<key>Comment</key>
	<string>AirPortBrcm4360 - fcvo</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>gflSqgAAdSk=</data>
	<key>Name</key>
	<string>AirPortBrcm4360</string>
	<key>Replace</key>
	<data>gflSqgAAZpA=</data>
</dict>

 

HI, good find, i've installed Sierra on an external FW800 drive in an old MBP 4,1 using a patch, but the Broadcom BCM4321 doesn't work, for any chance this patch works in a normal MBP?

Thanks, Carmelo.

Share this post


Link to post
Share on other sites

I've followed all the instructions for getting my Dell 1560 BCM94532Z card working, and it's not working...!

 

Attached are the last few lines of my boot log:

 

FSInjectionInstall ...

- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: D1516D18
FSInjectionInstall ...
- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: D1516D18
14:452  0:014  Use origin smbios table type 1 guid.
14:456  0:004    Force kext: System\Library\Extensions\IO80211Family.kext\Contents\PlugIns\AirPortBrcm4360.kext
15:635  1:178  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
15:674  0:038  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.12
15:697  0:023    Extra kext: EFI\CLOVER\kexts\10.12\BrcmFirmwareData.kext
15:753  0:055    Extra kext: EFI\CLOVER\kexts\10.12\BrcmPatchRAM2.kext
15:785  0:031    Extra kext: EFI\CLOVER\kexts\10.12\FakePCIID_Broadcom_WiFi.kext
15:791  0:006    Extra kext: EFI\CLOVER\kexts\10.12\FakePCIID.kext
15:800  0:008  Custom boot is disabled
 
 
 
=====
 
Attached as a file is a screenshot of the patches. It's just not loading!!! Ideas??

post-19334-0-77495400-1495688618_thumb.png

Share this post


Link to post
Share on other sites

@Da Pupster

 

what does the card/device look like to the system?

meaning did you add a FakeID or DSDT/SSDT to make the device look like a 4360? 

 

if i run "dspci" to list my PCI devices: i see this for my 1560

 

04:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03) (subsys 106b:0019)

 

and you may want to put those FakePCIID kexts on the HD in /Library/Extensions

 

BrcmFirmwareRepo.kext: Install to /Library/Extensions. This kext is much more memory efficient than BrcmFirmwareData.kext and is the preferred configuration.

BrcmFirmwareData.kext: Most appropriate for EFI/Clover/kexts. BrcmFirmwareRepo.kext, while much more memory efficient, cannot be injected as can BrcmFirmwareData.kext

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By The Krya
      Hi, I've upgraded from Mojave to Catalina and now my WiFi card didn't recognized in system. I upgraded clover and kexts to latest versions, but Wifi didn't appears.
      In "about this Mac" I see:
      CoreWLAN: 13.0 ((null))
      CoreWLANKit: 13.0 ((null))
      Menu Extra: 13.0 ((null))
      System Information: 12.0 (1355)
      IO80211 Family: 12.0 (1200.12.2b1
      Diagnostics: 1.0 (910)
      AirPort Utility: Not Installed
       
      My kexts is:
       
      I checked forum and table of supported Wifi cards - and everything should work (a lot of people has this card working on Catalina). When I was on Mojave my wifi was ok.
      As I can see in terminal output ( after command "kextstat") - kext for wifi not loaded, but I'm not sure because I haven't got a lot of experience of this
      *my english isn't good enough, sorry for that*
       
      Any help appreciated and thanks
      loaded-kexts

    • By HenryV
      m.2 DW1707/AR9565 shows yellow wifi indicator in network applet when turned on in 10.13.6, 10.14.6 and yellow ethernet in 10.15.2.
      Icon in desktop panel indicates looking but not find networks in all three.  Same wifi card detects available networks in linux without issue.
      The attached kext is labeled particularly for 10.13.6, but wifi is not being detected even in that version.  In all cases Atheros 40 kext is installed S/L/E as plugin in 80211 family kext with reparied permissions.
       
      Can anyone who has this working in sierra, high sierra, mojave or catalina please post what you did including any dsdt/config.plist mods?
       
      From what I have read in these forums the modded atheros 40 kext is supposed to work.  Is this failure to detect networks specific to any particular brand(s) of laptops?
       
      Any help appreciated.
      Thank you.
       
      AR956X-10.13.6.tar.gz
×