Jump to content
darkvoid

[FIX] macOS Sierra DP1 BCM94532Z WiFi

130 posts in this topic

Recommended Posts

Advertisement

This seems to be a real positive step forward for me.  I see the kext loading now but I still don't have a wifi device.  But then, I have a slightly different chipset (BCM94352HMB).

Share this post


Link to post
Share on other sites

@darkvoid

Hi, 

This works for me , got my wifi working.

My card is BCM94352 HMB/AzureWave AW-CE123H supports both Airport and BT4LE. Specs in signature.

 

Just a question should we use this as a replacement to earlier patches for this card or in addition to pre existing patches as described by Toleda in the following topic,

http://www.insanelymac.com/forum/topic/292542-airport-pcie-half-mini/ .

 

Great work.

Thanks

 

 

@ mnfesq

 

I have the same card as yours seems to be working for me.

 

This is my system report when using this patch in addition to the earlier patches for our card.

 

  Software Versions:

  CoreWLAN: 11.0 (1200.16)

  CoreWLANKit: 12.0 (1200.16)

  Menu Extra: 12.0 (1200.19)

  System Information: 12.0 (1200.2)

  IO80211 Family: 12.0 (1200.12.2)

  Diagnostics: 7.0 (700.5)

  AirPort Utility: 6.3.7 (637.3)

  Interfaces:

en1:

  Card Type: AirPort Extreme  (0x14E4, 0x2123)

  Firmware Version: Broadcom BCM43xx 1.0 (7.21.149.34.1a7)

  MAC Address: ------------------------

  Locale: FCC

  Country Code: US

  Supported PHY Modes: 802.11 a/b/g/n/ac

  Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165

  Wake On Wireless: Supported

  AirDrop: Supported

  AirDrop Channel: 149

  Status: Connected

Share this post


Link to post
Share on other sites

@macq,

Its too early to say which patches previously used are still relevant. We are just at DP1, once macOS Sierra reaches release it would be good to consolidate all required patches.

 

@FredWst,

I haven't tried booting this in recovery mode. Will see if there is anything to learn from the recovery mode boot scenario. Also the BMC94352Z working in recovery mode might indicate that future release of the developer preview could still support the device properly without additional patches.

Share this post


Link to post
Share on other sites

 

On macOS Sierra DP1, when using a BMC94532Z NGFF WiFi card, AirportBrcm4360.kext no longer successfully loads.

 

This problem is caused by the driver not being able to initialize the fvco (frequency voltage controlled oscillator).

 

Apply the following patch in Clover to enable WiFi using the BCM94352Z:

Kext:    AirPortBrcm4360
Find:    81F952AA00007529 
Replace: 81F952AA00006690

Through Clover config.plist:

<dict>
	<key>Comment</key>
	<string>AirPortBrcm4360 - fcvo</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>gflSqgAAdSk=</data>
	<key>Name</key>
	<string>AirPortBrcm4360</string>
	<key>Replace</key>
	<data>gflSqgAAZpA=</data>
</dict>

Thanks for such a great patch which also works with Enoch v.2830 by Hex Editor

Share this post


Link to post
Share on other sites

I have Dell DW1560 (BCM94532Z) in XPS 13 9350. Still failed to turn on Wi-Fi after patching. Bluetooth looks like working fine.

 

Console log is like this:

 

AirPort_Brcm4360:: init AirPortFamily_kexts -1200.17.1 "AirPortFamily_kexts-1200.17.1" Jun  3 2016 14:12:07

Service found 1000003cb

srom rev:11

ChangeVC0 => vco:960, xtalF:40, frac:98, ndivMode:3, ndivint:24

Data written into the PLL_CNTRL_ADDR2: 00000c31

Data written into the PLL_CNTRL_ADDR3 (Fractional): 0000100e

wlcStart failed

AirPort_Brcm43XX::start: failed

Memory leak of bytes 280

AirPort_Brcm43XX::start: Failed 'startGated()'

 

Share this post


Link to post
Share on other sites

@Axam,

 

I specifically made the patch for the card you are using. The patch must not be applied correctly in your case.

Please double-check that all is in place correctly.

Share this post


Link to post
Share on other sites

Confirmed working on Dell wireless DW1550. Hotspot/handoff does not. I guess it needs a new clover patch.

 

I am using the same patch for handoff/hotspot that I use with El Capitan and it is working fine for me.

 

post-270804-0-43953500-1467305231_thumb.png

Share this post


Link to post
Share on other sites

On macOS Sierra DP1, when using a BMC94532Z NGFF WiFi card, AirportBrcm4360.kext no longer successfully loads.

 

This problem is caused by the driver not being able to initialize the fvco (frequency voltage controlled oscillator).

 

Apply the following patch in Clover to enable WiFi using the BCM94352Z:

Kext:    AirPortBrcm4360
Find:    81F952AA00007529 
Replace: 81F952AA00006690
Through Clover config.plist:

<dict>
	<key>Comment</key>
	<string>AirPortBrcm4360 - fcvo</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>gflSqgAAdSk=</data>
	<key>Name</key>
	<string>AirPortBrcm4360</string>
	<key>Replace</key>
	<data>gflSqgAAZpA=</data>
</dict>

I had BCM94350ZAE/DW1820a [14e4:43a3] installed on HP EliteBook Folio 1020 G1. The card can power up. It seems works fine.

In `Status menu', Wi-Fi changing between `Wi-Fi: On' and `Wi-Fi: Looking for Networks...'.

When I click `Join Other Network...' -> Show Networks -> Scanning..., there is no wireless network list shown. Latest result:

In `System Information' (`System Report...') -> Network -> Wi-Fi

Software Versions:
  CoreWLAN:    11.0 (1101.20)
  CoreWLANKit:    11.0 (1101.20)
  Menu Extra:    11.0 (1121.34.2)
  System Information:    12.0 (1100.2)
  IO80211 Family:    11.1 (1110.26)
  Diagnostics:    5.1 (510.88)
  AirPort Utility:    6.3.6 (636.5)
  Interfaces:
en1:
  Card Type:    AirPort Extreme  (0x14E4, 0x21)
  Firmware Version:    Broadcom BCM43xx 1.0 (7.21.95.175.1a6)
  MAC Address:    ab:cd:ef:ab:cd:ef
  Locale:    FCC
  Country Code:    US
  Supported PHY Modes:    802.11 a/b/g/n/ac
  Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165
  Wake On Wireless:    Supported
  AirDrop:    Supported, Channel 149
  Status:    Not Associated

So the real problem is No Result after Scanning! Is it possible to develop a patch for it (may be in `AirPortBrcm4360.kext')? How to see the log of this problem, how to debug this problem?

 

Could you give a help?

 

Thanks.

 

PS: This card works fine in both Ubuntu & Win 8.1 / 10.

bcm.zip

Share this post


Link to post
Share on other sites

While this patch worked perfectly on my BCM94352HMB card in the DP1 Beta, after applying the DP2 Update though the Bluetooth/USB side of the card remains functional, Wi-Fi no longer works.

Share this post


Link to post
Share on other sites

have you tried adding the AirportBrcm4360 to the "force kexts to load" option of clover then booting without caches?

you would have to add the complete path to the Brcm kext in this manner if you want it to load

<key>ForceKextsToLoad</key>
 <array>
 <string>\System\Library\Extensions\IO80211Family.kext\Contents\PlugIns\AirPortBrcm4360.kext</string>
 </array>

you need to use back slashes not forward slashes like posted in the code box if not clover will not find the kexts info plist file.

Share this post


Link to post
Share on other sites

have you tried adding the AirportBrcm4360 to the "force kexts to load" option of clover then booting without caches?

you would have to add the complete path to the Brcm kext in this manner if you want it to load

<key>ForceKextsToLoad</key>
 <array>
 <string>\System\Library\Extensions\IO80211Family.kext\Contents\PlugIns\AirPortBrcm4360.kext</string>
 </array>

you need to use back slashes not forward slashes like posted in the code box if not clover will not find the kexts info plist file.

 

 

I applied the edits in clover (as shown) however I did not quite get the additional edit needed to the Brcm kext you described.   Where exactly is the Brcm kext and where in the info.plist should the string be placed ?

post-1126120-0-46184100-1468211656_thumb.jpg

post-1126120-0-96003100-1468211716_thumb.jpg

Share this post


Link to post
Share on other sites

In the first picture you only put the name of the kext.

Clover will have issues reading whatever kext you type in there when you do that. The issue is like I stated before. Clover will not read the info plist of any kext you put in there like that because it causes the kext to not be"Forced" loaded since clover finds it to be "incomplete". 

 

1- Put the path where you have it in the first picture in clover configurator like so (You can copy and past it from the code box below)

\System\Library\Extensions\IO80211Family.kext\Contents\PlugIns\AirPortBrcm4360.kext

2- In the ACPI patches menu make sure to have "AddDTGP" and "FixAirport" selected

 

3- in Devices menu, copy and paste into the wifi box 

0x43BA14E4

Share this post


Link to post
Share on other sites

Hi,

 

I found that 5ghz not working after some time running 10.12 dp2. Any similar problem?

 

5GHz patch applied and verified working under dp2. But after a while under system information Wifi tab it lists none of 5ghz channel.

Share this post


Link to post
Share on other sites

 

In the first picture you only put the name of the kext.

Clover will have issues reading whatever kext you type in there when you do that. The issue is like I stated before. Clover will not read the info plist of any kext you put in there like that because it causes the kext to not be"Forced" loaded since clover finds it to be "incomplete". 

 

1- Put the path where you have it in the first picture in clover configurator like so (You can copy and past it from the code box below)

\System\Library\Extensions\IO80211Family.kext\Contents\PlugIns\AirPortBrcm4360.kext

2- In the ACPI patches menu make sure to have "AddDTGP" and "FixAirport" selected

 

3- in Devices menu, copy and paste into the wifi box 

0x43BA14E4

 

Firstly, thanks for your reply and specific instructions.    After carefully inputing all of your directed changes, Clover booted to a blank/black screen on both my El Capitan 10.11.5 & Sierra Public Beta partitions.   My only confusion is are the above changes to be made in addition to or instead of your first listed hack ?

 

Kext: AirPortBrcm4360

Find: 81F952AA00007529

Replace: 81F952AA00006690

 

I assumed the new changes were to be made in addition to so I left the 1st/DP1 hack alone and did not remove it.   Maybe the additional changes require Sierra to be the only Volume that clover is booting ?

Share this post


Link to post
Share on other sites

yes you still need darkvoids sierra patch. i added DTGP fix to the list because it is necessary for wifi fix to work. if you already have a dtgp method in dsdt then i guess it is not needed but usually clover would detect if its there and not patch the dsdt for dtgp.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By NoEnd
      Hi team,
       
      I have tried to update to security update 2019-001 multiple time with no luck, today I've booted the update with -verbose and attached videos shows the details.
       
      Appreciate your help
       
      Thanks
      Untitled.mov
    • By JhonneR
      Good morning, everyone, I'm sorry if I was wrong in choosing the topic but I need help.
      I have found it extremely difficult to mount a Hackintosh in my acer.
      Setup;
      I5 2430m 2.4 6GB RAM
      Mobo P5we0 - Intel intel Graphics 3000
      At the moment I have not found out what my audio codecs are.
      but I'll leave the link on the motherboard.
      however, my real problem is several.
      I have already used the itakos image, I have already used several images that could be installed normally and that after installing the image I do not have internet via cable or wireless.
      And another, I already looked in other forums and I know that I will be called a donkey in the logical question but I have not been able to install the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] or clover to start from the Hard Disk, so I do not know what to do.At the moment I still do not know if there has already been someone who has already installed the High Sierra or just the Sierra in this notebook model and obtained permanent success.
      If anyone can help me, I'll be grateful.
      Installations without success, but with the system already installed in ACER;
      SIERRA
      HIGH SIERRA
      MOJAVE
      All with the same symptom. Starting only by the bootable USB stick and without internet connection via cable and wireless.
      Appreciate ! Acer 5750 Official Page
    • By valueimagery
      Hello,

      I've updated via system preference fro 10.14.2 to 10.14.3 successfully. However, I've lost location services for Siri and Maps.

      Anyone else?

      I've tried a little trial and error troubleshooting but no luck...
      SysPref->Privacy->Location Services is enabled with all settings checked. I've tried to disable and enable, but not luck.

      I tested booting from previous backup of 10.14.2 install/uefi (pre update) and Location Services worked.

      Prior to OSX update I also updated to latest clover, WEG, Lilu, AirportBrcmFixup, AppleALC.

      So I tested by downgrading all of the above one at a time to the previous state, and still no Location services on 10.14.3

      I've used kext utility to repair any broken kexts.

      I've also tried forcequiting from activity monitor:
      com.apple.geod

      And I've Try Deleting:
      Library/Preferences/com.apple.GEO.plist
      Library/Containers/com.apple.geod

      I've booted into a guest user and this did not allow location services either.

      My build is using a native Broadcom BCM94352Z Dell DW1560 and BrcmPatchRAM2.kext + BrcmFirmwareRepo.kext

      Any thoughts?
    • By ucif19
      Hi, First of all, sorry for my English.
      I want to buy a WiFi/bt card for my hackintosh. I want a card that have a native support for MacOS because I need to use Handoff and AirDrop. I saw the card in the link below: anyone could tell me if the card have the requirements I mentioned before?
       
      wifi/bt card  Broadcom 94352Z DW1560: https://rover.ebay.com/rover/0/0/0?mpre=https%3A%2F%2Fwww.ebay.it%2Fulk%2Fitm%2F272204993348
       
      my build
      macos Mojave 10.14.3
      mobo: H170N-WiFi 
      cpu: i5-6500
      gpu: gtx 1060 6gb (not work on Mojave)
      Ram: 16Gb ddr4 2133 MHz
    • By fantomas1
      Hi InsanelyMacaholics   

      Use this thread to link / talk about of the future Nvidia Web Driver updates for macOS Sierra.
       
      10.12.6
      Nvidia Web Driver - 378.05.05.25f13 --> build 16G1815 (thanks to flowrider) New!
      Nvidia Web Driver - 378.05.05.25f12 --> build 16G1710 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f11 --> build 16G1618 (thanks to Frank Nitty)
      Nvidia Web Driver - 378.05.05.25f10 --> build 16G1510 (thanks to BreBo) 
      Nvidia Web Driver - 378.05.05.25f09 --> build 16G1408 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f08 --> build 16G1314 (thanks to BreBo)
      Nvidia Web Driver - 378.05.05.25f07 --> build 16G1314 (thanks to haring)
      Nvidia Web Driver - 378.05.05.25f06 --> build 16G1212 (thanks to WeBeRiO)
      Nvidia Web Driver - 378.05.05.25f04 --> build 16G1114 (thanks to lukazm)
      Nvidia Web Driver - 378.05.05.25f03 --> build 16G1036 (thanks to Gradou)
      Nvidia Web Driver - 378.05.05.25f01 --> build 16G29 (thanks to Badruzeus)
       
       
      10.12.5
      Nvidia Web Driver - 378.05.05.15f01 --> build 16F73 (see this post)
       
       
      10.12.4
      Nvidia Web Driver - 378.05.05.05f02 --> build 16E195(thanks to crachmaster4999)
      Nvidia Web Driver - 378.05.05.05f01 --> build 16E195 (thanks to Moviemakergr)  Pascal support!!!
      Nvidia Web Driver - 367.15.10.45f01 --> build 16E195 (thanks to Lanc)
       
       
      10.12.3

      Nvidia Web Driver - 367.15.10.35f01 --> build 16D32 (thanks to shatterhenner)
       
       
      10.12.2
      Nvidia Web Driver - 367.15.10.25f02 --> build 16C68 (see this post)
      Nvidia Web Driver - 367.15.10.25f01 --> build 16C67 (see this post)
      Nvidia Web Driver - 367.15.10.25b06 --> build 16C60b/16C63a (see this post)
       
       
      10.12.1
      Nvidia Web Driver - 367.15.10.15f03 --> build 16B2657/16B2659 (thanks to Moviemakergr).
      Nvidia Web Driver - 367.15.10.15f01 --> build 16B2555 (thanks to Moviemakergr)
       
       
      10.12.0
      Nvidia Web Driver - 367.15.10.05f01 --> build 16A323 (thanks to phi777)
       
       
      GM
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A323 (same driver since DP4/PB3)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A322 (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A320 (see this post)
       
       
      DP/PB
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A313a (DP8 & PB7) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A304a (DP7 & PB6) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A294a (DP6 & PB5) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A286a (DP5 & PB4) (see this post)
      Nvidia Web Driver - 367.10.10.05b01 --> build 16A270f (DP4 & PB3) (thanks to TheRacerMaster)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A254g (DP3 & PB2) (see this post)
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A238m (PB1) (thanks to Faun) 
      Nvidia Web Driver - 367.05.10.05b07 --> build 16A239j (DP2) (thanks to Faun)
      Nvidia Web Driver - 367.05.10.05b03 --> build 16A201w (DP1) (thanks to Xmedik)
       
×