Jump to content
Mr. Xtreme

[AMD] macOS 10.12.x (Sierra) Kernel Testing & Release (for help use the Help Topic)

787 posts in this topic

Recommended Posts

Advertisement

kernel booted to Desktop with no issues :) and NO green icon bug too :) tested it both with Clover and enoch.Some things are not working like Siri (It can't switch to mic mode.I used ALC662v2 kext from Capitan I have sound and mic is tested ok but maybe I need an update) I can't switch keyboard type or function keys shortcuts (voodooPS2 1.8.24) but Kernel is beta as you said :) Used USB fix V3 and in fact I have info now about my USB3 ports (ApppleUSBXHCIPCI) on system information :) Safari with flash player works App Store works Sleep works :) Excellent Kernel for BETA.

 

iMAC 14.2

DSDT from Capitan (No changes)

USB Fix V3

Latest FakeSMC (1412)

VoodooPstate 1.0.3

 

Thank you Bronya GREAT Job as always.

What boot parameters did you use? 

Share this post


Link to post
Share on other sites

What boot parameters did you use? 

Nothing new or special in fact i copied config.plist for Clover testing and org.boot.cham.....plist for enoch from capitan 

dart=0 darkwake=10 npci=0x2000 nvda_drv=1

of course CSR is deactivated in both bootloaders 103 for enoch and 0x67 for clover and i didn't injected any kexts ALL extra kexts are in /S/L/E 

Phenom II X4 920 and 940BE are sse4a not sse4.1 wait for a kernel with sse4.1 in openemu.

Share this post


Link to post
Share on other sites

very happy for those who got to install.and I still and stuck with the mouse and keyboard.I would be happy to install and test the software,but the mouse and keyboard does not let on.a whole day to kill.tried everything.

Share this post


Link to post
Share on other sites

kernel booted to Desktop with no issues :) and NO green icon bug too :) tested it both with Clover and enoch.Some things are not working like Siri (It can't switch to mic mode.I used ALC662v2 kext from Capitan I have sound and mic is tested ok but maybe I need an update) I can't switch keyboard type or function keys shortcuts (voodooPS2 1.8.24) but Kernel is beta as you said :) Used USB fix V3 and in fact I have info now about my USB3 ports (ApppleUSBXHCIPCI) on system information :) Safari with flash player works App Store works Sleep works :) Excellent Kernel for BETA.

 

iMAC 14.2

DSDT from Capitan (No changes)

USB Fix V3

Latest FakeSMC (1412)

VoodooPstate 1.0.3

 

Thank you Bronya GREAT Job as always.

Thanks for your hint which works for FX-6300 now.

The key element is to replaced my previous FakeSMC.kext to this version (v.6.21.1412).

Big thanks to Bronya again: you are my hero !

According to my experiment it seems working for FX-6xxx (or FX-8xxx) only at 10.12GM(16A323/322) up to now, need further workout for Athlon or Phenom CPUs.

post-70188-0-73938500-1477874811_thumb.png

Edited by jsl

Share this post


Link to post
Share on other sites

kernel booted to Desktop with no issues :) and NO green icon bug too :) tested it both with Clover and enoch.Some things are not working like Siri (It can't switch to mic mode.I used ALC662v2 kext from Capitan I have sound and mic is tested ok but maybe I need an update) I can't switch keyboard type or function keys shortcuts (voodooPS2 1.8.24) but Kernel is beta as you said :) Used USB fix V3 and in fact I have info now about my USB3 ports (ApppleUSBXHCIPCI) on system information :) Safari with flash player works App Store works Sleep works :) Excellent Kernel for BETA.

 

iMAC 14.2

DSDT from Capitan (No changes)

USB Fix V3

Latest FakeSMC (1412)

VoodooPstate 1.0.3

 

Thank you Bronya GREAT Job as always.

Please pm me how to install AMD Hack with Clover ^_^ cuz I have never got succeeded doing that! Thanks in advanced.

 

Congrats Bronya, always brilliant as usual!

Share this post


Link to post
Share on other sites

AMD AthlonII X4 635  get "still waiting for root device "

 

  • bootloader latest enoch
  • Kernel.plist
  • bf : npci=0x3000/2000 UseKernelCache=Y/N
  • iMAC 14.2
  • USB Fix V3
  • Latest FakeSMC (1412)
  • VoodooPstate 1.0.3

post-1113740-0-48785500-1477912698_thumb.jpg

 

 

Share this post


Link to post
Share on other sites

I'm stuck at this point with the latest kernel posted by Bronya

 

I have an fx 8320 

Latest fake smc

kernel.plist

usb fix v3 

boot with npci=0x2000, csractiveconfig=103 

post-1872079-0-08468000-1477913253_thumb.jpg

Share this post


Link to post
Share on other sites

AMD AthlonII X4 635  get "still waiting for root device "

 

  • bootloader latest enoch
  • Kernel.plist
  • bf : npci=0x3000/2000 UseKernelCache=Y/N
  • iMAC 14.2
  • USB Fix V3
  • Latest FakeSMC (1412)
  • VoodooPstate 1.0.3

attachicon.gifIMG_20161031_165540.jpg

If you installing, USB disk not recognised by the kernel try installing from a sata partition (internal HDD), if you booting an already installed sierra SATA controller mode must be AHCI on bios sometimes is good to use SATA1 port else you need drivers for your sata controller.

 

I'm stuck at this point with the latest kernel posted by Bronya

 

I have an fx 8320 

Latest fake smc

kernel.plist

usb fix v3 

boot with npci=0x2000, csractiveconfig=103 

 

rebuild prems and caches and try again also you can try -xpc bootflag

Share this post


Link to post
Share on other sites

AMD AthlonII X4 635  get "still waiting for root device "

 

  • bootloader latest enoch
  • Kernel.plist
  • bf : npci=0x3000/2000 UseKernelCache=Y/N
  • iMAC 14.2
  • USB Fix V3
  • Latest FakeSMC (1412)
  • VoodooPstate 1.0.3

attachicon.gifIMG_20161031_165540.jpg

AMD AthlonII X4 635 does not support SSE 4.1 like my Phenom II X6 1405T (unlocked from Athlon II X4 640), Phenom X4 9850, and Athlon 64 X2 6000+.

Please wait for new kernel which can emulate this.

Share this post


Link to post
Share on other sites

I'm stuck at this point with the latest kernel posted by Bronya

 

I have an fx 8320 

Latest fake smc

kernel.plist

usb fix v3 

boot with npci=0x2000, csractiveconfig=103 

Hi, I'm having exactly the same problem,

Any help please. 

Share this post


Link to post
Share on other sites

Some of the problems that i had was because of the USB V3 FIX apparently most of those kexts are outdated or compiled with wrong headers so i restored vanilla kexts except IOBDStorageFamily.kext,IOUSBFamily.kext(inside i replaced IOUSBHIDDriver.kext plugin with vanilla),IOUSBHostFamily.kext,IOUSBMassStorageClass.kext. Kernel prelinks now without errors (using Bronya's System.kext) i have mouse settings and keyboard types on system prefs and all my USB ports are still working fine.

Share this post


Link to post
Share on other sites

Some of the problems that i had was because of the USB V3 FIX apparently most of those kexts are outdated or compiled with wrong headers so i restored vanilla kexts except IOBDStorageFamily.kext,IOUSBFamily.kext(inside i replaced IOUSBHIDDriver.kext plugin with vanilla),IOUSBHostFamily.kext,IOUSBMassStorageClass.kext. Kernel prelinks now without errors (using Bronya's System.kext) i have mouse settings and keyboard types on system prefs and all my USB ports are still working fine.

 

You could put a package together for this if it works well for other users.

 

 

Also guys this topic is for testing, not for support. 

Install support forum > http://www.insanelymac.com/forum/forum/542-amd/

Post install support forum > http://www.insanelymac.com/forum/forum/544-amd/

Share this post


Link to post
Share on other sites

Help.I reach the language selection on install with USB and it does not work the mouse and keyboard.what to do what to do?Which USB loader to change any kexts?

Share this post


Link to post
Share on other sites

Some of the problems that i had was because of the USB V3 FIX apparently most of those kexts are outdated or compiled with wrong headers so i restored vanilla kexts except IOBDStorageFamily.kext,IOUSBFamily.kext(inside i replaced IOUSBHIDDriver.kext plugin with vanilla),IOUSBHostFamily.kext,IOUSBMassStorageClass.kext. Kernel prelinks now without errors (using Bronya's System.kext) i have mouse settings and keyboard types on system prefs and all my USB ports are still working fine.ii

I did the same things, i also rebuild caches and perms and boot with -xpc flag, but still no booting into the installation. I'm stuck at the same point and it's a loop, i think the problem is com.apple.xpc.launchd but i don't know what i have to do. Please help me 

post-1872079-0-68864400-1477938339_thumb.jpg

Share this post


Link to post
Share on other sites

Guys this isn't a support thread... Read my previous post.

 

Help.I reach the language selection on install with USB and it does not work the mouse and keyboard.what to do what to do?Which USB loader to change any kexts?

 

Look here, http://www.insanelymac.com/forum/topic/312714-macos-sierra-amd-cpu-tests/page-10?p=2310942&do=findComment&comment=2310942

 

I did the same things, i also rebuild caches and perms and boot with -xpc flag, but still no booting into the installation. I'm stuck at the same point and it's a loop, i think the problem is com.apple.xpc.launchd but i don't know what i have to do. Please help me 

 

Let it sit and it will continue. I had the same on an Intel machine. Just give it some time.

Share this post


Link to post
Share on other sites

Guys this isn't a support thread... Read my previous post.

 

 

 

Look here, http://www.insanelymac.com/forum/topic/312714-macos-sierra-amd-cpu-tests/page-10?p=2310942&do=findComment&comment=2310942

 

 

 

Let it sit and it will continue. I had the same on an Intel machine. Just give it some time.

 

I wait about 30 minutes but nothing, still loop with com.apple.xpc.... I tested some of the kernels posted here but i had the same result.

Share this post


Link to post
Share on other sites

I'm just reporting about this "kernel" in old processor which not support SSE4, .. in my case I used corecrypto AnV to pass opmenu  .. (like Shaneee SS/photos)

so must be patient about old cpu or buy the new one??  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

×