Jump to content
Mr. Xtreme

[AMD] macOS 10.12.x (Sierra) Kernel Testing & Release (for help use the Help Topic)

787 posts in this topic

Recommended Posts

Advertisement

@jsl

can you send us a picture, please

 

Edit:

I will now install and test sierra on my hackintosh

Edited by spakk

Share this post


Link to post
Share on other sites

Please test and report

 

Hi guys!

 

Will need modified kext USB, currently I used "USB Fix_El_Capitan_V3"

 

Kernel: AMD10.12_SSEPLUS_V2.zip

 

Clover Bootloader system will not boot!

Enoch starts, but the installer does not start!

I have attached pictures!

Last picture pmtelemetry.kext and AppleIntelCPUPowerManagement, AppleTyMCEDriver.kext deleted

post-1166679-0-69498000-1475605128_thumb.jpg

post-1166679-0-55252300-1475605136_thumb.jpg

post-1166679-0-69641500-1475605144_thumb.jpg

post-1166679-0-33127200-1475605153_thumb.jpg

Share this post


Link to post
Share on other sites

it looks very good  :D , a step further

Share this post


Link to post
Share on other sites

it looks very good  :D , a step further

 

AMD10.12_SSEPlus_Phenom_V2.zip
 
Installation went through, but unfortunately the system will not boot!
The error image attached! It is what has been seen above! (Last picture)
 
Interestingly, the difference between the El Capitan installer log file and MacOS Sierra installer log file!

post-1166679-0-77561100-1475610168_thumb.jpg

post-1166679-0-55659300-1475610174_thumb.jpg

post-1166679-0-90627200-1475610179_thumb.jpg

post-1166679-0-12759200-1475610188_thumb.jpg

Share this post


Link to post
Share on other sites

opcode error, use another kernel...

have you installed the current the FakeSMC ?

 

  • delete AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext

Share this post


Link to post
Share on other sites

Can someone try this please. Instant reboot on Athlon but hope FX will work better.

Not working for my 3 hacintoshs.

Athlon & Phenom got immediate reboot.

FX-6300 got KP as below:

post-70188-0-56522200-1475659973_thumb.jpg

Share this post


Link to post
Share on other sites

Please still wait, the source must be modified. I tryto resolve the problem with OPCODE loop error which occurs with Phenom kernel during boot.

Share this post


Link to post
Share on other sites

Not working for my 3 hacintoshs.

Athlon & Phenom got immediate reboot.

FX-6300 got KP as below:

remove extra/modules folder

Share this post


Link to post
Share on other sites

 

  • AMD10.12_SSEPlus_V2.zip
  • AMD10.12_SSEPlus_Phenom_V2.zip
 

Both kernels can boot on installer but this message appears "macos cannot be installed on this computer"

Sorry my english

 

http://imgur.com/a/L3xkw

 

Please explain what have done, so that you have booted the system to the installation mode. You can also write this in their country language. Thx

 

Edit:

There may be various causes.
For example: a broken Essential.pkg or a missing chipset driver?.
What hardware do you have. Please write your hardware specification in the signature.
 
Info:
Do you have installed these drivers: AppleNForceATA 64-bit and VIA kext driver
The current version of FakeSMC.kext, NullpowerManagement.kext, voodooPS2Controller, GenericUSBXHCI.kext (currentVersion), and VoodooTSCSyncAMD
and delete the AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext in S/L/E

Share this post


Link to post
Share on other sites

It was tested without /extra/modules folder.

then use the current Enoch bootloader or the previous version

Share this post


Link to post
Share on other sites

 

opcode error, use another kernel...

have you installed the current the FakeSMC ?

 

  • delete AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext

 

 

Hello!

Only "NullCPUPowerManagement.kext" and the latest "FakeSMC.kext" is being used!

I deleted the "AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext"

 

It remains the error: "AMFI...." and "invalid user opcode..."

 

The "AMFI: allowing for exception handler 'logd'..." what does it mean?

Share this post


Link to post
Share on other sites

We are still working on the firehose, it will take a little  ^_^

Share this post


Link to post
Share on other sites

 

Please explain what have done, so that you have booted the system to the installation mode. You can also write this in their country language. Thx

 

Edit:

There may be various causes.
For example: a broken Essential.pkg or a missing chipset driver?.
What hardware do you have. Please write your hardware specification in the signature.
 
Info:
Do you have installed these drivers: AppleNForceATA 64-bit and VIA kext driver
The current version of FakeSMC.kext, NullpowerManagement.kext, voodooPS2Controller, GenericUSBXHCI.kext (currentVersion), and VoodooTSCSyncAMD
and delete the AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext in S/L/E

 

English: i've used all this kexts you menssioned. the error continues

i've made the usb installer like the tutorial of shanee's El capitan and booted with enoch bootloader (last version) deleted the  AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext   and installed usb fix v3 from el capitan.  The installer boots saying ""macos cannot be installed on this computer""

Sorry my english¹

 

Português BR: Eu instalei as kexts que você mencionou e mesmo problema continua. Fiz o instalador do sierra baseado no tutorial do El capitan do shanee e fiz o boot com o Enoch (ultima versao) Deletei as kexts AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext e instalei o usb fix v3 do el capitan. Ao entrar no instalador a primeira tela é "O macOS nao pode ser instalado no seu computador" "Esta versão do macOS 10.12 nao pode ser instalada neste computador."

 

 

Processor: FX-8350 

Mobo: Gygabyte 970A-DS3P  Cipset: AMD: RD9x0 rev.02

RAM: 10GB DDR3 2x 4GB 1x 2GB.

Video: Zotac GeForce GTX 660 2GBVram

Share this post


Link to post
Share on other sites

English: i've used all this kexts you menssioned. the error continues

i've made the usb installer like the tutorial of shanee's El capitan and booted with enoch bootloader (last version) deleted the  AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext   and installed usb fix v3 from el capitan.  The installer boots saying ""macos cannot be installed on this computer""

Sorry my english¹

 

Português BR: Eu instalei as kexts que você mencionou e mesmo problema continua. Fiz o instalador do sierra baseado no tutorial do El capitan do shanee e fiz o boot com o Enoch (ultima versao) Deletei as kexts AppleintelCPUPowerManagement, and AppleTyMCEDriver.kext e instalei o usb fix v3 do el capitan. Ao entrar no instalador a primeira tela é "O macOS nao pode ser instalado no seu computador" "Esta versão do macOS 10.12 nao pode ser instalada neste computador."

 

 

Processor: FX-8350 

Mobo: Gygabyte 970A-DS3P  Cipset: AMD: RD9x0 rev.02

RAM: 10GB DDR3 2x 4GB 1x 2GB.

Video: Zotac GeForce GTX 660 2GBVram

I think that the content of the USB-FIX-V3 is the cause, why the system is stuck in the installation mode. Try another USB installer without USB fix

 

Edit:

wait a litle, we are close to the goal to build a new kernel, In the hope that the booting will work without problems.

Edited by spakk

Share this post


Link to post
Share on other sites

I think that the content of the USB-FIX-V3 is the cause, why the system is stuck in the installation mode. Try another USB installer without USB fix

 

Edit:

wait a litle, we are close to the goal to build a new kernel, In the hope that the booting will work without problems.

ok i'll wait.

Without USB Fix my keyboard and mouse doesn't work. like on el capitan. so i can't test without usbfix for now. thanks for all. i'll be waiting for a new kernel.

Share this post


Link to post
Share on other sites
At least two USB slots will work without USB Fix, you have to search the two working USB slots, either on the front or on the rear side of your hackintosh.

after that you can fix the USB problems.

Share this post


Link to post
Share on other sites

mi amigo , make sure ur smbios is also higher than a MacPro3,1 infact a iMac14,1 or 14,2 otherwise the installer will always deny the installation,

 

or u ll have to modify coreservice etc to allow the MacPro3,1 model.

Share this post


Link to post
Share on other sites

mi amigo , make sure ur smbios is also higher than a MacPro3,1 infact a iMac14,1 or 14,2 otherwise the installer will always deny the installation,

 

or u ll have to modify coreservice etc to allow the MacPro3,1 model.

hey! it works!! Thanks. I will try to install now and back here to report.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×