Jump to content
MacPeet

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)

1,575 posts in this topic

Recommended Posts

Advertisement

 

in DSDT under HDEF, see DSDT post #1

             Device (HDEF)            
             {
                Name (_ADR, 0x001B0000)
                Method (_DSM, 4, NotSerialized)
                {
                    Store (Package (0x08)
                        {
                            "built-in", 
                            Buffer (One)
                            {
                                0x00
                            }, 
                            "layout-id", 
                            Buffer (0x04)
                            {
                                0x0B, 0x00, 0x00, 0x00    //0B for AppleALC or 01 for old method
                            }, 
                            "PinConfigurations", 
                            Buffer (Zero) {}, 
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                }
            }

Yes I did see post 1, had another look. Still none the wiser. I can't seem to find where this HDEF is. Thanks for the reply though.

Share this post


Link to post
Share on other sites

@runo

Compare DSDT and config.plist and the Kext's from Post#1 !!!

 

 

@kilo23
You can also update from the Capitan. (only SMBIOS iMac10,1, SMBIOS MacPro3,1 not works)
1. Backup from Capitan!!!
2. Before, install new Clover in Capitan, sample version 3773.
3. All Kext's to EFI/Clover/kexts/10.11/ and to EFI/Clover/kexts/10.12/   !!!
4. SIP 0x67
5. Download macOS Sierra from appstore and run
6. After restarting, switch to the installer in the CloverBootloader
7. The rest as always.
 
After the installation, audio no longer works. See Post#1 for more info.
 
 
@Aaronation
Which Optiplex model?
Which audio method did you have before? On-the-fly with Clover?
Post here your DSDT.aml, then I make the change.

Share this post


Link to post
Share on other sites

 

@runo

Compare DSDT and config.plist and the Kext's from Post#1 !!!

 

 

@kilo23
You can also update from the Capitan. (only SMBIOS iMac10,1, SMBIOS MacPro3,1 not works)
1. Backup from Capitan!!!
2. Before, install new Clover in Capitan, sample version 3773.
3. All Kext's to EFI/Clover/kexts/10.11/ and to EFI/Clover/kexts/10.12/   !!!
4. SIP 0x67
5. Download macOS Sierra from appstore and run
6. After restarting, switch to the installer in the CloverBootloader
7. The rest as always.
 
After the installation, audio no longer works. See Post#1 for more info.
 
 
@Aaronation
Which Optiplex model?
Which audio method did you have before? On-the-fly with Clover?
Post here your DSDT.aml, then I make the change.

 

Hello, I'm using a 780 2.66GHz Quad and yes it was on the fly audio with clover.

 

Thanks

Hello, I'm using a 780 2.66GHz Quad and yes it was on the fly audio with clover.

 

Thanks

It doesn't look like I can add my file?

Share this post


Link to post
Share on other sites

Woohoo, sorry I don't know why I didn't think to do that.

I'm looking at my file and it looks like I may have found the HDEF. Doh!

I'm still gonna send this though cos I'll probably mess mine up!

DSDT.aml.zip

Share this post


Link to post
Share on other sites

try this:  DSDT.aml.zip

 

Install back the original AppleHDA to S/L/E                <---ok?

Install the AppleALC to S/L/E                                    <---ok?
Delete all AppleHDA Kext-to-patch entries in Clover    <---ok?
delete realtekALC.kext of Clovers kext folder              <---ok?
 
rebuild cache and reboot

Share this post


Link to post
Share on other sites

 

try this:  attachicon.gifDSDT.aml.zip

 

Install back the original AppleHDA to S/L/E                <---ok?

Install the AppleALC to S/L/E                                    <---ok?
Delete all AppleHDA Kext-to-patch entries in Clover    <---ok?
delete realtekALC.kext of Clovers kext folder              <---ok?
 
rebuild cache and reboot

 

You are a diamond sir, thank you very much.

Its working.

Sorry for my incompetence, I'm usually better than this!  :thumbsup_anim:

Share this post


Link to post
Share on other sites

Very good, lots of fun with Optiplex and Sierra.

 

Write your User-Signature with your hardware here in the forum!

 

Edit:

Thank you.

I like your signature. Unfortunately, GT610 does not work with Sierra.

Share this post


Link to post
Share on other sites

 

Very good, lots of fun with Optiplex and Sierra.

 

Write your User-Signature with your hardware here in the forum!

 

Edit:

Thank you.

I like your signature. Unfortunately, GT610 does not work with Sierra.

 

Yes I was lucky enough to read that the GT610 was no longer supported before I started the Sierra install.

However I'm a bit gutted as I've been installing El Capitan for friends on various Dell Optiplex machines mainly 780 SFF.

And most of them bought the GT610 on my recommendation, so I just hope they don't want to update too soon.

Share this post


Link to post
Share on other sites

 

@runo

Compare DSDT and config.plist and the Kext's from Post#1 !!!

 

 

@kilo23
You can also update from the Capitan. (only SMBIOS iMac10,1, SMBIOS MacPro3,1 not works)
1. Backup from Capitan!!!
2. Before, install new Clover in Capitan, sample version 3773.
3. All Kext's to EFI/Clover/kexts/10.11/ and to EFI/Clover/kexts/10.12/   !!!
4. SIP 0x67
5. Download macOS Sierra from appstore and run
6. After restarting, switch to the installer in the CloverBootloader
7. The rest as always.
 
After the installation, audio no longer works. See Post#1 for more info.

 

Thanks I will try it.  Does the clover version matter? (e.g. can I get the latest? or does that specific one only work?)

I assume SIP stuff is changed via clover?

And by back-up... This is the first time using a Mac for me.. so I assume cloning the drive is a back up?

Share this post


Link to post
Share on other sites

Clover version is important. Old versions do not work with Sierra.

Example 3650 I had tested, working very well. Latest 3773 also works well.
 
When you install a new Clover version, your settings in the config.plist are not overwritten.
 
Cloning is the best backup method.
 
Write your User-Signature with your hardware here in the forum!

Share this post


Link to post
Share on other sites

I have Sierra installed on my 755 Optiplex which is connected to my tv via hdmi from my GTX 750Ti after upgrading I booted with nv_disable=1 and updated the webdrivers and rebooted, but the display will not come up via hdmi. Could it be something in the framebuffer ? Is there any possible solution to this issue?

Share this post


Link to post
Share on other sites

@MacPeet I have that set in my config.plist but still no signal from hdmi let me try taking out the nvda_drv=1 command out of my plist and try rebooting again

 

Edit: taking out nvda_drv=1 and still having a black screen on both hdmi and vga with my tv it won't recognize the external display with the webdrivers on Sierra

Share this post


Link to post
Share on other sites

Inject nvidia is off with the web drivers?

 

try this:

patched in /System/Library/Extensions/AppleGraphicsControl.kext/Contents/PlugIns/AppleGraphicsDevicePolicy.kext/Contents/info.plist your SMBIOS / Board-ID to "none"

<key>ConfigMap</key>
<dict>
<key>Mac-00BE6ED71E35EB86</key>
<string>none</string>
<key>Mac-031B6874CF7F642A</key>
<string>none</string>
<key>Mac-189A3D4F975D5FFC</key>
<string>none</string>
<key>Mac-27ADBB7B4CEE8E61</key>
<string>none</string>
<key>Mac-35C1E88140C3E6CF</key>
<string>none</string>
<key>Mac-42FD25EABCABB274</key>
<string>Config2</string>
<key>Mac-4B7AC7E43945597E</key>
<string>none</string>
<key>Mac-77EB7D7DAF985301</key>
<string>none</string>
<key>Mac-7DF21CB3ED6977E5</key>
<string>none</string>
<key>Mac-81E3E92DD6088272</key>
<string>none</string>
<key>Mac-C3EC7CD22292981F</key>
<string>none</string>
<key>Mac-C9CF552659EA9913</key>
<string>none</string>
<key>Mac-F221BEC8</key>
<string>none</string>
<key>Mac-F221DCC8</key>
<string>none</string>
<key>Mac-F42C88C8</key>
<string>none</string>
<key>Mac-F60DEB81FF30ACF6</key>
<string>Config1</string>
<key>Mac-FA842E06C61E91C5</key>
<string>Config2</string>
<key>Mac-FC02E91DDD3FA6A4</key>
<string>none</string>
<key>Mac-F2268CC8</key>   //iMac10,1
<string>none</string>
</dict>

Write your User-Signature with your hardware here in the forum!

Share this post


Link to post
Share on other sites

MacPeet does it matter what brand of ATI 5450 to use?

Is smaller brand like Powercolor or XFX ok? Or must be big brand like Gigabyte or Asus?

Share this post


Link to post
Share on other sites

Hello Gents, my mic is not working for some reason.  I'm using the Modified hda not the on the fly method.  So much for Siri! Any hints I will gladly take them.  Bootup seems to be a lot longer if I use a Nvidia card!  I lost my vpn ppp client, I am very sad :(.  Oh yeah and I loose my ethernet if I let the machine sleep for long periods of time.

 

 

Cheers, snakeman

Share this post


Link to post
Share on other sites

If i install mult ibea st, my usb doesent work (so i cant use keyboard or mouse)

If i change the config.plist with a config.plist posted here, the countdown of clover doesent work anymore (but keyboard and mouse work)

 

Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By gengstapo
      @Hervé
       
      Im having similar issue with my HS setup, dell latitute 3480, i5-7200U
      Once the hdmi plugged in, the laptop display went blank, only could see the external tv
      But, when i put my laptop to sleep & wake up again, both screen got display (hdmi still connected)
      Even the hdmi could be plugged off & in (after sleep), the laptop display is fine
       
      What could be the culprit?
      Dell’s MacBook Pro IORegistry.zip
      config.plist.zip
    • By NikTheNoob
      Hi,
       
      I'm rather new to Hackintosh and trying my first build with OpenCore on AMD, but I run into issues causing OpenCore to crash before even loading the macOS installer. As I'm not sure which one is causing the crash, I'm trying to resolve all of them and one of the error messages has to do with WhateverGreen, which I was able to see in this slow-mo loading video. Basically I'm getting an error that I'm running an unsupported processor, even though I think I was following this guide by the step.
      What could be causing this and what do I need to do to resolve it?
       
      CPU: AMD Ryzen 2700X
      MB: Gigabyte Aorus X470 Ultra Gaming
      Memory: 4x8 GB HyperX Predator, 3000 MHz Cl15
      Storage: Samsung Evo 970 Nvme 512 GB, Crucial MX500 500GB SATA
      GPU: MSI Radeon RX580 GamingX 8GB
    • By MaLd0n
      --Donations via PayPal--
      https://tinyurl.com/r2bvzm7
       
      --Original Topic--
      https://www.olarila.com/topic/6874-olarila-hackbook-lenovo-ideapad-s145-mojave-catalina-full-dsdt-patches/
       

       
      -Perfect HackBook, HDMI Audio/Video, Bluetooth, AirPlay, Sleep, Lid Sleep, Auto Sleep, Audio, etc!
      -Wifi card has been replaced with Dell DW1560!
      -I'm using a S145-15IWL Model with Intel Core i5 8265u / Intel UHD Graphics 620
      -Update bios/uefi to last version
       
      --Installation--
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
       
      --Clover Folder--
      Just paste EFI folder inside EFI partition
      https://www.olarila.com/files/Clover.Folder/Lenovo IdeaPad S145.zip
      Notebooks with ELAN trackpad use it with my folder above
      IdeaPad S145 ELAN.zip
       
      Bluetooth Broadcom
      Bluetooth Broadcom.zip
       
      CPUFriend for i5-8265U
      CPUFriend i5-8265U.zip
       
      --Full DSDT Patches--
      -My DSDT
      DSDT Lenovo IdeaPad S145.zip
       
      This DSDT work on S145-14IWL, S145-15IWL, V14-IWL, V15-IWL models
      -Patches
      -FIX ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 11 ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PRWs -_DSMs -PNLF -BRIGHTNESS KEYS -I2C -NATIVE USB -ARPT -GFX0 -DTGP -kUSBCompanionIndex -io-device-location -FULL RENAMED DEVICES   --IGPU Patch--
      Video solution with HDMI Audio and Video
      <key>PciRoot(0x0)/Pci(0x2,0x0)</key> <dict> <key>AAPL,GfxYTile</key> <data> AQAAAA== </data> <key>AAPL,ig-platform-id</key> <data> CQClPg== </data> <key>device-id</key> <data> pT4AAA== </data> <key>enable-hdmi20</key> <data> AQAAAA== </data> <key>framebuffer-con0-alldata</key> <data> AAAIAAIAAACYAAAA </data> <key>framebuffer-con0-enable</key> <integer>1</integer> <key>framebuffer-con1-alldata</key> <data> AQEJAAAIAADHAQAA </data> <key>framebuffer-con1-enable</key> <integer>1</integer> <key>framebuffer-con2-alldata</key> <data> AgYKAAAEAADHAQAA </data> <key>framebuffer-con2-enable</key> <integer>1</integer> <key>framebuffer-fbmem</key> <data> AACQAA== </data> <key>framebuffer-patch-enable</key> <data> AQAAAA== </data> <key>framebuffer-stolenmem</key> <data> AAAwAQ== </data> <key>framebuffer-unifiedmem</key> <data> AAAAgA== </data> <key>hda-gfx</key> <string>onboard-1</string> <key>model</key> <string>Intel Corporation, Cannon Point-LP Iris Plus Graphics 655</string> </dict>   --Native USB Fix for Notebooks - No Injector/Kext Required--
      https://www.olarila.com/topic/6878-guide-native-usb-fix-for-notebooks-no-injectorkext-required/
      https://www.olarila.com/topic/6181-guide-native-usb-fix-for-desktops-no-injectorkext-required-skylake/
       
       
      -ScreenShots

































      -Links
       
       
      Clover https://github.com/CloverHackyColor/CloverBootloader
      AirportBrcmFixup.kext https://github.com/acidanthera/AirportBrcmFixup
      AppleALC.kext https://github.com/acidanthera/AppleALC
      Brcm Bluetooth https://github.com/acidanthera/BrcmPatchRAM
      Lilu.kext https://github.com/acidanthera/Lilu
      SystemProfilerMemoryFixup.kext https://github.com/Goldfish64/SystemProfilerMemoryFixup
      VirtualSMC.kext https://github.com/acidanthera/VirtualSMC
      VoodooI2C.kext https://github.com/alexandred/VoodooI2C
      VoodooPS2Controller.kext https://github.com/acidanthera/VoodooPS2
      WhateverGreen.kext https://github.com/acidanthera/WhateverGreen
      MaciASL - https://github.com/acidanthera/MaciASL
      acpica - https://github.com/acpica/acpica
      AptioMemoryFix.efi https://github.com/acidanthera/AptioFixPkg
      ApfsDriverLoader.efi https://github.com/acidanthera/AppleSupportPkg
      HFSPlus.efi https://github.com/JrCs/CloverGrowerPro/blob/master/Files/HFSPlus/X64/HFSPlus.efi?raw=true
      Hackintool https://github.com/headkaze/Hackintool
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
       
      We're all here to have fun and learn from each other!
×