Jump to content
MacPeet

[Guide] macOS Sierra 10.12 - Dell Optiplex 780 (760) (755) (790) (990)

1,574 posts in this topic

Recommended Posts

Advertisement

This is what I can get before it starts scrolling too fast:

 

http://i.imgur.com/MjaemEs.jpg

 

And then I can only catch this:

 

http://i.imgur.com/oJUmLRc.jpg

http://i.imgur.com/Rd6BixX.jpg

 

I managed to fix this by setting DropOem to true.

Now I can get to the installer interface but Disk Utility crashes when I open it.

However I was able to launch it from the Log Viewer and partition the drive, but if I try to install macOS it crashes with the same exception and only lets me view or save the log, restart or shutdown, and sometimes it restarts after a while.

Here's a log I saved: https://pastebin.com/FBUL6tu7

Share this post


Link to post
Share on other sites

I managed to fix this by setting DropOem to true.

Now I can get to the installer interface but Disk Utility crashes when I open it.

However I was able to launch it from the Log Viewer and partition the drive, but if I try to install macOS it crashes with the same exception and only lets me view or save the log, restart or shutdown, and sometimes it restarts after a while.

Here's a log I saved: https://pastebin.com/FBUL6tu7

Please make a Signature of the Device you are use in your Dell

more précise is better, also post the EFI Folder you are used

and what is the installation méthode

Share this post


Link to post
Share on other sites

Please make a Signature of the Device you are use in your Dell

more précise is better, also post the EFI Folder you are used

and what is the installation méthode

Any specific site I should upload the EFI folder to?

I'm using the method outlined in the first page of this thread.

Share this post


Link to post
Share on other sites

Any specific site I should upload the EFI folder to?

I'm using the method outlined in the first page of this thread.

Used more replay Option and attaching the file in Zip

EDIT***

Do you have ?

post-951341-0-09334900-1503604471_thumb.png

Share this post


Link to post
Share on other sites

Guys, I'm hoping someone could shed some light for me. I have a few SFF 755 laying around and one is up and running with Sierra 10.12.6 now and everything works. However, i notice that the machine wakes up from deep sleep after a long period of time and reboots itself. What could be the culprit?  Anywhere specific i need to look?  Any help would be greatly appreciated.  Thanks. 

Share this post


Link to post
Share on other sites

I agree we need a new topic :).

 

Volunteers wanted!!!

 

maybe later

A complete guide is a lot of work.
 
So much in advance, …
 
General information, all files (dsdt, config) from the Sierra Guide also work with High Sierra. The install methods are the same.
 
 
Direct Update from 10.12 to 10.13:
 
Backup 10.12 !!! Backup 10.12 !!! Backup 10.12 !!!
 
Before Update - Update Clover version (HS supported), example 4173 or later (CloverConfigurator current? - 4.49 or later)
Clover must be on the ESP (EFI partition). High Sierra no longer works with Clover on System Partition!
All your Kext to / others. (I have all the kext in /10.12 and /10.13 and /others)
Download HS Installer from appstore and try...
 
 
Clean Install:
 
I had with this configuration and USBInjector.kext always problems with USB Install flash drive.
Always error failure device ...
 
post-1358580-0-53079500-1503649203_thumb.png post-1358580-0-77170300-1503649217_thumb.png
 
I have deleted the device EHC1 and 2 completely from the DSDT and the patches in the config.plist also deleted and changed to USBInjectAll.kext.
This works better here. OSX automatically configures USB.
 
Example: example.zip
 
In the meantime I work with this method on all Hackintosh's.
 
Ok, create USB Install flash drive with the createmedia method
Install Clover to ESP (EFI Partition) on USB Install flash drive.
Copy your files (config, dsdt, kext's) to USB Install flash drive.
Unplug all the other HDD's
 
Now try the installation.
 
 
 
HD5450 Users (or HD5770, …):
 
 
Only with APFS:
Current apfs.efi must according to EFI/Clover/drivers64/
 
NightShift:
works with beta6 and 7

Share this post


Link to post
Share on other sites

@MacPeet

In my Dell Optiplex 790

I have never used USBInjectAll.kext, either to install or post install
I have no USB problems from Snow Leopard 10.6.8 to MacOS High Sierra 10.13

I also have a PCIe card USB 3.0 Inatek 4 port that does not cause any problem USB , all my usb port works without problem and the sleep and wake too

 

I remove my Geforce 1030 because I work a lot in HS

I use my Geforce 710

with the HD 5450 radeon the sleep wake does not work and i never got it to know why

Share this post


Link to post
Share on other sites

@MacPeet

In my Dell Optiplex 790

 

I have never used USBInjectAll.kext, either to install or post install

I have no USB problems from Snow Leopard 10.6.8 to MacOS High Sierra 10.13

I also have a PCIe card USB 3.0 Inatek 4 port that does not cause any problem USB , all my usb port works without problem and the sleep and wake too

Same for me on my 790. On my 755 however I do need to inject the USB ports otherwise they won't work (Usb injector kext + Rename patch in dsdt)

 

Verstuurd vanaf mijn E5533 met Tapatalk

Share this post


Link to post
Share on other sites

Same for me on my 790. On my 755 however I do need to inject the USB ports otherwise they won't work (Usb injector kext + Rename patch in dsdt)

 

Verstuurd vanaf mijn E5533 met Tapatalk

Ok 

I dont have a 755, the last one i got was in 2010

Share this post


Link to post
Share on other sites

Can be so @ chris1111, the Optiplex790 is obviously different.

Optiplex780 (760/755) since Capitan without Injector -> no ports
 
My Optiplex780 with HD5450 has no problems with sleep. With FrameBufferName "Shrike" Sleep is working here.
Presumably your HD5450 has to a new GPU bios.
@morpheousman also had this problem with an HD5450 and made biosupdate.

Share this post


Link to post
Share on other sites

http://i.imgur.com/wFhsS57.jpg

 

This happens after "DSMOS has arrived" when the spinning wheel appears.

Wth this CPU Xeon X3363

May be needs NULCPU for install ?

try to put this kext on EFI/CLOVER/kexts/10.12

also if this is not work try with your origin config.plist and the kext NULCPU

NullCPUPowerManagement.kext.zip

Share this post


Link to post
Share on other sites

http://i.imgur.com/wFhsS57.jpg

 

This happens after "DSMOS has arrived" when the spinning wheel appears.

From your earlier pics i can see that the panic is related to your Cpu (inconsistent p-state count). I got the exact same problem on my 755. I'm not home right now, so I would suggest that you use nullcpupowermanagement.kext for now to get you installed.

 

Edit: Chris1111 said it already.

 

Verstuurd vanaf mijn E5533 met Tapatalk

Share this post


Link to post
Share on other sites

Tried both config.plist with the new kext, same result as the last image, but before the GUI would start right after "DSMOS has arrived".Now it takes forever trying to launch findmydeviced over and over.

 

Some pics when using nv_disable (kind of hard to read, sorry):

 

http://i.imgur.com/RgzwdzJ.jpg

http://i.imgur.com/AyMSaRs.jpg

 

This time after the usual exception when trying to install it seemed to open Language Chooser but then crashed:

http://i.imgur.com/qwRN3kn.png

Share this post


Link to post
Share on other sites

Tried both config.plist with the new kext, same result as the last image, but before the GUI would start right after "DSMOS has arrived".Now it takes forever trying to launch findmydeviced over and over.

 

Some pics when using nv_disable (kind of hard to read, sorry):

 

http://i.imgur.com/RgzwdzJ.jpg

http://i.imgur.com/AyMSaRs.jpg

 

This time after the usual exception when trying to install it seemed to open Language Chooser but then crashed:

http://i.imgur.com/qwRN3kn.png

Man you are used Developer Preview  :hysterical:  :hysterical:

This is not from App Store?  :angel_not:

 

use Install macOS Sierra.app from mac appstore  :D

Sierra 10.12.6

Share this post


Link to post
Share on other sites

Man you are used Developer Preview  :hysterical:  :hysterical:

This is not from App Store?  :angel_not:

 

use Install macOS Sierra.app from mac appstore  :D

Sierra 10.12.6

 

A friend gave me the USB he used for his 755 with it and since the OP mentioned the Developer Preview I just went with it.

Share this post


Link to post
Share on other sites

Ok, I've tried with 10.12.6, with both configs, with and without the nullcpupowermanagement kext, and with and without nv_disable.

It gets stuck here forever: http://i.imgur.com/VOLhJvD.jpg

 

then same lines about kext wait and IOHDACodec, GUI with spinning wheel and same kernel trap panic.

Share this post


Link to post
Share on other sites

Ok, I've tried with 10.12.6, with both configs, with and without the nullcpupowermanagement kext, and with and without nv_disable.

It gets stuck here forever: http://i.imgur.com/VOLhJvD.jpg

 

then same lines about kext wait and IOHDACodec, GUI with spinning wheel and same kernel trap panic.

 

These are my config, DSDT and kexts, taken from my working Optiplex 755.

 

CLOVER.zip

 

 
 
 

http://imgur.com/a/nfmel

 

Can anyone help me?

 

What's your graphics card?

Share this post


Link to post
Share on other sites

These are my config, DSDT and kexts, taken from my working Optiplex 755.

 

attachicon.gifCLOVER.zip

What's your graphics card?

 

Without DropOem: early kernel panic

With it: same as above but with sound assertion in AppleHDAEngine and AppleHDAWidget, after a long time boots up GUI, kernel panic when selecting Install.

Share this post


Link to post
Share on other sites

Without DropOem: early kernel panic

With it: same as above but with sound assertion in AppleHDAEngine and AppleHDAWidget, after a long time boots up GUI, kernel panic when selecting Install.

 

And if you use my files in combination with nullcpupowermanagement.kext posted by Chris1111 earlier? Also, how are your BIOS settings? 

 

I assume you are using a patched bios version in order to make your xeon work (added micro code)?

Share this post


Link to post
Share on other sites

These are my config, DSDT and kexts, taken from my working Optiplex 755.

 

attachicon.gifCLOVER.zip

What's your graphics card?

if i delete the dsdt file i boot normaly.

 

but the graphic is not full hd. is 1080x1024. And i have no sound. 

 

I have the Radeon HD5450 Graphics Card

when i boot without the usb i see this 

 

https://www.dropbox.... 18 42.jpg?dl=0

 

https://www.dropbox.... 18 46.jpg?dl=0

 

Now i try to boot from usb again but i see this 

https://www.dropbox.... 23 18.jpg?dl=0

 

and i cant open.

 

 

pfffff

 

 

what i do wrong???? 

So if i make a fresh install now i did not see my SSD to erase. WTF

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/forum/download/file.php?id=25033
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/download/file.php?id=24376
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By shinho73
      Can someone help me fix reboot issue? Actually it reboots, but sometimes the hackintosh just hangs with screen off. Here is the Extra folder containing org.chameleon.boot.plist. https://drive.google.com/drive/folders/1MX8-DpQk9kaRUfjPcToxf-ElWh-bN6EY?usp=sharing  and the spec of the PC. https://drive.google.com/drive/folders/1NlcUNK5DBzJFxeFeuyt92eRjQqwO5T32?usp=sharing Can someone look at it? I might be doing something wrong. Any help will be greatly appreciated. Thank you. 

    • By fusion71au
      This is a brief guide on how to create a vanilla El Capitan (also same process for Sierra) OS X Installer USB with an updated prelinked kernel containing FakeSMC.

      It is tailored for those users who want to understand the “nuts and bolts” of how to create an installer and also to help brush up on their terminal skills (rather than have one made for them with the numerous automated “tools” available or even Apple’s createinstallmedia) :
       
       
      Specifically, it is also a “Proof of Concept” which shows that installation is possible without even having to rely on boot loader kext injection.

      Prerequisites
      Existing Yosemite installation (or Mavericks - see post#4 for steps 7,8) “Install OS X El Capitan.app" downloaded to the Applications folder Pacifist FakeSMC.kext - Slice or Kozlek branch Bootloader - Clover or Chameleon 8GB or larger USB drive (16GB recommended), formatted HFS+ (MBR or GUID) named “Installer”  
      Procedure
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Open OS X terminal and type the following lines, followed by <Enter> after each line.
          The image restore and file copying may take a while to complete, and at the end of the process, the Installer volume is renamed to “OS X Base System"....
       
      sudo -s hdiutil attach /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/SharedSupport/InstallESD.dmg asr restore -source /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg  -target /Volumes/Installer -erase -format HFS+ -noprompt -noverify rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages cp -av /Volumes/OS\ X\ Install\ ESD/Packages /Volumes/OS\ X\ Base\ System/System/Installation cp -av /Volumes/OS\ X\ Install\ ESD/BaseSystem.dmg /Volumes/OS\ X\ Install\ ESD/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System diskutil unmount /Volumes/OS\ X\ Install\ ESD exit 3.  Right click on the “OS X Base System” Volume and click “Get Info”
       

      4.  Click on the lock icon and untick “Ignore ownership on this volume”
       

      5.  Extract/Copy the El Capitan Kernels folder into /System/Library/ of the USB with Pacifist.  NB It is found in the "Essentials.pkg" in /System/Installation/Packages
       

      6.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel —> OG.prelinkedkernel
       

      7.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of the installer USB using Finder.
       

      8.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel…..
       
      sudo -s chmod -R 755 /Volumes/OS\ X\ Base\ System/Library/Extensions chown -R 0:0 /Volumes/OS\ X\ Base\ System/Library/Extensions touch /Volumes/OS\ X\ Base\ System/System/Library/Extensions kextcache -u /Volumes/OS\ X\ Base\ System exit Any errors should be noted but the output below is normal e.g.


      9. Install your Bootloader targeting the OS X Base System volume
       
       
       
       
      10.  Boot your system with the USB without injected kexts into the OS X Installer GUI....
       
       
       
       
       
      Post Install
      The original prelinked kernel in a fresh install of El Capitan will also lack FakeSMC ie it will only be linked to Apple signed kexts.  In order to boot into El Capitan the first time around without boot loader kext injection, the PLK needs to be rebuilt for the El Capitan volume like we did for the installer:
       
      1.  Boot into Yosemite with the kext-dev-mode=1 boot flag
      2.  Delete or Rename the original /System/Library/PrelinkedKernels/prelinkedkernel for the El Capitan volume —> OG.prelinkedkernel
      3.  Copy FakeSMC.kext and other necessary kexts (e.g. VoodooPS2Controller.kext for laptops) into the /Library/Extensions folder of El Capitan using Finder
      4.  Back in terminal, type the following lines, followed by <Enter> after each line to rebuild the prelinkedkernel.  In this example, the El Capitan volume is named "El_Capitan" - change if you have named it something else...
      sudo -s chmod -R 755 /Volumes/El_Capitan/Library/Extensions chown -R 0:0 /Volumes/El_Capitan/Library/Extensions touch /Volumes/El_Capitan/System/Library/Extensions kextcache -u /Volumes/El_Capitan exit 5. Install your Bootloader targeting the El Capitan volume.  This step is only necessary if you are installing El Capitan on a new drive without existing boot loader (not required if installing on a disk with existing boot loader beside Yosemite).
      6. Reboot your system without injected kexts into El Capitan!
       
       
      Other links
      The All-In-One Guide to Vanilla OS X for beginners
       
      Updates for Sierra and High Sierra   Custom Prelinkedkernel Generator Tool I have made a custom prelinkedkernel generator "PLK.tool" for Sierra + El Capitan.  Instructions:   1.  Download and extract the attached BaseSystem_PLK.tool.zip into your ~/Downloads folder.   2.  Copy any extra kexts necessary for booting your hack to ~/Downloads/BaseSystem/ExtraKexts (e.g. FakeSMC, VoodooPS2Controller), making sure SIP is disabled. 3.  Copy BaseSystem.dmg to ~/Downloads/BaseSystem  4.  Open terminal and run the following commands... cd ~/Downloads/BaseSystem chmod +x PLK.tool ./PLK.tool ---> supply your admin password ---> will place your new custom prelinkedkernel on the desktop.       macOS High Sierra bypass Firmware and MBR checks in post#13.
      BaseSystem_PLK.tool_ElCap.zip
      BaseSystem_PLK.tool_Sierra.zip
      BaseSystem_PLK.tool_Mojave.zip (need to run in Mojave to avoid dependency errors)
      BaseSystem_PLK.tool_Catalina.zip
    • By fusion71au
      Clover r5051 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r5051 for VMware.zip". Mount Clover-v2.5k-5051-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×