Jump to content
fantomas

Nvidia Web Driver updates for macOS Sierra (UPDATE Sept 27, 2019)

1,064 posts in this topic

Recommended Posts

Advertisement

Hey,

 

After many, MANY, tests, I can't get my GTX 1060 to work on 16G1815 with this last Web Driver update. (I have two of these 1060s on my disposal)

When booting with nv-disable=0, the system will not.. "finish" to boot. In verbose mode, I'm having all the usual lines 'till the last, and nothing happening next.

 

The frustrating part is, my GTX 970 work perfectly fine !
With absolutely the same settings (just have to unplug the 1060, plug the 970, and go)

Even with two GTX 970, I can have 6 independent displays working (professional needs of that many screens...)

 

Everyone of these 4 GPUs (1060s and 970s) are from MSI, Gaming X version.

 

If someone has any idea of a little tip, something I could have missed, or good topic to post on...

 

Thanks

 

System 

MB : MSI Z97 Gaming 5
CPU : i7 4790k
Webdriver : f13, installed/re-installed many times, with or without the GPU plugged in, with or without the driver "EmuVariableUefi-64"


Drivers : OsxAptioFix2 + EmuVariable

Kexts : Lilu + Whatevergreen , both up to date

SIP off (0x67)
"NvidiaWeb" activated in CloverConfigurator
Clover up to date


I can not manage to install HighSierra either on this config, which is another problem I need to deal with, but can be the solution...

 

Share this post


Link to post
Share on other sites

^^^^Some models of the GTX 1060 have trouble on a Mac.  The GTX 1070 and GTX 1080 seem to be OK.  I am running a Gigabyte GTX1080 in HS. I recommend another GPU.

Lou

 

 

Edited by flowrider

Share this post


Link to post
Share on other sites

I updated my Sierra hackintosh tonight and graphics broke again. Build 16G1918 is not compatible. :grumble:

 

Edit: For giggles I chatted with support at Nvidia and they informed me that they do not have a fix and that I need to roll back my upgrade.  When I asked how long for an update to be released for the driver the reply was "we cannot comment on that."

 

Edit2: Nvidia just put out updated drivers for 16G1918.  I don't have a link, but they installed via Preference Pane.

Edited by turtle2472

Share this post


Link to post
Share on other sites
On 3/29/2019 at 8:44 PM, turtle2472 said:

I updated my Sierra hackintosh tonight and graphics broke again. Build 16G1918 is not compatible. :grumble:

 

Edit: For giggles I chatted with support at Nvidia and they informed me that they do not have a fix and that I need to roll back my upgrade.  When I asked how long for an update to be released for the driver the reply was "we cannot comment on that."

 

Edit2: Nvidia just put out updated drivers for 16G1918.  I don't have a link, but they installed via Preference Pane.

 

The same thing happened to me about the same time as you.  The update came out a few days later.  My practice now is to wait maybe a week before updating the OS.  Always check this site (link below) to see if there is a driver for a newer build.  In other words, see if there is a newer build with a new driver.  Don't proceed until you confirm that there is a graphic driver for the next build for your OS.  I have the latest graphics driver so I will no update my OS.  Even though the update may not effect the graphics.  I won't risk it.

 

10.12.6 16G1917.pdf

 

 

Edited by Mikentosh2016
Adding insanelymac link to graphic driver update list. Adding screenshot of list of current graphic driver available.

Share this post


Link to post
Share on other sites

Thank you for this listing.  I waited for the "new" build on this page before updating my OS. 

Edited by Mikentosh2016
Added "build"

Share this post


Link to post
Share on other sites

Thanks for 16G2136.  Smooth update.

Share this post


Link to post
Share on other sites

Can anyone help? I used this to install the correct driver for my build, worked fine first time.

 

Installed the latest driver and patched NVDAStartup and it just hung on spinning beach ball.

 

Exited this and restarted and now it tells me it's using the default driver because my system doesnt match.

 

Uninstalled everything, reinstalled correct driver and still tells me my system isn't valid... not sure what the patch did, but I'd like to undo it and install the valid Nvidia driver again... I know I should have just left it but hey.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By gengik84
      First beta... build 20A4299v 
       
      Useful information:
      macOSDeveloperBetaAccessUtility.dmg.zip OpenCore is now able to boot the installer and pre-existing installed macOS 11 Big Sur macOS Big Sur beta 2 (20A4300b)  New! VMware alternative topic installScript_1016fullapp
    • By MaLd0n
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -Tutorial
      https://tinyurl.com/re2c9sz
       
      -Post Installation
      Paste EFI folder into EFI Partition in your SSD, reboot and extract one full dump with this app and post here!
      https://tinyurl.com/ybwr9kq3
      RunMe.app
      https://tinyurl.com/y9562hz7
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--
       









































       
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
       
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, headkaze, onemanosx, erroruser, Jenny David, Sampath007, Facebook Hackintosh community, Facebook Olarila community, SchmockLord, daliansky and many, many, many others!
       
      We're all here to have fun and learn from each other!
    • By MaLd0n
      First...
      If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By gengik84
      First beta... build 20A4299v 
       
      Useful information:
      macOSDeveloperBetaAccessUtility.dmg.zip How to install macOS Big Sur on PC | Macintosh | Hackintosh
×