Jump to content
fantomas

Nvidia Web Driver updates for macOS Sierra (UPDATE Sept 27, 2019)

1,064 posts in this topic

Recommended Posts

Advertisement

Report: GT1030 works, according to a post on another forum. He also ran a benchmark.

 

are you speaking with me?

 

I'm speaking about Geekbench 4.1

you are speaking about unigine.

so thank you, but not related to my question

Share this post


Link to post
Share on other sites

I have had the same black screen bug with my GTX680.  I am using a quo motherboard with what i have confirmed is the latest BIOS installed.  Up until now i have just been using the built in driver and it's been fine but for some reason the 10.12.5 upgrade made my graphics card stop functioning.  I tried installing the NVIDIA web driver and disabling nvidia injection in defaults.plist but no luck.  Do you guys have any suggestions?  I was thinking of upgrading my graphics card anyway, is it possible that GTX 680 is just too old for the 10.12.5 web driver?  Has anyone else successfully used it with a GTX680? 

Share this post


Link to post
Share on other sites

I have had the same black screen bug with my GTX680.  I am using a quo motherboard with what i have confirmed is the latest BIOS installed.  Up until now i have just been using the built in driver and it's been fine but for some reason the 10.12.5 upgrade made my graphics card stop functioning.  I tried installing the NVIDIA web driver and disabling nvidia injection in defaults.plist but no luck.  Do you guys have any suggestions?  I was thinking of upgrading my graphics card anyway, is it possible that GTX 680 is just too old for the 10.12.5 web driver?  Has anyone else successfully used it with a GTX680? 

My GTX-680 is working at both 10.12.x and 10.13.beta2 with native OS X drivers.

I boot with nvda_drv=0 by Enoch 2883/2885.

For Nvidia Web Driver you should install the newest version for 10.12.5 if you want to enable it by Enoch 2883 or Clover 409x.

Share this post


Link to post
Share on other sites

:)

 

GTX 1050 Zotac itx // 10.12.6 beta 5

 

compute  LuxMark 3.1 OpenCL is good (Hotel no works) but OpenGL is very bad :(

 

compute OpenCL Geekbench 4.1 no works macOS and Windows 10 64  :hysterical:

 

 

post-2087795-0-19062000-1499130780_thumb.png

post-2087795-0-56536400-1499130793_thumb.png

post-2087795-0-84416300-1499130824_thumb.png

post-2087795-0-43184200-1499131055_thumb.png

Share this post


Link to post
Share on other sites

Hi guys,

 

I recently decided to delve into Hackintoshinginging again and installed Sierra.  I'm using a GTX 1080 and with the latest web drivers everything works ok except I am getting the black box flickering in menu bar thing. 

 

I am guessing this is something to do with the transparency?  I am just testing with 'reduce transparency' enabled in Accessibility.  I wouldn't actually mind having the menu bar fully opaque anyway; just wish enabling 'reduce transparency' didn't kill ALL transparency, like in the dock. 

 

Any ideas?  Thanks. 

 

EDIT: 'reduce transparency' makes no difference :o/

Share this post


Link to post
Share on other sites

Hi guys,

 

I recently decided to delve into Hackintoshinginging again and installed Sierra.  I'm using a GTX 1080 and with the latest web drivers everything works ok except I am getting the black box flickering in menu bar thing. 

 

I am guessing this is something to do with the transparency?  I am just testing with 'reduce transparency' enabled in Accessibility.  I wouldn't actually mind having the menu bar fully opaque anyway; just wish enabling 'reduce transparency' didn't kill ALL transparency, like in the dock. 

 

Any ideas?  Thanks. 

 

EDIT: 'reduce transparency' makes no difference :o/

Did you try to disable mirroring options in menu bar? (Settings > Display > Show mirroring options in the menu bar when available)

Share this post


Link to post
Share on other sites

Did you try to disable mirroring options in menu bar? (Settings > Display > Show mirroring options in the menu bar when available)

Ello,

 

I think mirroring options are already disabled. I will check though.

 

If anyone has any more suggestions that would be great thanks.

 

 

Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

I have had the same black screen bug with my GTX680.  I am using a quo motherboard with what i have confirmed is the latest BIOS installed.  Up until now i have just been using the built in driver and it's been fine but for some reason the 10.12.5 upgrade made my graphics card stop functioning.  I tried installing the NVIDIA web driver and disabling nvidia injection in defaults.plist but no luck.  Do you guys have any suggestions?  I was thinking of upgrading my graphics card anyway, is it possible that GTX 680 is just too old for the 10.12.5 web driver?  Has anyone else successfully used it with a GTX680? 

It's working NVIDIA GeForce GTX 680 4095 Mb.(Yes nv_web and No -  Metal: -- Yes).10.12.5 It's work. 

If not, then look for error "nvram.plist".

 

10.12.6 (16G24b) nvda_drv and NVIDIAWeb  No work.  - (OS X Default Apple Metal Yes).

Share this post


Link to post
Share on other sites

As far as i knwo an Pascal Cards only DisplayPort Audio ist working. HDMI not. Webdriver ist buggy with Pascal cards. maxmell is working well (DisplayPort and HDMI)

Share this post


Link to post
Share on other sites

My 1080 Ti is working with 10.12.5, but HDMI audio isn't working, unfortunately.

 

My EVGA 1050 TI FTW 4GB is working fine but get no audio trhougth HDMI or Display Port on boot, only after hot plug HDMI cable with DisplayPort connected.

 

Toleda help me alot and we will have to wait for a new version of the web driver.

 

:help:

Share this post


Link to post
Share on other sites

As far as i knwo an Pascal Cards only DisplayPort Audio ist working. HDMI not. Webdriver ist buggy with Pascal cards. maxmell is working well (DisplayPort and HDMI)

That is false. I have Gigabyte GTX 1080 Ti OC and I use HDMIaudio.kext in Clover\kexts\other folder and HDMI audio is working flawlessly.

It is also working correctly on my GTX 1070 FE as well as Zotac GTX 1060.

 

I really don't care if the kext is unsupported. As long as it is not unleashing a virus on my hackintosh, that damn kext is stayng in my clover folder. 

audio_CloverHDMI command does not work for 99% of people.

Share this post


Link to post
Share on other sites

I dont speak of Hacks with a additional KEXT. I talk about native Audio with Webdriver / DSDT.

With VoodooHDA HDMI always does/did work too. ;) But this is a unproper solution.

Share this post


Link to post
Share on other sites

I dont speak of Hacks with a additional KEXT. I talk about native Audio with Webdriver / DSDT.

With VoodooHDA HDMI always does/did work too. ;) But this is a unproper solution.

BTW HDMIAudio kext enables native audio unlike VoodooHDA.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Rohan20
      Opencore is running really really slow on Catalina 10.15.4. So It was running perfectly before I put the ssdt-pnlf for enabling Brightness control. it is running really slow and I verified my config with the sanity checker and its all correct. can someone please help. I am attaching my oc folder.

       
      https://www.dropbox.com/s/drkek0eaz19ina5/OC.zip?dl=0
       
    • By Prasanth_1991
      I recently installed Hackintosh Sierra. I don't have dedicated graphics card so I just used Intel integrated graphics which is Intel HD 4600 but since the Mac OS Sierra graphics acceleration not supported by native VGA output I'm left out options. I tired many things but nothing works. It's 2020 I'm pretty sure many people probably have better solution for this, if yes please help me.   Details PC Spec  i7 4790k HD 4600 Motherboard Gigabyte B85M-D3H-A
    • By Sagnik Ganguly
      Hello I'm Sagnik Ganguly, I'm trying to dual boot macOS 10.14 and Windows 10 (already installed) on a PC with Legacy BIOS. I've two hard drives one in where the windows is installed and another which is converted to GPT to install macOS Mojave 10.14 with a partion of Mac OS Extended (Journal) or APFS but when I went to the Install Disk Selection page, I'm selecting the partition but it says "This version of macOS 10.14 cannot be installed on this computer." can you help me please? 
      P. S. My motherboard doesn't support UEFI. 
      I'm attaching some pictures of the screens.


    • By y010204025
      Disclaimer: All files of this article are from itpwd.com and rehabman ’s github.com

       
      After Testing:
       
      Graphics card: NVIDIA K1000M / K2000M / K2100M / K3000M / K3100M / K4000M / M1000M (ordinary TN1600x900 or 1920x1080), AMD W5170M / W7170M (DC2 or 4K), Intel HD4000 (ordinary TN1600x900 or 1920x1080) can be driven normally, but NVIDIA graphics card Brightness adjustment is disabled. AMD W5170m and w7170m are the best choices on 8570W and 8770W. The brightness can be adjusted normally and the graphics performance is very good. For WX7100m and WX4170m, the graphics card fans cannot be controlled, and other methods are required to control the fans. CPU: 3rd generation Intel Core i3, i5 and i7 (Ivy Bridge architecture, including all dual-core and quad-core. Celeron and Pentium are not supported), frequency conversion is normal. In general: If you have 8570W, 8770W, and hope you can get the best Hackintosh experience, it is recommended to replace the CPU with i7-3840QM / i7-3940XM, 8570W is recommended to choose W5170M, 8770W, and it is recommended to choose W7170M. In addition: If you want to have a 4K experience or perfect HIDPI, W5170m / W7170M supports 4K output, you can choose a suitable 4K screen to replace, but because 4K screens are mostly edp interface, and 8570W / 8770W motherboard is lvds interface, This requires a custom screen cable, which seems to be a difficult choice, but you can choose to do it yourself or buy it separately. In China, taobao.com is almighty and may be more suitable for you than eBay.
       
      EFI features:
      out of the box, the relevant hardware can be driven after the OS is installed, and it is easy to use without code operation.
      Supported models: HP EliteBook 8470p, 8570p, 8570w, 8770w (click the model for official specifications)
      Wireless network card: Recommended: BCM94360cd (requires ipex4 to ipex1,3 antenna 1300mbps), BCM94352HMB / DW1550 (2 antennas, 867mbps)
      Wireless characteristics: no white list, wireless network card with Bluetooth does not support the Bluetooth function of the wireless network card (also does not need to shield the pins), but the wireless normal use, you need the Bluetooth function to use this machine comes with Bluetooth:
      Clover version: 5103, keyboard mapping has been added Command key = Alt key, Option key = Win key
      Supported systems: macOS Mojave 10.14.6 (18G103)-macOS Catalina 10.15.x,
       
      Notes on known issues:
      1. The touchpad and the left and right keys under the touchpad are normal, the pointing stick and the left and right keys above the touchpad are temporarily unavailable (recommended to use the second generation of Apple Magic Trackpad)
      2. Indicator display problem (can be ignored, function is normal): Caps light is sometimes not switched in time, mute / wireless key may be yellow
      3.AMD graphics card / Intel nuclear display has supported sleep and 15 levels of brightness adjustment, NVIDIA has no
      4. If the AMD graphics card enters Huaping, refer to editing the Clover startup parameters, and add the Boot parameter radpg = 15 (the EFI file that has been configured with this parameter has been uploaded, refer to the following EFI-guided download link)
      5. Using the above NVIDIA graphics card with a normal TN screen 1600x900 or 1920x1080 can not enter the installation interface, please check whether the VBiOS of the graphics card is exclusively for HP, thank you for your test face K1000M
      6. Due to product design defects, the MSata positions of 8570w and 8770w cannot be used as boot disks, so EFI boot can only be placed on the main hard disk (turn the machine over and open the hard disk in the lower left corner of the cover, which is the main hard disk). Put on msata plate
      +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      Hardware requirements:
      Model: 8470p, 8570p, 8570W, 8770W 1 or more, it is recommended to use another notebook for emergency Hard disk: It is recommended to choose an SSD hard disk of 240g or more. Samsung or Intel SATA hard disk is a good choice. Wireless card: BCM94352HMB, DW1550, BCM94360CD, miniPCIe slot U disk: 1 for 16g and above, another winPE emergency USB disk is recommended If you use a rescue USB flash drive, it means that you read this post carefully
       
      Make and install a USB flash drive:
      Get the mirror: please do it your way Making and installing a USB flash drive: macOS command line production is recommended, whether it is a real macOS model or a virtual machine (although this is not allowed to be discussed in many forums)Or you can choose to use TransMac or ether under Windows. This is not recommended, but it is simple enough for those new to Hackintosh. Make boot U disk: If you know how to put the boot into the installation U disk, unzip the EFI file and put it in the EFI partition, or you can choose a fat32 format U disk to store the EFI file separately Note: EFI is an unzipped folder, not a zip or ISO suffix file.
       
      BIOS settings From RehabMan
      To start, set BIOS to defaults.
      Then insure:
      UEFI boot is enabled (hybrid/with CSM for best result) secure boot is disabled disable fast boot IGPU graphics memory set to 64mb, if available disable the serial port via BIOS option, if available disable "LAN/WLAN switching", if available disable "Extended Idle Power States" if you find it under "Power Management Options" disable "Wake on LAN" and "Wake on USB" disable Firewire/IEEE 1394, if your laptop has it for Skylake and KabyLake laptop, enable "Launch Hotkeys without Fn keypress" Note: If you have a laptop with switchable graphics, leave it enabled. You can still use it on Windows, although the discrete card will be disabled when running OS X by the ACPI patches provided here. If you want to also disable it in Windows (via BIOS option), make sure you read about the DGPU option in your model specific SSDT (source is in SSDT-HACK.dsl), as in the scenario where the DGPU is disabled by BIOS, DGPU should be set to zero.
       
      Install:
      Please modify according to the above BIOS settings: Press F9 after booting, select the boot efi to file option, which is generally the last item. Enter your boot USB disk to find the location of cloverx64.efi, select cloverx64.efi, press Enter, and enter the clover boot interface. Select the location of the install entry and press Enter. Enter the macOS interface, use the disk tool to format the partition you need to install to hfs + or apfs format, do not choose the encryption option, this will make your efforts in vain. Note: The disk must be in gpt format, and the remaining EFI space is greater than 200M, 300mb + is recommended. If it is not, please try to modify it in WindowsPE environment. This may cause you to lose the Windows system boot and disk data. Please prepare for backup.
      After formatting the partition successfully, close the disk tool and select install, you will find the partition you installed, and follow the interface prompts. When the installation reaches a certain progress, it will restart. When restarting, select F9, enter from the boot U disk, select the disk partition where you installed macOS (no longer the U disk installation), the installation will continue, and it may restart 2 ~ 3 times Every time, you need F9 to select the boot. After entering the installation interface, except for the first installation, select the U disk, and then select the disk installation partition. Eventually you will enter the settings interface. After following the interface prompts, you will enter the macOS system interface. Remember the system password and turn off the Find my mac option.  
      Post install:
       
      After the installation is complete, you need to hang the EFI partition of the disk, copy the EFI file of the U disk to the EFI partition of the disk, so that you can directly use the disk to boot, otherwise you need to select the U disk to boot each time. The mount tool can choose cloverconfigurator. If after copying the EFI file to the disk, the computer cannot recognize your clover boot, you can use the custom boot option of bios: set the custom boot path to \efi\clover\cloverx64.efi, and set it as the first boot, Use bootice or easyUEFI to increase the clover boot option under Windows and set it as the first boot. If you do not have a wireless network card available temporarily, you can use the USB binding function of your Android phone to share the network. This may require the HoRndis driver. It is not recommended to use a US wireless network card. If you need Windows or Linux, you can install it normally. Be careful not to let Windows overwrite your boot files.  
      For other uses of macOS and brew, please pay attention to forums and other communities. Hackintosh is just the beginning.
       
      Finally, I would like to thank rehabman, vit9696 and others who contributed to Hackintosh. I also thank Cwen for his efforts to modify files and hardware tests. I hope that Hackintosh will be eternal.
       
      Please comply with the laws and regulations of your country or region. My description may not be clear or professional, but I think it is necessary. I think the existence of Hackintosh is everyone's technical hobby and experience macOS, not as a substitute for macOS cheap hardware.

      EFI_8x70_5103_W7170m_20200116 .zip
    • By rodrinico19
      Hola a todos, primero que nada estoy muy contento de a ver econtrado un foro de español sobre hackintosh.
      Mi problema consesite en que descargue unos drivers de esta pagina: https://github.com/chris1111/Wireless-USB-Adapter-Clover
      Seguí los pasos instale los kets en la carpeta EFI/CLOVER/OTHERS todo tal cual como dice ahi la instalación. luego segui los pasos de configurar la red dentro de configuracion del sistema etc.
      Lo cual el nombre me quedo en en0.
      El driver o kets funciona bien es reconocible por el S.O de hecho conecta la red, pero me dice que no tiene IP AUTO ASIGNADA Y LA OTRA QUE HAY UNA DESCONEXION A CADA RATO(como que desconectaras y conectaras el dispositvo usb a cada rato)
      Me gustaria que me ayuden con eso si es posible, Muchas Gracias!!
×