Jump to content
fantomas

Nvidia Web Driver updates for macOS Sierra (UPDATE Sept 27, 2019)

1,063 posts in this topic

Recommended Posts

Hi

is someone with Asus x99 deluxe II motherboard experiencing this popup?

It is not related to this new driver release because I have also in other condition but I would like to understand how to solve it

PS gfx is working well..only the panel does not load

post-468967-0-40321000-1492703514_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

I was getting strange look and textures, dark terrains on totalwar warhammer with gtx980. Now it's fixed with latest driver!!

 

 

Here is the video that I have sent to Feral

 

 

Textures are now okay :)

Share this post


Link to post
Share on other sites

I was getting strange look and textures, dark terrains on totalwar warhammer with gtx980. Now it's fixed with latest driver!!

 

Same here but with F1 2016 on 10.12.5 beta.

 

Latest drivers fixed that too :).

Share this post


Link to post
Share on other sites

Confirmed Working !  :)

 

 

Thanks to c_frio for pointing me to this thread.

 

post-66029-0-81676100-1492725989_thumb.png

 

i7 Kaby Lake 

 

Gigabyte z270XP-SLI BIOS version f5

 

iMac 17,1 profile

 

GTX-970

 

make sure that EmuVariableUefi.efi is installed in your EFI 

 

(I had to manually copy it... Clover didn't install the file when I upgraded regardless of it being selected) 

 

activate the driver from a terminal.

 

      $ sudo nvram nvda_drv=1

 

I was greeted with a black screen once the driver kicked in.

 

To Fix the black screen:

  1. unplug the monitor for a few seconds.

  2. plug the monitor back in.

 

 

 

Hope this tip helps someone out.

 

Share this post


Link to post
Share on other sites

Oh hey, I can play Metal games on my 1080 GTX without everything going completely nuts. Had to roll all the renderers back to OpenGL under f1.

Share this post


Link to post
Share on other sites

Hello,

 

I've successfully installed the latest driver on my following configuration:

Mac Mini with Sierra -> via TB2 to Sonnet Echo III-D with Gigabyte GTX 1060 -> via HDMI to external TV

 

Booting either to Win 10 for gaming (works perfekt!) or to OS X for other activities, however with two issues:

1. Sound via HDMI not possible (solved by using ear speaker out of the Mini connected to TV)

2. Noticed that under iTunes rented movies will not be displayed (black screen, movie not playing). Movie can only be played when reconnecting the Mac Mini via 2nd HDMI directly to the TV (with issue that the driver switches back to the internal GPU)

3. After some time under OS X using Safari to seek through the internet the safari window is partially flickering

 

Does anyone noticed same or similar issues and/or has solutions for my issues?

Share this post


Link to post
Share on other sites

Hello,

 

I've successfully installed the latest driver on my following configuration:

Mac Mini with Sierra -> via TB2 to Sonnet Echo III-D with Gigabyte GTX 1060 -> via HDMI to external TV

 

Booting either to Win 10 for gaming (works perfekt!) or to OS X for other activities, however with two issues:

1. Sound via HDMI not possible (solved by using ear speaker out of the Mini connected to TV)

2. Noticed that under iTunes rented movies will not be displayed (black screen, movie not playing). Movie can only be played when reconnecting the Mac Mini via 2nd HDMI directly to the TV (with issue that the driver switches back to the internal GPU)

3. After some time under OS X using Safari to seek through the internet the safari window is partially flickering

 

Does anyone noticed same or similar issues and/or has solutions for my issues?

Make sure About this Mac shows your actual card being displayed under 'Graphics' description and not being injected

Share this post


Link to post
Share on other sites

Nice... will check out soon after wrk. Hope this fixes my issue I addressed prior

Was able to get thru the opening cut scene in Witcher 2 w/o my hack restarting on me, however the the menu options in the UI keep flickering. Hope NVIDIA can release some better drivers to resolve this

Share this post


Link to post
Share on other sites

Make sure About this Mac shows your actual card being displayed under 'Graphics' description and not being injected

I don't know what you mean by "being injected" but the 1060 is only shown under "My Mac" if I disconnect my TV from my Mac Mini HDMI port. Otherwise the internal gpu is always "active" ...

IUsed HDMIAudio-1.1.dmg. and have sound though  two Display ports  TO HDMI  cable (1070 gtx) for sound

Ah, thank you for the hint ... I'll give it a try!

Share this post


Link to post
Share on other sites

@Hanrolo is your gpu showing up in  the hardware over view?

you mite need to turn off graphic injection as It can stop ports working. &not show the correct  graphics  card ram size (I think you can do it from clover)

get latest web drivers & cuda.

Then  download HDMIAudio-1.1 dmg. you should then have Hdmi sound

Share this post


Link to post
Share on other sites

@Hanrolo is your gpu showing up in  the hardware over view?

--> Yes with correct RAM size

 

you mite need to turn off graphic injection as It can stop ports working. &not show the correct  graphics  card ram size (I think you can do it from clover)

--> I thought clover is only needed to install OS X on standard PCs ... Do I need to install it on my Mac?

--> May be I should know but what is graphic injection?

--> With clover I can turn on/off graphic injection?

 

get latest web drivers & cuda.

--> Latest web driver is installed

--> Do I need to install cuda? I'm not using any cuda supporting software like Adobe ... 

 

Then  download HDMIAudio-1.1 dmg. you should then have Hdmi sound

--> I've installed HDMIAudio but with no result ...

 

Thank you BALDY_MAN that you are trying to help me! --> See my answers/questions above ...

Share this post


Link to post
Share on other sites

Anyone getting weird icon issues? I'm using an ASUS GTX 1080, IMac17,1 SMBIOS, Lilu + NvidiaGraphicsFixup, I7-6700K.. Doesn't happen if I use the IntelHD530 (integrated graphics).. Any ideas on how to fix it?

I've attached screenshots below as well as my config: config.plist.zip

 

Screenshots:

 

 

tM4jY4p.png

 

2R1MAi2.png

 

 

 

Share this post


Link to post
Share on other sites

to avoid black screen use Lilu.kext + NvidiaGraphicsFixup.kext in Clover/Kexts/Other

 

if ur bios is a last version(support Kabylake) need EmuVariableUefi-64.efi

Unfortunately I still get a black screen when I disable injection, even when using these kexts.

Anyone getting weird icon issues? I'm using an ASUS GTX 1080, IMac17,1 SMBIOS, Lilu + NvidiaGraphicsFixup, I7-6700K.. Doesn't happen if I use the IntelHD530 (integrated graphics).. Any ideas on how to fix it?

 

I've attached screenshots below as well as my config: attachicon.gifconfig.plist.zip

 

Screenshots:

 

 

tM4jY4p.png

 

2R1MAi2.png

 

 

 

Disable your IGPU within your BIOS.

Share this post


Link to post
Share on other sites

Any workarounds for multi - monitor setups?  I have to update my signature, but I have an EVGA 1080 FTW and 1 monitor connected to DVI and one to DP.  If I boot with just the DP monitor connected, it works fine...I just have to connect the DVI one and get multi monitors working.  Otherwise, if I boot with both connected, it's blank screens for both and have to hard reset.

 

Hi,

 

I'm having similar issues, KFA/Galaxy 1080 and multi-monitor setup. If I boot using two simultaneous connections from nvidia 1080, only works one of them (I have two DPs, one to a Samsung 4K Tv and the other to regular 4K monitor with DP).

 

I also experienced issues after wake from sleep (black screen, working everything else).

 

I wonder if some nvidia 1080 are "right" and others are "wrong", any thoughts? Anyone with same multi-monitor issues with nvidia 1080?

Share this post


Link to post
Share on other sites

....

I wonder if some nvidia 1080 are "right" and others are "wrong", any thoughts? Anyone with same multi-monitor issues with nvidia 1080?

Try using another OSes which has Pascal support, if it works just OK then there's nothing wrong with ur card.  :)

FYi, my GT 520M also got black screen issue after wake from sleep under Sierra.

Share this post


Link to post
Share on other sites

i also have this problem , I have tried to disable the igpu but doesn't work. Excuse me for my bad English 

 

Disable your IGPU within your BIOS.

 

 

That actually worked! So for MSI Gaming M7 z170 boards, there's no "Disable IGPU" option. I went into the BIOS, and under Integrated Graphics, I had PEG instead of IEG (Integrated Graphics).. still no cigar. On this same menu, I had to disable "IGD Multi-Monitor". Which disables the IGPU and now everything works (Safari no longer shows the weird icons and I no longer get the DRM-Status warning).

Share this post


Link to post
Share on other sites

Hi,

 

I'm having similar issues, KFA/Galaxy 1080 and multi-monitor setup. If I boot using two simultaneous connections from nvidia 1080, only works one of them (I have two DPs, one to a Samsung 4K Tv and the other to regular 4K monitor with DP).

 

I also experienced issues after wake from sleep (black screen, working everything else).

 

I wonder if some nvidia 1080 are "right" and others are "wrong", any thoughts? Anyone with same multi-monitor issues with nvidia 1080?

Yes, there's a few threads in the graphics card section

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      https://olarila.com/files/Clover.Folder/EFI CLOVER Z390 DESIGNARE.zip
      *Use this folder with FULL DSDT PATCHED
       
      ---OPENCORE FOLDER---
      https://olarila.com/forum/viewtopic.php?f=28&t=10578
      *Use this folder with FULL DSDT PATCHED
       
       
      ---Extract one Full dump for DSDT edits, post files---
       
      RunMe.app
       
       
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By HenryV
      I-5 Skylake/520 graphics/4gig RAM/UEFI boot/GPT
      Any one had issues with supplemental updates and/or security updates booting very slowly after install and using approx. 750 more megs of memory? This has happened with recent updates to Catalina 10.15.1, Mojave security update 2019-001, and High Sierra security update 2019-006. I know that the first reboot after updates is usually slow but this problem with slow booting and hard drive thrashing persists after multiple reboots. It seems as though hard drive access is being channeled though a buffer. In one instance Catalina paused for a long time on reboot and a message appeared indicating that enough information had been found to re-enable the soft bloc. afterward Catalina booted normally but Mojave was booting so slow that it was practically unusable. After multiple reboots High sierra takes around a minute for the desktop to fully initialize after the login, but it was usable.
      Does mac os use some kind of software input-output hard disk buffer that can be manually reset from the terminal? Disabling/enabling virtual memory paging seems to have no effect and the vm compressor mode is set to 2. The laptop only has 4 gig of memory but this has been enough to run all three os without boot issues in the past. Catalina on APFS, Mojave and High Sierra on HFS+.
      Any help appreciated.
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/forum/viewtopic.php?f=28&t=8222   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        First... If you need DSDT edits... -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation --Create a bootable copy of El Capitan /  Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder   https://olarila.com/files/Clover.Folder/CLOVER.LGA775.zip   --Install EL Capitan / Sierra / High Sierra and boot into system!     Post Installation   --Install Clover and replace with my folder   https://olarila.com/forum/viewtopic.php?f=28&t=8222     --Reboot and activate video!   Bingo! Now you need a fine tune! DSDT Time!   My DSDT GA P35-DS3   DSDT.MaLd0n.zip     Patches -FIX ERRORS AND WARNINGS -HPET -SATA -SLPB -DARWIN -LPC -HDEF -RTC -EHCI -UHCI -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -EC -PNLF --Native Power Management
       
      Use Clover, check Generate P and C States
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --AUDIO
       
      Device HDEF + AppleAlc + Lilu
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/293863-applehda-patch-requests/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
    • By fantomas
      macOS Catalina 10.15.2 beta (19C32e)
×