Jump to content
fantomas1

Nvidia Web Driver updates for macOS Sierra (UPDATE May 15, 2019)

1,060 posts in this topic

Recommended Posts

Care to expand on this? I have LittleSnitch running and, other than trustd reaching out to get new certs, I haven't really seen any "calling home"… Am I missing something? :o

 

Some services phoning home;

/usr/libexec/keyboardservicesd

/usr/libexec/nsurlsessiond

/System/Library/PrivateFrameworks/CoreParsec.framework/parsecd

/System/Library/PrivateFrameworks/PassKitCore.framework/passd

/System/Library/PrivateFrameworks/PhotoAnalysis.framework/Versions/A/Support/photoanalysisd

/System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Support/photolibraryd via /System/Library/PrivateFrameworks/PhotoLibraryPrivate.framework/Versions/A/Frameworks/PhotoLibraryServices.framework/Versions/A/XPCServices/com.apple.photomoments.xpc/Contents/MacOS/com.apple.photomoments

/usr/libexec/rtcreportingd

 

I left out a handful that, like trustd, I don't think are worth blocking. A couple on this list I can't find enough documentation on to blindly trust. The photo stuff I'm sure is associated with Photos but I don't want my library's information culled in any way, shape or form and Apple is a huge data mining company now. This brings me to that first service. Now is it tracking our keyboard usage the same way a mobile keyboard app would?

 

Inquiring minds would like to know... but for now it remains blocked until satisfactorily proven benign.

Share this post


Link to post
Share on other sites
Advertisement

I wouldn't use EmuVariableUEFI-64 and AGDP patch allows the OS to control power management of the gaphics cards

 

Any problem with this settings?

I have no problem running 10.11 and 10.12 like this except 10.12 no support for CUDA so cannot run applications such as Resolve...

Share this post


Link to post
Share on other sites

i had the same problem that you have right now, i spent all night trying all posible solutions, i finally fix it, i will upload the file for you, the problem is the web drivers, i tried fixing that version but i couldn't, but i use El Capitan latest drivers and i fixed, now is working in sierra 10.12.5 pb, i don't need to use the nvram value either, but the driver is in 99% i need to double check to try to make it 100%, the only problem is at startup it does the glitch like when you don't have acceleration enable, like when you use nv_disable but after that everything is enable and working perfectly fine both of my card are recognized in nvidia control panel , in about my mac, with the right ram, let me just double check everything and i will upload the files for you, i also felt the same way like you ,i was worried but now i'm not worry anymore , the official drivers will work the same way they always has, i look inside the beta drivers here and they have bunch of errors inside, incomplete system version, etc etc etc , i'm not saying that is the person that worked in the drivers here, most likely the drivers came broken from nvidia , just give me some time like an hour or 2 for me to prepare everything i just wanted to give you the good news. i'll be back later.

 

I can assure you that the drivers are not broken and are working. The reason the version number is simply "16A" in the drivers is not because they're "broken," but because they need to work across different betas (this happens with every beta driver). Don't hack harder than you need to (ie injecting the OS version into old drivers).

Share this post


Link to post
Share on other sites

Lol, alright -  I did not mean any offense, and thought I was being polite by pointing out a reason why a full version number isn't included in the driver's plist, but I thought the goal here was "vanilla OS X" :) Either way, you are hacking harder than you need to when the solution is to let things be broken (non-working boot arguments/NVRAM) and use old drivers.

 

Glad you figured out a solution for the proper drivers and things are working, sorry to have offended - happy hacking!

Share this post


Link to post
Share on other sites

Is anyone else having strangely inverted colors on the latest NVIDIA Web Driver on macOS Sierra Developer Beta 6? I’m running a GTX 960 4GB in a MacPro4,1 that’s been flashed to a 5,1 (but still running 2x quad-core Xeons, haven’t swapped out for new CPUs or RAM yet). Any idea what’s going on/how to fix?

 

EDIT: Upon further consideration, it looks like just the R and B channels are flipped; G is still correct. And, if I click on messages in Mail, I see the colors flip to normal in a message briefly before the message changes to the next one. VERY strange.

Share this post


Link to post
Share on other sites

@drowsyhaze

 

Interesting thing: my secondary monitor got screwed up colors after the 10.12 update. Worked fine in 10.11, works fine in W10… Tried a different cable, different port from the graphics card… Other monitor works just fine (in both ports and with both cables). Weeeeirdest thing. Basically, blues are yellows, yellows are blues, and reds are blues too… It's like my red channel got screwed up! :X SOO WEIRD! I tried checking the accessibility option to invert colors, but it's not it: whites and blacks are not inverted. I also tried switching to a different color profile… No help!

 

Any idea? Anybody running into similar issues?

 

PS: When booting with nv_disable=1 (aka no Nvidia driver), colors are perfectly fine! ¯\_(ツ)_/¯

 

IMG_1058.jpg

Edit

I can confirm Working Gigabyte 750TI but with some remarks:

1 - I think we should all back to using kext-dev-mode=1 and roothless=0
2 - remove Emuvariable-64 from EFI it will cause system to never load your video kext
3 - Nvidia webdriver should be enabled using it's settings panel under system preference
4 - transparency is buggy as hell so reduce it under Accessibility panel.
5 - Clover Configurator won't mount EFI so do it manually
6 - no messed up colors on my end*

7 - reset your NVRAN after removing Emuvariable (sudo  nvram -c)



 

post-580097-0-76735700-1471831777_thumb.png

Share this post


Link to post
Share on other sites

Is anyone else having strangely inverted colors on the latest NVIDIA Web Driver on macOS Sierra Developer Beta 6? I’m running a GTX 960 4GB in a MacPro4,1 that’s been flashed to a 5,1 (but still running 2x quad-core Xeons, haven’t swapped out for new CPUs or RAM yet). Any idea what’s going on/how to fix?

 

EDIT: Upon further consideration, it looks like just the R and B channels are flipped; G is still correct. And, if I click on messages in Mail, I see the colors flip to normal in a message briefly before the message changes to the next one. VERY strange.

 

Yes I am seeing inverted colours as well, this is on a Nvidia GTX 970 with an LG Ultrawide monitor 2560x1080. I'm using the WebDriver-367.10.10.05b01.pkg.

 

Safe mode is fine, only when booting with the nvidia driver.

 

--- Edit 

 

When shutting/rebooting down, the screen reverts to normal colouring.

Edited by tarasis

Share this post


Link to post
Share on other sites

Is there anybody else having trouble with setting Siri up? She's apologizing for trouble with connection, no clue what it is, here's a troubleshoot list of what I've already tried:

 

1 - Disable/Enable connection under System Preference
2 - Remove/Add connection
3 - Change DNS servers
4 - Reboot
5 - Disable/Enable Siri herself
6 - Update RTL drivers from 2.0 to 2.2

I'm sorry if I'm posting this to the wrong section I just think it doesn't deserve a thread of it's own but if an ADM thinks it should be put on a thread separately then I'll be more than happy to do it.

thanks

Share this post


Link to post
Share on other sites

Is there anybody else having trouble with setting Siri up? She's apologizing for trouble with connection, no clue what it is, here's a troubleshoot list of what I've already tried:

 

1 - Disable/Enable connection under System Preference

2 - Remove/Add connection

3 - Change DNS servers

4 - Reboot

5 - Disable/Enable Siri herself

6 - Update RTL drivers from 2.0 to 2.2

 

I'm sorry if I'm posting this to the wrong section I just think it doesn't deserve a thread of it's own but if an ADM thinks it should be put on a thread separately then I'll be more than happy to do it.

 

thanks

This is completely off topic, has nothing to do with Nvidia web drivers and macOS 10.12

Share this post


Link to post
Share on other sites

This is completely off topic, has nothing to do with Nvidia web drivers and macOS 10.12

if it's not asking too much would you make it into a thread of it's own, please? Otherwise just delete and I'll get the message, thanks.

 

BTW Public Beta 6 now available

post-580097-0-21749300-1471925862_thumb.png

Share this post


Link to post
Share on other sites

MacPro 4,1 flashed to identify as 5,1. EVGA GTX970, not flashed.

 

I decided to bite the bullet on PB6, now on build 16A304a with "DP4 & PB3" version drivers from first post (later ones don't work). I'm seeing no visual errors or glitching (used RGB Venn seen at https://en.wikipedia.org/wiki/RGB_color_model ). The later drivers simply gave me a black screen although I find it odd that they have the same MD5 hash (6771efaa5d2e4b42f949ff8f47b574ee). Nonetheless the later drivers weren't working, go figure.

 

 

 

 

EDIT: DP7 & PB6 driver pkg has same MD5 hash still. I've not been prompted to update and all still works so I'm not going to try installing the package.

Share this post


Link to post
Share on other sites

is there any working Sierra beta 5 drivers for a GTX 970 ?

 Yes, my GTX 970 is working with Sierra beta 1- 6 (PB).

Share this post


Link to post
Share on other sites

 Yes, my GTX 970 is working with Sierra beta 1- 6 (PB).

 

i am using iMac 14,2 and I got the nvidia drivers for PB5.. but when OSX boots there is no QE/CI and my card does not get detected. Also i have no resolution options, i tried changing a few SMBIOS's but no luck. Right now i am using my HD 530 on my i7 6700. It works fine.   I do not have Inject Nvidia selected also in my clover config... any thoughts?

Share this post


Link to post
Share on other sites

Is anyone else having strangely inverted colors on the latest NVIDIA Web Driver on macOS Sierra Developer Beta 6? I’m running a GTX 960 4GB in a MacPro4,1 that’s been flashed to a 5,1 (but still running 2x quad-core Xeons, haven’t swapped out for new CPUs or RAM yet). Any idea what’s going on/how to fix?

 

EDIT: Upon further consideration, it looks like just the R and B channels are flipped; G is still correct. And, if I click on messages in Mail, I see the colors flip to normal in a message briefly before the message changes to the next one. VERY strange.

 

 

That's basically what I explained in #170:) It's only happening on one of my displays (I have 2), which makes it even weirder. I've tried switching outputs/cables/etc between them, but it's always the same one… ¯\_(ツ)_/¯ Works fine in safe mode, Windows, 10.11, etc…

Share this post


Link to post
Share on other sites

Open The Monitor Panel and switch the resolution of the monitor in question and back and/or rotate it andback.

This will rewrite the stored settings and should solve your problem.

Share this post


Link to post
Share on other sites

Open The Monitor Panel and switch the resolution of the monitor in question and back and/or rotate it andback.

This will rewrite the stored settings and should solve your problem.

 

WOW HOLY {censored}!!! This works!!! <3 <3 <3

Edited by fantomas1
It's censored for a good reason.

Share this post


Link to post
Share on other sites

It's been working since DP1 (and 10.11 of course).

No!? It's not working :D My computer stocks on booting and crashes on 10.12. How did you get running? I've an NVIDIA GeForce GTX 980 Ti 6144 MB with flashed EFI.

Share this post


Link to post
Share on other sites

No!? It's not working :D My computer stocks on booting and crashes on 10.12. How did you get running? I've an NVIDIA GeForce GTX 980 Ti 6144 MB with flashed EFI.

I'm using a GTX 980 Ti with a Hackintosh (no need for flashed EFI). I just had to install the driver and it was working. I am injecting some device properties (mainly for cosmetics, NVIDIA Web Driver handles most of them), but I didn't need them to boot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By fantomas1
      First beta... macOS Catalina 10.15 beta (19A471t)  Release Notes!!!
       
      Useful information:
       
      macOSDeveloperBetaAccessUtility.dmg.zip (thanks to gengik84)
      Clover r4945 (thanks to Cyberdevs)
      Lilu_plugins (thanks to gengik84)
      Port Limit Patch (thanks to daliansky)
      older non metal nVidia and Intel cards (thanks to fusion71au))
    • By fusion71au
      Patch Catalina or Mojave macOS Installer App for Unsupported Machines
       
      Often for economic reasons, Apple prevents the Installer.app for its latest macOS from installing on older machines perfectly capable of running it eg macOS 10.14 Mojave on Unsupported Macs Thread.
       

       
      In Mojave 10.14, @ASentientBot posted a method to patch the distribution file in OSInstall.mpkg to enable the Mojave installer to install on unsupported machines (with or without graphics card metal support). 
       
      In Catalina 10.15beta, the above method no longer works since Apple is checking OSInstall.mpkg for its file signature and the mandatory requirement in Catalina to install to 2 separate apfs volumes necessitates using the original Catalina macOS Base System Installer.  Fortunately, it is still possible to substitute High Sierra’s Apple Signed OSInstall.mpkg inside the Catalina or Mojave InstallESD.dmg by making it R/W.
       
      The procedure below will allow Macs or Hacks able to install High Sierra to also install Catalina or Mojave (eg SMBIOS MacPro5,1, iMac11,3, MacBook Pro7,1 which have been unsupported in macOS 10.14.x and 10.15beta) -credit to @ASentientBot's post.
       
      Prerequisites
      1. Mac or Hack capable of and running High Sierra 10.13.x
      2. An original, untouched copy of OSInstall.mpkg from High Serra InstallESD.dmg - attached OSInstall_10.13.6.mpkg.zip save to your ~/Downloads folder
      3. macOS Installer App eg for Catalina beta or Mojave downloaded to /Applications
      4. Add NVRAM boot arg (or Clover config.plist boot arg on a hack) -no_compat_check to enable system to boot to final completed Mojave or Catalina install.
       
      Procedure
      1. Open Terminal and type the following
       
      open /Applications/Install*/Contents/SharedSupport/InstallESD.dmg (assuming the Catalina or Mojave Installer App is in /Applications)  
      2. Open Disk Utility, click File|New Image|Image from ‘InstallESD”
      3. Save as read/write image, no encryption in /Applications
      4. Unmount InstallESD in DU by clicking the "eject" icon next to it
       
       
      5. Open the R/W InstallSD.dmg in /Applications and replace Catalina’s/Mojave's OSInstall.mpkg with High Sierra’s version by typing in terminal
       
      open /Applications/InstallESD.dmg cp ~/Downloads/OSInstall_10.13.6.mpkg /Volumes/InstallESD/Packages/OSInstall.mpkg  
      6. Unmount InstallESD in DU by clicking the "eject" icon next to it
      7. Replace original Catalina/Mojave InstallESD.dmg with our patched one, making a backup of the original.  In terminal, type
       
      sudo mv /Applications/Install*/Contents/SharedSupport/InstallESD.dmg /Applications/InstallESD_orig.dmg sudo mv /Applications/InstallESD.dmg /Applications/Install*/Contents/SharedSupport/  
      8.  Test the newly patched installer!…

    • By fusion71au
      Clover r4961 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.14 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r4961 for VMware.zip". Mount Clover-v2.4k-4961-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  AptioMemory --> (consigliato) 
                               : Driver64UEFI  ApfsDriverLoader --> (consigliato) --> sostituisce l'uso del driver apfs.efi
                               : Selezionate l'altri driver come da successiva immagine,
       
      *Nota: Altri driver che si possono usare  al suo posto  sono:
       informazioni 
       
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      C_I_M.zip
       
      apfs.efi-10.14-beta1_No_Log.zip





       

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&amp;t=6771   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell     Skylake, Kabylake and Coffeelake is here http://www.insanelymac.com/forum/topic/321872-guide-sierra-on-gigabyte-mobos-serie-200-kabylake-dsdt/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://olarila.com/forum/viewtopic.php?f=50&t=8685
        Mojave Full DSDT patch   http://olarila.com/forum/viewtopic.php?f=59&amp;t=6428   First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://olarila.com/files/Clover.Folder/CLOVER.SERIES.CHIPSET.zip   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
×