Jump to content
fantomas1

Nvidia Web Driver updates for macOS Sierra (UPDATE July 30, 2019)

1,061 posts in this topic

Recommended Posts

 

Hello everybody,

Well sorry to say but I'm stuck. Was trying everything from this thread and from whatever google found it with no luck. Can't resolve for few days. After I enable nvidia web driver I getting balck screen after reboot. Three times reinstall 10.12.4, started from scratch. I can say I tried everything what possibly can. Hope I still missing something. Different system definitions, kexts lilu and nvidiafixup or AGDPfix patch, different monitor numbers in clover, inject EDID, custom EDID, override EDID, nvidia simple name, nvidia single and etc, same result, black screen. Through VNC I can see that system is up and running.

If anyone have any thoughts please help me.

Thank you.

P.S. forgot to mention that Monitor connected by HDMI

 

If you still need help contact me ;) 

Share this post


Link to post
Share on other sites
Advertisement

Hi all,

 

looking for some additional guidance...

 

I've installed a GT 730 2GB into my HP Z800 system. running Sierra on EFI(old system)

 

I can't for the life of me get Sierra to use the Nvidia drivers.

 

I've enabled the web drivers flag using Clover configurator, and removed nv_drv=1.

 

If it does manage to boot into OSX, I see artifacts on the screen and a black background on the login page and desktop

 

 

Thank you everyone, as always

Share this post


Link to post
Share on other sites

Same result. I even tried changing SMBIOS to 16,2 but no luck.

 

The card has three ports so should I change the 2 to 3?

Share this post


Link to post
Share on other sites

@ Frank Nitty . I'm using a gtx970 and was just toying with the idea of getting a GTX1070 if there working ok

Specs in signture Frank

Yeah my specs are in Rig #1 of my sig, and I'm running a 4770K on the Z97 platform as well. My system has been running 10.12.4 with my 1070's all day and I haven't had any problems so you're good to go since we pretty much have similar specs. Why wait now, go get that bad boy now while the prices are good.

Share this post


Link to post
Share on other sites

:D Works for me.. Using an ASUS GTX-1080 ROG STRIX GPU.

 

Build:

 

Screenshot: http://i.imgur.com/p2tgv7H.jpg

 

 

p2tgv7H.jpg

 

 

 

 

CPU: Intel Core i7-6700K
Motherboard: MSI Z170A Gaming M7
Video Card: Asus GeForce GTX 1080 STRIX
Operating System: MacOS Sierra 10.12.4

 

Configuration:

Boot: -v dart=0 nvda_drv=1

Graphics: videoports: 3

SMBIOS: Board-ID: Mac-27ADBB7B4CEE8E61, ProductName: iMac17,1

SystemParameters: Inject SystemID, NvidiaWeb

 

 

How I got it working? Install the Nvidia WebDrivers. Then I installed the SMBIOS iMac17,1 but then I manually changed the Board-ID to: iMac14,2 aka: Mac-27ADBB7B4CEE8E61. Next I changed VideoPorts to 3, added the boot flags and NvidiaWeb.

Why I changed the BoardID? Because without that Board-ID, I keep getting a black screen! I tried patching it via a KextPatch and DSDT patch but no cigar. The Board-ID change was way easier and works no problem. VideoPorts=3 aren't needed but I felt like I should specify it for completeness anyway..

Share this post


Link to post
Share on other sites

Oddly, I get a black screen on my GTX 1080 unless I use NvidiaInject=true. Works perfectly when injected, but I wonder why this is required?

Share this post


Link to post
Share on other sites

to avoid black screen use Lilu.kext + NvidiaGraphicsFixup.kext in Clover/Kexts/Other

 

if ur bios is a last version(support Kabylake) need EmuVariableUefi-64.efi

Share this post


Link to post
Share on other sites

Is NvidiaGraphicsFixup.kext used now instead of ADGPFix.app or manual patching? No more patching? No KextsToPatch?

 

Sent from my SM-G930F using Tapatalk

Share this post


Link to post
Share on other sites

Trying all week to get Nvidia WebDriver installed. 10.12.3. WebDriver-367.15.10.35f01.pkg gives me an error at end of install. 

 
Apr 16 21:38:09 newguys-iMac installd[456]: PackageKit: ----- Begin install -----
Apr 16 21:38:09 newguys-iMac installd[456]: PackageKit: Session UUID file exists - will not overwrite /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/694376A5-90BC-4C5B-9864-2F8C51A9712F.activeSandbox
Apr 16 21:38:24 newguys-iMac installd[456]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=121 "An error occurred while updating system extension information." UserInfo={NSUnderlyingError=0x7f8c60404380 {Error Domain=kextcache Code=71 "(null)"}, NSLocalizedDescription=An error occurred while updating system extension information., arguments=( "-update-volume",   "/",   "-Installer"
)} {   NSLocalizedDescription = "An error occurred while updating system extension information.";
   NSUnderlyingError = "Error Domain=kextcache Code=71 \"(null)\"";
   arguments =     ("-update-volume","/", "-Installer" );}
Apr 16 21:38:24 newguys-iMac Installer[2223]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Apr 16 21:38:24 newguys-iMac Installer[2223]: Displaying 'Install Failed' UI.
Apr 16 21:38:24 newguys-iMac Installer[2223]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.

Share this post


Link to post
Share on other sites

 

Trying all week to get Nvidia WebDriver installed. 10.12.3. WebDriver-367.15.10.35f01.pkg gives me an error at end of install. 

 
Apr 16 21:38:09 newguys-iMac installd[456]: PackageKit: ----- Begin install -----
Apr 16 21:38:09 newguys-iMac installd[456]: PackageKit: Session UUID file exists - will not overwrite /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/694376A5-90BC-4C5B-9864-2F8C51A9712F.activeSandbox
Apr 16 21:38:24 newguys-iMac installd[456]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=121 "An error occurred while updating system extension information." UserInfo={NSUnderlyingError=0x7f8c60404380 {Error Domain=kextcache Code=71 "(null)"}, NSLocalizedDescription=An error occurred while updating system extension information., arguments=( "-update-volume",   "/",   "-Installer"
)} {   NSLocalizedDescription = "An error occurred while updating system extension information.";
   NSUnderlyingError = "Error Domain=kextcache Code=71 \"(null)\"";
   arguments =     ("-update-volume","/", "-Installer" );}
Apr 16 21:38:24 newguys-iMac Installer[2223]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Apr 16 21:38:24 newguys-iMac Installer[2223]: Displaying 'Install Failed' UI.
Apr 16 21:38:24 newguys-iMac Installer[2223]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.

 

It can only be installed on 10.12.4

---EDIT---

Hey guys, I was running Witcher 2 on my hack using the newly released Pascal Web drivers and during the opening cut scene where the guy throws the freezing tube, as soon as the glass breaks my hack restarted. Anybody else have that problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By shinho73
      Hello everyone. I managed to install AMD Sierra V5(10.12.6) on my old AMD A8 7600 PC(Mother Board-A58M-E, GPU- Palit Geforce GT730 DDR3). Everything is working except the GPU. The GT730 DDR3 GF108 is natively supported on Sierra, but for some reason, it is not working. On Clover Config, "Inject Nvidia" is selected, no Nvidia Web, and nv_disable=1. On "About This Mac" it just says " NVIDIA Chip Model 3 MB".
      I have attached config.plist. Can someone look at it please? Any help will be greatly appreciated. Thank you. 





      config.plist
    • By fusion71au
      Clover r5050 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r5050 for VMware.zip". Mount Clover-v2.5k-5050-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
    • By Slice
      I successfully installed macOS 10.11.6 and Windows 7 Pro SP1 in UEFI mode on the laptop.
      I know, there are detailed guides here and on osxlatitude.com but I was not agree with them and carefully check and test every step to tune my Mac.
       
      Hardware
      Intel® Core� i5-3320M CPU @ 2.60GHz, speedstep works with Clover default settings
      Chipset Intel 7 series, no patches needed
      Video: IntelHD4000 or NVS5200M switchable in BIOS, work in both cases
      LAN; Intel 82579LM, works with IntelMausiEthernet.kext v2.2.1
      Audio: IDT 92HD93BXX, works with VoodooHDA 2.9.0.
      SDHC reader O2Micro; works with native AppleSDHC.kext with Clover Arbitrary properties.
      USB3.0 works natively if not disabled in DSDT
      PS2 keyboard and touchpad works with VoodooPS2.
      WiFi: Dell Intel WiFi was replaced by Dell DW1520, Broadcom BCM943224HMS. DeviceID=4353
      LCD Screen 1366x768
      BIOS A12. Initially was A02. Then I flashed A23 and found it is quite bad. The screen is full of artefacts. Flash A12 and all is OK. Not tested other versions.
      For some reason BIOS can switched from Intel to Nvidia by itself so I have to do my solution working independent on this state.
       
      WiFi
      It is not working OOB although it has DeviceID known to Apple. The reason is WhiteList in the driver.
      I set MacModel as MacBookPro10,1 while the WiFi will work on MacBookAir. I make a patch in Clover.
      As well a patch for channels.
      I deleted a kext Brcm4331 because it has the same DeviceID. Let kext Brcm4360 to work alone.
       
      VideoCards
      In Bios we can set Optimus = Enable/Disable
      If Enable then we have two videocards Intel first and Nvidia second. In this case additional SSDT-3.aml will switch off Nvidia.
      If Disable then we have only Nvidia card. It will work if Board-ID taken from iMac13,2.
      But here there is contradiction with WiFi with required Board-ID from MacBookAir.
      So I take MacModel as MacBookPro10,1 which is most close by CPU IvyBridge.
      Set BoardID like iMac13,2 to make Nvidia working.
      Patch BoardID in Brcm4360 to make WiFi working.
      Now I have
      Inject->
      ->Intel=YES
      ->Nvidia=YES
      and SSDT-3.aml in ACPI\patched folder. This SSDT will switch off Nvidia if Intel card ON.
      For Intel graphics there is a patch against 8 apples at start.
      This Nvidia 5200 is Fermi and works in ElCapitan.
       
      Brightness
      No special kexts.
      The brightness controlled by keys F1,F2 and slider in Control Panel in both case Intel or Nvidia. Details here  #72 
       
      DSDT and SSDT
      This is very long story and finally I have working sleep in both cases Intel or Nvidia.
       
      Sensors
      I use my HWSensors3 with FakeSMC 3.5.2.
      I got monitoring:
      CPU temperature
      GPU temperature
      GPU main frequency
      GPU shader frequency
      Battery state % full, time to charged or time to empty.
      Battery voltage dinamically.
      Battery amperage dynamically. I can see it changes on heavy games.
      HDD temperature.

       
      Audio
      I like VoodooHDA and have no problems with it.
      The sound is clear, loud, and switchable between internal speaker and headphone.
      Mic is working.
       
      Bluetooth
      Just tested with BTFirmwareUpdate.kext and it works in 10.11.6. I not needed it so switched off by wireless switch at right side.
      For 10.13.6 there is other kext BRCMInjector.
       
      Keyboard, Touchpad and Touchstick
      Post #14
      I made my fork of the VoodooPS2 driver, take here sources and release version
      https://github.com/SergeySlice/VoodooPS2-for-ALPS
       
      My config, ACPI files and kexts are in attachment.
      05.12.2017
      EFI.7z
       
      EDITED:
      Better DSDT in the post #6.
      Sleep working even when AC inserted.
       
      EDITED 06.12.2018
      Now I have HighSierra and this is my EFI folder. Note, HighSierra is possible only with Intel graphics (Optimus is enabled in BIOS)
       

       
       
      Welcome to discussion!
      EFI-E6430.7z
      BRCMInjector.kext.zip
    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI CLOVER Z390 DESIGNARE.zip
       
      ---OPENCORE FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI OPENCORE Z390 DESIGNARE.zip
       
      ---DSDT patch requests is here---
       
      https://olarila.com/forum/viewtopic.php?f=19&t=1131
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By fantomas1
      First beta... macOS Catalina 10.15 beta (19A471t)  Release Notes!!!
       
      Useful information:
       
      macOSDeveloperBetaAccessUtility.dmg.zip (thanks to gengik84)
      Clover r4945 (thanks to Cyberdevs)
      Lilu_plugins (thanks to gengik84)
      Port Limit Patch (thanks to daliansky)
      older non metal nVidia and Intel cards (thanks to fusion71au)
      MBR installation on macOS Catalina (thanks to crazybirdy) - workaround!!!
      Mac Downloader (thanks to ricoc90)
      Stuck boot in Beta 5 (thanks to MaLd0n)
       
×