Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
fantomas1

Nvidia Web Driver updates for macOS Sierra (UPDATE 04/02/2018)

1,035 posts in this topic

Recommended Posts

To get it working I enabled clover nvram emulator (emu variable) and installed startup rc scripts to enable the driver.Then select Nvidia Web-driver from menu bar applet and reboot

 

Don't know if it's a clover issue a difference in the way Nvidia detects which driver is active ,be it OS X default or web.

Share this post


Link to post
Share on other sites

So I tried every method described below my post and have got none of them to work. I seem to have tried every combination of those and still anytime I boot without nv_disable=1 I get stuck in a reboot loop.

 

I am assuming that enabling nvram emulator in cover is the "EmuVariableUefi" driver under "Drivers UEFI 64 BIT" - On the install drivers screen, I have the following installed;

EmuVariableUefi

OsxAptioFix2Drv

VBoxHfs

And under extra drivers, OsxFatBinaryDrv UEFI

 

Boot Flags are just dart=0 and nada_drv=1, of course that isn't working causing the reboot loop

 

I have tried both MacPro 6,1 and iMac14,1 (which was working great before this)

 

Please let me know if anyone has any ideas....

Share this post


Link to post
Share on other sites

When trying to 

 

 

set manually nvda_drv=1 in the nvram

I used 'sudo nvram boot-args="nvda_drv=1"' and the response I get is "nvram: Error setting variable - 'boot-args': (iokit/common) general error"

 

I have tested the nvram and confirmed values, even boot arguments I write like "-v", are retained after reboot. Though, when I rebooted it did not boot in verbose mode. So I am not sure even finding a way to add nada_drv=1 to my nvram is going to help if it is ignoring it. 

 

Why all of a sudden is the nvda flag in clover not enough for macOS? Is there a different flag I can try to force it to use the web drivers? 

Share this post


Link to post
Share on other sites

Ok I was able to get it to work. First thing I had to do was uninstall "EmuVariableUefi" in clover. After reboot, I was able to see the hidden file "NVRAM.plist" in the root OS directory, duplicate, edit, delete original, and replace with edited plist to include boot-arg "nvda_drv=1". Once I switched back my SMBIOS to iMac 17,1 booted up fine with the web drivers working!! Had to double check that my board id was still set to none in the graphic policy kext as well, but it was.

 

Also, I uninstalled the web drivers in the system preference pane and reinstalled during this process so that also could have helped. 

 

So now I am booting without any bootflags in clover, everything seems fine even without "dart=0" and the web driver utility is actually telling me it is using web drivers (check box next to it) which it never had done that before, so that made me happy.....haha

 

Thanks everyone for your posts as it all helped me tremdously in finally finding this solution.

Share this post


Link to post
Share on other sites

Guys, I'm getting reboots when trying to boot with the Nvidia driver on a GTX 950.

 

It used to work with DP1. Then I updated to DP2, I thought it's the driver. So now I also updated the driver, and I got the same issue: reboot on second stage boot, when booting with nvda_drv=1. The only way I can boot right now, is with nv_disable=1. But, of course, that denies the purpose of having the Nvidia driver installed in the first place.

 

Any idea what's wrong here? Am I missing something?

Share this post


Link to post
Share on other sites

Guys, I'm getting reboots when trying to boot with the Nvidia driver on a GTX 950.

 

It used to work with DP1. Then I updated to DP2, I thought it's the driver. So now I also updated the driver, and I got the same issue: reboot on second stage boot, when booting with nvda_drv=1. The only way I can boot right now, is with nv_disable=1. But, of course, that denies the purpose of having the Nvidia driver installed in the first place.

 

Any idea what's wrong here? Am I missing something?

I had the same problem, but now with latest Nvidia Web Driver - 367.05.10.05b07 it is Ok.

and Activate manually the Webdriver usage in Configuration panel

 

Hope this helps

Share this post


Link to post
Share on other sites

I had the same problem, but now with latest Nvidia Web Driver - 367.05.10.05b07 it is Ok.

and Activate manually the Webdriver usage in Configuration panel

 

Hope this helps

Well, I do have that driver version. And that's exactly what I can't seem to be able to do: activate it.

 

I mean, I do activate it, it requires restart, and after restart, it goes into restart again (the issue described in my previous post). I think the driver doesn't get activated, for some reason. Just can't pin point the reason.

Share this post


Link to post
Share on other sites

Well, I do have that driver version. And that's exactly what I can't seem to be able to do: activate it.

 

I mean, I do activate it, it requires restart, and after restart, it goes into restart again (the issue described in my previous post). I think the driver doesn't get activated, for some reason. Just can't pin point the reason.

 

Do you have the variable nvda_drv 1 defined in your nvram? It seems like the bootarg option is no longer recognised by the web driver. Type sudo nvram nvda_drv=1 in the console and check that the line nvda_drv 1 appears in you nvram (sudo nvram -p) and that it is persistent between boots. boot-args nvda_drv=1 seems like it is being ignored by the web driver.

 

Hope this helps.

 

Cheers,

Share this post


Link to post
Share on other sites

Do you have the variable nvda_drv 1 defined in your nvram? It seems like the bootarg option is no longer recognised by the web driver. Type sudo nvram nvda_drv=1 in the console and check that the line nvda_drv 1 appears in you nvram (sudo nvram -p) and that it is persistent between boots. boot-args nvda_drv=1 seems like it is being ignored by the web driver.

 

Hope this helps.

 

Cheers,

 

Thanks, I'll check that tomorrow. And yes, I was using it as boot argument. In case it's not in nvram, how exactly should I go from there?

Share this post


Link to post
Share on other sites

Ok, so  nvda_drv=1 is not persistent in nvram. But neither is it on El Capitan. So I'm not sure that's the issue here.

 

What are the options for this case?

Share this post


Link to post
Share on other sites

Hi arsradu,

 

Assuming that you are using clover in UEFI only mode you need the EmuVariableUefi driver, the RC scripts and the clover control panel to be installed, if you have this options already install proceed as below, otherwise install these option and restart you machine.

 

Now, in the clover control panel go to the NVRAM variables tab and from the dropbox "Save NVRAM variables to disk" select "Always", I'm not sure if this is necessary but in my case only started to work after this.

 

Now set the nvda_drv variable to 1 in the NVRAM, type in the console sudo nvram nvda_drv=1 and press enter, check that the variable has been set to 1, type nvram -p and look for the line "nvda_drv      1", no "=" should appear. Restart you machine and hope for the best, this worked for me but as you can see in the posts above is much hit or miss with the Sierra beta 2.

 

Good luck!

Share this post


Link to post
Share on other sites

Had these troubles too with Sierra, not with El Cap before. Anyways on a hunch I also saved the nvram to the disk and now it seems to work right... but surprised by it but whatever works works...

So far have restarted 20'ish times just to make sure, both restart + cold start, and no black screens anymore =).

Share this post


Link to post
Share on other sites

Hi arsradu,

 

Assuming that you are using clover in UEFI only mode you need the EmuVariableUefi driver, the RC scripts and the clover control panel to be installed, if you have this options already install proceed as below, otherwise install these option and restart you machine.

 

Now, in the clover control panel go to the NVRAM variables tab and from the dropbox "Save NVRAM variables to disk" select "Always", I'm not sure if this is necessary but in my case only started to work after this.

 

Now set the nvda_drv variable to 1 in the NVRAM, type in the console sudo nvram nvda_drv=1 and press enter, check that the variable has been set to 1, type nvram -p and look for the line "nvda_drv      1", no "=" should appear. Restart you machine and hope for the best, this worked for me but as you can see in the posts above is much hit or miss with the Sierra beta 2.

 

Good luck!

EmuVariableUefi driver - checked

RC Scripts - checked

Save NVRAM variables to disk - set to Always, but it changes back to Auto after restart.

 

Also, setting the nvda_drv=1 in nvram is not persistent after reboot. I think I'm gonna reinstall, and start with the PB1 maybe. Hope that works.

Share this post


Link to post
Share on other sites
Save NVRAM variables to disk - set to Always, but it changes back to Auto after restart.

 

Do you have an existing nvram.plist at the root of your disk ? If so, try to delete it then recheck Clover prefpane on next startup.

Share this post


Link to post
Share on other sites

Do you have an existing nvram.plist at the root of your disk ? If so, try to delete it then recheck Clover prefpane on next startup/

Finally, fixed! :)

 

I think there was a bit of failure on my side, as well, since I was booting from the El Capitan SSD, instead of Sierra HDD. And even though they both have the exact same EFI content, same Clover version, I was calling for a nvram.plist that was not located on the HDD I was trying to boot from. :D So..yeah... My bad on that part.

 

Maybe my failures can help others learn so that they can avoid issues like these in the future. :)

 

By the way, now there is no nvda_drv=1 boot argument in my config anymore. And...so far so good.

 

Thank you guys so much!

Share this post


Link to post
Share on other sites

@fantomas1,

 

Thank you for your Webdriver for Sierra public beta. It worked. 

I have GeForce GTX 960 4GB OC and I am running macOS Sierra Public Beta. 3 days in a row, when I played you tube video through Safari, after 3-4 songs, both montior screens suddenly turned black, then the disk icons reappeared while screen remaied black. Then the system crashed (unresponsive). Had to restart with restart button. Then, last night, I installed Chrome browser and played the same you tube videos, i did not experience black screens, freezes or system crashes even after 10 songs, It appeared this may be a Safari browser issue. Anybody has similar experience like me?  

Share this post


Link to post
Share on other sites

Hi Guys,

I have updated to DP3 with the latest web drivers but cannot boot up, only with nv_disable flag.

I used nvram patch and checked nvram -p looks OK.

Any other idea?

I don't know if my GFX supported under 10.2..

Share this post


Link to post
Share on other sites

Hi, seems I have the same a strange problem as Arsradu in post 69 here when using Sierra DP2  (Clover r3652) and Clover configurator 4.31

Even if I change the bootargument from nvda_drv=1 to nv_disable=1

On booting the both are remaining ! look on image below ( -> blackscreen)

 

So I have to modifiy it manually everytime at bootscreen and then boot is OK.

 

Never saw this before !

 

I have tried to nvram -c    but it comes back everytime ...

 

Seems it picks up nvram.plist parameters from my original bootdisk (Sierra DP2) from where I newely installed Sierra-SSD (PB2)

 

Is there a thing to change in Clover configurator preferencepane concerning NVRAM ? ( Auto save or never ?)

How usefull is NVRAM on hackintosh ? ( Tidbits releaved that resetting NVRAM desactivated localisation )

 

Thanks for your lights !

 

post-305243-0-75803000-1469373931_thumb.jpg

Share this post


Link to post
Share on other sites

Looks like you're right.

 

I got a GT 730 that absolutely needs webdrivers in El Capitan and below but runs just fine in Sierra without them.

for me no web drivers will boot with no gfx support, i have 750 TI

maybe my nvram related, how to clear nvram?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×